16:59:58 <sarob> #startmeeting training-manuals
16:59:59 <openstack> Meeting started Mon Aug  4 16:59:58 2014 UTC and is due to finish in 60 minutes.  The chair is sarob. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:00 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:02 <openstack> The meeting name has been set to 'training_manuals'
17:00:09 <sarob> roll call!
17:00:16 <rolu> hey
17:00:48 <sarob> rolu: new handle, eh?
17:00:54 <dbite> hey
17:01:12 <rolu> sarob: yeah, per accident :)
17:01:15 <sarob> very slimming, ;)
17:01:35 <sarob> rolu sounds pretty cool, i like it
17:02:14 <sarob> any of our new friends from symantec, ibm, or intel joining us?
17:02:20 <sarob> or HP?
17:02:50 <sarob> how about our friends from comcast?
17:03:01 <MeganR> Hi, I'm here
17:03:11 <MeganR> Shilla is still out and Scott is in training
17:03:15 <sarob> meganr: morning!
17:03:28 <MeganR> Good morning!
17:03:40 <sarob> or afternoon
17:03:45 <dbite> good morning
17:03:50 <rolu> or evening, as the case may be
17:04:12 <sarob> so i wanted to discuss briefly the idea of mentoring that has been making the rounds
17:04:23 <sarob> reed are you with us?
17:04:37 <sarob> no matter
17:05:08 <sarob> i have been getting alot of interest from different groups about joining congress and training
17:05:20 <sarob> im sure the same is for other projects as well
17:05:39 <sarob> we have been partially focusing on new contributors
17:05:47 <sarob> getting them into the openstack way
17:06:14 <sarob> i think we need to think about working with the foundation on a mentoring program
17:06:35 <sarob> a few of us might have the time to be a mentor
17:06:41 <sarob> but im thinking for our team
17:06:56 <dbite> sarob: we have OPW and GSoc and also there is openSUSE internship program
17:07:16 <sarob> that we can help with some kind of pair programming ideas for getting in the openstack way
17:07:26 <dbite> too early for me to say but I can try to put this up across SUSE and openSUSE community once I get some clarity there
17:07:54 <sarob> dbite: so we can coop their work?
17:08:48 <sarob> i dont want us to travel some new direction
17:09:03 <sarob> rather if we can help ourselves
17:09:11 <dbite> mostly we try to push our content
17:09:19 <dbite> and get people to use it for official programs
17:09:33 <dbite> that could be good start
17:09:33 <sarob> with mentoring a new contributor from intel or hp or the like
17:10:18 <sarob> i can line up a new person with our training materials and a live person to hand hold them for a bit
17:10:44 <sarob> i can ask reed to help us with finding the warm bodies
17:10:53 <dbite> ok
17:11:12 <sarob> does this make any sense, or too much coffee for sarob?
17:11:16 <matjazp> hi all
17:11:25 <dbite> matjazp: hello
17:11:25 <matjazp> sorry I'm late
17:11:26 <sarob> matjazp: evening!
17:11:29 <dbite> sarob: makes sense
17:11:36 <dbite> but how much help should be given?
17:11:48 <dbite> most of the things are up there on the wiki and are in pretty good shape
17:12:10 <sarob> dbite: the foundation and some others have been discussing mentoring
17:12:42 <sarob> dbite: give a bit of thought of what materials would be useful to start
17:12:55 <sarob> dbite: its all of our stuff
17:13:10 <dbite> hmm, mentoring for new contributors you mean
17:13:15 <sarob> dbite: right
17:13:17 <dbite> or for the training them for OpenStack?
17:13:19 <dbite> ok
17:13:29 <dbite> I dont mind that, which projects are you talking about?
17:13:52 <sarob> dbite: if i was to write up a wiki page for a user group mentor, what would i tell them and steps
17:14:13 <sarob> dbite: think of it this way
17:14:35 <sarob> intel is interested in getting a developer to help us with the training-guides
17:14:41 <sarob> awesome right?
17:14:56 <dbite> awesome news
17:14:59 <sarob> but i need to hand hold this new person
17:15:12 <dbite> the wiki page should contain links to other getting started wikis and docs
17:15:16 <dbite> a bit of introduction
17:15:22 <dbite> on why we need to follow these links
17:15:31 <matjazp> sarob: cool... it's one developer, or plural... developers? :)
17:15:32 <sarob> so i am going to make a date and time to walk them through getting started
17:15:36 <dbite> various procedures and may be showcase IRC stuff
17:15:49 <sarob> dbite, matjazp: exactly
17:16:01 <dbite> sure, sounds good
17:16:08 <sarob> so i am going to do it. i should write it down
17:16:24 <sarob> so other mentors can follow and improve
17:16:32 <dbite> yeah, just share the WIKI page with us so that we can pitch in
17:16:37 <dbite> yeah
17:16:45 <sarob> coolo
17:17:14 <sarob> i want to get the managers attention from these interested companies
17:17:21 <sarob> and then set the hook
17:17:34 <reed> this wiki page? https://wiki.openstack.org/wiki/Training-guides
17:17:43 <sarob> for the developer to be part of openstack
17:18:11 <dbite> reed: thats more for training project's contributors
17:18:15 <sarob> reed: i will probably set the page there eventually
17:18:34 <sarob> reed: i will start with wiki page for right now
17:18:46 <sarob> reed: we have lots of good info
17:18:57 <reed> ok, I was just checking since there are lots of moving parts
17:19:04 <reed> I myself get confused
17:19:11 <sarob> reed: i want to create a mentor/trainer starting place
17:19:28 <reed> sarob, there should already be a random page
17:19:29 <sarob> reed: we are very, very close to that
17:19:32 <reed> let me pull it
17:20:05 <sarob> reed: i will training this new intel dev and write down what i do
17:20:16 <sarob> reed: train that is
17:20:28 <sarob> sorry to sidetrack us folks
17:20:55 <reed> #link https://wiki.openstack.org/wiki/Mentors
17:21:07 <sarob> i want to build the depth of this team, and this seems like a way to do it
17:22:12 <reed> the Mentors on that page responded to a call on the dev list recently, a request to help new contributors get their patches accepted faster
17:22:12 <sarob> reed: after i write up my notes, you want me to link to the mentor page?
17:22:54 <reed> sarob, can you expand a bit about what your notes are about?
17:23:18 <dbite> sarob: the idea of mentors getting the newbie's patches in faster is really nice
17:23:41 <dbite> I think that should cushion their fall
17:23:43 <dbite> a bit
17:24:30 <sarob> reed: i am going to train a new intel dev becoming a new contributor to openstack
17:24:35 <reed> dbite, there was recently a conversation about this topic on the dev list, a couple of tasks also generated from that
17:24:59 <dbite> reed: ok, sorry I must have missed that
17:25:30 <sarob> reed: the tasks, can we create a community blueprint with tasks for mentoring?
17:25:43 <reed> sarob, cool... using the training material?
17:25:53 <sarob> reed: or storyboard even better
17:26:01 <sarob> reed: yup
17:26:33 <reed> sarob, not worth creating blueprints honestly, it takes longer to create a bp than to act on them :)
17:26:35 <dbite> it is a good idea to put it under training guides
17:26:54 <reed> the tasks are just to collect the couple questions and answers raised on the mlist and put them on Ask
17:27:11 <matjazp_> sarob: can we use storyboard? Isn't that only in plans for fall?
17:27:40 <reed> #link http://lists.openstack.org/pipermail/openstack-dev/2014-February/026931.html
17:28:16 <reed> #note check Open Hatch as a  resource to collaborate too
17:28:47 <reed> matjazp_, storyboard is still in heavy development, and it may break
17:29:10 <sarob> reed: it seems to be broken right now :/
17:29:26 <reed> matjazp_, a decision to use it (or not) should be made after talking to its developers
17:29:31 <reed> sarob, indeed :)
17:30:23 <matjazp_> reed: yup, i know, that is why I asked... maybe we should use bp's untill its stable
17:30:24 <krotscheck> that would be me :)
17:30:30 <sarob> okay, well i dont want to get sidetracked more here
17:30:42 <dbite> krotscheck: hello
17:31:13 <sarob> krotscheck: has rightfully warned me off using storyboard until it is ready for production
17:31:57 <sarob> reed: i will write up my trainer notes and we can go from there of how to build on them
17:32:52 <sarob> lets get back to the regularly scheduled program
17:33:36 <sarob> #action sarob will train a new dev from intel this week and post the trainer notes as a start for mentoring
17:33:55 <sarob> #topic stable docs team update
17:34:26 <dbite> 1. so stable team should be renamed
17:35:08 <dbite> I think we agreed to call it simply docs team
17:35:13 <dbite> or training docs team
17:35:17 <rolu> weren't we supposed to have an email discussion on that?
17:35:34 <rolu> ML discussion, actually.
17:35:34 <dbite> rolu: yes, my bad. I got too busy last week
17:36:08 <reed> sarob, what's epiclisde?
17:36:09 <matjazp_> dbite: we can vote now, if you would like?
17:36:24 <sarob> dbite: ah right, the new name idea is "training docs" instead of stable
17:36:28 <dbite> I think so, I mean it does not affect other projects
17:36:35 <dbite> so putting it up on ML may be over kill IMHO
17:36:50 <dbite> matjazp_: yes, should we vote on this rite now?
17:36:58 <sarob> okay we can vote
17:37:11 <dbite> so I propose training docs for stable content
17:37:45 <rolu> dbite: what would be the name for old "development"?
17:37:50 <sarob> dbite: "training docs" as the new name for the "stable" training team?
17:38:09 <dbite> sarob: yes
17:38:17 <sarob> #startvote rename the "stable" training team to "training docs"
17:38:18 <dbite> rolu: may be draft or current
17:38:19 <openstack> Unable to parse vote topic and options.
17:38:31 <dbite> +1
17:38:51 <sarob> #startvote rename the stable training team to training docs
17:38:52 <openstack> Unable to parse vote topic and options.
17:38:52 <dbite> I think startvote command failed
17:39:07 <sarob> dbite: :/
17:39:22 <sarob> #startvote "rename the stable training team to training docs"
17:39:23 <openstack> Unable to parse vote topic and options.
17:39:29 <dbite> sarob: :|
17:39:37 <rolu> :D
17:39:39 <sarob> whatever
17:39:54 <dbite> lets just say +1 or -1
17:39:55 <dbite> for now
17:39:57 <sarob> vote with +/- my friends
17:40:04 <sarob> dbite right
17:40:05 <dbite> and add it as a an action item
17:40:06 <matjazp_> #action we should look into this #voting stuff on irc :)
17:40:06 <dbite> +1
17:40:13 <rolu> +1
17:40:15 <matjazp_> +1
17:40:17 <sarob> +1
17:40:17 <MeganR> +1
17:40:28 <sarob> moost excceeelent
17:40:37 <sarob> +5 to 0
17:40:46 <dbite> then its decided
17:41:10 <sarob> dbite: can you update the training guides wiki?
17:41:11 <rolu> #startvote rename the stable training team to training docs? Yes, No, Maybe
17:41:24 <rolu> that syntax should do it.
17:41:27 <reed> #link http://wiki.debian.org/MeetBot
17:41:30 <sarob> #startvote rename the stable training team to training docs? Yes, No, Maybe
17:41:31 <openstack> Begin voting on: rename the stable training team to training docs? Valid vote options are Yes, No, Maybe.
17:41:32 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
17:41:38 <sarob> yes
17:41:41 <dbite> #vote Yes
17:41:45 <rolu> #vote Yes
17:41:48 <sarob> #vote yes
17:41:53 <matjazp_> #vote Yes
17:41:56 <MeganR> #vote yes
17:42:45 <sarob> #endvote
17:42:46 <openstack> Voted on "rename the stable training team to training docs?" Results are
17:42:47 <openstack> Yes (5): sarob, MeganR, rolu, matjazp_, dbite
17:42:56 <sarob> super awesome
17:43:26 <sarob> what else my friend?
17:43:28 <dbite> move on?
17:43:53 <dbite> we have renamed most of the XML files for stable content and nearly done with cleaning up of filenames
17:44:09 <dbite> I want some clarification on release tracking
17:44:20 <dbite> when to create git version tags
17:46:18 <sarob> annegentle: when do we want to create git version tags?
17:47:11 <sarob> dbite: more specifically when can we publish to icehouse?
17:47:45 <dbite> sarob: yeah, so we create Icehouse tag and start with Juno
17:48:01 <sarob> dbite: annegentle is offline right now
17:48:06 <dbite> I need some help intially with this
17:48:24 <dbite> ok, I will initiate a conv. later
17:48:32 <sarob> dbite: lets discuss with doc channel and ml
17:48:52 <dbite> #action dbite, ask for git version tags to Manuals PTL and core team
17:48:57 <sarob> dbite: so we can coordinate with the broader team
17:48:59 <rolu> shouldn't we use branches rather than tags?
17:49:17 <dbite> my bad, by tags I mean branches and tags
17:49:36 <rolu> dbite: ah, okay :)
17:49:39 <sarob> rolu: ah right i was lost there for a bit
17:49:39 <dbite> rolu: tags are used for a stable release like RC1 etc. if I am not wrong
17:49:55 <rolu> tags are just labels.
17:50:05 <dbite> yes
17:50:08 <rolu> but if you want to go back and fix something in icehouse, you need branches.
17:50:15 <sarob> rolu: during build we use tags
17:50:39 <dbite> I think we should move on to other teams, we have limited time
17:50:46 <sarob> dbite: we will need to get a bit a planning around cherrypicking
17:51:07 <dbite> sarob: yes, that sounds like a discussion for the Summit
17:51:14 <sarob> #action dbite: cherrypicking plan
17:51:49 <sarob> #topic any other business since i took up all the time in the beginning of the meeting
17:52:11 <sarob> matjazp or rolu?
17:52:37 <matjazp_> sarob: I updated wiki a bit. I decided to go with bugs, not bp's
17:52:45 <rolu> sarob:  scripts are not as far along as I would like, but we are making progress.
17:53:22 <sarob> as a get new people, do either of you want me to send me your way?
17:53:35 <sarob> send you one i mean
17:53:46 <matjazp_> sarob: sure
17:54:01 <dbite> sarob: in future, right now its not possible for me
17:54:17 <sarob> rolu?
17:54:40 <rolu> depends on what you expect from my side. we are stretched thin in labs scripts.
17:54:43 <dbite> rolu: it would be good if you can take up mentoring someone for the labs section
17:55:15 <matjazp_> sarob: but to write questions/quizzes you need to know Openstack
17:55:16 <rolu> we could do with some help, I had a trivial patch more then 4 days in the review queue with no takers.
17:55:39 <matjazp_> are  they  "fresh" on OS?
17:55:44 <sarob> #action sarob send new training help to testing and infra teams
17:56:00 <dbite> rolu: patches will more in faster now
17:56:12 <sarob> matjazp_: these are people with python experience
17:56:14 <rolu> yeah, now that you are back :).
17:56:34 <dbite> by the way, I almost forgot, me and a rally core recently took a openstack Developer 101
17:56:41 <dbite> in one of the local university in India
17:56:47 <sarob> i have been massively distracted
17:56:52 <matjazp_> rolu: I'm still on vacation.. but I have more regular internet access now..
17:57:12 <sarob> dbite: like attended a class or ran it?
17:57:14 <dbite> matjazp_: dont worry much about reviews, I will cover them till the next week or two
17:57:16 <reed> dbite, interesting... who was the teacher?
17:57:23 <dbite> sarob: ran it ofcourse ;D
17:57:34 <reed> oh
17:57:41 <sarob> dbite: awesome, blog it !
17:57:55 <dbite> my bad, should have phrased it a bit better
17:57:58 <reed> I second that, dbite, write about it :)
17:58:03 <sarob> dbite: you can use mine if you need a place to write it up
17:58:13 <dbite> yes, I will
17:58:20 <sarob> or use wordpress online
17:58:26 <sarob> cool
17:58:30 <dbite> I have my blog
17:58:39 <dbite> http://dguitarbite.wordpress.com/
17:58:40 <sarob> :( didnt know
17:58:49 <dbite> sarob: nps :)
17:58:51 <reed> dbite, is it on planet.openstack.org?
17:59:00 <sarob> its on my list now
17:59:09 <sarob> almost done here
17:59:16 <matjazp_> sarob: what's with Upstream univ review?
17:59:18 <dbite> reed: not yet, I post some personal weird stuff there too, I wil lcreate another one for planet soon
17:59:32 <dbite> guys lets switch over to docs channel
17:59:46 <sarob> majazp_ docs channel right
18:00:02 <sarob> goodbye my friends until next week!
18:00:08 <reed> bye
18:00:08 <matjazp_> bye
18:00:10 <dbite> bye
18:00:11 <rolu> bye
18:00:13 <MeganR> bye
18:00:20 <sarob> #endmeeting