17:00:55 <sarob> #startmeeting training-manuals
17:00:56 <openstack> Meeting started Mon Jun 23 17:00:55 2014 UTC and is due to finish in 60 minutes.  The chair is sarob. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:58 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:00 <openstack> The meeting name has been set to 'training_manuals'
17:01:07 <sarob> Roll call
17:01:15 <rluethi> hi
17:01:18 <dguitarbite> hey
17:01:19 <dguitarbite> guys
17:01:24 <fthamura> hi all :) greet from jakarta
17:01:30 <sarob> Evening
17:01:35 <matjazp_> hi all
17:01:43 <sarob> Helloooo
17:01:54 <sarob> Let's start
17:02:15 <sarob> I want to spend half the meeting on
17:02:43 <sarob> Current stable, testing, infra
17:02:58 <sarob> Then last half on developer guide design
17:03:10 <dguitarbite> +1
17:03:22 <sarob> #topic stable team
17:03:54 <dguitarbite> current focus is on install guide
17:04:11 <dguitarbite> also fixing a few things from Associate and Operator guides
17:04:31 <dguitarbite> to have better collaboration we had a meeting with Comcast guys over hangouts
17:04:58 <dguitarbite> Etherpad Link for Install Guides : https://etherpad.openstack.org/p/training-guides-install-guide
17:05:05 <dguitarbite> I need to port my notes here
17:05:51 <dguitarbite> I am planning to use Etherpad for keeping various information about install guides
17:06:10 <dguitarbite> which sections to break from openstack-manuals and how to assemble them
17:06:19 <dguitarbite> so we could also use this to show it to guys who maintain install guides
17:06:35 <sarob> Sounds good
17:06:35 <dguitarbite> any suggestions?
17:07:16 <fthamura> any idea to break from os-manual, but keep linked?
17:07:28 <sarob> I'd reach out to Sam-I-am and others active on the install guides
17:07:30 <fthamura> so we can know, this content from which chapter and section
17:07:56 <dguitarbite> sarob: I plan to do that as soon as we are prepared with the changes to install guide on manuals
17:08:02 <dguitarbite> fthamura: we are already doing that, it is possible
17:08:11 <annegent_> he, sorry I'm late
17:08:15 <annegent_> will catch up next
17:08:26 <sarob> Annegent_ no prob
17:09:13 <fthamura> i can see training manual have pattern, can we make template for all modules, apt-get, setting .conf, keystone create, load content, list, restart. ?
17:09:42 <fthamura> and this pattern linked to openstack-manual, and we can have like matrix installation
17:09:44 <fthamura> i am working on that
17:09:51 <annegent_> fthamura: that's pretty much the install pattern isn't it?
17:09:53 <dguitarbite> fthamura: we will keep skeleton/basic framework and reuse the actual content from install guides from openstack-manuals
17:10:02 <annegent_> fthamura: the goal is to not replicate
17:10:13 <dguitarbite> fthamura: the distro switch and the content will be re-used
17:10:20 <dguitarbite> we dont need to do the same thing again
17:10:25 <fthamura> annegent_: this pattern help student to learn, and how easy install openstack
17:10:31 <fthamura> dguitarbite: right!! :)
17:10:34 <annegent_> fthamura: the install guide already does that
17:10:59 <annegent_> fthamura: our goal with the install guide matches learning and easy installation, the training project will enhance it for a training lab setting
17:11:19 <fthamura> annegent_: yup, already, and find nova db sync vs keystone db_sync / glance db_sync -> i think must submit bugs because different way of sync
17:11:43 <dguitarbite> fthamura: that is out of documentation's domain
17:12:12 <annegent_> dguitarbite: agreed, and yes fthamura I also agree that docs can push dev to be better about consistency but we have to document reality
17:12:15 <fthamura> dguitarbite: +1, based on doc i can find input for developer and future version
17:12:22 <dguitarbite> fthamura: you need to talk to the specific projects developers
17:13:02 <fthamura> dguitarbite: working on it, and will update shortly, and hope this patch will make new revision for better doc/training manual instruction, the pattern become standard for next new openstack's project
17:13:08 <sarob> Dguitarbite what's the plan for icehouse bugs?
17:13:28 <dguitarbite> sarob: I need to take a look into it
17:13:37 <annegent_> sarob: I have to step away for about 15 minutes, are we talking about -specs later in the meeting?
17:13:51 <sarob> Yup
17:14:00 <dguitarbite> I do not have any idea about the number of bugs now
17:14:19 <dguitarbite> sarob: any thing specific about bugs?
17:14:36 <sarob> Dguitarbite I'm looking for a timeline to review the current state of two books
17:14:57 <sarob> Dguitarbite create the icehouse bugs along the way
17:15:12 <dguitarbite> hmm, can I do some background checks and give you a realistic date in a day or two?
17:15:19 <sarob> Dguitarbite so we can start handing out the big work
17:15:23 <sarob> Bug
17:15:59 <sarob> Dguitarbite okay. We not want to lose our audience by being out of date
17:16:14 <sarob> Moving on?
17:16:24 <dguitarbite> yes
17:16:36 <dguitarbite> I will start a conversation in the docs mailing list soon
17:16:41 <dguitarbite> in a day mostly
17:16:45 <dguitarbite> *days time
17:17:00 <sarob> #action dguitarbite icehouse bug plan
17:17:17 <sarob> #topic testing team
17:17:19 <dguitarbite> #action dguitarbite will check the bugs for operators and associate guides
17:17:35 <matjazp_> There is some overlap in responsibilities regarding quizzes/questions between Testing subgroup and Development/Stable Subgroup
17:17:46 <matjazp_> We should write content of the guide first, quizzes second, with a separate BP, right?
17:18:08 <matjazp_> You need to see the content before you write quizzes about it… Otherwise, there could be a mismatch between content and quizzes…
17:18:31 <sarob> Matjazp_ maybe. You can dig through the icehouse install guides
17:19:10 <sarob> Matjazp_ but I get your point. Maybe you can help dguitarbite get the icehouse bugs out
17:19:30 <dguitarbite> sarob: that would be great
17:19:31 <matjazp_> Also... what is the BP granularity: write a separate BP for each chapter in each Guide? Or one BP for One Guide...
17:19:47 <dguitarbite> matjazp_: I think keep it logically seperate
17:20:04 <dguitarbite> if one blueprint delivers the points, it should be good enough
17:20:14 <sarob> Matjazp_ id like to have blueprints very task specific
17:20:25 <matjazp_> OK... many BPs than, one for each quizz
17:20:49 <sarob> Matjazp_ think agile, blueprints as your backlog task
17:20:55 <sarob> Card
17:21:03 <fthamura> who is quizz team? can i part of ? and where the discussion discuss regarding question bank creation?
17:21:04 <matjazp_> -specs usage will be discussed later?
17:21:21 <sarob> Matjazp_ in a few min
17:21:34 <matjazp_> fthamura: sure... I'll make BPs as soon as we agree on spec usage
17:21:49 <sarob> matjazp_ what's the plan with LPI ?
17:22:10 <sarob> Matjazp_ can they be of help to us?
17:22:16 <matjazp_> sarob: can't say it yet... Will update as soon it is official
17:22:40 <sarob> matjazp_ okay. Anything else?
17:22:53 <matjazp_> no
17:22:58 <sarob> #topic infrastructure team
17:23:46 <sarob> We have the content getting updated
17:23:53 <sarob> Good work
17:24:05 <dguitarbite> We are almost done with the generic scripts
17:24:21 <dguitarbite> kudos to rleuthi
17:24:30 <sarob> we need to start thinking about new Jenkins jobs
17:24:40 <sarob> Like lang builders
17:24:47 <dguitarbite> yes, but there is still some time for that
17:25:04 <dguitarbite> we need to get the install scripts for OpenStack running
17:25:19 <sarob> Openstack-manuals already has the ja out there
17:25:36 <sarob> Dguitarbite understood
17:25:52 <dguitarbite> rluethi: any thing on infra?
17:26:10 <rluethi> you covered it pretty much. scripts are ready for testing.
17:26:31 <sarob> #action new Jenkins jobs after trainer scripts completed
17:26:49 <rluethi> I am concerned that nobody understood the magic that made Jenkins work all of a sudden.
17:27:05 <sarob> Rluethi me too
17:27:26 <dguitarbite> me too
17:27:34 <sarob> CI is super critical and not well understood
17:27:43 * dguitarbite wondering if theres a god of binaries
17:28:05 <sarob> We should study our tests well
17:28:20 <sarob> Anything else?
17:28:27 <matjazp_> dguitarbite: sure it is.. it's often on infra channel ;)
17:28:48 <dguitarbite> I may not have been magical, we changed the tox.ini which is referred by jenkins to run the CI jobs
17:29:04 <dguitarbite> Jenkins may be updating the tox.ini every * hours or so
17:29:09 <dguitarbite> we need to confirm that
17:29:21 <dguitarbite> since there was no other change and Rogers patch on infra was not merged
17:29:29 <sarob> Dguitarbite that makes more sense
17:29:34 <rluethi> but I couldn't find the actual copy job in the Jenkins config.
17:29:42 <fthamura> can we use the install script in installation guide? or just jenkin specific?
17:29:55 <sarob> Publish isn't it?
17:30:34 <dguitarbite> rluethi: need to take a look into it
17:30:44 <sarob> Fthamura Jenkins is the tool that builds the guides, verifies the code
17:30:47 <rluethi> dguitarbite: yeah, we should.
17:31:03 <dguitarbite> it very well can be a trigger from manuals which is copying it, which would be bad since we need to control that
17:31:33 <dguitarbite> rluethi: you want to take up the investigation?
17:32:01 <dguitarbite> fthamura: http://jenkins-ci.org/
17:32:11 <rluethi> dguitarbite: I can take another look, and then we can discuss the findings. how's that?
17:32:27 <dguitarbite> sounds good
17:32:35 <matjazp_> rluethi: how about infra channel? just post there?
17:33:02 <dguitarbite> matjazp_: we need to make sure that we are doing it right from our end before approacing infra with this issue, what do you guys think?
17:33:27 <dguitarbite> #action dguitarbite rluethi investigate jenkins jobs for training-guides
17:33:31 <rluethi> dguitarbite: agreed
17:33:37 <sarob> Docs people understand their jobs a lot better than infra
17:33:47 <sarob> I'd start there
17:33:56 <rluethi> andreas is back :)
17:34:04 <fthamura> +1 agree, doc make we are more structured and organized :)
17:34:06 <sarob> Righto
17:34:24 <sarob> Move on?
17:34:31 <dguitarbite> one more thing
17:34:47 <dguitarbite> we need the server for setting up ZNC
17:34:50 <dguitarbite> for our core reviewers
17:35:00 <sarob> Ah boy
17:35:04 <sarob> I dropped that
17:35:05 <fthamura> ZNC?
17:35:13 <sarob> Irc bouncer
17:35:35 <rluethi> fthamura: http://wiki.znc.in/ZNC
17:35:41 <sarob> Dguitarbite I'll forward user info today
17:35:46 <dguitarbite> sure
17:35:50 <sarob> Me flake
17:35:54 <dguitarbite> Ill ping you on skype after I wake up
17:35:59 <dguitarbite> sarob: no issues
17:36:02 <dguitarbite> :)
17:36:13 <sarob> #topic spec, blueprint, how to
17:36:28 <sarob> Annegentle around ?
17:36:55 <sarob> Let's start with our team
17:37:03 <sarob> #link https://review.openstack.org/#/c/100993/
17:37:16 <matjazp_> annegent_: specs/BP talk?
17:37:43 <annegent_> so just wanted to say, I like the idea of specs, but that I want them organized a particular way, so I wanted to talk about that here
17:37:47 <sarob> I started writing up spec patches for our team to debate and review
17:38:13 <annegent_> and on the mailing list --
17:38:21 <matjazp_> annegent_: what's you proposal?
17:38:30 <annegent_> sarob: yes, but the doc program does not current have specs, and we run specs through the program.
17:39:02 <annegent_> so what I'd like is a doc-specs repo with training in one directory, api in another, users in another, and admin or ops in another
17:39:13 <annegent_> I can propose this to the list but wanted your take
17:39:28 <sarob> Annegentl_ hmm, okay. We haven't discussed training guide books as the larger team before
17:39:36 <annegent_> sarob: which larger team?
17:39:38 <dguitarbite> annegent_: +1 for docs-specs repo
17:39:46 <dguitarbite> other projects have seperate repo for specs
17:39:52 <dguitarbite> I guess better for managing the History
17:39:55 <annegent_> dguitarbite: yep
17:40:03 <sarob> Annegentl_ I'm happy to do it
17:40:15 <annegent_> out of the summit I figured the roadmaps would be enough for docs, but now I think doc-specs is what we need
17:40:32 <sarob> annegent_ it would be great to get broad input on design
17:40:41 <annegent_> doc-specs should also help with the install guide reuse, that sort of thing
17:41:04 <sarob> annegent_ I like it. Team?
17:41:14 <matjazp_> sarob: annegent_: in the mean time, we can still use "our" specs?
17:41:15 <annegent_> and I want you guys to think of yourselves as a team within the Documentation Program
17:41:15 <dguitarbite> +1 for doc-specs repo
17:41:25 <matjazp_> +1
17:41:29 * rluethi shrugs
17:41:31 <rluethi> sure
17:41:31 <annegent_> matjazp_: sarob: it just means moving to another repo is all
17:42:00 <sarob> anngent_ can I get the new repo going today?
17:42:09 <dguitarbite> matjazp_: it will not make any difference for the blueprints, just change it from backend
17:42:24 <sarob> Dguitarbite agreed
17:42:40 <annegent_> sarob: what I asked last week was a mailing list post, can you start there and point to a patch that contains the new repo? (double up for efficiency)
17:43:26 <sarob> Annegent_ does the docs-spec repo exist?
17:43:50 <annegent_> sarob: no it does not
17:44:00 <annegent_> sarob: that's what we're discussing now, whether to create it
17:44:34 <annegent_> I also think we'll need to talk about whether the dev specs template is what we want
17:44:50 <annegent_> or if we need a different template
17:44:57 <sarob> annegent_ okay, so I will post our list of specs to the docs ML to add to the overall discussion
17:45:21 <annegent_> I also don't know if you can have a separate review team per directory in a repo
17:45:33 <matjazp_> sarob: ok, so discussion and voting will be on ML?
17:45:39 <sarob> Annegentl_ why not?
17:46:06 <annegent_> sarob: I think it'd be great to have a separate review team per directory but I don't know if it's technologically feasible already
17:46:08 <sarob> Matjazp_ voting needs to be gerrit
17:46:10 <dguitarbite> matjazp_: for the initial Repo setup, yes
17:46:18 <dguitarbite> but once the specs repo is setup
17:46:25 <dguitarbite> it will be similar to code review
17:46:27 <dguitarbite> on gerrit
17:46:40 <matjazp_> dguitarbite: of course.. was talking about first setup and proposed layout of specs
17:46:51 <annegent_> we're talking about something like nova-specs https://review.openstack.org/#/q/project:openstack/nova-specs,n,z
17:47:07 <sarob> Annegent_ we just follow this #link https://wiki.openstack.org/wiki/Training-guides#Create_a_Blueprint
17:47:09 <dguitarbite> matjazp_: I guess, the discussion will start from there, but the initial setup is also a commit to the new repo
17:47:17 <dguitarbite> it should use gerrit
17:47:44 <annegent_> sarob: but you just made that process up, right? we need to think of the bigger picture and existing patterns that people will recognize
17:47:58 <sarob> annegent_ well yes we made it
17:48:38 <annegent_> sarob: right, so I'm asking that you bring this pattern to the docs mailing list -- I think it's a match and I don't want a one-off process so hence my request
17:48:46 <sarob> Annegent_ we start there is what I am pointing out.
17:49:49 <sarob> #action sarob post current training guides specs to the docs ML
17:49:54 <annegent_> sarob: what we do currently is step 1 but then step 2 forward is all done on the wiki. I'm asking for step 2 to be in a doc-spec repo
17:50:28 <annegent_> sarob: no the action is for you to post a proposal to use a doc-specs repo
17:50:41 <annegent_> sarob: is it possible to revise actions? I dunno meetbot :)
17:51:05 <dguitarbite> annegent_: I think its above meetbots pay grade ;)
17:51:20 <sarob> #action sarob propose docs-spec repo to docs ML
17:51:22 <annegent_> dguitarbite: heh.
17:51:23 <fthamura> is there doc-spec's draft? so i can know, what will be inside?
17:51:39 <annegent_> fthamura: that's also part of the discussion, is the dev template appropriate for us?
17:51:45 <rluethi> actually, there should be #undo
17:51:54 <rluethi> but it works on the last item, so too late now.
17:52:04 <sarob> #undo stupid stuff
17:52:05 <openstack> Removing item from minutes: <ircmeeting.items.Action object at 0x2e12a10>
17:52:31 <sarob> OOO ahhhh
17:52:37 <annegent_> ooo!
17:52:41 <matjazp_> sarob: :))
17:52:43 <annegent_> irobot do you? :)
17:52:48 <dguitarbite> nice one roger
17:52:50 <dguitarbite> :)
17:53:03 <fthamura> annegent_: what do u mean of "is appropirate for us?"?
17:53:08 * rluethi bows
17:53:52 * dguitarbite bows back
17:53:53 <annegent_> fthamura: the template is here: https://review.openstack.org/#/c/87596/7/specs/template.rst
17:53:56 <annegent_> #link https://review.openstack.org/#/c/87596/7/specs/template.rst
17:54:08 <sarob> #action sarob propose docs-spec repo to doc ML
17:54:09 <annegent_> #action Anne to respond to sarob's post with discussion about the template
17:54:30 <annegent_> I really want us to go in this direction, let's make it happen this week
17:54:31 <sarob> I think we are good now
17:54:51 <sarob> Annegent_ this morning
17:55:07 <sarob> #topic any other business
17:55:11 <matjazp_> ok.. so I'll delay new BPs for few days
17:55:16 <sarob> 5 minute warning
17:55:32 <annegent_> sarob: gogogo
17:55:45 <fthamura> matjazp_: what is BPs? i see several time mentioned here.
17:55:52 <sarob> Matjazp_ put the details into the wiki for right now
17:55:56 <matjazp_> BP=BluePrint
17:56:06 <matjazp_> sarob: its already there
17:56:17 <dguitarbite> I guess, we meet later for discussing about Developer Guides design
17:56:18 <sarob> Matjazp sweet
17:56:20 <rluethi> fthamura: https://wiki.openstack.org/wiki/Blueprints
17:56:27 <fthamura> aha :) thx ;)
17:57:05 <sarob> Dguitarbite yes, it's gotten mixed up in this process change
17:57:05 <annegent_> or discuss in the blueprint :)
17:57:26 <dguitarbite> sarob: yeah, lets discuss the time then or keep it for next week?
17:57:42 <sarob> Next week I think
17:57:51 <dguitarbite> ok
17:57:59 <sarob> We can start a doc ML thread in the mean time
17:58:07 * dguitarbite +1
17:58:12 <matjazp_> sarob: agree
17:58:19 <sarob> Coolo
17:58:37 <sarob> Anything else ?
17:59:14 <sarob> silence = acceptance
17:59:21 <sarob> Cheers people
17:59:21 <annegent_> that's all I got
17:59:27 <matjazp_> bye
17:59:30 <annegent_> thanks sarob dguitarbite matjazp_ rluethi fthamura :)
17:59:31 <rluethi> bye
17:59:31 <Guest87913> bye
17:59:31 <dguitarbite> bye
17:59:36 <fthamura> bye ;)
17:59:37 <dguitarbite> thanks for attending the meeting :)
17:59:44 <sarob> #endmeeting