17:00:42 <sarob> #startmeeting training-manuals
17:00:43 <openstack> Meeting started Mon Jun 16 17:00:42 2014 UTC and is due to finish in 60 minutes.  The chair is sarob. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:44 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:46 <openstack> The meeting name has been set to 'training_manuals'
17:01:03 <fthamura> hi all
17:01:08 <sarob> Roll call
17:01:12 <sarob> Hi
17:01:14 <rluethi> howdy
17:01:15 <fthamura> i am new in this training meeting.
17:01:18 <dguitarbite> hello
17:01:20 <fthamura> greet from indonesia, jakarta ;)
17:01:22 <matjazp> hi all
17:01:43 <matjazp> hi fthamura, welcome
17:02:27 <fthamura> hope can become part of this great work , we use your work here to teach students, and working to adopt as curriculums, and interest with certification (today meeting), so i am listening to know more..
17:02:36 <sarob> #topic stable actions
17:02:44 <dguitarbite> fthamura: good to know that
17:03:03 <dguitarbite> stable: I am working on install guide, not much work done yet
17:03:19 <dguitarbite> mostly focsing on breaking down install-guide from openstack manuals
17:03:25 <dguitarbite> I have a doubt
17:03:29 <dguitarbite> what release should we focus on?
17:03:37 <dguitarbite> that is maintain and design?
17:04:04 <sarob> Icehouse
17:04:18 <matjazp> +1 for Icehouse
17:04:20 <rluethi> agreed. icehouse. check this out: https://review.openstack.org/99942
17:04:25 <dguitarbite> ok
17:04:30 <sarob> Morning sparkycollier
17:04:32 <rluethi> sorry, wrong link
17:04:36 <dguitarbite> also, which projects should we support for training
17:04:36 <rluethi> https://wiki.ubuntu.com/ServerTeam/CloudArchive/
17:04:39 <rluethi> that one.
17:05:13 <dguitarbite> should we consider new projeccts Ceilometer and Heat?
17:05:26 <dguitarbite> as they are covered by install guide
17:05:45 <dguitarbite> I am aiming for 90% re-use atleast .. it will be very easy to maintain new projects added to OpenStack
17:05:56 <matjazp> well ceilometer and heat are nto so new projects.. so I say we include them
17:06:19 <rluethi> let's start with the core projects, see how the work out, then expand from there.
17:06:23 <dguitarbite> vote?
17:06:41 <sarob> Rluethi +1
17:06:54 <dguitarbite> dguitarbite +1
17:06:57 <matjazp> rluethi: sure, core first
17:07:23 <dguitarbite> *rluethi +1
17:08:29 <dguitarbite> anything else for stable?
17:09:06 <fthamura> we are working to translate the material, we have a step-by-step training here, based on your training-guide, any idea for me to get that, the material using indonesian language
17:09:21 <fthamura> should i work with anne for this or all of you?
17:09:35 <dguitarbite> fthamura: I think anne should give you better idea for getting started
17:09:46 <matjazp> good question... translations for training guides
17:10:10 <sarob> Fthamura you should work with tfifield on translations
17:10:16 <rluethi> the language sections are currently disabled in our tox.ini
17:10:43 <sarob> There is a translation project and team
17:10:52 <fthamura> mostly student here, using javanese language rather indonesia, 6 months ago, i gave the english, they busy using google translate, so we translate, and now we can setup openstack in 3 days, still using 12.x and workint go make 14.x and icehouse
17:10:59 <matjazp> sarob: so translation is out of scope for us?
17:11:27 <sarob> Matjazp the translation team already does it
17:11:28 <fthamura> my interest only in training transation right now, but our work still not match with all the content right now,
17:11:55 <sarob> #action sarob make sure translations continue
17:11:56 <rluethi> matjazp: I suspect it was mostly to get the repo up and running without any complex configuration.
17:11:59 <matjazp> sarob: ok so it's a separate project. cool..
17:12:00 <fthamura> will post in docs ML to ask this, i posted our work last week anyway
17:12:33 <sarob> #action sarob verify Javanese translation
17:12:40 <sarob> Good
17:12:52 <sarob> #link http://eavesdrop.openstack.org/meetings/training_manuals/2014/training_manuals.2014-06-09-17.03.html
17:13:01 <dguitarbite> fthamura: sounds good to have our content translated
17:13:06 <sarob> Take a look at your actions
17:13:07 <fthamura> sarob, we use indonesia language, the student mostly cities around java island, using javanese language
17:13:18 <sarob> Ah right
17:13:18 <fthamura> thx dguitarbite
17:13:47 <fthamura> we use our material as hackathon material here ;)
17:13:48 <sarob> #sarob verify Indonesia translation
17:14:18 <rluethi> sarob: I had a go at bug 1329567, do you know the status?
17:14:21 <sarob> #action sarob verify Indonesia translation
17:14:23 <uvirtbot> Launchpad bug 1329567 in openstack-training-guides "since the repo move, new html is not getting on docs.openstack.org" [Critical,Triaged] https://launchpad.net/bugs/1329567
17:15:03 <sarob> Doesn't look like anyone picked it up yet
17:15:16 <sarob> Hold everything for a
17:15:19 <dguitarbite> sarob: does it come under stable?
17:15:20 <sarob> Minute
17:15:21 <rluethi> I'm not sure it would work. I can't really test it.
17:15:56 <sarob> #topic sparkycollier talks training
17:16:07 <sparkycollier> hi all
17:16:13 <rluethi> hey
17:16:17 <matjazp> hi
17:16:23 <dguitarbite> hi
17:16:54 <sarob> I asked Sparkycollier to give us
17:17:06 <sparkycollier> the foundation plans to roll out a baseline certification.  we are now in the process of negotiating with 3rd party companies to help us execute that plan
17:17:07 <sarob> A foundation update
17:17:35 <dguitarbite> sparkycollier: sounds good
17:17:44 <fthamura> any idea for certification, i can become foundation hand here?
17:17:47 <sparkycollier> once we have negotiated an agreement with a 3rd party to help us with execution, we will be asking for as many subject matter experts as possible to join in the development phase
17:18:02 <fthamura> so my student can get certification
17:18:02 <sparkycollier> which will take several months.. to develop the test itself
17:18:19 <sparkycollier> the end goal is to make it possible for people all over the world to take the test and get a certification
17:18:26 <dguitarbite> sparkycollier: is the foundation targeting something like coursera?
17:18:55 <sparkycollier> we are also hiring someone to help us in this area (ecosystem manager job) see posting http://www.openstack.org/community/jobs/?foundation=1
17:19:11 <matjazp> sparkycollier: so the plan is to create a pool of questions/taska/tests that can be taken online?
17:19:23 <sparkycollier> the details are TBD but my expectation is that hte testing will be done in person at 3rd party testing centers not online
17:20:07 <sparkycollier> I hope to have more details to share in a few weeks when we are further along
17:20:33 <dguitarbite> ok
17:20:39 <matjazp> sparkycollier: can we reuse some of the questions in the pool for inclusion in training guides?
17:21:15 <sparkycollier> good question, let me look into that.
17:21:21 <matjazp> sparkycollier: of course, when we'll create our own set, we it can be also integrated into Certificate's pool
17:21:36 <sparkycollier> my thinking is that a goal of any training might be to prepare you to pass the test, among other things, including the online training you all are working on now
17:22:02 <matjazp> sparkycollier: agree
17:22:13 <dguitarbite> sparkycollier: agree
17:22:14 <sparkycollier> I would think that many people on this team will want to particpate in the test development once we kick that off
17:22:35 <matjazp> sparkycollier: sure
17:23:22 <fthamura> sound like OpenStack Ceritified Professional
17:23:29 <matjazp> sparkycollier: if the question pool is large, then there is no need for hidning the questions ;)
17:23:37 <fthamura> Redhat starts rollout this kind of certification also here
17:23:42 <sparkycollier> thanks all, I'll be happy to join the meeting again with future updates and to ask for your help :)
17:23:43 <matjazp> hinding=hiding
17:23:59 <dguitarbite> sparkycollier: thanks a lot for joining us
17:24:03 <fthamura> how this certification work with RedHat, and will we use Ubuntu as default distro?
17:24:06 <matjazp> bye
17:24:38 <sparkycollier> our expectation is that this certification will be vendor neutral and then other distro vendors may offer "add on" certifications that specialize in that particular distro
17:25:16 <fthamura> sparkycollier: i interest with this positioning, neutral, that will be awesome,
17:26:12 <sparkycollier> I think that is an important aspect
17:26:48 <dguitarbite> fthamura: foundation always maintains the balance and keeps their official projects vendor neurtal
17:27:11 <sarob> Roger that
17:27:11 <fthamura> dguitarbite: that why i love openstack movement :)
17:27:26 <dguitarbite> :)
17:27:43 <fthamura> the first open foundation that work and care about education :)
17:27:46 <sarob> Thanks for joining us sparkycollier
17:27:55 <sparkycollier> happy to!
17:28:13 <sarob> Let's move back to outstanding actions
17:28:24 <sarob> #topic stable actions
17:28:51 <dguitarbite> 1. Use install guides except where it is not possible
17:29:03 <sarob> We can continue the training cert discussion later on docs channel
17:29:26 <dguitarbite> 2. Target Fedora and CentOS along side Ubuntu
17:29:34 <dguitarbite> also makes it easier to transition for the official certification program
17:30:06 <fthamura> +1 for Fedora and CentOS
17:30:08 <sarob> Dguitarbite plan inline maven switch
17:30:22 <sarob> Like install guides?
17:30:28 <dguitarbite> yes
17:30:36 <dguitarbite> very much like install guides
17:30:49 <dguitarbite> mostly the skeleton will be ours
17:31:04 <dguitarbite> the content should be taken from install guides
17:31:21 <sarob> Okay
17:31:28 <fthamura> anyone evaluate, the syntax between distro, and make a list what different?
17:31:42 <fthamura> like apache2 structure in rpm world and deb world usually different
17:31:50 <dguitarbite> fthamura: you could start with that, may be have some thing like basics of each distro and differences
17:32:12 <dguitarbite> to make it easy to adopt for students who have little to no idea about Linux OSs
17:32:15 <fthamura> i am using ubuntu and centos, can do that in the future,
17:32:26 <rluethi> fthamura: compare the install guides, that will give you a good start
17:32:26 <fthamura> dguitarbite, right!! :)
17:33:00 <sarob> Dguitarbite update your plans in the wiki
17:33:05 <dguitarbite> yes
17:33:10 <fthamura> i think several feedback to the training, we should have a mini openstack spec to start, like 1 server, 3 server or 5 server, or 10 (ubuntu orange box)
17:33:26 <dguitarbite> sarob: another thing, should we aim to be with the current releases?
17:33:31 <dguitarbite> fthamura: we wont target Ubuntu Orange box
17:33:38 <dguitarbite> we will keep our materials vendor neutral
17:33:49 <sarob> Dguitarbite same schedule as docs to start
17:34:02 <fthamura> no, i am not target ubuntu box also, i said about 10 servers
17:34:21 <fthamura> right now, i am working with 1 server, and will move to 3 server
17:34:26 <dguitarbite> sarob: when should we get there? I think we should have some road map to get there ...
17:34:48 <fthamura> will high availability material part of training guide?
17:34:56 <sarob> Dguitarbite hmm, true.
17:34:56 <dguitarbite> fthamura: hmm, ok. Just be sure about Ubuntu box, I have not yet heard any review
17:35:05 <dguitarbite> HA may be part of Architect Guide
17:35:27 <dguitarbite> but definatly not for Associate, Operator or even Developer guide
17:35:34 <dguitarbite> HA is kind of advanced concept to start with
17:35:36 <fthamura> i steal ubuntu box idea, i bought intel nuc 10 ;) and setup on it ;) rather buy ubuntu box, 1 nuc $500 :)
17:35:44 <sarob> Dguitarbite can we match docs schedule for juno
17:35:45 <fthamura> so we can setup cheap lab for poor school
17:36:03 <sarob> Dguitarbite with stable team
17:36:13 <fthamura> ubuntu box 12000$, intel nuc 10 pcs  5000$
17:36:25 <dguitarbite> sarob: I think so, I aim to finish Ice House part by end of this month, we could start
17:36:38 <dguitarbite> Juno adoption next month onwards
17:36:42 <dguitarbite> I guess it will be on time
17:36:43 <sarob> Guys it's good to discuss details offline in the docs channel
17:37:03 <sarob> We need to talk tasks
17:37:04 <sarob> Right now
17:37:07 <dguitarbite> fthamura: lets talk about it after the meeting, we have limited time
17:37:17 <sarob> Hard stop at 11am pdt
17:37:39 <fthamura> any place to ask training thing outside this weekly? doc ML is not the place.. can we have training@openstack.org ML dedicated, so student can discuss and ask material there
17:38:03 <sarob> #action dguitarbite stable team plans for matching docs team release cycle
17:38:20 <sarob> Docs ML is the place
17:38:44 <sarob> As well as #openstack-docs channel
17:39:02 <dguitarbite> #action dguitarbite update stable team plans on Wiki Page
17:39:11 <sarob> Moving on
17:39:26 <sarob> #topic development actions
17:40:13 <sarob> Comcast guys introduced to dguitarbite
17:40:41 <dguitarbite> sarob: are they not attending the meeting?
17:40:49 <dguitarbite> or they missed it somehow
17:40:53 <sarob> Doesn't look like it
17:40:55 <MeganR> Hi, Scott and I are on
17:41:06 <sarob> Sweet
17:41:12 <MeganR> Shilla will not be able to attend today
17:41:14 <sarob> Hi meganr
17:41:18 <sarob> Np
17:41:26 <dguitarbite> MeganR: hello
17:41:33 <rluethi> megan_w: hi
17:41:36 <ZucanGK> Hello :)
17:41:42 <ZucanGK> (I'm Scott)
17:41:42 <dguitarbite> ZucanGK: hello
17:42:21 <rluethi> hey
17:42:22 <matjazp> hi MeganR, ZucanGK
17:42:34 <MeganR> Hi, we are getting up to speed and look forward to helping out
17:43:04 <sarob> Zucangk meganr welcome
17:43:27 <dguitarbite> ok, just reach out to me, rluethi anytime on IRC openstack-doc or on email, mailing list
17:43:28 <sarob> Real quick I will finish up
17:43:32 <dguitarbite> we are happy to help you guys out
17:43:37 <dguitarbite> sarob: yep
17:43:42 <sarob> I posted a spec https://review.openstack.org/#/c/99724/
17:43:42 <MeganR> sounds great, thank you
17:44:03 <sarob> I'll work on proper word wrapping
17:44:15 <sarob> More Dev specs today
17:44:35 <sarob> #topic testing action
17:44:57 <matjazp> 1. we still haven't resolved the Moodle usage..
17:45:14 <matjazp> so I will make a spec for it
17:45:20 <sarob> Matjazp good
17:45:32 <sarob> Matjazp update the wiki with your plans
17:45:36 <fthamura> can i see the moodle? where is the URL , and how to join?
17:46:03 <sarob> Matjazp anything else task wise?
17:46:10 <matjazp> 2. questions are sliced for 4 Guides... no need to slice them further for topics inside guides?
17:46:19 <dguitarbite> fthamura: we have not hosted it, I can help you out with Moodle's links http://moodle.com/
17:46:23 <matjazp> what do you think?
17:46:38 <sarob> Matjazp agreed
17:46:55 <dguitarbite> matjazp: would be really good for topic wise slicing of the questions
17:46:55 <matjazp> sarob: ok, will make it into specs
17:47:06 <sarob> Moving on
17:47:15 <matjazp> #action sparkycollier will look into reusing questions for Certification program for Training guides
17:47:24 <sarob> #topic infrastructure actions
17:47:58 <dguitarbite> rluethi and I have been working hard to get the infrastructure up
17:48:08 <dguitarbite> rluethi: wanna pitch in?
17:48:29 <rluethi> uploading is going slowly, but we hope to have the scripts up later this week.
17:48:44 <sarob> Rluethi dguitarbite irc bouncer?
17:48:47 <rluethi> I hit a little snag, though.
17:48:58 <rluethi> hosting of preseed/kickstart files.
17:49:10 <rluethi> Ubuntu 12.04 needs http, not https.
17:49:19 <rluethi> github raw files are only https.
17:49:21 <matjazp> rluethi: I can host at Arnes..
17:49:47 <sarob> Update the wiki with the details floating around
17:49:55 <rluethi> openstack git works, I tested it. is there a policy against serving files from there?
17:50:00 <sarob> I'm lost on scripting status
17:50:04 <rluethi> (it's not much traffic, a few small files)
17:50:11 <dguitarbite> rluethi: SSL offloading?
17:50:35 <rluethi> huh?
17:51:04 <sarob> Don't forget git.openstack.org mirrors github
17:51:05 <rluethi> it's just that the old Ubuntu/Debian installer can't grab a config file through https.
17:51:08 <dguitarbite> rluethi: SSL offloading -- converts https to http and vice versa
17:51:11 <clarkb> rluethi: yes please use git.openstack.org
17:51:18 <clarkb> github is known for not being very reliable
17:51:41 <rluethi> sarob: if I can use git.openstack.org, there's no problem, because it offers http downloads.
17:52:05 <rluethi> okay, will do. we can still change the URLs later.
17:52:07 <sarob> Rluethi yup use that
17:52:23 <rluethi> matjazp: thanks!
17:52:24 <sarob> Irc bouncer?
17:52:47 <sarob> Only a few minutes left
17:53:04 * annegentle waves
17:53:06 <rluethi> sarob: I was wondering about that, too. who would host the bouncer?
17:53:15 * rluethi waves back
17:53:17 * sarob waves back
17:53:21 <rluethi> hi anne.
17:53:27 <dguitarbite> sarob: I need to work on that, I was waiting for decision for openstack-training IRC channel. Since we decided not to use it
17:53:27 <annegentle> I read thru the log, just wanted to say hi
17:53:33 <matjazp> hi annegentle
17:53:37 <dguitarbite> annegentle: hello
17:53:55 <sarob> We are going to use #openstack-docs
17:54:07 <matjazp> sarob: do we still need irc bouncer if we use docs channel?
17:54:10 <sarob> Until we get too noisey
17:54:19 <fthamura> +1 for the openstack-training manual, so we have a room for training focus chat, can bring student there and interact with people
17:54:24 <dguitarbite> sarob: yep, was waiting for that, could not get time after that, do we still need IRC bouncer?
17:54:25 <sarob> Yes it's for our clients
17:54:30 <sarob> Not server
17:54:31 <fthamura> +1 openstack-training channel .
17:54:48 <annegentle> dguitarbite: the bouncer lets you catch up even when you're away from the channel
17:54:57 <sarob> Yup
17:55:12 <dguitarbite> annegentle: yep, I got that ...
17:55:23 <sarob> I'll catch up on bouncer with you guys later
17:55:27 <dguitarbite> sarob: any leads on where to start for setting it up?
17:55:35 <annegentle> fthamura: I think students would have a better experience in #openstack or on ask.openstack.org, the regular support channels, would you agree? Or have you seen otherwise?
17:55:35 <dguitarbite> or should I talk to the infra team for setting it up
17:55:37 <rluethi> sarob: znc still needs to run on some sort of server.
17:56:06 <sarob> We can use my Bluehost acct
17:56:07 <dguitarbite> rluethi: I guess infra team will provide the ZNC server for us
17:56:23 <dguitarbite> sarob: sounds good
17:56:24 <sarob> And or talk to infra team
17:56:31 <rluethi> dguitarbite: well, if they do: +1
17:56:35 <fthamura> annehgentle: yup just start to use ask.openstack.org. i try to list all the media to interact and exp if we have exam question, they can discuss there
17:56:35 <sarob> Let's start with Bluehost
17:56:40 <dguitarbite> yep, if the infra team is generous it would be awesome
17:56:46 <dguitarbite> ok
17:56:58 <dguitarbite> sarob: just shoot me the details later
17:57:05 <annegentle> fthamura: good, better to train them early on the official channels
17:57:07 <sarob> Ask is a good place for learning
17:57:21 <fthamura> annegentle: tx
17:57:25 <sarob> #topic other business
17:58:06 <sarob> So let's get the stable team new contributors working on creating bugs
17:58:15 <sarob> First focus
17:58:56 <sarob> Then as stable starts working bugs as
17:59:11 <sarob> Soon as you feel you are ready
17:59:11 <sarob> Team
17:59:14 <sarob> Wise
17:59:25 <sarob> Critical bugs fix immediately
17:59:48 <sarob> Sound like plan?
17:59:55 <matjazp> sarob: update wiki :)
17:59:58 <dguitarbite> yes
18:00:06 <sarob> Cool
18:00:09 <sarob> We are done
18:00:22 <dguitarbite> ill get them started
18:00:24 <rluethi> just in time
18:00:33 <sarob> Thanks people !
18:00:39 <sarob> #endmeeting