17:03:10 <sarob> #startmeeting training-manuals
17:03:11 <openstack> Meeting started Mon Jun  9 17:03:10 2014 UTC and is due to finish in 60 minutes.  The chair is sarob. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:03:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:03:14 <openstack> The meeting name has been set to 'training_manuals'
17:03:23 <dguitarbite> rollcall
17:03:33 <matjazp> hi all
17:03:36 <rluethi> hey
17:03:39 <dguitarbite> hello
17:04:01 <sarob> Morning/evening
17:04:08 <dguitarbite> gday
17:04:29 <sarob> Let's start with the leads and get updates
17:04:45 <sarob> #topic stable update
17:05:27 <sarob> rl or dguitarbite?
17:05:47 <sarob> Wait sorry just
17:05:52 <dguitarbite> I believe I am the lead
17:05:53 <sarob> Dguitarbite
17:05:54 <dguitarbite> sorry my bad
17:06:02 <sarob> Nope I'm
17:06:11 <sarob> Still getting used to change
17:06:28 <sarob> Dguitarbite your floor
17:06:31 <dguitarbite> yep
17:06:40 <dguitarbite> well, I guess we could not work at all because the repo folder is frozen
17:07:01 <dguitarbite> still working on labs and install guide scetion
17:07:02 <dguitarbite> *section
17:07:15 <sarob> annegentle responded to the thread
17:07:19 <dguitarbite> but could not push any changes at al
17:07:20 <dguitarbite> l
17:08:07 <sarob> So I'm hoping to get the stackforge patch through today
17:08:25 <rluethi> that one? https://review.openstack.org/#/c/96334/
17:08:44 <sarob> First patch will be to move the training content
17:08:48 <sarob> Yup that one
17:08:49 <dguitarbite> kool
17:09:16 <sarob> I have asked annegentle to add to the review
17:09:40 <dguitarbite> nice
17:09:45 <dguitarbite> do you need +1's there?
17:10:04 <sarob> Feel free to add to the review
17:10:24 <dguitarbite> kool
17:10:28 <sarob> Remember this is new ground
17:10:40 <sarob> So infra is a bit wary
17:10:47 <sarob> Understandable
17:10:48 <dguitarbite> yes, I can understand
17:11:10 <dguitarbite> we may touch 3-4 projects atleast for the testing part
17:11:22 <dguitarbite> as we need to validate shell scripts, puppet/python (in near future)
17:11:25 <dguitarbite> n xml
17:11:35 <dguitarbite> may be even vagrant, etc.
17:11:43 <sarob> Right
17:12:08 <sarob> You think we should just use the same tests for our repo?
17:12:13 <sarob> To start
17:13:28 <rluethi> For the manuals, it would make sense. For code, openstack-manuals didn't have much.
17:13:37 <dguitarbite> yep
17:14:01 <dguitarbite> I think we can even plan to update the test-cases for other repos to tweak n add our bits in there
17:14:03 <dguitarbite> if required
17:14:22 <dguitarbite> dont need to re-invent the wheel, and also overburden our tiny set of contributors
17:14:59 <sarob> Go ahead and add in plans to stable subsection of the wiki
17:15:02 <dguitarbite> rluethi: its totally up to us now, how to design n implement n stuff
17:15:07 <sarob> It's your part
17:15:10 <rluethi> Testing in other projects is very much focused on Python. A bit sphinx, docbook, too.
17:15:30 <rluethi> devstack has still an open bug to use the bash8 package.
17:15:31 <dguitarbite> rluethi: yeah, devstack's coming up with bash8
17:15:43 <dguitarbite> we can re-use and help them build that
17:15:46 <dguitarbite> along side
17:15:49 <dguitarbite> what do you think?
17:16:16 <dguitarbite> *along with our usecases
17:16:18 <rluethi> I think we should use the opportunity to try something in our repo. Then we can offer it to others.
17:16:32 <rluethi> Unless they are faster, then we copy them.
17:16:41 <rluethi> Seems unlikely right now.
17:17:04 <rluethi> https://bugs.launchpad.net/devstack/+bug/1320535
17:17:05 <uvirtbot> Launchpad bug 1320535 in devstack "DevStack should use new bash8 pypi package" [Undecided,New]
17:17:08 <dguitarbite> rluethi: if they are faster, I suggest that we should use their stuff instead of copying
17:17:13 <sarob> #action infra team to explore new tests
17:17:17 <dguitarbite> otherwise, I agree
17:17:29 <rluethi> with copying, I mean tox.ini or whatever will be used.
17:17:39 <dguitarbite> sure
17:17:56 <sarob> #action sarob move over content to stackforge training-guides repo
17:18:19 <sarob> So blueprints
17:18:23 <sarob> And spec
17:18:42 <sarob> I'd like to stop using trello
17:18:56 <sarob> And start using spec and blueprints
17:18:58 <dguitarbite> #action dguitarbite update training-manuals wiki with the recent changes, sub-groups and their leads
17:19:05 <dguitarbite> sorry, continue
17:19:20 <dguitarbite> +1
17:19:24 <sarob> Wiki mostly updated, but have at it
17:19:30 <sarob> np
17:19:31 <dguitarbite> ok
17:19:33 <matjazp> sarob: agree
17:19:39 <dguitarbite> sarob: agree
17:19:48 <sarob> Cool
17:20:00 <rluethi> sarob: agree
17:20:24 <sarob> #action sarob will create spec subdir
17:20:55 <sarob> #action training team will start following the spec to blueprints process
17:21:23 <sarob> #action trello use will be discontinued
17:21:50 <sarob> Ready to move on to testing?
17:21:54 <matjazp> sarob: change should be announced to others on Trello
17:22:03 <sarob> Agreed
17:22:34 <dguitarbite> matjazp: +1
17:22:42 <sarob> #action sarob will announced trello discontinue on docs ML and trello
17:23:15 <matjazp> testing: I've been wondering...how is our testing connected to openstack certifications? no connection?
17:23:23 <sarob> #topic testing update
17:23:37 <sarob> Hmm, good question
17:23:48 <sarob> Right now it's not
17:23:57 <matjazp> but we want it to be?
17:24:35 <sarob> Since I'm on the board, I need to tread lightly here
17:25:05 <dguitarbite> matjazp: we may use those tests for providing certificates in future
17:25:17 <dguitarbite> matjazp: not sure as of now, but theres a good chance in future
17:25:20 <sarob> Mark collier is developing the foundation plan
17:25:31 <matjazp> sarob: how far are they
17:25:41 <sarob> It would be great if our work helped that effort
17:25:59 <sarob> I can ask him to join us next week and discuss
17:26:43 <dguitarbite> sarob: ok, we might be able to contribute a few ideas
17:26:43 <sarob> #action sarob invite mark collier to next meeting to discuss status of foundation training certification
17:26:46 <matjazp> sarob: sure... but generally speaking... nothing is decided jet about it, right? not even if there will be certifications?
17:27:09 <sarob> Matjazp probably so
17:27:32 <sarob> Matjazp haven't discussed for about month
17:28:36 <sarob> anything else?
17:28:51 <rluethi> related to testing?
17:28:53 <matjazp> nope
17:28:54 <dguitarbite> well, we need a party this summit
17:29:10 <dguitarbite> sarob: what do you say?
17:29:21 <sarob> umm
17:29:42 <sarob> Anything more about testing?
17:29:49 <rluethi> no. but something else.
17:30:21 <sarob> Matjazp can you update the state and plans for the testing subgroup?
17:30:33 <sarob> On the wiki
17:31:22 <matjazp> sarob: ok.. will do
17:31:35 <sarob> #action dguitarbite update wiki stable state and plans
17:32:10 <sarob> #action matjazp update wiki testing state and plans
17:32:32 <sarob> #topic development update
17:33:13 <sarob> I have a couple of people from comcast
17:33:16 <sarob> Joining
17:33:17 <sarob> Us
17:33:27 <dguitarbite> sarob: sounds really good
17:33:34 <sarob> I'm starting to train them today
17:33:52 <sarob> Intel is slowly coming around
17:34:18 <sarob> It probably will be two weeks before I get a name
17:34:38 <sarob> Redhat, hp, and Rackspace are maybes
17:34:49 <dguitarbite> well, good enough time for us to get comfy on new ground
17:34:52 <sarob> One step at a time
17:34:58 <sarob> True
17:35:52 <sarob> I'm itching to get Dev guide going but the incubation work is priority
17:36:42 <sarob> #info comcast new devs being trained this week. They will join the meeting next week.
17:37:10 <sarob> #topic infrastructure update
17:38:04 <dguitarbite> repo folder locked down, could not get any code pushed, rluethi has done some work on training-labs
17:38:26 <rluethi> so far, scripts used VirtualBox guest additions for installation.
17:38:28 <dguitarbite> we will push it as soon as we get access to the new repo on stackforge (or where ever it will be placed)
17:38:32 <sarob> I moved one blueprint to training-guides
17:38:35 <rluethi> that is necessary on windows;
17:38:40 <sarob> Other I left under devstack
17:38:43 <dguitarbite> sarob: which one?
17:38:51 <dguitarbite> training-labs?
17:39:02 <sarob> Yup, from docs
17:39:17 <sarob> Just organizing
17:39:36 <dguitarbite> sarob: yeah, that time training-labs was incubated. Thanks for moving it
17:39:49 <sarob> np
17:41:34 <dguitarbite> sarob: have another question ... any ground rules for the new repository?
17:42:09 <sarob> #action rluethi, dguitarbite update wiki infra section
17:42:46 <sarob> Dguitarbite like what?
17:43:04 <dguitarbite> like, as core-reviewers
17:43:14 <dguitarbite> any specific guidelines
17:43:32 <dguitarbite> or we gotta design that too?
17:44:34 <sarob> Yeah, our repo, our rules
17:44:54 <sarob> I'd say each lead as core reviewer to start
17:45:16 <sarob> Adding Colin as core reviewer
17:45:40 <dguitarbite> yep
17:45:44 <sarob> Core reviewers get notified of each patch
17:46:10 <rluethi> how do we coordinate? especially in the beginning, a weekly IRC meeting will not be enough. ML?
17:46:33 <sarob> I'd like to use docs ML for now
17:46:38 <rluethi> sarob: ok
17:46:53 <sarob> We can breakout if we create too much noise
17:46:53 <dguitarbite> sarob: can we host our own IRC channel?
17:47:22 <annegentle_> hi sarob dguitarbite rluethi catching up
17:47:32 <rluethi> hey!
17:47:43 <sarob> #openstack-training-guides channel, same as repo sounds good
17:47:49 <annegentle_> dguitarbite: yep, you just patch one of the openstack-infra repos to get your own irc channel
17:48:03 <dguitarbite> annegentle_: hello
17:48:06 <annegentle_> sarob: I wrote back on the review and mailing list threads
17:48:07 <dguitarbite> annegentle_: sure thing
17:48:19 <annegentle_> and agreed on using the openstack-docs ML
17:48:23 <sarob> annegentle_ got it thx
17:48:27 <annegentle_> I think there's plenty of crossover interests
17:48:43 <annegentle_> any questions feel free to ask
17:49:36 <rluethi> One concern I have: how much are the scripts supposed to be training material?
17:49:39 <sarob> #action training infra team patch Openstack infra for creating, logging channel #openstack-training-guides
17:50:15 <rluethi> The doc team doesn't like manuals that use non-core tools (i.e. debian's preseed).
17:50:28 <rluethi> but if we use devstack, that's pretty much what we're doing.
17:50:34 <sarob> dguitarbite have you
17:50:40 <rluethi> the scripts will install, but they won't be readable.
17:50:47 <annegentle_> rluethi: thinking
17:50:54 <sarob> dguitarbite znc before?
17:51:05 <annegentle_> rluethi: I think the idea of having scripts for anyone to set up a training labs is flat-out awesome.
17:51:17 <annegentle_> rluethi: but other training groups haven't used devstack
17:51:18 <dguitarbite> znc?
17:51:20 <annegentle_> and I'm not entirely sure why
17:51:35 <sarob> dguitarbite irc bouncer
17:51:41 <matjazp> rluethi: but scripts can be manuals too... I sometimes read devstack :)
17:51:49 <annegentle_> matjazp: for sure
17:52:01 <rluethi> devstack is hard to read for the uninitiated.
17:52:09 <sarob> dguitarbite I'd like to make required for core reviewers
17:52:12 <annegentle_> rluethi: I think that at Rackspace the "all in one" nature of devstack made it not realistic enough
17:52:17 <rluethi> they have generic commands like install_package.
17:52:36 <annegentle_> rluethi: so I'd lean towards more realistic labs
17:52:36 <dguitarbite> sarob: sure thing
17:52:41 <dguitarbite> sarob: action?
17:53:05 <sarob> dguitarbite you want to take on setting it up?
17:53:13 <dguitarbite> sarob: yep
17:53:27 <dguitarbite> annegentle_: one doubt, is it worthwhile getting devstack tuned to our requirements or just keep our scripts ready to be used?
17:53:30 <rluethi> we are using some of devstack's functions already, but the question is, how far do we want to go?
17:53:41 <dguitarbite> *keep separate copy of our scripts
17:53:50 <sarob> #action infra team set irc bouncer znc for the training team whole
17:54:24 <sarob> #action training team core reviewers need to use irc bouncer
17:54:55 <sarob> Time check
17:55:31 <sarob> you guys keep discussing
17:55:44 <dguitarbite> ok
17:55:46 <sarob> We will need to move it to the docs channel
17:56:07 <sarob> #topic any other business
17:56:08 <annegentle_> dguitarbite: hm, good question
17:56:29 <annegentle_> We can keep chatting in openstack-doc
17:57:30 <matjazp> I'll have to go guys... see you next week... just update wiki with stuff that you decide, and I'll read it later
17:57:36 <dguitarbite> matjazp: see ya
17:57:41 <rluethi> bye
17:57:53 <sarob> Dguitarbite annegentle_ why don't we just use #openstack-docs instead of creating a new training channel?
17:58:11 <sarob> matjazp see you later
17:58:59 <sarob> I'd rather keep the docs team in the loop the maximum amount
17:59:06 <dguitarbite> sarob: lets conti. on docs channel
17:59:20 <annegentle_> sarob: you sure could
17:59:22 <sarob> Until we become too noisy
17:59:26 <annegentle_> sarob: yah
17:59:32 <sarob> Cool
18:00:23 <sarob> #action rescind new channel action above
18:00:31 <sarob> Done
18:00:35 <sarob> And done
18:00:39 <sarob> Good meet
18:00:45 <sarob> Training out
18:00:53 <sarob> #endmeeting