17:00:04 <sarob> #startmeeting training-manuals
17:00:05 <openstack> Meeting started Mon Apr 28 17:00:04 2014 UTC and is due to finish in 60 minutes.  The chair is sarob. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:06 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:08 <openstack> The meeting name has been set to 'training_manuals'
17:00:40 <sarob> Roll call
17:01:58 <sarob> -
17:03:13 <sarob> Roll call
17:04:49 <sarob> -
17:06:45 <sarob> Roll call
17:08:16 <sarob> -
17:09:28 <rl> I'm here. You invited me to attend a few days ago.
17:09:58 <sarob> Great
17:10:37 <sarob> Did you take look at the wiki
17:10:49 <rl> which part?
17:11:07 <sarob> Training manuals wiki
17:11:08 <rl> oh, training-manuals. duh
17:11:12 <rl> :-)
17:11:27 <rl> yes, i did
17:11:44 <sarob> Trello
17:11:56 <rl> that, too.
17:12:15 <sarob> Thoughts
17:12:39 <rl> I am currently mostly interested in the training-labs scripts.
17:12:53 <sarob> Excellent
17:12:57 <rl> one thing I noticed is that IP addresses in the docs are all over the place.
17:13:31 <rl> If you want to reuse the docs, it might help if you had conventions for IP subnets for, say, data networks etc.
17:14:02 <rl> also, I am curious what platform the scripts are supposed to use, going forward.
17:14:18 <rl> ubuntu 12.04 with grizzly won't last forever.
17:14:29 <sarob> Good points all
17:15:02 <sarob> The best way to log your ideas on existing material
17:15:15 <sarob> Is to log a bug
17:15:21 <rl> Some docs have contain special characters: mostly nbsp, some soft-hypen.
17:15:35 <sarob> On each major point
17:15:38 <rl> Maybe we should have some scripts to check for those.
17:15:50 <rl> Okay, can do.
17:15:53 <sarob> Check on IP?
17:16:08 <rl> IP?
17:16:21 <sarob> Once you have a bug and the URL
17:16:52 <sarob> You can use that to get comments and summit a patch on the bug
17:17:32 <sarob> #moodle integration with infra over oauth2 outstanding
17:18:04 <sarob> #info moodle integration with infra over oauth2 outstanding
17:18:32 <sarob> Got any other questions
17:19:15 <sarob> #info LPI and other new partners will be joining the team
17:19:37 <rl> So I file bug reports to do surveys?
17:19:56 <sarob> Hmm survey?
17:20:07 <rl> For instance, which distro to use.
17:20:19 <sarob> Ah
17:20:19 <rl> Whether IP subnets should be standardized.
17:20:45 <dguitarbite> hello
17:20:51 <sarob> On IP I'd say propose a IP standard
17:20:54 <dguitarbite> sorry I drifted out
17:21:01 <sarob> No problem
17:21:19 <annegentle> rl: sarob: one thing I think Matt Kassawara asked on the openstack-docs mailing list is if the training guides could follow install guide conventions
17:21:19 <rl> Okay.
17:21:37 <annegentle> rl: are you familiar enough to take a look at the install guide diagrams and see if that's a fit?
17:21:44 <dguitarbite> rl: we could work on the scripts ... many changes to be made
17:21:57 <sarob> Annegentle: I'll take a look
17:22:07 <rl> dguitarbite: indeed
17:22:20 <dguitarbite> annegentle: I think it would be perfect for training manuals installation section
17:22:33 <rl> annashen: i can take a look, too
17:22:36 <sarob> annegentle: I have been stretched a thin lately
17:23:03 <dguitarbite> may be I could propose some additional changes for Vitual Box conventions there too.
17:23:30 <dguitarbite> also the installation section under Training Manuals can be good replacement for Basic Install Guide
17:23:30 <sarob> annegentle: I'm working on partners so we have better coverage
17:24:03 <sarob> dguitarbite yup, needs some tlc
17:24:37 <annegentle> sarob: rl: Oh, looking at http://lists.openstack.org/pipermail/openstack-docs/2014-March/003999.html he was actually trying to see if trainees could just use the install guide rather than scripts.
17:25:02 <annegentle> scripts have their place but trainees should definitely use the install guides if they can
17:25:21 <sarob> annegentle scripts are for the trainer not the trainee
17:25:22 <dguitarbite> the scripts are for setting up the lab environment using VirtualBox
17:25:32 <dguitarbite> so the trainer saves time
17:25:54 <annegentle> dguitarbite: ah got it
17:26:16 <annegentle> at Rackspace we didn't find networking robust enough with VMs
17:26:17 <rl> it could also be useful in other cases to have a standardized set up so readers can play along while reading manuals
17:26:27 <dguitarbite> I think the Install Guide is a bit complex for Trainees to start using it. We are talking about people having no experience (freshers) who could be joining the training
17:27:05 <sarob> annegentle: I'd love to get active participation from Rackspace on training project
17:27:09 <annegentle> agreed: it's a balancing act
17:27:10 <dguitarbite> annegentle: Networking works with VMs. DHCP works fine, some issues arise due to Virtualization Over head.
17:27:40 <annegentle> sarob: their trainers tend to rely on the docs and prefer to improve those
17:27:50 <annegentle> sarob: like the Security Guide and Ops Guide
17:27:51 <rl> annegentle: vbox had more networking problems than others, in my experience, but it's cross-platform
17:28:16 <sarob> I thought that's what we are doing too
17:28:29 <annegentle> sarob: and install guide
17:28:37 <sarob> Just structuring
17:28:42 <sarob> As training
17:29:05 <dguitarbite> may be I have to refactor the virtualbox section, but I have the VMs running from Grizzly RC1. At Aptira we have used virtualbox extensively for commercial training.
17:29:20 <annegentle> sarob: agreed, but you're seeing where there are difficulties (VirtualBox refactoring) -- that's all I'm saying, we likely violently agree
17:29:47 <sarob> Annegentle: what's the latest thoughts on training become a separate project?
17:30:07 <sarob> Should I bring up at a TC meet?
17:30:39 <sarob> Do you think we are ready?
17:32:06 <annegentle> sarob: I'd like to get you all into a separate repo and see how you do with reviews
17:32:21 <annegentle> sarob: that's what the TC will look for -- the team deliverables and make-up of team members
17:32:40 <sarob> Okay
17:32:43 <annegentle> sarob: so an interim would be a separate repo if that's amenable to you all
17:33:20 <dguitarbite> ok
17:33:22 <sarob> Sound reasonable
17:33:28 <annegentle> sarob: there may be other considerations but I think that's a good path
17:34:10 <sarob> I'll chk with mark
17:34:17 <annegentle> sarob: then we can look at http://git.openstack.org/cgit/openstack/governance/tree/reference/incubation-integration-requirements -- I still house a bit of a concern with duplication
17:34:22 <sarob> Before pull trigger
17:34:26 <annegentle> house? Not sure that's a term :)
17:34:51 <sarob> ?
17:35:04 <annegentle> sarob: and let's shop the idea further on the TC, since I'm just one pair of eyes
17:35:26 <sarob> Right
17:35:41 <dguitarbite> annegentle: can we reuse material from other repos? Is that possible?
17:36:02 <sarob> If still use includes
17:36:08 <sarob> I'd
17:36:55 <dguitarbite> ok, then I think we can continue reusing and contributing to the common folder under manuals to reduce repetition
17:37:00 <annegentle> dguitarbite: yep we do that with links to the git mirror
17:38:07 <annegentle> dguitarbite: ayup
17:39:07 <sarob> annegentle so we will discussion a new repo and TC incubation req
17:39:46 <annegentle> sarob: I don't have a Summit session left, where/how would you like to shop the idea?
17:40:10 <sarob> #action sarob will discuss a new repo and TC incubation req
17:40:15 <sarob> Hmm
17:40:36 <sarob> Let me talk to mark first
17:41:05 <annegentle> sarob: sure
17:41:05 <sarob> I want to sync his plans with ours
17:41:10 <annegentle> yeah makes sense
17:42:20 <sarob> #action sarob work out training project next steps with mark
17:42:46 <dguitarbite> annegentle: can you guide us to set up Conventions Document and how to get Manuals team to contribute to it? Should I just create a wiki and pass that link around or just add another page inside training manuals?
17:42:47 <sarob> Soooo present team members
17:44:47 <annegentle> dguitarbite: thinking... what are examples of difference between Documentation/Conventions and TrainingManuals/Conventions?
17:45:14 <annegentle> sorry sarob don't want to get off your agenda!
17:45:22 <sarob> Np
17:45:26 <dguitarbite> hmm... we need to Virtual Box section
17:45:35 <annegentle> #link https://wiki.openstack.org/wiki/Documentation/Conventions
17:45:38 <dguitarbite> *add
17:46:02 <rl> dguitarbite: what should be in that section?
17:46:25 <dguitarbite> and also for some conventions for shell scripts
17:46:32 <annegentle> dguitarbite: I'd say just add to the specific "Guide Conventions" section with a Training Manuals section
17:46:39 <dguitarbite> rl: mostly how to present the adapters and ip addresses
17:47:03 <dguitarbite> annegentle: ok
17:47:07 <annegentle> rl: for example, the Operations Guide follows O'Reilly style (the biggest difference being sentence cap for OpenStack and Title Cap for O'Reilly)
17:47:30 <annegentle> dguitarbite: I think that's a good placement, adding to the Conventions wiki page
17:48:15 <sarob> Sounds right to me
17:48:34 <dguitarbite> okey, sounds good
17:49:46 <sarob> Anything else people?
17:50:23 <dguitarbite> we need to identify repeating content
17:50:26 <sarob> I need to catch up on trello activity offline
17:50:54 <sarob> Dguitarbite duplicate?
17:51:01 <dguitarbite> yeah duplicates
17:51:17 <dguitarbite> loads of content can be reused
17:51:50 <dguitarbite> I will also work on some good way to try and re-use install-guide as much as possible
17:51:55 <sarob> True
17:52:12 <sarob> That's our goal
17:52:31 <sarob> Tighter coordination with the install guide team
17:52:40 <dguitarbite> yeah
17:52:42 <sarob> Is what we need to execute on
17:53:09 <dguitarbite> #action dguitarbite work on reusing install guide (tigher coordination with install guide)
17:53:43 <dguitarbite> #action dguitarbite and rl work on Shell Scripts (for IceHouse & Juno)
17:53:54 <rl> ack
17:54:36 <sarob> Good stuff
17:54:39 <dguitarbite> rl: which is the best way to communicate with you? We might need to collaborate a bit more, may be some pair-programming
17:54:55 <dguitarbite> sarob: yeah :)
17:55:28 <rl> dguitarbite: what would you prefer?
17:55:56 <dguitarbite> hangouts or skype?
17:56:35 <rl> I have yet to try hangouts. let's do skype then for now.
17:57:06 <rl> IRC works for me, too, of course.
17:57:23 <sarob> Thx dguitarbite. Teaming up to teach is what this effort is all about
17:58:30 <dguitarbite> sarob: welcome :), I guess I experienced the importance of high bus factor
17:58:40 <sarob> ;)
17:58:46 <dguitarbite> :D
17:58:58 <sarob> Let's wrap this one up
17:59:13 <dguitarbite> yep
17:59:16 <sarob> Tweet me at @sarob or irc for more
17:59:24 <sarob> Before the next meet
17:59:45 <sarob> #endmeeting