17:01:16 <sarob> #startmeeting training-manuals
17:01:16 <openstack> Meeting started Mon Dec 30 17:01:16 2013 UTC and is due to finish in 60 minutes.  The chair is sarob. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:17 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:19 <openstack> The meeting name has been set to 'training_manuals'
17:01:48 <sarob> I have news on publishing
17:02:05 <sarob> Whatcha you got?
17:03:04 <colinmcnamara> well
17:03:26 <colinmcnamara> either being productive or not productive
17:03:36 <colinmcnamara> but it may be relevant to training-guides
17:03:49 <colinmcnamara> you go first
17:03:56 <sarob> Sure
17:04:13 <sarob> #topic publishing
17:04:34 <sarob> I worked out the plan
17:05:12 <sarob> We will keep a single repo location,
17:05:37 <sarob> Rather branch of master
17:06:22 <sarob> Publish to http via docs.openstack.org/training-guides
17:06:50 <sarob> I'll add a redirect for training as well
17:07:42 <sarob> Andreas should have the yaml files updated today
17:07:49 <colinmcnamara> cool
17:07:49 <sarob> For the FTP moves
17:08:34 <colinmcnamara> the publishing job in the CI system?
17:08:37 <sarob> I'll update the index, redirect,
17:08:44 <sarob> Right
17:09:35 <sarob> #topic quizzes
17:10:08 <sarob> I'll finish the patch with Ed's quiz questions
17:10:09 <sarob> Today
17:10:35 <sarob> Dguitarbyte here?
17:10:36 <colinmcnamara> k
17:11:31 <sarob> #action sarob publish ehorley quiz questions today
17:12:16 <sarob> #action dguitarbyte needs to update us on moodle hosting design
17:12:29 <sarob> Anything else?
17:13:02 <sarob> #topic active contributors
17:13:14 <colinmcnamara> yeah
17:13:40 <colinmcnamara> so, I have to say. If I never see a bug in docbooks xml again I'll be happy
17:13:50 <colinmcnamara> so, over this weekend
17:13:52 <sarob> I'd like to post the monthly active contributors to help promote
17:14:00 <colinmcnamara> agreed
17:14:05 <colinmcnamara> so, I've been working on something
17:14:11 <colinmcnamara> that addresses a few issues
17:14:17 <sarob> Cool
17:14:21 <colinmcnamara> 1. without oxygen, really can't write for training-guides
17:14:34 <colinmcnamara> 2. docbooks xml is a pain in the but, even with oxygen
17:14:54 <colinmcnamara> 3. still have to integrated with the openstack -docs toolchain
17:14:57 <sarob> Sure
17:15:02 <colinmcnamara> the background is
17:15:10 <colinmcnamara> I signed up to write a chapter for an O'reilly book
17:15:19 <colinmcnamara> and they are basically the king of docbooks
17:15:20 <sarob> Cool
17:15:30 <colinmcnamara> and then switched over to a new system instead of oxygen
17:15:35 <colinmcnamara> to generate the docbooks xml files
17:15:52 <sarob> I'm very interested
17:16:11 <colinmcnamara> so, they use a toolchain similar to what the redhat jboss team (and publican if you remember the demo)
17:16:20 <colinmcnamara> that takes a markdown format called asciidoc
17:16:21 <sarob> Yup
17:16:24 <colinmcnamara> which is super f'n simple
17:16:27 <colinmcnamara> human readable
17:16:32 <colinmcnamara> no xml
17:16:57 <colinmcnamara> they basically have a translator that goes from docbooks to asciidoc and back again
17:17:15 <colinmcnamara> sooo
17:17:30 <colinmcnamara> I've been experimenting in a place where I won't rock the boat
17:17:37 <colinmcnamara> and creating
17:17:39 <colinmcnamara> a workflow
17:17:50 <colinmcnamara> where you write in AsciiDOc
17:18:01 <colinmcnamara> then mvn tranlates to docbooks
17:18:14 <colinmcnamara> and then it fits right into the normal openstack asciidoc toolchain
17:18:44 <colinmcnamara> I'm doing it for OpenDaylight OVSDB. which will be used as the reference SDN controller for nuetron
17:18:59 <colinmcnamara> basically making it so all their docs will be able to be integrated into the openstack docs
17:19:03 <sarob> Could we develop using asciidoc, patch with xml
17:19:07 <colinmcnamara> yup
17:19:09 <colinmcnamara> exactly
17:19:15 <colinmcnamara> we can lower the barrier to contribution
17:19:26 <colinmcnamara> as well as integrate a web (kind of like wiki)
17:19:28 <colinmcnamara> UI
17:19:28 <sarob> So the yaml jobs run as is
17:19:55 <colinmcnamara> mvn runs the pom.xml
17:19:58 <colinmcnamara> multple jobs
17:20:12 <colinmcnamara> it basically prepends the openstack mvn jobs
17:20:15 <sarob> HTML and PDF now
17:20:18 <colinmcnamara> yup
17:20:22 <colinmcnamara> but, you can do more stuff
17:20:24 <colinmcnamara> like slidey
17:20:27 <colinmcnamara> ppt
17:20:28 <colinmcnamara> odf
17:20:29 <colinmcnamara> etc
17:20:49 <colinmcnamara> so, it's WIP right now
17:20:52 <sarob> So we would need to mod our pom?
17:21:46 <sarob> Or could we start with just using asciidocs like an editor?
17:22:08 <colinmcnamara> well, first
17:22:19 <colinmcnamara> I need to make sure the bidir workflow works with the clouddocs plugin
17:22:28 <colinmcnamara> other projects us jdocbooks
17:22:52 <colinmcnamara> I'm thinking this is parallel work, probably 4-6 weeks worth
17:22:54 <colinmcnamara> but at the end
17:23:10 <colinmcnamara> we may have a way of getting non-tech writers to contribute
17:23:19 <colinmcnamara> as well as maybe have a solution to the dev-docs challenge
17:23:32 <sarob> Sounds great
17:23:47 <sarob> Sync up the work on daylight as well
17:24:10 <colinmcnamara> yup
17:24:11 <colinmcnamara> exactly
17:24:22 <Edh> hate to derail - did either of you look at the question pool I started?
17:24:23 <colinmcnamara> since the ODL docs are going to have to fit into the Nuetron docs
17:24:34 <colinmcnamara> morning edh:
17:25:03 <sarob> Edh I like and I'm patching it to master this morning
17:25:14 <sarob> You ready to make more?
17:26:13 <sarob> Edh you keep it coming and I will add it to the repo
17:27:12 <sarob> Edh we will have training-guides published on docs.openstack.org early this week
17:27:36 <Edh> okay - I will work on sections as I have time - I just trying and pull directly from the text
17:27:49 <Edh> but I want a better way to tag where I am pulling the question from
17:28:01 <Edh> so in case the section gets updated - the question can get updated
17:28:09 <Edh> and the answer(s) updated too
17:28:32 <sarob> And I will get them added to the training.openstack.org
17:29:03 <sarob> If you file a bug on the page
17:29:21 <sarob> The bug marks the file version
17:29:55 <sarob> So make sure the bug filed is on the quiz page you want to update
17:30:04 <Edh> Right, I am aware of that, just the concern is that the questions have some sort of meta data to associate them to a section
17:30:27 <Edh> so if someone updates a section they know that a question is affected - does that make sense?
17:30:46 <sarob> Ah right
17:31:11 <sarob> Well, not sure how to automajikally fix that
17:31:56 <Edh> We can crank out questions all day but they are basically out of context...
17:32:01 <Edh> Yeah, I'm not sure either
17:32:03 <sarob> Best right now that we as reviewer make sure before approving patches
17:32:35 <sarob> That the quiz questions get patched at the same time
17:33:33 <sarob> And tests
17:34:11 <sarob> So basically Colin and I will enforce for now
17:34:24 <Edh> Fair enough - I also am not sure if the question and answer method I am using is appropriate for the level
17:34:33 <Edh> I am using choose all that apply
17:34:40 <Edh> and true and false
17:35:16 <sarob> It's good with me. Until someone comes up with something better.
17:35:46 <sarob> Help is help
17:35:54 <colinmcnamara> it's really awesome
17:36:24 <sarob> Spectacular maybe but not awesome
17:36:31 <colinmcnamara> lol
17:36:56 <sarob> Don't want to give edh a big head
17:37:24 <sarob> I'm tapped out of new stuff
17:37:42 <sarob> Any more news or info?
17:37:48 <Edh> lol - okay - I need to run - conference call - later
17:37:56 <colinmcnamara> i'm good.
17:37:56 <sarob> Righto
17:38:01 <sarob> Sweet
17:38:19 <sarob> Thanks for joining guys
17:38:29 <sarob> Happy new yearish
17:39:01 <sarob> #endmeeting