20:00:04 <sarob> #startmeeting training-manuals
20:00:05 <openstack> Meeting started Mon Jul 22 20:00:04 2013 UTC.  The chair is sarob. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:05 <colinmcnamara> just zoomed over tehachapi pass and found LTE connectivity #WIN
20:00:06 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:08 <openstack> The meeting name has been set to 'training_manuals'
20:00:54 <sarob> we have sarob and colinmcnamara present
20:01:08 <sarob> who else joins us
20:02:18 <sarob> #topic who, what is core
20:02:57 <colinmcnamara> when I was tagging core in trello
20:03:09 <colinmcnamara> it was items that were seperate from content
20:03:18 <sarob> ahh, right
20:03:27 <sarob> i was thinking core team
20:03:31 <colinmcnamara> oh, gothca
20:03:35 <sarob> like def in wiki
20:03:59 <sarob> does what I put into the the wiki https://wiki.openstack.org/wiki/Training-manuals
20:04:21 <sarob> seem the way to defn?
20:04:22 <colinmcnamara> gotcha, on same page now
20:04:27 <colinmcnamara> agree
20:04:34 <colinmcnamara> very accurate actually
20:04:37 <sarob> okay, coolness
20:05:08 <sarob> so we what good spread of skills
20:05:32 <sarob> and commitment to get the the sprint when we schedule it out
20:05:36 <sarob> 3-4 weeks
20:06:02 <colinmcnamara> you are suggesting a 3-4 sprint duration?
20:06:21 <colinmcnamara> and suggesting that the core team manages commitments to deliver in those sprints?
20:06:25 <sarob> nope, one sprint, 3-5 days, in 3-4 weeks
20:06:26 <colinmcnamara> I agree with those statements
20:06:30 <colinmcnamara> ahh
20:06:40 <sarob> we all get in one room
20:06:49 <sarob> build on bones we
20:06:54 <sarob> are putting together now
20:07:04 <colinmcnamara> for me, those are doable depending on the schedule. I need to get it on the calendar ahead of time though
20:07:11 <sarob> right me too
20:07:19 <sarob> so mark voelker
20:07:26 <sarob> mestery
20:07:33 <sarob> they are in for that?
20:08:01 <colinmcnamara> we need to check, now that we have defied the responsibility levels for core
20:08:15 <colinmcnamara> probably need to layout sub-core (or pick a friendlier name)
20:08:22 <colinmcnamara> so we can present them with multiple options
20:08:37 <sarob> outer core
20:08:56 <sarob> mantle
20:09:48 <sarob> core mantle crust
20:09:49 <colinmcnamara> community ?
20:10:10 <sarob> for what?
20:10:17 <colinmcnamara> the level below core
20:10:41 <sarob> so core, community, extended
20:10:48 <colinmcnamara> that sounds very inclusive
20:10:51 <colinmcnamara> which is good
20:10:59 <sarob> okay, i buy that
20:11:04 <colinmcnamara> this may seem odd, but I love the idea of
20:11:12 <colinmcnamara> a new user or community organizer
20:11:21 <colinmcnamara> seeing each level as a step up, and inclusive
20:11:39 <sarob> sound right to me
20:11:56 <sarob> so i will update the wiki with the new name for sub-core
20:12:46 <sarob> #action sarob change sub-core team name to community
20:13:45 <sarob> #action sarob: colinmcnamara: get 4 people signed up for core
20:13:58 <sarob> #action sarob: get 4 people signed up for core
20:14:09 <sarob> #action colinmcnamara: get 4 people signed up for core
20:14:32 <sarob> done with this topic?
20:14:40 <colinmcnamara> just updated the trello card reflecting 4
20:14:43 <colinmcnamara> yes, done
20:14:55 <sarob> #topic update on getting training published to docs.openstack.org
20:16:02 <colinmcnamara> I'm looking through my calendar to see the dates that Anne had called out
20:16:03 <sarob> it looks like we need to update 3 files, manuals.yaml, layout.yaml, and the doc.openstack.org index file
20:16:25 <sarob> dates for the docs meeting?
20:16:27 <colinmcnamara> I got that as feedback on my submistion
20:16:45 <colinmcnamara> let me answer your questions first
20:17:04 <colinmcnamara> when I pick the review, to patch it
20:17:27 <colinmcnamara> I'm getting an error, I think because patches were submitted after I branched
20:17:30 <colinmcnamara> and I need to merge
20:17:36 <colinmcnamara> I'll be back in the office starting tomorrow morning
20:17:40 <colinmcnamara> for the next two weeks
20:17:43 <sarob> okay
20:18:15 <colinmcnamara> my target is to get it figured out tomorrow morning
20:18:17 <sarob> i wanted to get training published to docs before this weeks hackathon if possible
20:18:34 <sarob> so before thursday would be soon enough
20:18:51 <colinmcnamara> yeah, should be good
20:19:01 <colinmcnamara> this is my first time going through submitting patches to a review
20:19:06 <colinmcnamara> you had to figure that out last week right?
20:19:20 <colinmcnamara> here is the review in question https://review.openstack.org/#/c/37388/
20:19:45 <sarob> right
20:20:03 <sarob> plan is to publish training to doc.openstack.org/grizzly/training
20:20:07 <colinmcnamara> error I get - Errors running git rebase -i remotes/gerrit/master
20:20:07 <colinmcnamara> error: could not apply 4e5cf4b... Blueprint - CI coverage for OpenStack Training within OpenStack Manuals https://blueprints.launchpad.net/openstack-manuals/+spec/training-manuals
20:20:27 <colinmcnamara> I'll have to change the yaml file to grizzly vs trunk
20:20:37 <sarob> okay
20:20:40 <colinmcnamara> but that is simple once I find out what I am borking in the patching workflow
20:21:28 <sarob> it looks like the build worked, just blair and boylan wanted some changes
20:21:40 <colinmcnamara> correct. it was good feedback
20:21:47 <colinmcnamara> it's somethign locally with my setup
20:21:51 <colinmcnamara> I think I need to rebase manually
20:22:01 <colinmcnamara> need to whip out the pro-git book to figure it out
20:22:05 <sarob> i still have issues with rebasing
20:22:25 <sarob> it fried my local
20:22:37 <sarob> on monday
20:22:43 <colinmcnamara> I tried just checking out a fresh repositiory, then checking out the review branch, and ammending
20:22:48 <colinmcnamara> still nogo
20:22:51 <sarob> had to blow it all away
20:23:00 <colinmcnamara> and then it worked?
20:23:05 <sarob> yup
20:23:18 <colinmcnamara> I might blow it away again tommorrow morning
20:23:19 <sarob> we should figure out how to rebase correctly
20:23:30 <colinmcnamara> and document the workflow
20:23:35 <sarob> right
20:23:38 <colinmcnamara> some chapters out of pro-git are in my future
20:23:45 <sarob> ;)
20:23:50 <colinmcnamara> http://git-scm.com/book
20:24:06 <sarob> #action colinmcnamara publish training to doc.openstack.org/grizzly/training
20:24:30 <sarob> #topic CI test coverage
20:24:56 <sarob> are you planning on tweaking this separately from above?
20:25:14 <colinmcnamara> I am just trying to get it to work
20:25:37 <colinmcnamara> I guess I could just abandon the change, and submit new
20:25:50 <colinmcnamara> and if I can't figure the workflow out by COB tuesday
20:25:54 <colinmcnamara> then I will do just that
20:26:29 <colinmcnamara> I'll submit fresh code, with all of the commentary taken into account as a seperate contribution
20:26:42 <sarob> okay, i was trying to understand if you merging ci test coverage and publishing into one patch or two
20:26:58 <colinmcnamara> into one
20:27:03 <sarob> okay
20:27:20 <colinmcnamara> it is a statement in the bottom of the section covering openstack-training
20:27:43 <colinmcnamara> by publish are you saying showing up in the index? or a deep link?
20:27:52 <sarob> i will continue to work on local clean maven builds so you can run ci maven with validation
20:28:23 <sarob> right publish
20:28:58 <colinmcnamara> I just realized that I didnt grab the maven resource declaration chapter that I had read
20:28:59 <sarob> im fine with an up front link with /grizzly/training
20:29:23 <colinmcnamara> the reason I bring that up however, is that I need to figure out how to update that site
20:29:32 <colinmcnamara> I don't think that is updated from Jenkins
20:29:35 <sarob> if we do that, I will need to add something like a rough draft watermark or something
20:29:38 <colinmcnamara> or, automatically
20:29:40 <colinmcnamara> exactly
20:29:47 <colinmcnamara> and run it by Anne
20:29:59 <colinmcnamara> I'd hate for a new user
20:30:03 <sarob> the infra team owns the index file
20:30:14 <sarob> i remember seeing a patch for it
20:30:14 <colinmcnamara> to stumble into it, and run down a path and get stuck
20:30:19 <colinmcnamara> ok
20:30:30 <colinmcnamara> vs beta's being run through the users groups
20:30:39 <colinmcnamara> so we can capture feedback, and help people through errors
20:30:42 <sarob> cant find it again though, looked through repos
20:31:05 <sarob> prob just a quick question for infra channel
20:31:11 <colinmcnamara> good point
20:31:39 <sarob> no action here, covered in previous topic
20:31:44 <colinmcnamara> great point on the watermark btw
20:32:01 <sarob> ill see what i can do
20:32:26 <sarob> #topic review of what goes into trello, wiki, and blueprint
20:33:06 <sarob> do you think we have the right stuff in these three places?
20:33:34 <colinmcnamara> for now
20:33:51 <colinmcnamara> I think that in a future state our kanban board should be closer linked into the infra systems
20:34:05 <colinmcnamara> oh, probably want to output the weekly board state
20:34:09 <colinmcnamara> and either paste it into here
20:34:13 <colinmcnamara> or put in in the wiki
20:34:21 <sarob> hmm, that sounds cool
20:34:58 <sarob> we are going to need to keep the wiki uptodate
20:35:07 <sarob> its already too big
20:35:12 <colinmcnamara> should we put that in the wiki? or the meeting notes?
20:35:40 <sarob> my thought was the blueprint is our reason for existing
20:35:53 <colinmcnamara> ok
20:36:05 <sarob> but keep it as clean as possible, with patch updates only
20:36:22 <colinmcnamara> the blueprint page
20:36:25 <colinmcnamara> ?
20:36:26 <sarob> wiki defines what the blueprint specification is
20:36:40 <sarob> https://blueprints.launchpad.net/openstack-manuals/+spec/training-manuals
20:36:51 <colinmcnamara> agreed
20:37:16 <sarob> so then the kanban board is our work in progress, plans
20:37:50 <colinmcnamara> and specifically, a place to manage flow
20:37:59 <sarob> you and i will need to keep all three as fresh and clean as possible
20:38:03 <colinmcnamara> and for the team to see what tasks are prioritized and available for pick up next
20:38:05 <sarob> right
20:38:10 <colinmcnamara> I was going to bring that up
20:38:18 <colinmcnamara> basically being a scrum/ban nazi
20:38:35 <colinmcnamara> e.g. making sure when a patch is merged, that a card is moved
20:38:42 <sarob> id like to start assigning chapters to the community team
20:38:46 <sarob> from the board
20:39:06 <colinmcnamara> me too
20:39:11 <sarob> i think we are close
20:39:21 <sarob> we get the pages published
20:39:32 <colinmcnamara> I envision the community pulling from the story qeueus
20:39:36 <sarob> get the bones laid out
20:39:45 <colinmcnamara> and editing the bones that you are laying out
20:39:51 <colinmcnamara> that way it is a low barrier ot entry
20:39:52 <sarob> so maybe 20 community members?
20:40:07 <colinmcnamara> thats pretty big, I'd hope we can grow it that large
20:40:22 <sarob> 10 core, 20 community, extended=user groups
20:40:35 <sarob> me too
20:40:58 <sarob> i figure that we will get active work out of half
20:41:05 <sarob> week to week
20:41:22 <colinmcnamara> sounds about right
20:41:29 <colinmcnamara> would be interesting to use the in person meetups
20:41:34 <colinmcnamara> to trigger bugs / work
20:41:37 <colinmcnamara> graph that out
20:41:41 <colinmcnamara> not really a sprint
20:41:53 <colinmcnamara> but, similar effect
20:42:32 <sarob> #action sarob colinmcnamara continue to keep the wiki, kanban board fresh
20:42:59 <colinmcnamara> I'll volunteer to be the kanban nazi
20:43:17 <sarob> that would be cool to have an weekly activity graph
20:43:30 <sarob> move on?
20:43:52 <sarob> #action colinmcnamara will be kanban lead
20:44:24 <sarob> #topic doc-core update
20:44:54 <sarob> so i tried out merging my own patches
20:45:20 <sarob> kinda wierd and self-serving, but pretty quick
20:45:44 <sarob> zuul picked it up within minutes
20:46:20 <sarob> try it, you'll like it
20:48:15 <sarob> you were running off a perth au freenode server
20:48:17 <colinmcnamara> sarob: back. internat access
20:48:21 <colinmcnamara> really?
20:48:23 <colinmcnamara> wow
20:48:26 <colinmcnamara> just auto logged in
20:48:33 <sarob> now texas
20:48:37 <colinmcnamara> sitting in a field outside of bakersfield
20:48:44 <colinmcnamara> first place I could get LTE
20:48:48 <colinmcnamara> on my drive back from havasu
20:48:54 <sarob> all cool, thx for joining
20:49:01 <sarob> i would have been lonely
20:49:26 <colinmcnamara> Definition of core, attends IRC meetings ;)
20:49:40 <colinmcnamara> even if that means driving 90 MPH over tehachapi pass
20:49:41 <sarob> right, that good with me
20:49:56 <colinmcnamara> ok, I have a burnd down chart btw
20:50:09 <colinmcnamara> and since we aren't really enforcing a sprint right now
20:50:13 <colinmcnamara> well, it shows inverse
20:50:26 <sarob> the last time i did that on grapevine it didnt end well
20:50:58 <colinmcnamara> already had a CHP convo while stopped
20:51:26 <sarob> so try out your new powers of doc-core
20:51:42 <sarob> zuul will pick up the build job within minutes
20:52:03 <colinmcnamara> really?
20:52:05 <colinmcnamara> wow
20:52:12 <colinmcnamara> I'm going to add that to my day tomorrow
20:52:26 <colinmcnamara> as in, once I review
20:52:31 <colinmcnamara> that it will build and merge?
20:52:37 <sarob> our powers of rebase will need to be strong
20:52:48 <colinmcnamara> git jujitsu
20:52:51 <colinmcnamara> interesting note
20:52:53 <sarob> as more of us start piling on
20:52:57 <colinmcnamara> when you think about our journey here
20:53:16 <colinmcnamara> we are proving the concept that working on Doc's eases a user into contribution workflows
20:53:22 <sarob> true
20:53:23 <colinmcnamara> I'm learning new stuff all the time
20:53:41 <sarob> aob?
20:53:48 <colinmcnamara> ?
20:53:53 <sarob> any other business
20:53:54 <colinmcnamara> oab?
20:53:56 <colinmcnamara> none
20:54:08 <sarob> sweet
20:54:33 <sarob> lets get our new cores/victims in next irc meeting
20:54:49 <colinmcnamara> agreed. I'll ping you tomorrow re: CI merge
20:54:56 <colinmcnamara> and see you on thursday?
20:55:03 <sarob> roger that
20:55:30 <sarob> ill help with the ci merge, tweet me to get my attention
20:55:40 <colinmcnamara> thx dude, I appreciate it
20:55:42 <sarob> if you need it
20:56:03 <colinmcnamara> probably will. though I'll bang my head up against a wall for the morning ;)
20:56:47 <colinmcnamara> if thats all, I'll get back on the road
20:56:48 <sarob> manson real loud helps with that
20:57:01 <sarob> yup, im done, thanks for your time
20:57:11 <colinmcnamara> likewise
20:57:14 <colinmcnamara> signing off
20:57:16 <sarob> #endmeeting