10:33:03 <dguitarbite> #startmeeting training-labs
10:33:04 <openstack> Meeting started Wed Dec 30 10:33:03 2015 UTC and is due to finish in 60 minutes.  The chair is dguitarbite. Information about MeetBot at http://wiki.debian.org/MeetBot.
10:33:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
10:33:07 <openstack> The meeting name has been set to 'training_labs'
10:33:19 <dguitarbite> roll call
10:35:13 <rluethi> hi
10:35:30 <dguitarbite> hi rluethi
10:36:01 <dguitarbite> #topic Liberty Release
10:36:11 <dguitarbite> #link https://review.openstack.org/#/c/257063/
10:36:22 <dguitarbite> oops my bad
10:36:31 <dguitarbite> #link https://review.openstack.org/#/c/252297/
10:37:17 <dguitarbite> rluethi: How far have you reached?
10:37:52 <rluethi> The changes I made some time ago should get us to the point where our tests pass.
10:38:07 <rluethi> no block storage, no object storage, though.
10:38:15 <rluethi> and needs some cleanup.
10:38:33 <dguitarbite> rluethi: I have trouble launching an instance at present
10:39:03 <dguitarbite> rluethi: the cluster sometimes gets stuck at random places in case of repeat-test.sh but I assume its something to do with existing nodes from last cluster build
10:39:43 <rluethi> I have a patch for that.
10:39:57 <rluethi> currently it's virtualbox only, though.
10:40:11 <dguitarbite> ok, we can fix KVM later on. Not an issue.
10:40:42 <dguitarbite> I am trying to fix horizon, Ill send the patch soonish. Horizon is not able to auth. with Keystone hence, login is unsuccessful
10:41:25 <rluethi> do you already know the reason?
10:42:07 <dguitarbite> not yet, I am trying to figure it out. I will start with re-verifying horizon section from install guides before I can start debugging.
10:42:14 <rluethi> k.
10:42:28 <dguitarbite> I did not see anything suspicious in the logs yet.
10:43:04 <rluethi> I always find lots of suspicious stuff in the logs, even if everything seems to be working.
10:43:09 <dguitarbite> anything else for Liberty release?
10:43:33 <dguitarbite> #topic Python Port
10:44:15 <dguitarbite> I am working on labs-poc. At present the code is being pushed to https://github.com/dguitarbite/labs-POC
10:44:20 <dguitarbite> #link https://github.com/dguitarbite/labs-POC
10:44:46 <dguitarbite> I have tried my best to classify required methods/actions and have stubs/poor-mans-interfaces implemented.
10:45:13 <dguitarbite> I might have gone a bit creating while naming some of the methods but the doc strings should be handy there.
10:45:33 <rluethi> I will try to take a look over the weekend.
10:46:24 <dguitarbite> rluethi: ok, I should be able to push some more meaningful code into it till then.
10:46:49 <dguitarbite> anything else on this topic?
10:47:05 <rluethi> nope
10:47:10 <dguitarbite> #topic Any other buiz
10:47:36 <dguitarbite> I have to update the webpages and host tar balls. I have been a bit sloppy there
10:48:01 <dguitarbite> #action dguitarbite: Create training-labs webpage/link from docs page and host tarballs/zip files.
10:48:09 <rluethi> I consider the tar balls a bigger priority.
10:48:17 <rluethi> anyone can improve the website.
10:48:55 <dguitarbite> rluethi: The point being, where will the tar balls be hosted? We would need to push a link somewhere and we need FTP access for the same.
10:49:25 <rluethi> true.
10:49:56 <rluethi> we had a working setup in the old repo.
10:50:18 <rluethi> I suppose it is a matter of copying bits over and getting permissions.
10:50:49 <dguitarbite> rluethi: yes, the process should be same for web page. I will write some basic HTML code to publish the links there.
10:51:17 <rluethi> sounds good.
10:51:34 <dguitarbite> I can start today evening by attending docs meeting if it happens and if I get free during that time. The meeting is suspiciously close to dinner time for India :|
10:52:12 <dguitarbite> Also it makes sense for one of us to try and attend openstack-manuals team meetings.
10:52:54 <dguitarbite> do you agree?
10:53:16 <rluethi> I have to check the times, I am not very flexible in this respect.
10:53:34 <rluethi> we may have to resort to the ML
10:54:02 <dguitarbite> rluethi: ok, I should be able to attend most of them since its around 4/5 pm CET/CEST. But for the next two weeks, its a bit difficult.
10:55:02 <dguitarbite> anything else that we should discuss?
10:55:48 <dguitarbite> shall we call it a day?
10:55:53 <rluethi> I don't have anything right now.
10:55:59 <dguitarbite> #endmeeting