17:00:38 <matjazp> #startmeeting training-guides
17:00:39 <openstack> Meeting started Mon Sep  5 17:00:38 2016 UTC and is due to finish in 60 minutes.  The chair is matjazp. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:41 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:43 <openstack> The meeting name has been set to 'training_guides'
17:00:44 <matjazp> hey all
17:00:51 <matjazp> roll call
17:00:52 <ildikov> o/
17:01:10 <matjazp> Agenda at https://etherpad.openstack.org/p/training-guides-meeting-agenda
17:01:25 <diablo_rojo> Hello
17:01:33 <matjazp> hey ildikov diablo_rojo
17:02:14 <matjazp> First, lets agree on IRC meeting frequency
17:02:21 <matjazp> #info we'll switch back to the weekly meeting format, at least until Summit (agreed on Docs ML)
17:02:30 <matjazp> there were no objections, so I guess I'll see you all next week, right? :)
17:02:42 <ianychoi> Hello yes +1
17:02:53 <matjazp> hey ianychoi
17:03:09 <ianychoi> Hi matjazp! :)
17:03:13 <ildikov> matjazp: I have a collision for next week
17:03:31 <ildikov> but that should not hold the whole team back from having the meeting :)
17:03:47 <matjazp> ildikov: np. I just hope the attendance will be >1 ;)
17:03:54 <ildikov> so my vote is weekly until the Summit still
17:04:12 <ildikov> matjazp: that I hope so too!
17:04:18 <ildikov> :)
17:04:32 <ildikov> we have lots of work to do
17:04:41 <ianychoi> Actually, we might change the wat of our current 1st and 3rd week in every month
17:04:42 <matjazp> ildikov: +1... since there were no objections on ML, I guess we can safely switch and that the attendance will be better
17:04:50 <matjazp> #topic Review of action items from the previous meeting
17:04:55 <matjazp> http://eavesdrop.openstack.org/meetings/training_guides/2016/training_guides.2016-08-15-17.00.html
17:05:28 <matjazp> ildikov: just for backup.. did you check with dreamhost?
17:05:39 <ildikov> the last time I talked to Stefano at Dreamhost he was supportive
17:05:59 <matjazp> cool
17:06:11 <matjazp> I saw some feedback for openstack-training-virtual-environment
17:06:13 <ildikov> I haven't talked to him since and in the meantime we also decided to go with local VMs
17:06:29 <matjazp> so i guess that action item is developing
17:06:56 <ildikov> I will ping him and double check to be sure we have backup
17:07:05 <matjazp> ildikov: yes, local as primary platform, but VMs in the cloud as a backup for a few
17:07:11 <ildikov> I think so, I think Mark will be available tomorrow
17:07:16 <ianychoi> Cool... okay
17:07:31 <ildikov> or at least according to Doodle
17:07:34 <matjazp> we don't need much.. just a plan b if someone's laptop "dies"
17:08:10 <matjazp> ok moving on
17:08:13 <matjazp> #topic Upstream training
17:08:26 <matjazp> #link https://etherpad.openstack.org/p/upstream-university-improvements
17:08:42 <matjazp> #info Upstream training virtual sprint September 6, 12-13 and 16: https://wiki.openstack.org/wiki/VirtualSprints#Upstream_training_Sprint
17:08:50 <ildikov> matjazp: well, if the laptop itself dies, that's a bigger issue than public cloud, but I got the point :)
17:09:01 <ildikov> matjazp: thanks
17:09:15 <ildikov> I think I set up everything for the sprint days
17:09:30 <matjazp> ok, just to fine tune the topic
17:09:31 <ildikov> I mean we have an IRC channel that can be used, I added a Google Hangouts link
17:09:34 <matjazp> #topic Upstream training virtual sprint: topics and goals
17:09:43 <ianychoi> Cool :)
17:09:46 <matjazp> ildikov: stage is yours :)
17:09:47 <ildikov> haha, tnx :)
17:10:02 <ildikov> my bad, I should've changed the order
17:10:16 <ildikov> so we have four days when most of us is available
17:10:58 <ildikov> I added the details to the wiki, I can send out one more reminder mail, maybe I can even add the dev list this time, I don't know whether we would have anyone from there showing up to help
17:11:26 <ildikov> with diablo_rojo we also started to add a few new etherpads to the topics to have better readability on the material
17:11:30 <ildikov> and plan
17:11:31 <ildikov> s
17:11:39 <matjazp> excelent
17:11:53 <ildikov> I think as primary focus we would need to work on the common items and code contribution
17:12:01 <ildikov> I mean these two bigger parts
17:12:02 <ianychoi> Hope that many more people will participate on.
17:12:08 <diablo_rojo> I got code contribution :)
17:12:08 <ianychoi> How do think about sandbox launchpad?
17:12:20 <ildikov> also if anyone has the capacity and haven't tried yet we also need to finalise the VM setup
17:12:58 <ianychoi> ildikov, you can try the VM setup during the sprint :)
17:13:07 <ildikov> ianychoi: I think that would be good to play with bug reports
17:13:29 <diablo_rojo> Once I get done with the code contribution section I can work on it if someone else hasn't picked it up by then.
17:13:35 <ildikov> ianychoi: right, when I'm sick of the content I'll go and play with the VMs :)
17:13:47 <matjazp> ildikov: true,.. in my experience, ppl always try to spin up the VM in the Devstack and expect to be available on the "internet".. so I usually modified similar setup as is this with a "proper" net config
17:14:09 <ildikov> diablo_rojo: kmARC is working on the VM setup, he needs feedback and maybe some finalisation with the network setup
17:14:39 <diablo_rojo> ildikov, I can definitely give feedback, not sure how much I can help with networking, but I will try : )
17:15:06 <ildikov> diablo_rojo: if you can provide feedback, that's already very helpful :)
17:15:36 <diablo_rojo> Can do :)
17:15:39 <matjazp> I used vagrant for my class, and added a config for KVM provider, its much more performant that virtualbox
17:15:42 <ildikov> diablo_rojo: if you cannot reach kmARC on IRC, then just drop a mail if there's anything
17:16:21 <diablo_rojo> Sounds good.
17:16:35 <matjazp> not tommorow, but I can look at the networking part and help there
17:16:40 <ildikov> matjazp: if that works for all operating systems more backup options is always better
17:17:09 <matjazp> ildikov: sure, but with vbox, not with KVM provider
17:17:11 <ildikov> matjazp: cool, we have multiple days for virtual sprint and also the weekly meetings to discuss
17:17:26 <ildikov> matjazp: ah, ok
17:17:44 <ildikov> so back to the sprints a bit
17:17:46 <matjazp> kvm provider needs Linux host
17:17:50 <matjazp> ok
17:18:12 <matjazp> what is the focus for tomorrow?
17:18:18 <ildikov> sorry, I would like to be sure the sprints goals are set before we run out of time :)
17:18:55 <ildikov> so as I said I think we have two main modules that would be great to finish asap
17:19:09 <ildikov> the common parts and code contribution
17:19:50 <ildikov> diablo_rojo volunteered to drive the code contrib part, we have an etherpad for it: https://etherpad.openstack.org/p/upstream-uni-code-contribution
17:20:27 <ildikov> i also started to draft my ideas for the common items: https://etherpad.openstack.org/p/upstream-uni-common-items
17:20:34 <diablo_rojo> I should have a patch up in the next day or so for the initial changes. The next step after that is to get the exercises in.
17:20:50 <matjazp> #info Upstream sprint 6 Sep https://etherpad.openstack.org/p/upstream-uni-code-contribution and  https://etherpad.openstack.org/p/upstream-uni-common-items
17:21:29 <ildikov> I don't think we should work on only one or the other tomorrow
17:21:43 <diablo_rojo> I agree.
17:22:05 <ianychoi> #link http://docs.openstack.org/upstream-training/#outline-and-online-slide-index
17:22:10 <ildikov> if we have more people online at the same time we can brainstorm and finalise ideas and content any blocks in these two modules
17:22:37 <ianychoi> ildikov, so we may need to change the table of contents? like 'Common' section, 'Code contribution', ..?
17:22:56 <ildikov> ianychoi: we will need to, yes
17:23:36 <matjazp> #undo
17:23:36 <ildikov> ianychoi: is that generated from the trainig-guides repo also?
17:23:36 <openstack> Removing item from minutes: <ircmeeting.items.Link object at 0x7f5bc02e0ed0>
17:23:56 <matjazp> ildikov: thats the landing page
17:24:05 <matjazp> in the same repo
17:24:12 <ildikov> ok, cool
17:24:31 <matjazp> we generate slides and a landing page that connects everything together
17:24:45 <matjazp> so it's easy to change/restructure anything
17:25:02 <ildikov> that sounds great
17:25:05 <matjazp> we can easily move content form slide format to the text and vice versa
17:25:16 <ildikov> I think we might change the overall ToC only at the end
17:25:17 <ianychoi> Yep actually I have not deeply seen two additional etherpads, but some table of content "organization" stuff is needed
17:25:18 <matjazp> everything in in RST
17:25:47 <ildikov> ianychoi: I will add a main block to the top of the main etherpad
17:26:03 <ildikov> and we can work on the details of each block in the separate etherpads
17:26:39 <ildikov> and the high level agenda can be the skeleton for the whole class and then we can agree on one level lower details in the separate etherpads
17:26:44 <ildikov> if this makes sense
17:27:02 <ianychoi> ildikov, okay, and I heard that Lego will not be used in Barcelona upstream training. However, I would like to keep Lego section as '(Optional)' section.
17:27:38 <ildikov> ianychoi: we will not have Lego at all and also we only have 1,5 days this time
17:28:29 <ildikov> ianychoi: I thought to focus a bit on the message of the Lego block at the beginning, talk a little bit about Agile terms and discuss why OpenStack has the way of working what it has today
17:29:17 <ianychoi> ildikov, okay I see.
17:29:40 <ianychoi> And it would be much better if we set our desired timeline during 1.5 days
17:29:48 <ildikov> ianychoi: also Lana cannot come to the training this time unfortunately and she really is the queen of facilitating that game :(
17:30:14 <ildikov> ianychoi: I agree
17:30:36 <ildikov> I had ideas to have the common items during Sunday afternoon and maybe Monday morning as well
17:30:42 <ianychoi> ildikov, Yep Lana updated a lot of Lego content last time.
17:31:17 <ildikov> she saved us in Austin, if she wasn't there the Lego game would've been a disaster!
17:31:53 <ildikov> after the common parts we have options in my mind
17:32:54 <ildikov> we either try to run parallel sessions or do things still in order, focus much on the code contribution, hands on parts and also talk about other ways of contributing, like working groups or docs as a main focus, etc.
17:33:26 <diablo_rojo> That sounds like a good plan to me
17:33:32 <matjazp> you mean parallel sessions with different topics?
17:33:51 <ianychoi> I have just found that the 1st day (Sunday) is for 4 hours and the 2nd day (Monday) is for 6 hours
17:34:04 <ildikov> the training registration form has a question about people's primary interest, if everyone says code it will be easy to design the training :)
17:34:23 <ildikov> matjazp: at a certain point maybe, I'm less and less sure we can make that happen in Barcelona
17:34:44 <ianychoi> It is relatively short.. but fine
17:34:56 <ildikov> matjazp: the idea is not about distract the developers, but give a chance to architects, manager or operators to attend the training and participate in OpenStack
17:35:14 <ianychoi> Parallel sessions may depend on the number of participants
17:35:31 <ildikov> ianychoi: I will double check, I remembered Sunday is relatively short, I thought Monday is longer
17:36:09 <ildikov> ianychoi: also much on the participants, so what I shared above is more long term ideas rather than strict plan for Barcelona
17:37:02 <ildikov> this is why I think we should focus on the common parts and code contrib during the virtual sprints with a 'hands-on and interactive' mind set
17:37:40 <ildikov> if we can get that two right and maybe some small blocks of info about other areas, then I think people will be satisfied when they leave
17:38:39 <ildikov> I tried to get people involved to have content for other blocks, but that goes slow too
17:39:00 <ildikov> ianychoi: does it make sense? ^^
17:39:27 <matjazp> for the sprint: we could also increase the pool of possible contributors with a list of predefined smaller tasks they can pick up... for devs that just want to help a bit and don't have time to engage "full" time
17:39:55 <ildikov> matjazp: that's a good idea
17:40:04 <ianychoi> I have some ideas on parallel sessions if we would like to run. 1) defining what type of parallel sessions: a) bug report and fix b) code contribution c) user group (community) participation d) blueprint   2) how the number of each group will make sense? three? four? 3) For each group, there should be at least one mentor.
17:40:32 <diablo_rojo> I had thought about that too, it will depend on what tasks exist in the community that are easy enough to pick up.
17:40:36 <ianychoi> ildikov, yep make sense :) I was writing my ideas above
17:41:07 <ildikov> I think we could do that tomorrow in order to have more people next week to get stuff done
17:41:19 <matjazp> ildikov: we usually just enter this small tasks as bugs, but we can also leave them in the etherpad, but we need to see that there is no duplication of effort.
17:42:01 <ildikov> ianychoi: hmm, I think bug and blueprint are under code contrib, but we can chat about it tomorrow or next week on one of the sprint days :)
17:42:28 <ianychoi> Before upstream training, some mentors selected 'low-hanging-fruit' bugs which were relevant during upstream training
17:42:41 <ildikov> matjazp: sure, I thought to add items to the etherpad and then let people sign up
17:43:00 <matjazp> diablo_rojo: I'm talking about tasks to contribute to the Training guides/Upstream training (as in: rewrite the topic about IRC, include this and that on the page, etc.)
17:43:19 <matjazp> diablo_rojo: you're talking about tasks that they can do AT the training, right?
17:43:22 <ildikov> ianychoi: ah ok, I misunderstood what you wrote
17:44:01 <ildikov> ianychoi: if you check the common parts etherpad I added a question about creating groups already at the beginning, so I think we kind of think about a similar setup :)
17:44:23 <diablo_rojo> matjazp, Ah I missed the contributing to the training guides part, I thought you meant the big tent projects.
17:44:24 <ianychoi> ildikov, fine :) And I most liked IRC participation during upstream training. How was it during last Austin upstream training?
17:44:46 <ildikov> ianychoi: it wasn't that active
17:44:49 <matjazp> diablo_rojo: we need both types of tasks
17:44:58 <diablo_rojo> I know that the focus is things they can do at the training though :)
17:45:01 <matjazp> one for the training, and other for the sprint
17:45:32 <ildikov> ianychoi: unfortunately the presenters including myself we weren't prepared for the training well enough :(
17:46:14 <diablo_rojo> ildikov, We will be ready this time
17:46:16 <ildikov> matjazp: it could be one small task to people to identify items that people can work on
17:46:48 <ianychoi> ildikov, that's quite okay. For me I was so satisfied with upstream training because I learned how OpenStack people make decisions and how they contribute.
17:46:51 <ildikov> diablo_rojo: nah, we will never be ready, I'm sure, but we will be way more prepared :)
17:47:15 <ildikov> ianychoi: that's what I would like to bring back
17:47:37 <ildikov> ianychoi: much more discussions within the groups of students and with the trainers
17:47:45 <ianychoi> For common section, I am not sure, but usually famous guys emphasize '4 opens' for OpenStack and illustrate how '4 opens' reflect in OpenStack
17:48:04 <ildikov> and also more things that teach people how to find information and how to solve problems, etc.
17:48:11 <diablo_rojo> ildikov, touche :)
17:48:18 <ianychoi> And then trainers illustrated how IRC is important to discuss and make decision.
17:48:39 <ildikov> ianychoi: good point, I'll add it there
17:49:22 <ianychoi> I will read ildikov 's common section items on Etherpad thanks, ildikov !
17:49:45 <ildikov> ianychoi: :)
17:50:13 <matjazp> ok, do we have any action items for next week?
17:50:43 <ianychoi> Aa, and project code contribution and document code contribution may be different, so both will be treated differently I think. How do you think, diablo_rojo ?
17:50:51 <ildikov> I think to revisit what we've done this week mostly
17:51:07 <ildikov> next Monday is also a sprint day, so the meeting can be used as a checkpoint
17:51:31 <matjazp> ianychoi: contributing to the docs is very similar to contributing code
17:51:42 <ildikov> ianychoi: diablo_rojo: I had a short mail chat with Lana and she is against differentiating
17:51:51 <matjazp> ianychoi: same process
17:51:56 <diablo_rojo> ianychoi, I think they are slightly, different, but I'm not sure they are different enough that they need to be different sections.
17:52:08 <matjazp> diablo_rojo: agree
17:52:19 <ildikov> my thinking is that we should have that as part of the code contribution part on the level of 'write docs to you feature'
17:52:22 <ianychoi> matjazp, doing launchpad and gerrit is the same and they have same process, but the perspective can be different.
17:52:29 <matjazp> diablo_rojo: they are similar enough that we don't need to distinguish them
17:52:42 <ianychoi> Moreover, student's expectation might be different.
17:52:44 <ildikov> I think if it comes to OpenStack Manuals, that's different
17:52:54 <diablo_rojo> ildikov, +1
17:53:03 <ianychoi> +1 for ildikov :)
17:53:30 <ildikov> if we have tech writers among the students, I would like to have a docs section to them while others are playing with the unit tests and hacking the Python code
17:53:54 <diablo_rojo> That could work
17:54:08 <diablo_rojo> Six min left as a heads up
17:54:34 <ianychoi> And one more.... matjazp, I am not sure where upunbot on #upstream-university.. For this bot, maybe Tim Freund or Loic operated..
17:54:52 <ildikov> I think that makes more sense, we might think about how to help those who're interested in OpenStack Manuals to work together with the community, understand projects and code on the level they need and most importantly really how to get along with people here
17:54:55 <matjazp> ianychoi: don't think so... we should just ask infra team
17:54:59 <ianychoi> In this case, incorporating "openstack" bot into the channel will be the right choice?
17:55:08 <ildikov> but that's not for Barcelona, that's too close to have this covered
17:55:32 <ianychoi> I think upunbot is not openstack-infra's result..
17:56:00 <ianychoi> I remember that the eavesdrop HTML results from upunbot was not eavesdrop.openstack.org
17:56:20 <matjazp> hmm.. anyone wants to investigate this?
17:56:27 * ildikov is not a bot specialist
17:56:30 <ianychoi> Hmm.... Me will investigate this :)
17:56:52 <matjazp> #action ianychoi looks into bot for #upstream-university channel
17:57:05 <matjazp> move to aob?
17:57:08 <ildikov> thanks ianychoi! :)
17:57:17 <ianychoi> ildikov, it's my pleasure :)
17:57:18 <ianychoi> Okay
17:57:30 <matjazp> #topic any other business
17:57:32 <ildikov> if everyone has an idea on what to work on tomorrow, then AOB is fine with me :)
17:57:35 <matjazp> anything else?
17:57:54 <matjazp> ildikov: etherpad is the source of the truth ;)
17:58:05 <ianychoi> By the way, matjazp , will you attend all of four days on Summit?
17:58:06 <ildikov> matjazp: +1 :)
17:58:31 <matjazp> ianychoi: I'll try to, but don't know yet.. it's in the middle of the semester
17:58:54 <ianychoi> I definitely wanted to go to Barcelona, but unfortunately my two presentation submissions were not selected.
17:59:34 <matjazp> ok, I guess that's it for tonight
17:59:44 <matjazp> thanks for your time
17:59:51 <matjazp> see you around
17:59:54 <ildikov> thanks guys
17:59:55 <matjazp> bye!
17:59:56 <ianychoi> So I am not still sure whether I can go to Barcelona, but I would like to help upstream training as much as possible
18:00:00 <ianychoi> Thank you all!
18:00:08 <matjazp> #endmeeting