17:01:32 <sarob> #startmeeting training-guides
17:01:33 <openstack> Meeting started Mon Aug  3 17:01:32 2015 UTC and is due to finish in 60 minutes.  The chair is sarob. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:34 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:36 <openstack> The meeting name has been set to 'training_guides'
17:01:53 <rluethi> hey
17:02:08 <sarob> hey
17:03:04 <sarob> ive been terribly distracted by work
17:03:23 <rluethi> k?
17:03:26 <rluethi> anyone else?
17:03:48 <sarob> i noticed a few patches for osbash
17:03:53 <sarob> formally known as
17:04:10 <sarob> any progress on setting up the new repo?
17:04:31 <sarob> matjazp: hey
17:04:33 <rluethi> I believe pranav is working on it.
17:04:35 <matjazp> hey all
17:04:42 <rluethi> i posted some patches for osbash, yes.
17:04:44 <matjazp> sorry I'm a bit late
17:04:59 <sarob> matjazp: hows the certification going?
17:05:00 <rluethi> minor tweaking, and a workaround for the floating IPs.
17:05:07 <matjazp> hey sarob, long time no see
17:05:17 <sarob> matjazp: indeed
17:05:23 <dguitarbite> hello
17:05:34 <sarob> i can only join for 30 min
17:05:44 <sarob> i have a hard stop at 30 after
17:05:52 <sayalilunkad> hello
17:05:56 <sarob> sayalilunkad: hey
17:06:09 <matjazp> sarob: why haven't we discussed about shifting time sot on ML?
17:06:16 <matjazp> sot=slot
17:06:44 <sarob> matjazp: i believe i popped it out there
17:07:05 <sarob> matjazp: i may have only mentioned on irc
17:07:17 <matjazp> sarob: ? you did? I didn't see it
17:08:10 <sarob> matjazp: back on 01jul
17:08:31 <sarob> matjazp: i didnt follow up though
17:09:14 <sarob> matjazp: hows the certification meetings going?
17:09:41 <matjazp> sarob: now sayali is in CET timezone (you are, right? :), maybe we can find a more suitable time slot for all of us
17:10:08 <sayalilunkad> matjazp: I am
17:10:08 <matjazp> sarob: you have to ask dguitarbite about that
17:10:33 <sarob> sayalilunkad: congrats
17:10:53 <matjazp> sayalilunkad: nice... I guess we (CET TZ) kinda steal you guys from +5.5 ;)
17:10:57 <sayalilunkad> sarob: thanks :)
17:11:13 <matjazp> sayalilunkad: first dguitarbite, now you
17:11:24 <sayalilunkad> haha
17:11:57 <rluethi> soon, there will nobody be left in india.
17:12:29 <matjazp> if we extrapolate this trend even further, even sarob will move here ;)
17:12:29 <sarob> im good with moving the meeting to earlier
17:12:45 <sarob> matjazp: my wife would love that
17:12:58 <sarob> matjazp: she spend two years in GER
17:13:03 <sarob> spent
17:14:27 <matjazp> sarob: earlier? when do you wake up man? (I was hoping to postpone it for 2 to 3 hours ;)
17:14:41 <sarob> matjazp: im good either way
17:15:51 <sarob> whats the status of publishing the upstream materials?
17:15:58 <matjazp> do we have a "standard" agenda?
17:16:13 <sarob> the last time i updated it was june
17:16:20 <sarob> i think its a bit out of date
17:17:01 <matjazp> sarob: it is updated a bit, but not some large changes
17:17:07 <sarob> i have new stuff for upstream
17:17:26 <sarob> im running my second training of it this thursday
17:18:27 <matjazp> sarob: nice. can you push some patches for review?
17:18:46 <sarob> sure
17:19:33 <sarob> ill rewrite my pub slides http://www.slideshare.net/SeanRoberts1/4-hr-upstream-training
17:19:35 <sarob> in rst
17:19:38 <matjazp> sarob: now it is much easier to review this stuff since we have draft publishing in the gate
17:19:54 <sarob> cool
17:20:12 <matjazp> sarob: hmm... is this a shorter version of the "official" upstream training?
17:20:40 <sarob> it is
17:20:56 <sarob> a few hours
17:21:01 <sarob> for user groups
17:21:26 <matjazp> hmm.. any ideas how can we incorporate this stuff into the longer version?
17:22:41 <sarob> my thinking is we have different ones
17:22:56 <sarob> 2, 4, 18 hr versions
17:23:13 <sarob> overlap in content
17:23:26 <sarob> but will need to be tweaked differently
17:23:30 <matjazp> sure, it makes sense, but how we avoid duplication
17:24:14 <sarob> its possible to only change a slide or two between the three
17:24:28 <sarob> ill have to do some research
17:24:30 <matjazp> idealy, we would have shorter versions "generated" from a more complete longer version, we could just skip slides
17:24:43 <sarob> i agree
17:24:49 <sarob> it would be the best
17:25:38 <matjazp> so the shorter versions are hand picked slides from a longer version
17:25:48 <matjazp> what do others think of this idea?
17:26:39 <rluethi> matjazp: It's what I would do, too.
17:27:17 <sarob> #action sarob research how to incorporate 2, 4hr versions of upstream training without duplication
17:27:33 <sarob> i have to jump out for 15 minutes
17:27:37 <matjazp> this way we avoid duplication (at the expense of some flexibility, eg. it would not be possible to mix two slides into one)
17:27:37 <sarob> ill be back
17:27:44 <dguitarbite> I gtg now. Have a event to attend
17:28:06 <sarob> dguitarbite: cheers
17:28:18 <dguitarbite> sarob: :). See ya guys.
17:28:21 <sarob> dguitarbite: ping the ML on your repo progress
17:28:21 <matjazp> dguitarbite: bye, see you
17:29:07 <rluethi> bye
17:29:59 <rluethi> okay, now what? do we entertain ourselves for 15 min?
17:30:26 <rluethi> I tried to answer all questions regarding the patches under review. any other questions/comments?
17:30:56 <matjazp> for this "hand picking" of the existing slides: we should just make custom code that matches the slide title and include content into new shorter generated slide
17:31:10 <sayalilunkad> I gtg too. See you next week!
17:31:37 <matjazp> rluethi: sure, it's ok. we did discuss everything
17:32:17 <rluethi> I have another logging patch ready once these are merged.
17:32:44 <matjazp> rluethi: comments in the Gerrit are the best way for this (as it stays woth the patch for future reference)
17:32:57 <matjazp> rluethi: which one are you waiting for?
17:33:43 <rluethi> well, my next patch depends on "Keep additional logs files".
17:34:13 <rluethi> all my patches sort of depend on "Wait for floating IP to turn up", because I can't test without it :-).
17:34:55 <matjazp> I can merge this patient_ping :))))) workaround, it has 2 +2 :)
17:35:38 <rluethi> cool.
17:38:16 <matjazp> hehe... patient_ping() :) nice naming
17:39:21 <rluethi> thx :-). I think the function could be use elsewhere in the test script (there are other test ping).
17:39:56 <matjazp> if you also +2 the https://review.openstack.org/#/c/208193/, it can be also merged , as it will have 2 +2s
17:41:12 <rluethi> done
17:41:45 <matjazp> merged
17:42:00 <rluethi> thank you.
17:42:14 <matjazp> hey, what's with https://review.openstack.org/#/c/204626/ ?? it should be merged!
17:43:05 <matjazp> Gerrit bug?
17:43:28 <rluethi> I dunno.
17:43:38 <rluethi> I gave it another shot.
17:44:21 <matjazp> lets see what happens :)
17:47:09 <matjazp> hmm.. maybe this hard stop at 19:30 for sean and pranav is a good thing? we could have shorter meetings ;)
17:47:49 <sarob> maybe so
17:47:51 <rluethi> :-)
17:48:10 <rluethi> hah! we're just waiting for #endmeeting
17:48:24 <matjazp> sarob: we fixed the review queue
17:48:30 <rluethi> matjazp: it's been merged
17:48:32 <sarob> okay
17:48:40 <matjazp> rluethi: nice.. just a gerrit bug than
17:48:56 <matjazp> just one review in the queue
17:49:08 <matjazp> hmm.. what about bugs?
17:49:23 <rluethi> matjazp: which bugs?
17:49:51 <matjazp> rluethi: do you think we have an empty bug queue?
17:50:49 <rluethi> matjazp: plenty of things to improve, port to kilo is not done yet, but no showstopper bugs that I know of.
17:51:02 <matjazp> we need to remove old ones (for old content)
17:51:18 <matjazp> https://bugs.launchpad.net/openstack-training-guides
17:51:21 <matjazp> #link
17:51:21 <rluethi> actually, I had a problem with the test script on opensuse.
17:51:27 <rluethi> no idea why.
17:51:40 <rluethi> it never got a dhcp lease.
17:51:55 <rluethi> same script that worked on every other platform.
17:51:57 <matjazp> rluethi: where are we with CI and using labs for install guides?
17:52:15 <rluethi> for CI we pretty much need a KVM backend.
17:52:24 <matjazp> rluethi: is it a stable bug? or just a fluke? (race condition?)
17:52:43 <rluethi> it seemed pretty damn stable to me.
17:52:53 <rluethi> but only on that opensuse setup I had.
17:53:01 <rluethi> never seen it anywhere else.
17:53:07 <rluethi> I blame pranav.
17:53:21 <matjazp> rluethi: botched opensuse install?
17:54:21 <rluethi> opensuse (tumbleweed, that is) comes with virtualbox 5.0, maybe that's the reason.
17:54:29 <rluethi> but that's pure speculation.
17:55:17 <matjazp> sarob: we can try few meetings with 30 min time slot? and see how it goes?
17:55:27 <sarob> sounds good to me
17:55:36 <sarob> sorry my other meeting is running long
17:56:03 <matjazp> sarob: discuss all "your" stuff first, and if we need more time, we just continue without you
17:56:11 <sarob> sounds good
17:56:30 <matjazp> rluethi: what do you think?
17:56:43 <rluethi> works for me.
17:57:07 <matjazp> ok.. so.. we wrap it up for today
17:57:39 <sarob> roger
17:57:42 <rluethi> yup
17:57:46 <sarob> orr matjaz
17:57:53 <sarob> #endmeeting