17:01:54 <sarob_> #startmeeting training-guides
17:01:55 <openstack> Meeting started Mon Sep 22 17:01:54 2014 UTC and is due to finish in 60 minutes.  The chair is sarob_. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:56 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:58 <openstack> The meeting name has been set to 'training_guides'
17:02:03 <sarob_> Hallo!
17:02:12 <sayali_> Hello
17:02:23 <MeganR> Hello
17:03:52 <ShillaSaebi> hello
17:04:40 <sarob_> The timing of this meeting is going to be harder on dguitarbite now
17:05:12 <sarob_> Anyone that's working on docs want to fill in for him?
17:05:14 <dbite> sorry for the delay
17:05:18 <dbite> im here
17:05:21 <dbite> :)
17:05:24 <sarob_> Cool
17:05:36 <sarob_> #topic docs
17:05:44 <sarob_> Go
17:06:00 <dbite> docs needs update for the older version
17:06:09 <dbite> I will be working with Anne Gentle on this
17:06:22 <dbite> some of the updates require deleting old webpages from the www folder
17:06:26 <dbite> under openstack-manuals repository
17:06:49 <dbite> I apologize for the delay in pushing the doc-tools for building the PDF files
17:06:58 <dbite> I will finalize that part soon
17:08:37 <sarob_> Yeah, so what's your plan about cleaning up the ftp site?
17:08:50 <dbite> it needs to be manual
17:08:59 <dbite> and the access is limited to Anne as of now
17:09:05 <dbite> who has agreed to help us out
17:09:24 <sarob_> I was just going to wipe it all after hours and rerun a publish job
17:09:41 <sarob_> Is that too extreme
17:09:44 <sarob_> ?
17:09:46 <dbite> no
17:09:51 <dbite> if extra pages get deleted
17:09:55 <dbite> they will be automatically updated
17:09:59 <dbite> with the new patch
17:10:15 <sarob_> My thought as well
17:10:17 <dbite> but for the sake of not doing unwanted things, I am taking extra precautions
17:10:25 <sarob_> Okay
17:10:29 <sarob_> Like what?
17:10:33 <dbite> the problem is that the pages do not get deleted from the FTP site
17:10:58 <dbite> I just wanted to verify which files are obsolete which is a bit tedious and takes some time
17:11:25 <dbite> once that part is done, we are ready for a release for Icehouse
17:11:32 <sarob_> How about making a full copy
17:11:44 <dbite> hmm, I think I should think about that
17:11:52 <sarob_> And start cleaning out the copy first
17:12:03 <dbite> I will ping annegentle once I am done verifying the content
17:12:10 <sarob_> Doc the changes or script them
17:12:12 <dbite> verifying the new content
17:12:24 <dbite> yes
17:12:25 <sarob_> Then do it to the online version
17:12:45 <dbite> #action dguitarbite will update the ftp site this week
17:12:52 <sarob_> More work but less likely to Bork
17:13:22 <dbite> sarob_: yes, I do not mind more work, till it makes sense to preserve the sanity of our content
17:13:52 <sarob_> Sanity
17:13:58 <dbite> so if everyone agrees, I will ask annegentle to delete everything and push a patch immediately to get new content in
17:14:01 <sarob_> I miss it
17:14:19 <dbite> meaning, I do not want to do a mistake which will reflect on the online version
17:14:27 <dbite> because we are dependent on Anne to fix it for us
17:14:52 <sarob_> Hmm, I'm bit confused now
17:14:54 <dbite> so what I mean to say is that, I will go through the current master branch, verify the content and then push it
17:15:20 <sarob_> With deletions in the patch?
17:15:35 <dbite> no
17:15:44 <dbite> I will verify the content
17:15:57 <dbite> then ask annegentle to delete everything, complete cleanup on FTP
17:16:03 <dbite> and to update the new content push a dummy patch
17:16:09 <sarob_> Okay got it
17:16:14 <dbite> :)
17:16:30 <sarob_> Anything else?
17:16:37 <dbite> no, not from docs side
17:17:04 <sarob_> #topic incubation
17:17:43 <dbite> sarob_: We need to confirm if we meet the official criteria for incubation
17:17:53 <dbite> if that is met, I vote for going forward with it
17:18:34 <sarob_> Dbite: what do you see as the goal of incubation?
17:18:46 <sarob_> Or goals
17:19:09 <dbite> I see that major task of incubation is already taken care of (moving the repository to openstack/)
17:19:19 <sarob_> Agreed
17:19:39 <dbite> we have active commiters and core reviewers which is good progress
17:20:12 <dbite> and another important part is that we have
17:20:12 <dbite> Shell 60.8%
17:20:12 <dbite> JavaScript 15.0%
17:20:12 <dbite> CSS 12.2%
17:20:12 <dbite> Python 8.3%
17:20:12 <dbite> Ruby 3.7%
17:20:30 <sarob_> But how does this team benefit from the incubation designation?
17:20:31 <dbite> which differs from openstack-manuals roadmap to keep XML content
17:21:42 <dbite> to be honest, I do not understand the scope of this question. I will need to update my information on incubation process
17:21:45 <sarob_> I'm being a bit contrarian here
17:21:51 <sarob_> On purpose
17:22:02 * dbite is glad for that
17:22:18 <dbite> I understand we need to do this
17:22:24 <sarob_> We have one incubation benefit already
17:22:51 <sarob_> If we get the incubation designation
17:23:07 <sarob_> We will get more attention
17:23:09 <dbite> yes, more than stating the obvious that we are meeting most of the criteria for incubation and already have the repository in the right location for it, it should be under consideration
17:23:30 <sarob_> Which could mean more developers and users
17:23:31 <dbite> also our project differs a lot from openstack manuals for arguments sake
17:23:44 <dbite> ahh, I did not think of that
17:23:45 <dbite> yes
17:23:56 <dbite> more adoption
17:23:59 <sarob_> Mgmt true we are different
17:24:31 <sarob_> iOS spell chk is killing me
17:25:15 <sarob_> We want to stay in the docs program right?
17:25:28 <sarob_> Or not?
17:25:59 <sarob_> Anyone else want to weigh in?
17:26:14 <dbite> sarob_: can we not stay under docs program
17:26:20 <dbite> as independent/incubated project?
17:26:25 <dbite> we need to stay in docs program
17:26:35 <dbite> otherwise reusing content would be difficult!
17:27:04 <sarob_> I think it makes sense to stay in the docs program
17:27:13 <sayali_> yeah its easier to manage the content for training guides with docs
17:27:18 <dbite> I would say that we need to stay in the docs program
17:27:27 <sarob_> Well we are already In a separate repo
17:27:47 <dbite> yes, that is what I meant to ask, can we not be independent project under docs program?
17:27:49 <dbite> is that not possible?
17:27:53 <sarob_> Reusing is as hard as it's going to be already
17:28:22 <sarob_> Dbite yes we can stay under docs program
17:28:39 <dbite> then, I see no negative side for moving on
17:29:17 <sarob_> Does anyone have a requirement of this project being incubated ?
17:29:35 <dbite> I think audio visual may be good reason
17:29:38 <dbite> for incubation
17:29:55 <sarob_> How so?
17:30:08 <dbite> to manage the content
17:30:24 <dbite> but we need some progress under this sub team
17:30:36 <sayali_> I think a major change the incubation would bring is the increase in contributors
17:31:33 <sayali_> since it will bring to notice the different things being worked upon
17:31:45 <sarob_> My goals for the team "I'm looking for greater adoption, participation, and keeping up with the releases. The recognition of incubation would help with that. "
17:31:49 <dbite> I agree with sayali
17:32:11 <dbite> sarob_: I think that would be a good answer
17:32:16 <dbite> for the question you asked :D
17:32:51 <sarob_> Anyone think we are not ready for incubation
17:33:10 <sarob_> Or not understand what incubation is?
17:33:56 <sarob_> Okey dokey
17:33:57 <MeganR> Honestly, I don't understand what incubation is
17:34:08 <sarob_> Ah not a problem
17:34:19 * dbite looking for the links
17:34:27 <sarob_> As a project matures
17:34:49 <ShillaSaebi> https://wiki.openstack.org/wiki/Governance/Approved/Incubation
17:34:49 <sarob_> It gets recognized by the technology council TC
17:35:19 <sarob_> The two stages right now are incubation and integrated
17:35:53 <dbite> #link https://wiki.openstack.org/wiki/Governance/Approved/Incubation
17:35:54 <sarob_> Another of saying your team is mature
17:36:28 <MeganR> ok, I am looking at the link Shilla sent, it makes sense to move forward
17:36:29 <sarob_> I have our steps to incubation at the bottom of our wiki
17:36:38 <sarob_> Okay
17:36:44 <MeganR> thank you
17:37:13 <sarob_> I'm going to ask annegentle about the timing
17:37:25 <ShillaSaebi> cool
17:37:26 <sarob_> On the ML thread we have going
17:37:45 <sarob_> Either before Paris or right after
17:37:49 <sarob_> I'm thinking
17:37:57 <dbite> well, can we arrange for a meeting during the summit?
17:38:02 <dbite> to discuss this in person?
17:38:48 <sarob_> Let's ask on the ML thread
17:39:16 <sarob_> I would be great to have the team chime in on the ML discussion
17:39:39 <dbite> yes
17:39:39 <sarob_> Let's move on
17:39:50 <sarob_> #topic testing
17:40:08 <sarob_> Matjazp how's it going!
17:40:30 <sarob_> Geez iOS 8 is really messing with me
17:40:43 <dbite> matjazp will not be able to make it
17:40:52 <dbite> can someone paste his email
17:40:55 <dbite> for the sake of records?
17:41:01 <sayali_> Unfortunately, it seems like I won�t be able to make it either. If I�m home in time, I�ll pop on IRC to talk to you guys in person.
17:41:01 <sayali_> But just in case, a quick status for the Testing subproject:
17:41:01 <sayali_> - Compute node quiz finished, with one longer question still in the pipeline - I have to amend the patch 121100.
17:41:01 <sayali_> - I�m currently working on Network node Quizzes - draft is practically finished, the patch will be submitted soon
17:41:03 <sayali_> - Megan sent me her draft for the object storage node quiz in the Associate guide, so I believe this patch will also be submitted soon.
17:41:06 <sayali_> We have to debate a bit about the last thing that is missing - the Assessment (chapter 11) - next IRC meeting or maybe Docs ML?
17:41:09 <sayali_> -M
17:41:09 <sarob_> Dbite: did i miss an email
17:41:46 <sayali_> sarob: I guess you did
17:42:15 <sarob_> So the final test.
17:42:49 <dbite> one more thing from roger
17:42:57 <dbite> he could not make it too for the meeting
17:42:57 <sarob_> I would normally think it would be made up of quiz question alternates
17:42:57 <sayali_> Hi there
17:42:58 <sayali_> I won't be able to make it to the IRC meeting today, so I'll give you a
17:42:58 <sayali_> quick report via email.
17:42:58 <sayali_> As far as I can tell, I have a working cluster now, meaning: I can boot an
17:42:58 <sayali_> instance VM reliably, ping it and ssh into it. The required patches have
17:42:58 <sayali_> been merged into the repo.
17:43:00 <sayali_> I also submitted a patch that enables DNS name resolution within instance
17:43:02 <sayali_> VMs. But Internet access for instance VMs will not be a standard feature
17:43:04 <sayali_> (at least for now). If your computer has IP forwarding enabled, it will
17:43:06 <sayali_> happily send out packets from the ext-subnet (192.168.100.x) toward the
17:43:08 <sayali_> public Internet which is unlikely to yield the desired results. -- A
17:43:10 <sayali_> solution is for the host computer to masquerade packets coming from the
17:43:12 <sayali_> instance VM. This is how I got it to work. However, configuring that is
17:43:16 <sayali_> beyond the scope of the scripts.
17:43:18 <sayali_> Although there are plenty of known issues with the scripts, they seem to be
17:43:19 <sayali_> in a somewhat usable shape now. For some time we have been talking about
17:43:21 <sayali_> getting outside testers involved. I propose that at least every one of you
17:43:23 <sayali_> guys (core reviewers) should have successfully used the scripts before we
17:43:26 <sayali_> encourage outside users to try it.
17:43:27 <sayali_> Cheers.
17:43:29 <sayali_> that was roger's email
17:44:06 <sarob_> Okay
17:44:55 <sarob_> About the assessment
17:45:00 <sarob_> Test
17:45:17 <sarob_> Does my comment make sense?
17:45:37 <dbite> I did not understand
17:45:43 <sarob_> For the first two books
17:45:57 <dbite> ahh yes
17:46:01 <sarob_> I think keeping the final test as a written
17:46:19 <sarob_> Long version of the quizzes makes sense
17:46:26 <dbite> sarob_: I think we should wait for Matjaz for this discussion
17:46:27 <sarob_> With alt questions
17:46:36 <sarob_> Agreed
17:46:39 <dbite> I cannot comment on this, sorry ... not a piece of my cake
17:46:54 <sarob_> I'm not making a decision
17:47:03 <dbite> ahh, well in that case
17:47:04 <sarob_> Just stating my opinion
17:47:08 <dbite> we could have a written exam
17:47:19 <dbite> but do you think asking theory questions is a good idea?
17:47:27 <sayali_> no!
17:47:58 <sarob_> I think theory belongs to the last two books
17:48:01 * dbite wants to state that he always failed in exams and is probably the worst person to ask about setting them
17:48:26 <sarob_> I'm thinking first two are implementation
17:48:52 <sarob_> Last two are theory, creativity, outside the box
17:48:58 <dbite> yes
17:49:04 <dbite> lets try not to call them theory
17:49:07 <sarob_> Half written, half hands on
17:49:14 <dbite> more like deisng the architecture etc.
17:49:30 <sarob_> Anyway let's wait for matjazp
17:49:39 <dbite> yes
17:49:53 <sarob_> Moving on
17:50:01 <dbite> being a prof. he is the best person
17:50:03 <dbite> IMHO
17:50:04 <sarob_> #topic av
17:50:22 <sarob_> Saw the ml email
17:50:32 <sarob_> Any response?
17:50:36 <sayali_> got no response though
17:50:48 <sarob_> Okay
17:50:57 <matjazp> hi all
17:51:06 <dbite> hello matjazp, we missed you
17:51:07 <sarob_> Matjazp hi!
17:51:14 <matjazp> just got home
17:51:52 <sayali_> I have updated the wiki but we can't do much with the existing videos till we get the license sorted
17:52:11 <dbite> can I suggest to make our own content?
17:52:24 <dbite> we could have openstack-training channel on youtube and upload our own video
17:52:26 <sarob_> Can you come up with a plan for user group
17:52:45 <sarob_> That SFBay and others could start following?
17:53:23 <sayali_> sarob: I don't understand what you say completely
17:53:53 <sarob_> The user groups are using the training content
17:54:08 <sarob_> They can make and use videos
17:54:24 <sayali_> Oh that sounds good
17:55:32 <sarob_> This is the user group how to page #link https://wiki.openstack.org/wiki/OpenStackUserGroups/HowTo
17:56:02 <sarob_> Some bits are there on video recording
17:56:08 <sayali_> ok will look at it
17:56:15 <sarob_> We should add to it
17:56:26 <sarob_> I will ask user groups to follow
17:56:38 <dbite> sarob_: it would be great to have user groups contribute by creating videos
17:56:40 <dbite> I like that idea
17:56:58 <sayali_> alright sarob
17:56:59 <sarob_> Agreed
17:57:03 <sarob_> #topic any other business
17:57:15 <matjazp> yes, training team can be more or less like editors... selecting best available content
17:57:35 <dbite> #action sayali will contribute on a model for user groups to follow and create AV content
17:57:49 <sarob_> Action #sayali_ will work on the user group training videos plan on the user group wiki
17:58:01 <sarob_> Beat me
17:58:20 <sarob_> Matjazp and the foundation
17:58:29 <matjazp> sarob_: sure
17:58:36 <dbite> sarob: you did a typo
17:58:45 <sarob_> And we coordinate more with reed
17:58:47 <dbite> #action sayali will work on the yser group training videos plan on the user group wiki
17:59:22 <reed> did you follow the hangout last friday by Dague and Pipes?
17:59:47 <matjazp> reed: Dague will have more or less more advanced content, yes?
17:59:53 <dbite> time check
17:59:55 <sarob_> Reed didn't I was running the policy summit :(
18:00:11 <matjazp> time's up.. bye
18:00:15 <reed> matjazp, it's content for developers, not necessarily 'advanced'
18:00:17 <sarob_> We can move to docs channel
18:00:27 <sarob_> #endmeeting