17:03:20 <sarob> #startmeeting training-guides
17:03:22 <openstack> Meeting started Mon Sep  8 17:03:20 2014 UTC and is due to finish in 60 minutes.  The chair is sarob. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:03:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:03:25 <openstack> The meeting name has been set to 'training_guides'
17:03:38 <sarob> #topic docs
17:03:56 <dguitarbite> docs is under slow transition for Icehouse
17:04:14 <dguitarbite> partly its my mistake, I did not get enough time to update them due to my busy schedule
17:04:27 <dguitarbite> sarob: can you help me out with the docs?
17:04:35 <dguitarbite> to update/modify them for Icehouse
17:04:52 <sarob> I'm slammed this week, but yes I
17:04:56 <sarob> Can help
17:05:11 <dguitarbite> sure, thanks :)
17:05:22 <dguitarbite> I think sayali has taken up the bug for associate guide
17:05:31 <sayali_> yep
17:05:39 <dguitarbite> I am almost done fixing the basic-install-guide for Icehouse
17:05:42 <dguitarbite> needs another brushup
17:05:56 <dguitarbite> operator guide is left, which needs serious refactoring for now
17:06:04 <dguitarbite> sayali_: thanks
17:06:22 <annegent_> dguitarbite: what's the status of bringing back any changes you've made to install guide?
17:06:31 <annegent_> dguitarbite: are they icehouse only?
17:06:54 <dguitarbite> annegent_: we are thinking of releasing Icehouse first and then focus on Juno
17:07:41 <sarob> That's my pref
17:07:50 <dguitarbite> I am still not sure if training guides needs should publish content one release later or with the current release
17:08:00 <dguitarbite> what do you guys think?
17:08:34 <sarob> I'd like to stay current
17:08:45 <rluethi> We depend on distros to make the packages available in time, or the scripts won't work.
17:08:52 <matjazp> there is a small lag for the training content, but we should be current
17:08:53 <sarob> Stay with the rest of the docs program
17:09:23 <rluethi> i.e. we can install what's not in the repo, we don't do devstack.
17:09:24 <dguitarbite> hmm, ok
17:09:58 * rluethi wonders if there's some form of chair inheritence
17:10:13 * dguitarbite problem solved
17:10:20 <rluethi> phew :)
17:10:25 <dguitarbite> :D
17:11:03 <sarob> Hey colinmcnamara
17:11:06 <dguitarbite> I think we should not have to worry about the package preferences
17:11:13 <dguitarbite> hello colinmcnamara
17:12:39 <sarob> Rluethi: why would we?
17:12:53 <rluethi> sarob: do what?
17:12:58 <dguitarbite> sarob: we need the distro packages for our labs section and install section
17:13:14 <dguitarbite> we cannot use the repositories like devstack except may be for the developer guides
17:13:33 <sarob> Dguitarbite: ah right
17:13:39 <rluethi> sarob: we can't install juno if ubuntu repos don't have them.
17:14:00 <colinmcnamara> hey guys
17:14:10 <rluethi> hey colinmcnamara
17:14:11 <matjazp> rluethi: whats the usual lag for repos?
17:14:18 <matjazp> hey colinmcnamara
17:14:21 <sarob> Rluethi: so canonical is about 1 month behind stable
17:14:27 <dguitarbite> We should ask the install guides people and the distros maintainers for this issue, Im pretty sure they have their unstable (not exact term) repos
17:14:39 <dguitarbite> sarob: I agree
17:14:59 <sarob> Afternoon colinmcnamara
17:15:13 <dguitarbite> lets move on, we could continue this discussion on the docs channel later on. Any questions for the docs sub team?
17:15:17 <rluethi> sarob: that means our scripts will lag somewhat, too; but I certainly wouldn't like us to always be a full release behind.
17:15:29 <colinmcnamara> afternoon Sarob:
17:15:46 <dguitarbite> afternoon colinmcnamara good to see you
17:15:54 <colinmcnamara> :)
17:16:06 <sarob> #topic infra
17:16:37 <sayali_> The audio visual content is in progress. Need everyone's inputs and opinions on it
17:17:08 <sayali_> https://etherpad.openstack.org/p/openstck-training-guides%28Audio_Visual_Content%29
17:17:09 <rluethi> sayali_: I missed the memo on this. is there a link?
17:17:20 <rluethi> nm.
17:17:28 <dguitarbite> #link https://etherpad.openstack.org/p/openstck-training-guides%28Audio_Visual_Content%29
17:18:30 <sayali_> The etherpad link was sent out on the mailing list and it is on the wiki
17:18:35 <sarob> Sayali_: so these are slides or topics to be covered on video?
17:19:23 <sayali_> Well initially I was thinking we could have them as seperate slides and or combine some
17:19:53 <sayali_> for instance for controller node we could combine it in one video
17:19:54 <rluethi> sayali_: which mailing list?
17:20:14 <sayali_> where as in the basic install guides we maintain the modularity
17:20:34 <sarob> Sayali_: so we would just cover the training guide books?
17:20:39 <sayali_> rluethi,  <openstack-dev@lists.openstack.org>
17:20:55 <sarob> Sayali_: I'm confused
17:21:02 <rluethi> sayali_: ah. that explains a lot :).
17:21:02 <matjazp> don't we use Docs ML?
17:21:05 <sayali_> sarob, yes we could start with that
17:21:09 <dguitarbite> sayali_: we use openstack-docs mailing list
17:22:16 <sayali_> sarob, I am open to not following the training guide structure and building a new structure covering all the content
17:22:38 <sayali_> dguitarbite, oops, my bad. Will send it on that
17:22:40 <sarob> Sayali: I'd start by just recording teaching each book to a user group and/or class
17:23:01 <matjazp> sayali_: hmm.. that will complicate things
17:23:03 <dguitarbite> sayali_: following current content initially would be a good start
17:23:31 <sayali_> sarob, I was also considering having the videos as a screenshare of what is being deployed
17:23:56 <sarob> Sayali_: that sounds good too
17:24:02 <sayali_> instead of just an audio book
17:24:40 <sarob> Sayali_: keep it simple. Just help deliver the training guide content
17:24:53 <sayali_> matjazp, Initially it would, but we might cover more content without repitition in that case
17:25:12 <sarob> Sayali_: we may do more someday, but let's do that as a team
17:25:22 <dguitarbite> I agree
17:25:26 <dguitarbite> should we vote on this?
17:25:37 <sayali_> sarob, alright so we keep the structure similar to the training-guides?
17:25:48 <sayali_> sure sarob
17:25:54 <sarob> Sayali_: yes please
17:26:07 <matjazp> sayali_: not the structure per se, but content should augment training guides
17:26:21 <sarob> Sayali_: making good video quality is hard enuf on its own
17:26:44 <sarob> What he said
17:27:06 <sarob> As the place to start
17:27:08 <sayali_> sarob, yes we need to decide on what we would be using for the recording too
17:27:12 * dguitarbite has a question
17:27:16 <matjazp> sarob: that's why we should use clips already recorded (summits, etc.)
17:27:35 <sarob> Matjazp I like that
17:27:44 <dguitarbite> who will record the videos (if required)?
17:28:01 <sarob> The next upstream training at the summit would be awesome
17:28:29 <sarob> Sayali_: who records?
17:28:52 <sayali_> sarob, I can do it
17:29:10 <dguitarbite> sarob: we could also use the videos from hackathons
17:29:16 <matjazp> at summit, there's already a professional recordings
17:29:33 <sarob> Sayali_: go ahead and write down what your plans are into your section on the wiki
17:29:34 <dguitarbite> and may be try to keep 20-30 mins in the hackathon for creating audio visual content
17:29:39 <sayali_> sarob, anybody else who wants can help too, once we decide on what would render good video recordings
17:30:16 <sarob> Sayali_: focus on the operations of making video to start
17:30:40 <sayali_> sarob, sure thing
17:30:48 <sarob> Sayali_: augmenting the existing training materials
17:31:23 <sayali_> sarob, yep
17:31:26 <sarob> Sayali_: once we get that down, we can move onto new ideas
17:31:47 <sarob> Sayali_: thx for picking this up
17:32:16 <sayali_> sarob, glad to help :)
17:32:28 <sarob> #action sayali_ updates av wiki section with plans
17:32:38 <dguitarbite> next thing, about the labs section
17:32:47 <dguitarbite> the openstack cluster builds, VMs are running
17:33:03 <dguitarbite> the current issue is that the VM's (openstack instances) do not get DHCP and metadata
17:33:09 <dguitarbite> hence cannot be accessed from the host machine
17:33:36 <sarob> Dguitarbite virtualbox bug?
17:33:51 <dguitarbite> sarob: I am not sure if its virtualbox bug, or its something to do with ML2
17:34:03 <dguitarbite> I had complete cluster running for Grizzly
17:34:06 <matjazp> wireshark?
17:34:10 <dguitarbite> with DHCP and metadata
17:34:17 <matjazp> and see where packets die?
17:34:23 <dguitarbite> matjazp: I use tcpdump, ip, etc. to do this
17:34:30 <dguitarbite> Neutron seems to work fine
17:34:44 <dguitarbite> it may be something to do with libvirt/qemu/kvm/ml2
17:34:50 <dguitarbite> the OVS tunnels work fine
17:35:01 <dguitarbite> I am trying to use VLAN tagging instead of GRE to see if that works
17:35:28 <dguitarbite> the packets seems to reach the compute node, after that I am lost (for now)
17:35:40 <rluethi> I plan to start looking into this, too. I have spent the past week tracking down a particularly elusive filesystem corruption bug.
17:36:03 <dguitarbite> rluethi: thanks
17:36:27 <dguitarbite> I hope its not due to hardware limitations and I wish this issue to be resolved without having to tweak any code
17:36:28 <sarob> We can put it out on ask
17:36:36 <dguitarbite> yes, I think we should
17:36:51 <sarob> And link it back to a bug
17:37:28 <dguitarbite> sarob: I'm not sure if it should be logged as a known bug yet
17:37:41 <matjazp> are we sure its a bug? or is it a misconfiguration
17:37:42 <dguitarbite> I need some more people to test it and confirm if its the same issue for them too
17:37:48 <sarob> Dguitarbite your call
17:38:01 <dguitarbite> matjazp: even if its a misconfiguration, its a bug for training guides labs
17:38:02 <rluethi> sarob: agree with dguitarbite, we don't really know what the problem is yet.
17:38:23 <matjazp> rluethi: I tried it, and yes, no DHCP
17:38:23 <dguitarbite> we wont be logging a bug under neutron or nova for sure at present till we are extremely sure
17:38:30 <matjazp> or metadata
17:38:35 <sarob> As soon as the scripts are going, I want to put the call out to the operators ML
17:38:53 <sarob> To start using as part of training
17:39:11 <dguitarbite> sarob: this can be used for associate guides training to certain extent
17:39:16 <dguitarbite> if hardware is the limitation
17:39:27 <dguitarbite> for hackathos etc. for now
17:39:43 <rluethi> KVM backend would be helpful for debugging that kind of issues. redundancy helps.
17:39:47 <sarob> More people using good thing
17:39:55 <sarob> Right?
17:40:08 <dguitarbite> sarob: yes
17:40:15 <dguitarbite> we are about 99% there with the scripts
17:40:18 <rluethi> sarob: as soon as it is usable.
17:40:30 <dguitarbite> we may put it under BETA tag and start spreading the word around
17:40:36 <dguitarbite> should we vote on this?
17:40:42 <matjazp> dguitarbite: it should work first
17:40:49 <rluethi> dguitarbite: everybody knows that the last % takes half the time.
17:41:06 <rluethi> agree with matjazp.
17:41:07 <matjazp> these scripts will be used by beginners and they will be confused
17:41:12 <sarob> Sure, what are voting on?
17:41:19 <rluethi> doesn't have to be perfect, but no known major issues.
17:41:24 <dguitarbite> matjazp, rluethi: ok, then I will log this as a known bug under training guides labs section and fix this issue
17:41:29 <matjazp> no IPs are major issue
17:41:40 <rluethi> matjazp: indeed :).
17:41:47 <dguitarbite> sarob: I think I got my answer, I wanted to know if we should advertise training labs
17:42:02 <sarob> Ah right
17:42:04 <dguitarbite> matjazp: I agree
17:42:25 <dguitarbite> #action dguitarbite will log a bug about the DHCP issue in openstack training labs
17:43:45 <sarob> And I will notify the sfbay user group
17:43:59 <sarob> about 5k people
17:44:20 <sarob> Should provide good feedback when you are ready
17:44:32 <sarob> Moving on
17:44:36 <dguitarbite> sarob: sure, that would be awesome
17:44:54 <sarob> #topic upstream training patches
17:45:18 <dguitarbite> there are two issues in my mind: 1. This review https://review.openstack.org/#/c/119264/
17:45:21 <dguitarbite> #link https://review.openstack.org/#/c/119264/
17:45:38 <dguitarbite> this review adds odp presentation which is a binary, should we let this through?
17:45:59 <matjazp> look at review comments
17:46:26 <matjazp> we should merge this
17:46:57 <dguitarbite> matjazp: ok, I saw the comments but I dont see a +1 or +2 :)
17:47:12 <sarob> I'll add my +2
17:47:16 <matjazp> my bad
17:47:21 <matjazp> fixed
17:47:23 <matjazp> :)
17:47:26 <dguitarbite> so I got confused
17:47:30 <sarob> I need get on the horse
17:47:32 <dguitarbite> sure, lets merge them
17:48:22 <matjazp> ahh.. to quick.. There's still Rogers comments to fix
17:49:46 <sarob> Oops, I guess I can fix and patch
17:50:26 <matjazp> sarob: yes, do that
17:50:58 <sarob> So what's this about pushing landslide
17:51:08 <sarob> From the last meeting
17:51:54 <sarob> You want to merge a stable version to training guides?
17:52:01 <sarob> Or something else?
17:52:52 <sarob> Dguitarbite ....
17:52:57 <dguitarbite> sarob: I dont follow about pushing landslide
17:53:26 <sarob> There was an action from the last meeting
17:53:43 <dguitarbite> sarob: ah, yes
17:53:49 <sarob> Dbite will push python tool
17:53:56 <dguitarbite> I was trying to figure out where the python tool goes into
17:54:18 <dguitarbite> ajaeger and I decided to push the python scripts to openstack-doc-tool
17:54:28 <dguitarbite> so that it runs landslide, builds the html and pdf files
17:54:43 <sarob> Dguitarbite ah okay. Nice
17:54:46 <dguitarbite> similar to the maven part it handels as of now
17:54:48 <matjazp> dguitarbite: nice
17:54:54 <dguitarbite> and it could also be a gate test in jenkins
17:55:00 * sarob likes
17:55:02 <dguitarbite> for future slides
17:55:13 <dguitarbite> but it will take some time, 2-3 weeks
17:55:23 * sarob automakic good
17:55:32 <matjazp> dguitarbite: in the mean time, we do it manually
17:55:40 <sarob> Dguitarbite thanks for getting that going
17:55:42 <dguitarbite> yes, I will push it on wiki
17:55:52 <dguitarbite> the steps to do it manually its not that difficule
17:56:05 <dguitarbite> *difficult and also provide the barebone python scripts for the same
17:56:06 <sarob> Good wiki fooder
17:56:09 <dguitarbite> yes
17:56:19 <sarob> #topic incubation
17:56:41 <dguitarbite> #action dguitarbite will continue working on python scripts to provide PDF for HTML as a part of openstack-doc-tools
17:56:55 <sarob> So how does the team feel about asking the TC for this?
17:57:00 <dguitarbite> #action dguitarbite will update the wiki for manual steps to build the presentations to PDF format
17:57:42 <dguitarbite> sarob: should we keep this as the priority discussion for next weeks meeting?
17:57:56 <sarob> Let's do that
17:58:01 <rluethi> sarob: may be a bit early. I'd give it another week or two.
17:58:03 <dguitarbite> we are kind of out of time and I think we need to prepare a bit more on this
17:58:27 <sarob> I'm not sure what incubation gets us at this point
17:58:38 <sarob> Let's talk about it next week
17:58:58 <sarob> #action speak of incubation at next meeting
17:59:13 <sarob> #topic any other business
17:59:29 <sarob> Real quick like
17:59:34 <dguitarbite> I think we are out of time now :|
17:59:36 <dguitarbite> im good
17:59:44 <rluethi> I got nothing.
17:59:44 <sarob> Me too
17:59:50 <dguitarbite> lets talk on docs channel if requried
17:59:51 <MeganR> I'm good
17:59:52 <sarob> Cheers !
17:59:53 <matjazp> next meeting
17:59:58 <MeganR> Bye
18:00:02 <dguitarbite> thanks a lot, bye
18:00:08 <sarob> #endmeeting