16:59:53 <sarob_> #startmeeting training-guides
16:59:54 <openstack> Meeting started Mon Aug 18 16:59:53 2014 UTC and is due to finish in 60 minutes.  The chair is sarob_. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:59:55 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:59:58 <openstack> The meeting name has been set to 'training_guides'
17:00:10 <sarob_> Roll call
17:00:16 <dbite> hello
17:00:23 <matjazp> hi
17:00:25 <sayali> Hello
17:00:32 <rluethi> hey
17:00:34 <sarob_> Evening and morning
17:00:53 <dbite> morning, evening
17:01:27 <sarob_> #topic training docs update
17:01:51 <dbite> hosted a hangout with Comcast team on Friday 15th Aug
17:02:14 <dbite> also, Icehouse stable seems pretty close, docs will be ready for Icehouse release by end of August
17:02:22 <sarob_> Sweet
17:02:27 <annegentle> sweet dbite niceone
17:02:45 <dbite> thanks, I got lot of help from the community :)
17:03:28 <dbite> not much to discuss for the docs section this time, any questions or ideas?
17:03:55 <annegentle> nothing here
17:04:06 <sarob_> So the two etherpads you were using for planning
17:04:19 <sarob_> Are all complete? Or mostly ?
17:04:58 <dbite> the first one was for basic-install-guides (for Icehouse release)
17:05:05 <dbite> its under transition, should be completed soon
17:05:09 <dbite> I have to push the patch
17:05:21 <dbite> the other one is for Juno, which is in sync with install-guides
17:05:39 <dbite> there is time for this one
17:06:17 <sarob_> Okay which one?
17:06:40 <annegentle> time for Juno I'd guess :)
17:06:46 <dbite> yes Juno
17:06:59 <dbite> the Icehouse etherpad should be completed soon
17:07:30 <annegentle> sorry to meet-n-dash but I have to drive for a bit -- ping me if you need anything
17:07:35 <sarob_> Okay sounds good
17:07:43 <dbite> annegentle: sure
17:07:43 <sarob_> Annegentle okay
17:08:20 <sarob_> Moving on
17:08:33 <sarob_> #topic infrastructure
17:09:43 <rluethi> script development chugging along; controller and compute node should be done; network node is not quite finished yet
17:09:55 <sarob_> Rluethi: good progress
17:10:17 <dbite> rluethi: nice job ;)
17:10:43 <sarob_> Rluethi: I have some renewed interest from hp
17:10:53 <rluethi> sarob: ?
17:10:55 <dbite> ?
17:11:15 <sarob_> In getting involved through rick Evans
17:11:36 <sarob_> Rick is helping with the sfbay user group
17:11:44 <sarob_> As a trainer
17:11:56 <rluethi> sarob: involved doing what? training? scripts?
17:12:11 <sarob_> Training using theatricals
17:12:15 <sarob_> Serf
17:12:18 <sarob_> Crap
17:12:26 <sarob_> Spell chk he'll
17:12:56 <sarob_> Training using the materials
17:13:01 <rluethi> how to install openstack, a story in expressive dance.
17:13:18 <sarob_> Indeed
17:13:36 <sarob_> Openstack the play on broadway is next
17:13:45 <rluethi> I hope we'll have something useful next week.
17:14:04 <rluethi> alpha quality, but useable. what do you say, dbite?
17:14:07 <matjazp> expressive dance.. well that one novel way to engage new community members :)
17:14:31 <dbite> alpha would be good description
17:14:34 <sarob_> Rick will have more ammo to get other hp trainers involved with our dance
17:14:45 <dbite> we need a week atleast to get it to beta quality
17:14:52 <dbite> and some more testing to finalize it
17:15:10 <sarob_> Rick will test as well
17:15:19 <rluethi> I just hope that networking and virtualization on virtualbox are holding up.
17:15:35 <matjazp> rluethi: just ping when we can all start testing again
17:15:39 <sarob_> I'll be on the road so not a lot from me
17:15:50 <rluethi> matjazp: will do, thanks!
17:16:23 <sarob_> Rluethi really appreciate you getting this done
17:16:26 <matjazp> rluethi: It's bash scripts first, Vagrant later, right?
17:16:42 <sarob_> Rluethi very big deal
17:16:57 <rluethi> matjazp: I try to keep Vagrant working, I think it still does, but some features will be missing (snapshotting).
17:17:35 <rluethi> matjazp: but I test regularly on Windows, so that should still work.
17:17:38 <matjazp> rluethi: np, maybe just update readme with this info
17:17:54 <sarob_> Coolness
17:18:09 <sarob_> Time to move on?
17:18:18 * rluethi nods
17:19:18 <sarob_> #topic testing
17:19:36 <matjazp> I'm working on quizzes for associate guide
17:19:52 <sarob_> Matjazp: nice
17:20:07 <matjazp> now that sarob has pushed reed's patch I can also start to work on slides
17:20:46 <matjazp> just write them in RST, and well see the epicslide/landslide isssue later, rihght?
17:20:48 <dbite> sarob_: I got landslide's html ppts. converted to pdf using python's library
17:21:09 <sarob_> Dbite: really?
17:21:13 <dbite> yes
17:21:27 <dbite> using pdfkit
17:21:28 <dbite> https://pypi.python.org/pypi/pdfkit
17:21:34 <matjazp> dbite: cool... no PrinceXML right?
17:21:36 <sayali> impress.js didn't work out too well
17:21:38 <sarob_> Dbite: goodness
17:21:43 <dbite> simple python program, converts the html to pdf
17:22:00 <dbite> so we could write a simple python script which does the conversion
17:22:02 <dbite> automatically
17:22:06 * sarob_ sarob like simple
17:22:13 <dbite> so we can proceed with reed's style
17:22:20 * dbite agrees
17:22:31 <matjazp> cool...
17:22:35 <sarob_> Dbite: so let's merge https://review.openstack.org/#/c/100999/
17:22:40 <dbite> yes
17:22:51 <rluethi> there's the dependency on wkhtmltopdf, but it's available for many platforms.
17:22:58 <sarob_> Dbite: your +2 is needed
17:23:04 <dbite> yes
17:23:04 <matjazp> dbite: I think you must remove -2 on that review?
17:23:57 <dbite> +2 it is
17:24:14 <sarob_> #info pypi pdfkit is the solution to our rst to
17:24:20 <matjazp> also... maybe we should all confirm bugs? we have 19 new bugs
17:24:54 <sarob_> We hijacked your part of the meet
17:24:56 <dbite> yes
17:25:46 <matjazp> np... I'm more than interested in the slide issues ...
17:26:09 <sarob_> Matjazp: can you get done with the assoc quiz updated this month?
17:26:20 <matjazp> sarob_: yes, thats the plan
17:26:50 <matjazp> sarob_: at least 5 quizz questions for all chapters
17:27:11 <matjazp> sarob_: later we can add/refine
17:27:16 <sarob_> #action matjazp update associate quizzes with 5 questions for each chapter
17:27:28 <sarob_> Matjazp sounds awesome
17:28:03 <sarob_> #topic upstream training
17:28:21 <sarob_> So we are good on merging the current patch
17:28:25 <dbite> yes
17:28:36 <sarob_> So we are good with the structure for now
17:28:39 <matjazp> yes, lets start the ball rolling :)
17:28:50 <dbite> I will work on the python scripts for building the pdf files
17:29:13 <matjazp> sarob_: we can start with one file for each chapter of each guide? Like Upstream's material
17:29:47 <sarob_> Matjazp: sounds good. I'm not
17:30:28 <sarob_> Matjazp: familiar with pdfkit yet so let's start there
17:31:08 <rluethi> someone should try pdfkit on mac. just to make sure the dependencies are easy enough to get.
17:31:10 <matjazp> sarob_: well this is more like infra issue, it can be done in parallel to the content
17:31:17 <dbite> sarob_ I will push initial patch soon using pdfkit
17:31:32 <dbite> rluethi: we dont need pdfkit on mac
17:31:36 <sarob_> Dbite: sounds good
17:31:43 <dbite> our main aim is to provide automatic way to convert pdf
17:31:50 <rluethi> mac was the problem with epicslide.
17:31:59 <dbite> so that it is provided via. the website
17:32:05 <matjazp> dbite: exactly... wee just need PDFs on OpenStacks's site
17:32:10 <dbite> docs.openstack.org or the web portal for upstream project
17:32:30 <dbite> rest, the html files are also provided on the website
17:32:41 <dbite> matjazp: I agree
17:33:09 <sarob_> Moving on then
17:33:43 <sarob_> #Topic any other business
17:34:28 <dbite> im good
17:34:48 <sarob_> Excellent progress team
17:35:34 <dbite> sarob_: thanks :)
17:35:56 <sarob_> Matjazp rluethi any thing else?
17:36:04 <matjazp> not from me
17:36:06 <rluethi> I'm good, too.
17:36:32 <sarob_> Any one else that hasn't spoken up?
17:36:41 <MeganR> I'm good  :)
17:36:54 <sayali> Nope all good
17:37:04 <sayali> :)
17:37:42 <sarob_> Good work everyone
17:37:58 <sarob_> I'm calling this a wrap.
17:38:18 <sarob_> A great day / evening!
17:38:24 <rluethi> bye everyone.
17:38:25 <sarob_> To all
17:38:29 <matjazp> bye all
17:38:33 <sayali> Bye
17:38:38 <sarob_> #endmeeting