17:00:09 <mmedvede> #startmeeting third-party
17:00:10 <openstack> Meeting started Tue Sep  6 17:00:09 2016 UTC and is due to finish in 60 minutes.  The chair is mmedvede. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:13 <openstack> The meeting name has been set to 'third_party'
17:00:43 <mmedvede> #link meeting agenda https://wiki.openstack.org/wiki/Meetings/ThirdParty
17:01:11 <mmedvede> anyone around for third-party wg meeting?
17:01:21 <ja3> I yam
17:01:49 <mmedvede> hi ja3
17:02:47 <mmedvede> I have one item on agenda
17:02:52 <mmedvede> #topic Jenkins Security-170
17:03:43 <mmedvede> it was brought up that people deploying puppet-openstackci still have non-functioning CI due to the security fix in new Jenkins
17:04:45 <mmedvede> and it looks like the version pinning does not work for jenkins as proposed in
17:05:00 <mmedvede> #link https://review.openstack.org/#/c/354086
17:05:44 <ja3> quoting jar jar: how wooed
17:06:26 <mmedvede> so maybe we should concentrate on getting jenkins config more flexible, as proposed in
17:06:29 <mmedvede> #link https://review.openstack.org/#/c/262787/
17:06:57 <mmedvede> asselin: are you around?
17:08:33 <mmedvede> I'll update the patch, seems like there was no activity on it recently
17:08:40 <mmedvede> #action mmedvede to update https://review.openstack.org/#/c/262787/
17:09:03 <mmedvede> ja3: did you have any troubles with jenkins?
17:09:52 <ja3> I have not heard of any.  I'm not sure that we're caught up to infra yet in terms of how we configure that piece.  We might still be horsing around pre-refactoring in some areas.
17:10:33 <ja3> ...but I also have been routing anythingn from here, and the -dev email I saw with [third party ci] today, same subject, to bob.
17:10:51 <ja3> It appears that The Bob is still OTL
17:11:45 <mmedvede> ja3: if you have Jenkins <= 1.651.1, you are fine. For newer version you'll need to have some workaround to allow it to set environment variables from zuul
17:12:28 <ja3> ok
17:12:46 <ja3> always nice to know where damacles is lurking
17:12:59 <mmedvede> :)
17:13:06 <mmedvede> #topic Open Discussion
17:14:25 <mmedvede> I might be unable to chair the next two meetings
17:14:57 <mmedvede> so with low attendance, I wonder if we should cancel them
17:15:46 <ja3> not sure - depends what ramy is up to.
17:16:13 <ja3> if it's just the two of us, canceling (or not) won't hurt.
17:16:36 <ja3> if ramy has some new 3pci iron in the fire, potentially a different story.
17:16:41 <mmedvede> +1, I'll catch him later
17:17:31 <mmedvede> ja3: do you want to discuss anything else?
17:17:49 <ja3> nope; Bob back, says we're not auto-updating
17:18:10 <mmedvede> it is wise
17:18:41 <mmedvede> thanks for attending
17:18:48 <ja3> prod is 1.642.1, dev is 1.651.2
17:19:27 <mmedvede> dev is not broken?
17:20:19 <ja3> he says not.  I call that "intewesting"
17:20:20 <mmedvede> ja3: ^
17:20:24 <mmedvede> sorry
17:21:00 <mmedvede> ja3: ok, I got 1.651.1 from https://wiki.jenkins-ci.org/display/JENKINS/Plugins+affected+by+fix+for+SECURITY-170
17:21:17 <mmedvede> maybe 1.651.2 is not completely broken
17:21:53 <ja3> that fits the observed behavior
17:25:11 <mmedvede> #endmeeting