17:00:31 <mmedvede> #startmeeting third-party
17:00:31 <openstack> Meeting started Tue Jun 28 17:00:31 2016 UTC and is due to finish in 60 minutes.  The chair is mmedvede. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:32 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:34 <openstack> The meeting name has been set to 'third_party'
17:01:08 <mmedvede> anyone here for third-party meeting?
17:01:22 <ja3> moi, misha
17:02:52 <mmedvede> hey ja3
17:03:17 <mmedvede> #topic CI Watch
17:03:55 <mmedvede> initial puppet code to deploy ci-watch has landed
17:03:58 <mmedvede> #link https://review.openstack.org/#/c/238606/
17:04:40 <mmedvede> so we now can proceed with the spec to deploy it on an infra server
17:04:42 <asselin_> hi mmedvede
17:04:49 <mmedvede> hi asselin_
17:04:59 <asselin_> hi ja3
17:05:09 <asselin_> saw that patch landed. awesome
17:05:32 <mmedvede> also, related, http://ci-watch.tintri.com seems to have lost connection to gerrit stream, and shows no recent events
17:05:50 <ja3> howdy asselin
17:06:00 <mmedvede> I have contacted apoorvad on email just now, hopefully it would get fixed
17:06:22 <mmedvede> In a meantime, I have deployed a temporary instance of ci-watch at
17:06:35 <mmedvede> #link http://54.205.162.64:5000
17:07:20 <mmedvede> any questions on this topic?
17:07:44 <ja3> nope
17:07:50 <asselin_> should we send that to the mailing list?
17:08:18 <mmedvede> asselin_: not sure. It is my personal instance, and I may take it down any time
17:08:35 <mmedvede> asselin_: I want to avoid people thinking it is a permanent place
17:08:46 <anshukch> #quit
17:09:03 <asselin_> understood...
17:09:05 <mmedvede> asselin_: you think I should still announce, even for temp?
17:09:22 <asselin_> let's wait for apoorvad's response
17:09:29 <mmedvede> +1
17:10:06 <mmedvede> #topic Common-CI Solution
17:10:28 <mmedvede> asselin_: any updates here, or should we proceed to open discussion?
17:10:46 <asselin_> not really. upstream has moved away from using jenkins
17:10:55 <asselin_> but the solution hasn't been updated yet.
17:11:04 <mmedvede> how did I forget about that?
17:11:08 <mmedvede> thanks asselin_
17:11:18 <mmedvede> asselin_: I do not think it should be updated until zuul v3
17:11:19 <asselin_> My understanding it that 3rd party folk should wait a bit more before switching to jenkins-less solution
17:11:43 <asselin_> that said, I haven't checked if the current docs and scripts still work
17:12:18 <asselin_> is zuul v2.5 used by upstream master or special branch?
17:12:21 <mmedvede> asselin_: they work for infra (zuul and nodepool part of it)
17:12:56 <asselin_> Also I did hear of a bug that the latest version of jenkins gets installed which doesn't work anymore due to permissions issues.
17:13:05 <ja3> Bob has been building our CI-dev env using old zuul + the refactored puppet work, if that's what you mean by "current" docs/scripts
17:13:33 <asselin_> 'current' is what's in puppet-openstackci master
17:15:40 <mmedvede> there are quite a few open reviews
17:15:42 <mmedvede> #link https://review.openstack.org/#/q/project:openstack-infra/puppet-openstackci+status:open
17:15:52 <asselin_> I see zuul is tagged 13th months ago..so i suppose they're on the feature branch http://git.openstack.org/cgit/openstack-infra/zuul/
17:17:01 <mmedvede> zuul.o.o shows the exact version OpenStack infra is using
17:17:35 <mmedvede> which is now a strange "Zuul version: 0.0.1.dev1071"
17:17:44 <ja3> brb
17:18:06 <asselin_> yeah, not sure what that means
17:19:17 <mmedvede> maybe something broke in zuul version display recently
17:20:33 <mmedvede> asselin_: I do not see any patches regarding openstackci jenkins deployment not working
17:21:18 <asselin_> cbader ran into an issue. I don't think he submitted any patches
17:22:17 <mmedvede> ok, thanks asselin_
17:22:57 <mmedvede> #topic Open Discussion
17:23:53 <asselin_> "The version of Jenkins that seems to work is 1.642.4.
17:23:53 <asselin_> To downgrade Jenkins all you need to do is stop Jenkins and replace the jenkins.war file in the /usr/share/Jenkins directory, then restart the service.
17:23:53 <asselin_> "
17:25:08 <mmedvede> strange, I have 1.651.1 working ok
17:25:58 <cbader> mmedvede: asselin_ is correct you will need to downgrade jenkins or you will need to change your jobs support the new jenkins requirements.
17:25:59 <asselin_> I don't think he bisected the  last working version.
17:26:22 <asselin_> cbader, what was the error/symptom?
17:26:53 <mmedvede> cbader: is it related to new security for gearman plugin? i.e. you can not pass arbitrary parameters any more, and need to predefine them?
17:27:29 <cbader> asselin_; correct
17:27:34 <asselin_> that sounds familiar
17:28:24 <cbader> mmedvede, asselin_, after build 1.652.1 is was added.
17:28:43 <cbader> I backed up to 1.642.4 to fix it.
17:28:52 <BobH_> 1.642.1 works for me
17:29:32 <cbader> the latest war I could find was 1.642.4
17:30:00 <mmedvede> maybe a version cap on jenkins config in puppet-openstackci is in order then
17:30:24 <asselin_> #link jenkins cap  might need to be added to here: http://git.openstack.org/cgit/openstack-infra/puppet-jenkins/tree/manifests/master.pp#n30
17:31:18 <asselin_> #link corrected location: http://git.openstack.org/cgit/openstack-infra/puppet-jenkins/tree/manifests/master.pp#n114
17:32:37 <mmedvede> any takers to add the cap?
17:33:26 <mmedvede> #action mmedvede to add jenkins version cap in puppet-openstackci
17:33:40 <asselin_> I think we should just cap it in puppet-jenkins and keep it simple
17:34:04 <asselin_> especially since jenkins is going away.
17:34:12 <mmedvede> #undo
17:34:12 <openstack> Removing item from minutes: <ircmeeting.items.Action object at 0x7f2b35f96610>
17:34:34 <mmedvede> #action mmedvede to add jenkins version cap in puppet-jenkins
17:34:44 <asselin_> then it's just 1 line to add
17:35:16 <asselin_> thanks mmedvede
17:35:27 <mmedvede> yes, should be simple and useful. Because there is definitely not going to be support added for new "secure" jenkins
17:35:46 <asselin_> +1
17:36:17 <cbader> +1
17:36:18 <asselin_> either way, for 3rd party ci, most folks have security behind corp firewalls, so it's not relevant
17:36:27 <mmedvede> exactly
17:37:10 <mmedvede> so it seems the latest confirmed working version is 1.651.1
17:37:49 <asselin_> seems. fwiw, I never benefit from any 'features' of newer versions
17:38:01 <asselin_> usually just bugs creeping in whenever there's an upgrade
17:38:19 <mmedvede> that +1000
17:39:32 <mmedvede> sorry I got open discussion too early
17:39:44 <mmedvede> anything for open discussion? speak up
17:41:00 <mmedvede> I then motion to end the meeting
17:41:02 <asselin_> nothing from me mmedvede. thanks for chairing!
17:41:13 <mmedvede> thanks asselin_
17:41:28 <ja3> +1
17:41:53 <mmedvede> thank you all for attending
17:41:56 <mmedvede> #endmeeting