17:01:38 <asselin_> #startmeeting third-party
17:01:39 <openstack> Meeting started Tue Feb  9 17:01:38 2016 UTC and is due to finish in 60 minutes.  The chair is asselin_. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:41 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:43 <openstack> The meeting name has been set to 'third_party'
17:01:54 <asselin_> who's here for 3rd party ci working group meeting?
17:02:02 <mmedvede> o/
17:02:15 <asselin_> hi mmedvede
17:02:35 <mmedvede> hi
17:02:48 <ja3> [mrs gorilla voice] morning
17:03:19 <ja3> lively crowd here today
17:03:36 <mmedvede> hehe, yes we are
17:03:37 <asselin_> first, I apologize for not updating the agenda. i've been away on travel for the past week.
17:04:28 <asselin_> so  how are things going?
17:04:38 <ja3> well if the topics haven't changed much, seems like an efficient tack
17:04:53 <asselin_> ok then
17:04:56 <asselin_> #topic Announcements
17:05:03 <asselin_> any announcements?
17:05:52 <asselin_> #topic CI Watch
17:06:03 <asselin_> how's ci watch going?
17:06:27 <Swanson> hi
17:06:35 <mmedvede> eantyshev proposed a good change that got merged and deployed - row selection/filtering
17:06:44 <asselin_> hi Swanson
17:07:21 <mmedvede> other than that, past couple of weeks I did not have time to spend on ciwatch unit tests
17:08:00 <asselin_> select is very nice!
17:09:08 <mmedvede> yes it is. I am also noticing that http://ci-watch.tintri.com gets a little more use, as people refer to it
17:09:38 <mmedvede> e.g. yesterday during gate failures it was useful
17:09:39 <asselin_> I'm noticing that too in irc and mailing list
17:11:08 <apoorvad> hi
17:11:09 <asselin_> mmedvede, are you waiting on more reviews of the feature/unit tests?
17:11:13 <asselin_> hi apoorvad
17:12:17 <mmedvede> asselin_: no, I just did not have time to make more progress on that
17:13:00 <mmedvede> maybe my approach is wrong at the moment, I did try to refactor a little to add tests
17:13:10 <asselin_> ok. would it be helpful to carve out some time and work on it as a group?
17:13:18 <mmedvede> other way would be to add integration test first
17:14:47 <asselin_> can you explain the issue a bit more?
17:14:54 <mmedvede> asselin_: yes, I would appreciate help. Mostly on how to go about to add the tests
17:15:03 <mmedvede> sure
17:15:25 <mmedvede> if you want to add a unit test, the thing you want to test needs to be reasonably isolated
17:15:53 <mmedvede> and the codebase we have is a little intertwined
17:16:09 <mmedvede> so no adding unit tests without refactoring first
17:16:30 <mmedvede> but, adding a high level functional test could be easier
17:16:48 <asselin_> ok I see
17:16:56 <asselin_> functional seems more useful initially
17:17:37 <asselin_> and would help reduce regressions as we refactor
17:17:53 <mmedvede> right
17:18:21 <mmedvede> one case is to test gerrit event getting added to the database
17:21:19 <asselin_> mmedvede, let's setup some time and discuss it offline. Perhaps later today?
17:21:33 <asselin_> apoorvad ja3 Swanson, what's your level of interest to join?
17:21:49 <apoorvad> asselin_ I will join
17:21:57 <mmedvede> +1
17:22:19 <asselin_> apoorvad, what time zone are you in?
17:22:26 <Swanson> Sorry, coworker in the office, join what?
17:22:42 <apoorvad> asselin_ Pacific
17:23:06 <asselin_> Swanson, working meeting to figure out testing of ciwatch
17:23:08 <mmedvede> Swanson: I would like to discuss how to go about adding some testing to ciwatch
17:23:26 <ja3> I'm still flogging my (newly arrived) CI hardware
17:23:42 <asselin_> i'm thinking 4:00 pacific?
17:23:51 <ja3> so interested but restrained by the laws of spacetime
17:24:07 <apoorvad> asselin_ +1
17:24:41 <mmedvede> 4:00 pacific works
17:24:47 <Swanson> I'm out this afternoon so I don't think I can.
17:25:21 <asselin_> ok let's do that and meet in #openstack-third-party-ci
17:26:02 <asselin_> #agree meet in #openstack-third-party-ci today 4pm PST  to discuss how to go about adding some testing to ciwatch
17:26:49 <mmedvede> 4pm PST = 00:00 utc, just in case
17:27:31 <asselin_> ack
17:27:58 <asselin_> #topic Common-CI Solution
17:28:40 <asselin_> I don't have any updates on this, although I've been seeing quite a few  nodepool patches
17:29:07 <mmedvede> asselin_: I finally migrated our nodepool to openstackci :)
17:29:26 <asselin_> mmedvede, awesome!
17:29:45 <mmedvede> feels good to reduce LOC one have to maintain
17:30:14 <asselin_> yes, I'm looking forward to do the same on my new team.
17:30:31 <mmedvede> I did submit one patch that could in theory break some of deployments, looking for link
17:30:56 <mmedvede> # link https://review.openstack.org/#/c/276964/
17:31:42 <mmedvede> It removes yaml_path from nodepool class in favor of using standard project_config params
17:31:50 <Swanson> I've been trying to get a bare ubuntu node running that can talk to jenkins.  What should I be loading other than 'ubuntu'?
17:31:51 <asselin_> looks good. will review it more carefully after the meeting
17:32:42 <Swanson> That's probably a monday meeting questino.
17:32:45 <asselin_> Swanson, you should probably be following what upstream does
17:33:11 <mmedvede> Swanson: it needs jenkins user setup that can be accessed by your jenkins
17:33:29 <Swanson> mmedvede, I'll look for that.
17:33:32 <Swanson> mmedvede, thanks!
17:33:43 <asselin_> Swanson, actually, getting the bare images would make sense to add here: https://github.com/openstack-infra/project-config-example
17:35:03 <Swanson> asselin_, biggest issue with using the nodepool-base and node-devstack stuff is that I can't get the networking right.
17:35:33 <asselin_> Swanson, what is nodepool-base and node-devstack? oh..the elements?
17:36:21 <Swanson> asselin_, yah.
17:37:00 <Swanson> asselin_, working on a base one that sets up for my environment.
17:37:22 <asselin_> I can tell you that we skip a lot of those and use the default networking provided
17:37:55 <Swanson> asselin_, Is it just a case of whacking most of the default scripts that go with those elements?
17:38:28 <asselin_> yes, and a few places commenting out and disabling e.g. unbound
17:38:59 <asselin_> those were needed by upstream to work across multiple clouds, afiak
17:39:13 <asselin_> since each cloud was doing something different
17:39:39 <Swanson> Then I have a plan.  I was trying to set everything to make sure my env looked the same but in the end it doesn't.
17:39:41 <Swanson> Thanks!
17:40:20 <Swanson> Otherwise everything else works.  Just the nodes are funky and the actual test runs fail.
17:41:22 <asselin_> Swanson, this class has an option to disable unbound: http://git.openstack.org/cgit/openstack-infra/project-config/tree/nodepool/elements/puppet/bin/prepare-node#n40
17:41:35 <asselin_> so that files needs some customization
17:42:47 <asselin_> Swanson, here's another that might be needed: https://review.openstack.org/#/c/217914/
17:43:04 <asselin_> will have to fix those merge conflicts
17:43:43 <asselin_> anything else on common ci?
17:43:47 <Swanson> asselin_, Nice.  Thanks!
17:45:07 <asselin_> #topic open discussion
17:46:19 <asselin_> anything else to discuss?
17:47:34 <asselin_> ok, cool. well see some of you later today!
17:47:37 <asselin_> thanks everyone!
17:47:38 <asselin_> #endmeeting