17:00:20 <asselin> #startmeeting third-party
17:00:21 <openstack> Meeting started Tue Sep 29 17:00:20 2015 UTC and is due to finish in 60 minutes.  The chair is asselin. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:22 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:25 <openstack> The meeting name has been set to 'third_party'
17:00:40 <asselin> Hi who's here for 3rd party ops working meeting?
17:00:48 <sweston> \o
17:01:07 <asselin> hey sweston!
17:01:30 <asselin> patrickeast, skylerberg mmedvede krtaylor rfolco
17:01:34 <skylerberg> \o
17:01:35 <sweston> hi asselin !  just got back from vacation, so haven't been able to answer your ping yet.
17:01:40 <patrickeast> hey
17:01:46 <krtaylor> o/
17:01:57 <mmedvede> o/
17:02:09 <asselin> #link agenda for today is: https://wiki.openstack.org/wiki/Meetings/ThirdParty#Agenda_for_next_Working_Group_meeting
17:02:29 <asselin> #topic Announcements
17:02:37 <asselin> #link Nodepool image-upload issue: http://lists.openstack.org/pipermail/openstack-dev/2015-September/075368.html
17:02:56 <asselin> in case you missed the mailing list post, there's a known issue with nodepool uploading images
17:03:18 <asselin> anyone else have announcements to make?
17:03:52 <asselin> #topic Comparison of CI Dashboards
17:03:59 <rfolco> o/ (late)
17:04:10 <asselin> #link https://etherpad.openstack.org/p/third-party-ci-dashboard-comp
17:04:36 <asselin> so last time we only had a few people, but hopefully today we can go into more detail
17:06:04 <asselin> sweston, radar's I suppose is not up yet?
17:06:31 <sweston> asselin: it is up, and should be showing the list of CI systems
17:06:37 <asselin> link?
17:06:51 <sweston> asselin: been trying to get to the gerrit queries, but have been buried.
17:07:00 <sweston> https://dashboard.triniplex.com
17:07:33 <asselin> sweston, works for me w/o the https, just htp
17:07:38 <asselin> http*
17:08:21 <asselin> last time we met, there was general concensus to use the ci-watch solution
17:08:41 <sweston> right, no https
17:09:05 <asselin> anyone have a different opinion?
17:09:38 <rfolco> +1 on starting with ci-watch and implementing other features gradually
17:11:08 <krtaylor> no strong opinion here, except that if we are decided, to get infra to approve it
17:11:17 <krtaylor> they feel like we can't make a decision
17:11:31 <krtaylor> when it has been so close to merging many times
17:11:33 <mmedvede> krtaylor: it is on today's agenda
17:11:40 <mmedvede> for infra meeting
17:11:48 <krtaylor> not holding my breath
17:11:51 <asselin> yes, on today's agenda
17:12:11 <patrickeast> heh yea, i'm game for any of the options but we do need to move forward with the infra stuff
17:12:15 <asselin> but we couldn't make a solid decision b/c we lacked many stakeholders
17:12:24 <patrickeast> once we have the repo's, servers, puppet, etc we can do whatever we want with it
17:12:38 <asselin> in particular, no dashboard developers were present
17:13:16 <krtaylor> decision has been made before :)
17:13:24 <krtaylor> if this is the decision let's stick with it
17:13:59 <krtaylor> next dashboard that pops up, we have to stand on this one and get it merged
17:14:04 <asselin> #agreed we use ci-watch
17:14:10 <mmedvede> +1
17:14:11 <krtaylor> +1
17:14:14 <skylerberg> +1
17:14:17 <rfolco> +1
17:14:49 <ja2> +1
17:15:00 <sweston> +1
17:15:43 <asselin> #topic ci-watch features (<skylerberg>)
17:15:44 <patrickeast> so, now that we've got our starting point picked
17:16:02 <patrickeast> do we have a plan as far as future requirements on it?
17:16:12 <rfolco> perhaps create bugs for each feature missing in ci-watch that other solutions have?
17:16:15 <skylerberg> The first thing we should do is make a project for CI Watch
17:16:23 <skylerberg> #link https://review.openstack.org/#/c/216840/
17:16:28 <patrickeast> or maybe rephrased, do we will plan to 'finish' the other dashboard spec?
17:16:53 <mmedvede> I myself would like to concentrate on features invisible on ui first, i.e. make the ciwatch adhere to some openstack service common-sense standards
17:17:06 <asselin> patrickeast, the spec will go today to infra meeting to vote as-is.
17:17:34 <skylerberg> mmedvede: Agreed
17:17:34 <rfolco> mmedvede, +1 on backend first
17:17:36 <krtaylor> mmedvede, well said
17:17:49 <asselin> mmedvede, +1
17:17:56 <mmedvede> the current spec is about hosting ciwatch, it brushes over requirements, but does not define them exactly
17:18:29 <asselin> ok, so let's get it into its own project and iterate it from there
17:18:47 <mmedvede> # link https://review.openstack.org/#/c/216840/
17:18:49 <asselin> #link review ci-watch project spec https://review.openstack.org/#/c/216840/
17:18:53 <mmedvede> this needs updating? ^
17:18:58 <asselin> skylerberg, please take it out of WIP
17:18:58 <skylerberg> rfolco: Once we merge the project-config patch we can start loading up a ci-watch bug tracker with everything we would like.
17:19:27 <asselin> skylerberg, good point. Should we use launchpad or storybaord?
17:19:40 <skylerberg> asselin: done
17:19:49 <asselin> most of openstack is on launchpad, most of infra is on storyboard
17:20:10 <skylerberg> I was anticipating using launchpad and have not actually seen storyboard. I have not strong opinion, not having used both.
17:20:37 <skylerberg> Does anyone have reasons to pick one over the other or have a strong opinion either way?
17:21:03 <rfolco> No strong opinion, would go for launchpad unless infra has objections
17:21:27 <skylerberg> rfolco: That sounds sensible.
17:21:53 <asselin> Using storyboard sets up automatically, but not a full-featured as launchpad.
17:21:54 <ja2> if we think new bodies would come from other openstack projects mostly (vs mostly from infra), we should favor what most coming in will already know.
17:22:12 <asselin> launchpad requires some manual setup, but it's documented
17:22:43 <skylerberg> asselin: it was a while ago, but I may have actually completed that setup before submitting the review.
17:23:08 <skylerberg> I was following the project creation guide, so I think it is all set up at this point.
17:23:18 <mmedvede> no strong opinion. Other than storyboard is going away
17:23:21 <asselin> skylerberg, ok then we'll use that
17:23:34 <asselin> skylerberg, do you have the link?
17:23:50 <skylerberg> #link https://launchpad.net/~ciwatch-drivers
17:23:54 <skylerberg> #link https://launchpad.net/~ciwatch-bugs
17:24:27 <asselin> #link https://launchpad.net/ciwatch
17:24:41 <asselin> #agreed use launchpad for ciwatch
17:24:57 <asselin> anything else on this topic?
17:24:58 <mmedvede> skylerberg: might be good idea to update topic for 216840 to ci-dashboard, so we can track all ci-dashboard things easier with
17:25:02 <mmedvede> #link https://review.openstack.org/#/q/topic:ci-dashboard,n,z
17:25:36 <mmedvede> skylerberg: so you think we would not have to rename ciwatch?
17:25:44 <mmedvede> my only concern at that point
17:26:23 <skylerberg> mmedvede: I do not think we will need to change it.
17:26:55 <skylerberg> mmedvede: topic has now been changed.
17:27:00 <krtaylor> mmedvede, why would we need to change it?
17:27:20 <krtaylor> mmedvede, what is your concern?
17:27:23 <mmedvede> because of this spec https://review.openstack.org/#/c/192253/, but it has not been updated in a while
17:27:29 <krtaylor> oops we lost asselin
17:28:15 <mmedvede> asselin_: you here?
17:28:42 <asselin> sorry....lost network for a bit....
17:28:53 <skylerberg> I will see if I can get ahold of sdague, but since it hasn't been updated in a while and the latest comments were asking for sdague to change the name, I don't think we will have a problem.
17:29:05 <krtaylor> mmedvede, as I commented in that patch, it has nothing to do with CI, it is for periodic testing
17:29:26 <asselin> I think we should stick to the name. If infra approves the spec, then we keep it.
17:29:32 <mmedvede> agreed
17:29:54 <krtaylor> but the url is what is in question, or is that the name you are referring to, the project can be named anything
17:30:18 <asselin> krtaylor, which url are you referring to?
17:31:03 <mmedvede> krtaylor: the ciwatch project itself was my concern
17:31:07 <asselin> I think the name is going to be openstack-infra/ciwatch
17:31:19 <krtaylor> perfect
17:31:23 <mmedvede> the service is proposed to be hosted as ci-dashboard.o.o
17:31:23 <asselin> actually patch has openstack/ciwatch
17:31:50 <krtaylor> works for me
17:33:02 <asselin> #action  review the patch to create ci-watch project https://review.openstack.org/#/c/216840/1
17:33:26 <asselin> #topic Common-CI Solution
17:33:54 <asselin> I made a lot of progess with the common-ci work
17:34:01 <asselin> #link Documentation / Instructions: https://review.openstack.org/#/c/227584/
17:34:07 <asselin> #link Single-node ci puppet class: https://review.openstack.org/#/c/200330/
17:34:12 <asselin> #link project-config-example: https://review.openstack.org/#/c/228540/
17:35:06 <asselin> The last link is to create a project-config example project
17:36:00 <asselin> it wasn't part of the original common-ci spec, but I think it's useful to setup a working test system that runs all the tempest tests
17:36:20 <asselin> and a good starting point to add your own configurations
17:37:11 <ja2> +1 on example being useful
17:37:11 <mmedvede> asselin: +1, but I have already reviewed :)
17:38:24 <asselin> any comments or questions?
17:38:52 <asselin> #topic Open Discussion
17:39:38 <asselin> any other topics?
17:39:58 <asselin> anyone new that would like to introduce themselves?
17:40:31 <ja2> I had a question worth running past this group, although I'm guessing I'll need to go to nova with it in the end.
17:40:49 <asselin> ja2, go ahead
17:41:34 <ja2> We're getting our CI system for z/VM actually running, slowly but surely.  tempest full runs a bunch of stuff we don't need, so we're config'ing our way through that.
17:42:09 <ja2> nova's hypervisor support matrix lists tens of functions - is there a named tempest subset for each?
17:42:33 <ja2> #link http://docs.openstack.org/developer/nova/support-matrix.html
17:43:03 <ja2> there's nothing like a tempest subset name on the details for each row in that table (further down, same page)
17:44:03 <rfolco> having tempest tests mapped to each row would be most excellent
17:44:34 <ja2> "would be" sounds like an implicit "...but there is no such mapping today"
17:45:10 <rfolco> the problem is that its too complex, scenario tests for example... they require multiple features in the same test
17:46:24 <ja2> let's say I'm skeptical of the "too complex" assertion, but if there's not existant mapping then that's what I need to proceed anyway.
17:46:52 <asselin> I know that tempest has ways of tagging certain tests
17:47:06 <ja2> (if one cannot reliably map those functions to tests, effectively it's impossible to audit the assertions in the matrix)
17:47:19 <asselin> or only running those when a config is enabled
17:47:52 <rfolco> ja2, I am also interested in that mapping
17:48:09 <ja2> there are some coarser-grained nova.conf "feature" booleans that _probably_ are the 80-20 easy part of the solution
17:48:30 <asselin> ja2 +1
17:48:54 <asselin> ja2 might be worth discussing with the qa team as well
17:49:24 <ja2> "the qa team" meaning the -qa channel?
17:49:30 <asselin> ja2, yes
17:49:34 <ja2> ok thx
17:49:39 <asselin> mtreinish is the ptl
17:50:31 <asselin> what do you all think about removing the old agendas from https://wiki.openstack.org/wiki/Meetings/ThirdParty
17:51:06 <ja2> "removing" meaning deletion, or archival somewhere?
17:51:52 <asselin> either way...wiki has the history but may be cumbersome to use
17:53:23 <mmedvede> asselin: the old agendas do not really bother me. What do other meeting's wikis do?
17:53:41 <asselin> infra only has the latest agenda
17:53:57 <asselin> https://wiki.openstack.org/wiki/Meetings/InfraTeamMeeting
17:54:44 <mmedvede> asselin: works for me then
17:54:53 <ja2> deletion implies most users will have no way they know of to find it, regardless of effort (I'm assuing that sites like Internet Time Machine will have them anyway), so the stakes are higher than if they're archived with a pointer to the archives.
17:55:28 <mmedvede> ja2: the meetings logs remain
17:55:50 <ja2> mmedvede
17:56:15 <ja2> mmedvede, true enough.  so yes, fine to nuke agendas.
17:57:41 <asselin> ok I'll see if there's an easy way to archive them first.
17:58:09 <asselin> if there's nothign else I'll end the meeting
17:58:13 <SotK> Hi folks, I was wondering which channel would be useful for a StoryBoard developer to chat to the project team?
17:58:31 <asselin> SotK, #openstack-infra
17:58:55 <SotK> asselin: thanks :)
17:59:14 * stevemar lurks patiently
17:59:26 <asselin> #endmeeting