17:00:16 <krtaylor> #startmeeting third-party
17:00:16 <openstack> Meeting started Tue Jun 23 17:00:16 2015 UTC and is due to finish in 60 minutes.  The chair is krtaylor. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:17 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:20 <openstack> The meeting name has been set to 'third_party'
17:00:44 <krtaylor> Who's here for the Third Party CI Working Group meeting?
17:00:49 <patrickeast> o/
17:00:56 <mmedvede> o/
17:01:36 <krtaylor> hey patrickeast , mmedvede
17:01:36 <marcusvrn> o/
17:01:45 <krtaylor> hi marcusvrn
17:01:53 <krtaylor> asselin, around?
17:02:15 <asselin> o/
17:02:24 <krtaylor> hey asselin
17:02:27 <asselin> hi
17:02:31 <krtaylor> thanks everyone for joining
17:02:46 <krtaylor> I was hoping that a few would find the new time :)
17:03:08 <asselin> this is a more convenient time for me
17:03:19 <krtaylor> I'll continue to send out email reminders too
17:03:21 <krtaylor> excellent
17:03:24 <marcusvrn> for me too
17:03:32 <mmedvede> +1
17:03:42 <krtaylor> it was hard to find a time that did not conflict with cinder or neutron
17:03:56 <krtaylor> lots of metings
17:03:59 <krtaylor> and meetings
17:04:33 <krtaylor> so, please spread the word, hopefully this time will agree with more people
17:04:48 <krtaylor> #link https://wiki.openstack.org/wiki/Meetings/ThirdParty#6.2F23.2F15_1700_UTC
17:04:55 <krtaylor> there's the link for todays agenda
17:06:18 <krtaylor> #topic Common CI virtual sprint
17:06:32 <krtaylor> asselin, your up first, do you have any thing to discuss for the sprint
17:06:44 <krtaylor> you're
17:06:56 <asselin> just requesting review os zuul patches: https://review.openstack.org/#/q/topic:downstream-puppet+owner:%22Fabien+Boucher+%253Cfabien.boucher%2540enovance.com%253E%22+status:open,n,z
17:07:26 <asselin> fbo has been working on them. I'd like to prioritize these reviews so we can merge this one next
17:07:41 <asselin> fbo_, ping if you're around
17:08:36 <asselin> goal is to get as much done before the sprint, so we can really finish then
17:08:45 <asselin> then=during the sprint
17:09:00 <krtaylor> sounds like a good plan
17:09:11 <krtaylor> the etherpad is listed in the agenda
17:09:38 <krtaylor> #link https://etherpad.openstack.org/p/common-ci-sprint
17:09:44 <krtaylor> for completeness
17:09:52 <asselin> #link https://review.openstack.org/#/q/topic:downstream-puppet+owner:%22Fabien+Boucher+%253Cfabien.boucher%2540enovance.com%253E%22+status:open,n,z
17:09:54 <krtaylor> mmedvede, I see you ave reviewed some
17:10:29 <mmedvede> yes, I did, but I need to do more. I have actually been using some patches for our deploy
17:10:41 <asselin> mmedvede, wow nice
17:10:51 <krtaylor> can anyone else review?
17:11:02 * krtaylor takes a look
17:11:38 <marcusvrn> I can try it, I review the code, but I need to test in my deploy to ensure that's working
17:11:44 <asselin> ctlaugh_ said he's interested
17:12:12 <asselin> marcusvrn, +1
17:12:14 <mmedvede> marcusvrn: exactly my sentiment, I do reviews after I test them manually
17:12:31 <mmedvede> I did not look into beaker testing yet
17:12:56 <marcusvrn> I have a question, there's a simple way to pull the code and test it manually in a current deploy?
17:13:47 <marcusvrn> current deploy (zuul installed by asselin's scripts)
17:13:50 <asselin> marcusvrn, i've been pulling them manually in my /etc/puppet/modules/
17:14:09 <asselin> e.g.  /etc/puppet/modules/openstackci
17:14:17 <marcusvrn> asselin: hmmm nice
17:14:23 * krtaylor googles beaker
17:14:31 <asselin> sudo git checkout....fetch_head copied link from gerrit
17:15:04 <asselin> marcusvrn, also used this approach: https://review.openstack.org/#/c/169117/
17:15:42 <marcusvrn> asselin: excellent
17:16:16 <krtaylor> hm, beaker looks interesting
17:17:08 <krtaylor> asselin, anything else that you need help with pre-sprint?
17:17:17 <asselin> krtaylor, http://specs.openstack.org/openstack-infra/infra-specs/specs/puppet-module-functional-testing.html
17:17:34 <asselin> that's the spek for testing puppet modules ^^
17:17:45 <asselin> krtaylor, no
17:18:18 <krtaylor> ah, that ties it together, thanks
17:18:29 <krtaylor> #link  http://specs.openstack.org/openstack-infra/infra-specs/specs/puppet-module-functional-testing.html
17:18:45 <krtaylor> any questions for asselin about the sprint?
17:19:10 <krtaylor> next topic then
17:19:15 <krtaylor> #topic Move spec to third-party-ci-tools repo
17:19:36 <krtaylor> I didn't work on this partially because I wanted to get the spec done first
17:20:20 <asselin> so just to clarify, there are 2 specs now
17:20:51 <krtaylor> there really isn't a precedent for moving a spec to a different project, but we'll try to do it a seamlessly as possible
17:21:12 <krtaylor> yes, one for hosting, one for the complete monitoring solution
17:21:17 <krtaylor> asselin, ^^^
17:21:25 <asselin> yeah...looking for links
17:22:00 <krtaylor> asselin,  they are both in the agenda
17:22:01 <asselin> in agenda :)
17:22:05 <krtaylor> yes :)
17:23:10 <krtaylor> ok, so I'm thinking I'll create a specs dir and copy sweston 's monitoring solution spec into it as-is
17:23:18 <krtaylor> then we can work it there
17:23:41 <krtaylor> then I'll ask sweston to abandon that one
17:23:54 <krtaylor> any questions?
17:23:57 <asselin> if you keep the change id, will gerrit move it?
17:24:08 <krtaylor> I was wondering that
17:24:18 <krtaylor> didn't have a chance to look into it
17:24:48 <sweston> sweston's tired ears perked up ... krtaylor I'll work with you on this
17:25:00 <krtaylor> sweston, hey
17:25:10 <sweston> krtaylor: hello!!
17:25:14 <krtaylor> thanks, asselin makes a good point
17:25:31 <sweston> I think he is right
17:25:38 <krtaylor> maybe you can just git add the spec to the new location
17:25:46 <krtaylor> and keep all the history
17:26:11 <krtaylor> that would be much preferred IMHO
17:26:58 <krtaylor> sweston, let me know when would be a good time, I'll be happy to help with that process
17:27:10 <mmedvede> I think gerrit patchsets have project associated with it in the db, so not sure that would work without direct db editing
17:27:35 <sweston> krtaylor: ok, I think I will test it out on my gerrit server first, then move forward
17:28:05 <krtaylor> mmedvede, I know you can add a file in an --amend
17:28:08 <asselin> yeah...if there's an issue, git review would likely complain similar to updating an abandoned patch...
17:28:24 <krtaylor> oh, the change id is associated with a project?
17:28:28 <krtaylor> oh
17:28:40 <krtaylor> ok, that might force the other way then
17:29:05 <krtaylor> ok, either way, we'll get it done this week
17:29:24 <krtaylor> sweston, thanks for looking at that, I know you are busy
17:29:32 <krtaylor> anything elase on this?
17:29:36 <krtaylor> else
17:29:39 <sweston> k, we'll let everyone know how it shakes out, knowledge is good
17:29:51 * krtaylor can't type today
17:30:02 <krtaylor> sweston, perfect
17:30:23 <sweston> krtaylor: no worries, good to do something else than kernel drivers for a few minutes ;-)
17:30:35 <krtaylor> ok, next then is
17:30:39 <krtaylor> #topic Spec to have infra host scoreboard
17:30:56 <krtaylor> I finished a rough draft here:
17:31:06 <krtaylor> #link https://review.openstack.org/#/c/194437/
17:31:21 <krtaylor> I would really appreciate reviews and comments
17:31:55 <asselin> krtaylor, is it will WIP?
17:32:00 <asselin> still *
17:32:03 <krtaylor> it is modeled after the codesearch hosting spec from fungi
17:32:13 <krtaylor> asselin, yes, I marked it WIP
17:32:58 * fungi is not sure it's wise to copy from his specs. do so at your own risk ;)
17:33:23 <krtaylor> fungi, it was very complete!
17:33:39 <asselin> fungi, I really liked it...
17:33:59 <krtaylor> anyway, I'd like to get some reviews done on it before allowing it to be considered for merge
17:34:28 <krtaylor> I had some questions marked in the spec
17:34:54 <krtaylor> should we have a storyboard story?
17:35:06 <asselin> krtaylor, yes we should
17:35:16 <krtaylor> it makes sense
17:35:34 <asselin> storyboard migraton spec will copy over
17:35:52 <krtaylor> ok, I'll take that as a todo
17:36:30 <krtaylor> #action krtaylor to create dashboard hosting story and revise the spec
17:37:04 <krtaylor> also, it would be good to have a primary assignee
17:37:14 <krtaylor> I am open to suggestions  :)
17:37:39 <krtaylor> I listed me there, and I don't mind doing it, just open to anyone else driving it
17:38:46 * krtaylor imagines everyone else taking one step back
17:39:09 <krtaylor> ok, I'll drive it then
17:39:28 <krtaylor> at least for now
17:39:33 <asselin> krtaylor, some other people might be interested just not present here now
17:40:31 <marcusvrn> krtaylor: what should primary assignee do?
17:40:35 <krtaylor> asselin, true, I'll be happy to hand over at some future date
17:41:00 <asselin> krtaylor, also once the tasks are in storyboard it's easier to divide and conquer
17:41:01 <marcusvrn> s/do/does
17:41:09 <krtaylor> marcusvrn, it's the person responsible for making sure it happens, including patches, docs, etc
17:41:18 <krtaylor> asselin, good point
17:41:37 <krtaylor> any questions about the content of the spec
17:41:55 <krtaylor> has anyone read it yet?  :)
17:42:13 * asselin read draft 1 :)
17:42:47 <marcusvrn> krtaylor: I got it. I'll read it after this meeting
17:42:53 <krtaylor> pretty straight forward, new vm, spin up apache with puppet to serve it
17:42:56 <patrickeast> sry was afk for a few min
17:43:01 * patrickeast looking at spec now
17:43:07 <krtaylor> patrickeast, no worries
17:43:52 <mmedvede> I have only skimmed it
17:44:31 <krtaylor> not sure we can review it section by section in 15 mins left
17:44:53 <krtaylor> so, I'll ask everyone to go through it carefully and comment please
17:45:01 <patrickeast> will do
17:45:07 <asselin> +1
17:45:08 <krtaylor> its a chance to increase your negative reviews  :)
17:45:13 <marcusvrn> krtaylor: +1
17:46:10 <krtaylor> once it gets a few reviews and corrected, I'll take the WIP off
17:46:30 <krtaylor> and, if it needs, I can discuss at an infra meeting
17:46:50 <krtaylor> any questions about the hosting spec?
17:47:12 <krtaylor> else onward
17:47:21 <krtaylor> #topic Open Discussion
17:47:30 <krtaylor> so I'll open the floor
17:48:23 <krtaylor> any thoughts on how to increase the involvement in these meetings?
17:48:45 <krtaylor> that was my todo from summit
17:49:09 <krtaylor> weekly reminders to openstack-dev, check, what else?
17:49:12 <patrickeast> free cookies?
17:49:15 <krtaylor> hehheh
17:49:19 <marcusvrn> hahaha
17:49:53 <krtaylor> I need to get more teams to come and tell us about their system, I think that has been a big success
17:50:09 <asselin> krtaylor, +1
17:50:10 <patrickeast> yea thats a good way to get others involved
17:50:10 <krtaylor> we've only done a handfull of those
17:50:16 <asselin> those are great
17:50:21 <patrickeast> we could just go down the list of ci systems and reach out
17:50:32 <patrickeast> asking them to talk to us
17:50:32 <krtaylor> patrickeast, exactly
17:50:50 <asselin> +1
17:51:00 <marcusvrn> maybe in the cinder channel which CI is "new" and too many teams are working on it
17:51:40 <krtaylor> marcusvrn, I agree that a lot of teams are new and using all their time to get it running
17:52:31 <krtaylor> but there is a lot of benefit of using that tension to better what we have, a huge part of that is the influence we have made on the common-ci effort
17:53:16 * krtaylor applauds asselin
17:53:36 <asselin> thanks
17:53:46 <krtaylor> but it is a common theme that teams don't have time to do anything "extra"
17:53:59 <marcusvrn> krtaylor: yep...
17:54:27 <krtaylor> not sure how we can fix that, except to help the teams explain to their management that this is a big commitment
17:54:50 <krtaylor> much bigger than anyone realizes just starting out
17:55:11 <marcusvrn> krtaylor: that what I did.....It was not easy....hehehe
17:55:20 <asselin> yes....that's why common ci is so important....waste less effort reinventing the wheel and chasing bugs
17:55:50 <krtaylor> asselin, agreed, and with the TPCIWG repo, we can also share everything else
17:56:20 <krtaylor> now we just need to get more involvement, with 100+ teams it is bizarre that we have 5 or so regulars
17:57:01 * krtaylor gets off his soapbox
17:57:12 <krtaylor> anything else in the last few minutes?
17:57:42 <asselin> i do...one sec
17:57:55 <breton> hello
17:58:06 <asselin> please take a look at https://review.openstack.org/#/c/192819/
17:58:14 * krtaylor looks
17:58:16 <asselin> Add the ability to abort jobs on a patch merge
17:58:26 <asselin> #link Add the ability to abort jobs on a patch merge https://review.openstack.org/#/c/192819/
17:58:38 <krtaylor> asselin, yes, good patch, I'll comment
17:59:06 <asselin> thanks
17:59:11 <marcusvrn> asselin: that's really interesting... I'll review it too
17:59:12 <peristeri> On the question of getting people involved, a "how-to" document can go a long way.
18:00:13 <asselin> peristeri, can you elaborate in -infra?
18:00:13 <krtaylor> that's all for today, thanks everyone!
18:00:28 <krtaylor> #endmeeting