04:00:16 <krtaylor> #startmeeting third-party
04:00:17 <openstack> Meeting started Wed Jan 14 04:00:16 2015 UTC and is due to finish in 60 minutes.  The chair is krtaylor. Information about MeetBot at http://wiki.debian.org/MeetBot.
04:00:19 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
04:00:21 <openstack> The meeting name has been set to 'third_party'
04:00:39 <krtaylor> anyone here for third-party ci working group?
04:00:52 <patrickeast> hey
04:01:08 <patrickeast> finally remembered to update my calander reminders for the new meeting times :D
04:01:13 <krtaylor> hi patrickeast
04:02:00 <krtaylor> I see asselin_ and mmedvede joined the channel earlier, maybe they are lurking
04:02:02 <asselin_> hi
04:02:09 <krtaylor> hi asselin_
04:02:28 <krtaylor> looks like sweston is in channel also
04:03:33 <krtaylor> well, not a huge agenda today, so that will give us time to discuss
04:03:43 <krtaylor> #topic Active work
04:04:26 <krtaylor> so, first up is third-party documentation refresh
04:04:59 <krtaylor> there is now 2 patches
04:05:21 <asselin_> I will update my query to include the new topic
04:05:22 <krtaylor> I pushed a Overview section refresh
04:05:34 <krtaylor> here is the etherpad
04:05:37 <krtaylor> #link  https://etherpad.openstack.org/p/third-party-ci-documentation
04:05:57 <krtaylor> yes asselin_ that would be great
04:06:04 <krtaylor> I added that to the etherpad today
04:06:20 <krtaylor> I figured that would be a good thing to have the topics set
04:06:59 <asselin_> yes, much easier to find and review as a group ++
04:07:26 <krtaylor> I am still not sure what the best way to handle that is, we may need to queue up a few patches and then get on infra agenda
04:07:59 <krtaylor> or maybe schedule a mini-sprint, but I hate to wait until Feb to land some of the changes
04:08:27 <krtaylor> but we would need infra at the sprint
04:08:31 <asselin_> I think a mini-sprint is a good idea
04:08:44 <asselin_> infra had good results in their doc sprint
04:09:00 <asselin_> doc --> infra manual
04:09:03 <krtaylor> and it sounded like everybody was busy until Feb, we barely got the split one scheduled
04:09:11 <krtaylor> yes, that was a huge success
04:10:00 <asselin_> I think it would be good to start scheduling the next one, especially if it's a few weeks out.
04:10:43 <krtaylor> yeah, I guess it would have to be the first week of Feb, 3 weeks out
04:10:44 <asselin_> But maybe we can do it sooner. We just need to get 2 cores to support approvals
04:11:10 <asselin_> I'm out the 1st week of Feb :/
04:11:18 <krtaylor> ouch
04:11:28 <krtaylor> ok, well we need to do it sooner then
04:11:53 <krtaylor> I'll send email to discuss and see if we can get infra core interest
04:13:12 <asselin_> last week of Jan is the cinder midcycle meetup
04:13:17 <krtaylor> #action krtaylor to rally infra core and third-party with via email around third-party documentation mini-sprint
04:13:26 <krtaylor> yeah, that was the problem
04:13:32 <asselin_> We should try to do something this week or next.
04:14:04 <krtaylor> next Wed is our early meeting, we could start a sprint then
04:14:40 <krtaylor> I have one section fairly done, and requirements well underway
04:14:52 <krtaylor> but there is a lot of detail in the later sections
04:15:08 <krtaylor> we need to decide what to document and then do it
04:16:15 <asselin_> that's what's nice about the sprint...forces your to allocate some time.
04:16:39 <asselin_> next wed & thursday are good
04:16:49 <krtaylor> yes, thanks for signing up to help, I bet I can get mmedvede to help too
04:16:53 <asselin_> we can do 48 hour sprint
04:17:12 <krtaylor> yes, I think we'll need more time than 24 hrs
04:17:31 <asselin_> infra doc manual was 48
04:18:01 <asselin_> patrickeast, you still there?
04:18:06 <patrickeast> yep
04:18:18 <krtaylor> we'll need just as much time I am afraid, fewer helpers
04:18:23 <krtaylor> I hope I am wrong
04:18:58 <asselin_> what do you think about sprint next wed & thurs?
04:19:48 <patrickeast> i should be available, although i'm not sure how much help i
04:19:53 <patrickeast> 'll be*
04:20:22 <patrickeast> i find myself asking you guys how things work most of the time, so not sure if i can run off and write up docs easily
04:20:36 <patrickeast> little tasks maybe, if there are some
04:20:43 <krtaylor> I'll propose the idea tomorrow morning via email
04:20:43 <asselin_> well, you can write the Q part of the FAQ :)
04:20:52 <patrickeast> haha yea, can do
04:20:57 <krtaylor> yes, actually there is a lot of cut and paste
04:21:20 <krtaylor> we have tons of meeting logs, good sources for q/a
04:21:28 <asselin_> krtaylor, ++
04:21:51 <krtaylor> we can prob get Omri and Andreas involved too
04:22:02 <krtaylor> oh and sweston
04:22:20 <sweston> yup ;-)
04:22:26 <krtaylor> hey sweston
04:22:29 <asselin_> hi sweston
04:22:41 <sweston> krtaylor, asselin_ hello
04:22:44 <krtaylor> just in time :)
04:23:24 <sweston> I have been slammed with handling design/implementation issues for my software defined hardware switch.  unfortunately, I have had no time for the dashboard, or (anything else not directly related to my company) since we last met.
04:23:41 <krtaylor> so if there is not anything else on docs, next topic is monitoring dashboard
04:23:51 <krtaylor> beat me to it
04:24:10 <sweston> so we can probably skip the next topic :-)
04:24:37 <krtaylor> sweston, understood, I think all of us have a "day job", let us know when you are ready to jump back in
04:25:04 <sweston> krtaylor: sure thing.  thanks for understanding
04:25:05 <krtaylor> sweston, is there anything we can do in the mean time?
04:25:48 <sweston> krtaylor: sure, everyone is welcome to start looking over the new code in the radar repository
04:26:07 <sweston> there is lots there
04:26:20 <krtaylor> I know jhesketh has commented, but the spec is prob low on your priorities currently
04:26:50 <krtaylor> yes, I did see that you were using that repo, thats good
04:27:12 <sweston> yup
04:27:52 <krtaylor> I was wondering if we could patch together the old radar as a quick fix while we were rolling out the new monitoring service
04:28:31 <sweston> the old radar code is in the scripts directory
04:28:39 <krtaylor> I have not had time to figure out what broke though, I suspect CI member lists?
04:29:06 <sweston> you are welcome to look over it, but there is not much there
04:29:27 <krtaylor> I was always a fan of the gauges, but I am easily amused
04:29:49 <sweston> i've already completed most of the effort for this in creating the rest api and web client
04:30:00 <krtaylor> I may, but I can't commit to it
04:30:11 <krtaylor> sweston, yes, and that is where we should invest review time
04:30:37 <sweston> the easy part is next, which will be implementing some of the data gathering methods
04:31:06 <krtaylor> good to know, that will help
04:31:30 <krtaylor> do you have a rough idea for when you will be able to return to it?
04:31:51 <sweston> next week, most likely
04:32:48 <krtaylor> that should work since my extra hours will be on documentation through the mini-sprint, if we are going to pull that off
04:33:10 <sweston> ok, that sounds good
04:33:18 <krtaylor> anything else for monitoring dashboard?
04:33:31 <sweston> not from me, no
04:33:53 <krtaylor> next is puppet module split out
04:34:12 <krtaylor> mini sprint is Jan 28th
04:34:31 <asselin_> 15:00 UTC
04:34:34 <krtaylor> asselin_, I did see that you added to the etherpad, with examples
04:34:41 <krtaylor> that will really help
04:34:54 <asselin_> yes, they were there before but got lost somehow
04:35:34 <asselin_> #link https://etherpad.openstack.org/p/puppet-module-split-sprint
04:36:09 <asselin_> #link https://wiki.openstack.org/wiki/VirtualSprints#Schedule_of_Upcoming_OpenStack_Virtual_Sprints
04:36:16 <asselin_> official sprint page ^^
04:36:49 <krtaylor> are you thinking that the patch sets will be mostly done before then and that mini-sprint will be discussions and approvals?
04:37:06 <asselin_> krtaylor, not necessarily
04:38:02 <asselin_> in theory, we shouldn't have to do the patches beforehand, but we can
04:38:14 <krtaylor> ok, so any advance work is proof of concept
04:38:43 <asselin_> yes, anything done beforehand will help iron out issues
04:38:53 <asselin_> sweston, is your script still running in cron?
04:39:06 <asselin_> sweston, will you be available for the sprint?
04:39:08 <krtaylor> I'll see if I can get my patches revised beforehand
04:39:40 <sweston> asselin_: yes, I will be there.  I stopped the script last week when I created the last patchset
04:40:09 <krtaylor> that will be a fun one, to crank all that out in a day or so and get it done
04:40:47 <asselin_> sweston, ok, I'm hoping we can use those repos.
04:41:00 <asselin_> krtaylor, ++
04:41:18 <sweston> asselin_: yup, I'll start the script back up again tonight
04:41:35 <krtaylor> and the question I had in the meeting agenda is answered in the etherpad
04:41:40 <krtaylor> about the storyboard
04:41:43 <asselin_> sweston, ok. if you have ideas for the script, and just lack time, let me know and I can try to help out.
04:41:56 <sweston> asselin_: sure
04:42:06 <krtaylor> mmedvede and I can too
04:42:21 <asselin_> yes, I think storyboard would be a good idea. It coordinates and you get recognition there too.
04:42:23 <sweston> krtaylor: excellent
04:42:52 <asselin_> #action asselin_ to make sure storyboard is up-to-date
04:43:04 <krtaylor> ah, yes, good point
04:43:51 <asselin_> patrickeast, if you want to help, these are pretty simple tasks
04:44:22 <asselin_> unless you're at the cinder mid-cycle meetup
04:44:32 <patrickeast> yea i'll be at the meetup
04:45:19 <krtaylor> ok, anyone have anything else on puppet module split out?
04:46:00 <krtaylor> and finally,  in-tree 3rd party ci, also yours asselin_
04:46:18 <krtaylor> that would be good to have infra feedback on
04:46:28 <asselin_> yes, not much update. just lots of thoughts
04:46:39 <krtaylor> #link https://review.openstack.org/#/q/topic:thirdpartyci,n,z
04:46:47 <asselin_> seems that will accelerate after the puppet module splits are done
04:47:04 <krtaylor> like, how to centralize configuration?
04:47:23 <krtaylor> for both upstream and third-party
04:47:30 <asselin_> no, I wasn't thinking of that
04:47:53 <asselin_> really, what's the best approach to refactor and where to put the new pieces
04:48:52 <asselin_> My latest thinking is to start an etherpad and go through the different pieces.
04:49:12 <asselin_> I hope to get some time later this week and do that
04:49:17 <krtaylor> well, we can come up with a suggestion, but I feel like the solution will be whatever has the least impact on infra
04:49:32 <krtaylor> that would be a great start
04:49:59 <asselin_> yes, that's why it's tricky and needs input from them.
04:50:05 <krtaylor> agreed
04:50:40 <asselin_> refactoring puppet is not that easy. unless there are some tools I don't know about.
04:51:26 <krtaylor> I am still learning the subtleties of puppet
04:52:14 <asselin_> so that's it unless anyone has questions or ideas
04:53:03 <krtaylor> great, thanks for all the effort in everything
04:53:14 <krtaylor> #topic Open Discussion
04:53:26 <krtaylor> anyone have anything not on the agenda?
04:53:39 <krtaylor> anyone else still awake?  :)
04:55:05 <krtaylor> well I'll end the meeting then
04:55:10 <krtaylor> thanks everyone!
04:55:11 <asselin_> thanks krtaylor
04:55:30 <sweston> thanks krtaylor
04:55:31 <krtaylor> #endmeeting