18:00:57 <krtaylor> #startmeeting third-party
18:00:58 <openstack> Meeting started Mon Nov 24 18:00:57 2014 UTC and is due to finish in 60 minutes.  The chair is krtaylor. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:59 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:01:03 <openstack> The meeting name has been set to 'third_party'
18:01:08 <mmedvede> o/
18:01:12 <sweston_> o/
18:01:21 <krtaylor> third-party ci folks?
18:01:57 <krtaylor> not sure if we will have a quorum this week or not
18:02:12 <sweston_> krtaylor: looks pretty light
18:02:29 <krtaylor> sweston, agreed
18:02:36 <asselin> hi
18:02:58 <sweston> asselin: welcome
18:03:12 <krtaylor> OK, well there are a few of us, we can determine if we need to re-discuss anything at Dec 1 meeting
18:03:36 <krtaylor> hard to tell how many lurking - Hi everyone, welcome!
18:03:42 <asselin> I would like to meet briefly. I'll have some 'quiet' time this week to help out.
18:03:53 <asselin> I won't be here next week.
18:04:05 <krtaylor> sure, lets get started
18:04:08 <krtaylor> #topic Welcome & Reminder of OpenStack Mission
18:04:18 <krtaylor> #info The OpenStack Open Source Cloud Mission: to produce the ubiquitous Open Source Cloud Computing platform that will meet the needs of public and private clouds regardless of size, by being simple to implement and massively scalable.
18:04:36 <krtaylor> and today's agenda:
18:04:40 <krtaylor> #link https://wiki.openstack.org/wiki/Meetings/ThirdParty#11.2F24.2F14
18:04:56 <krtaylor> lots of carry over still from summit
18:05:05 <krtaylor> which is to be expected this time of year
18:05:25 <krtaylor> #topic Review of previous week's open action items
18:05:59 <krtaylor> we did have actions from last time
18:06:06 <krtaylor> first was mine
18:06:18 <asselin> krtaylor, where do you see the actions?
18:06:29 <krtaylor> asselin, in the meeting log
18:06:43 <krtaylor> #link http://eavesdrop.openstack.org/meetings/third_party/2014/third_party.2014-11-17-18.01.html
18:06:49 <krtaylor> asselin, ^^^
18:07:14 <krtaylor> I created the etherpad, but did not (yet) send out email
18:07:21 <asselin> krtaylor, not seeing that on the agenda...will look later
18:07:38 <krtaylor> #link https://etherpad.openstack.org/p/third-party-ci-documentation
18:07:57 <krtaylor> asselin, not seeing action items?
18:08:28 <asselin> krtaylor, not from the agenda link....
18:08:58 <asselin> krtaylor, we can look at that later
18:09:10 <krtaylor> asselin, no they are in the meeting log, the agenda item is "Review ...action items"
18:09:44 <krtaylor> I do not break out the actions from each meeting in the meeting agenda, but thats not a bad idea
18:09:58 <krtaylor> its just a cut/paste
18:10:08 <krtaylor> most of this is just a cut/paste
18:10:13 <sweston> hehe
18:10:21 <krtaylor> just need more cut/pasters  :)
18:10:35 <sweston> good to have all the info consolidated, though
18:10:47 <asselin> krtaylor, no, I mean, I don't see the link to the past meetings from the agenda page.
18:11:18 <krtaylor> yeah, and we have discussed archiving past meetings after a while, but it would move stuff around a bit, so not needed yet
18:11:25 <dougwig> o/, sorry i'm late
18:11:30 <asselin> krtaylor, nevermind, found it
18:11:36 <asselin> sorry
18:11:49 <krtaylor> asselin, yeah, at the very bottom, that should move too
18:12:03 * krtaylor makes a metal note to move that to the top
18:12:09 <asselin> (I clicked the 2nd one, which was very old)
18:12:17 <krtaylor> yes it irritates me too
18:12:28 <krtaylor> that was before we "standardized" the name
18:12:43 <asselin> krtaylor, I'll take the action to move it :)
18:12:46 <krtaylor> thats why I insist everything be "third-party"
18:13:00 <krtaylor> not my first choice, but what we agreed to
18:13:07 <krtaylor> anyway...
18:13:30 <krtaylor> I'll email doc formation by tomorrow, hoping this will be a lighter week
18:13:56 <krtaylor> #action krtaylor to finish initial CI doc work group formation
18:14:14 <krtaylor> altright then, sweston had the second
18:14:28 <krtaylor> and that was completed, any comments sweston ?
18:14:46 <krtaylor> although we will discuss fully later
18:14:58 <sweston> krtaylor: yup, spec was completed, although no comments are posted yet, so would like to get some eyes on that
18:15:10 <krtaylor> +1, on my list too
18:15:23 <asselin> link?
18:15:31 <krtaylor> I added jhesketh to reviewers, he is out for another week
18:15:58 <sweston> also sent out an email to mikal on the stackforge radar repository, have not heard anything back
18:16:09 <krtaylor> asselin, in the agenda later
18:16:38 <krtaylor> sweston, this is something we will need to discuss for several weeks, especially this time of year
18:16:39 <asselin> must be monday morning
18:16:43 <krtaylor> hehheh
18:17:11 <sweston> also, just settled on the javascript ui framework, and have updated the github repo and the test system
18:17:29 <krtaylor> lets move along then and get to that discussion
18:17:32 <krtaylor> #topic Announcements
18:17:39 <krtaylor> any anouncements?
18:18:06 <krtaylor> onward then
18:18:17 <krtaylor> #topic OpenStack Program items
18:18:52 <krtaylor> CI documentation, I have already commented on the state of that, there was a lot of interest at summit
18:18:58 <krtaylor> need to get that kicked off
18:19:17 <asselin> krtaylor, I'm interested to help out with that
18:19:26 <krtaylor> asselin, yes, please
18:19:38 <krtaylor> I figured most everyone here will have patches for that
18:19:56 <krtaylor> we'll just need to coordinate what parts each will work on initially
18:20:09 <krtaylor> so we dont re-write a section 3 times
18:20:23 <krtaylor> stay tuned for email soon
18:20:35 <krtaylor> anythings else on that?
18:20:57 <sweston> krtaylor: maybe we can have bug tracking for the docs
18:21:19 <sweston> that might give some order to the chaos
18:21:31 <krtaylor> sweston, hm, I was thinking maybe jumping in and using storyboard
18:21:34 <sweston> it's a bit more sophisticated than dibs, ;-)
18:22:00 <krtaylor> dividing up the doc into tasks
18:22:08 <sweston> krtaylor: +1, storyboard would be great
18:22:14 <krtaylor> then someone can assign a section to themselves
18:22:14 <asselin> does etherpad have an export to rst. wondering if there's a way to do 'live' updates
18:22:31 <krtaylor> similar to what we are doing with puppet modules
18:22:32 <asselin> or a wiki page with sections
18:23:02 <krtaylor> asselin, either way, we'd need patches for review
18:23:21 <asselin> true
18:23:23 <sayali> I agree too./part
18:23:24 <krtaylor> I think it would be easier for comments and agreement
18:24:12 <krtaylor> my thought was to bust up the doc into proposed sections, then reach agreement on that in etherpad, then I'll populate storyboard
18:24:24 <krtaylor> then we can start patch party
18:24:47 <krtaylor> it will be good to follow along with the infra documentation work that is coming up too
18:24:55 <asselin> ok
18:24:56 <sweston> asselin: that's a good question, it does doku wiki, I don't think it does rst
18:25:03 <krtaylor> I believe the virtual sprint is coming up
18:25:15 <sweston> patch party, yeah!
18:25:33 <krtaylor> do we want to start a virtual sprint for this work?
18:25:51 <krtaylor> that would be a 2-3 day meeting in the new sprint irc channel
18:26:06 <sweston> krtaylor: that would be lovely
18:26:31 <krtaylor> let's see how the infra doc sprint goes and we can follow, maybe 1st or 2nd week of January
18:26:47 <krtaylor> that will give us time to identify sections
18:27:22 <sweston> sounds good
18:27:26 <asselin> agree
18:27:31 <krtaylor> excellent, sounds like a plan
18:27:46 <krtaylor> ok, onward, CI monitoring and dashboard
18:27:53 <krtaylor> sweston, any comments
18:28:08 <sweston> let me find the link to the review
18:28:14 <krtaylor> I did review the spec, it is good I have a few additions that I'll add
18:28:31 <krtaylor> #link https://review.openstack.org/#/c/135170
18:28:44 <krtaylor> sweston, it is in the agenda too
18:28:58 <sweston> krtaylor: ok, see that now, thanks
18:29:25 <sweston> looking forward to the input
18:29:53 <sweston> here is a link to the dashboard test server, http://dashboard.triniplex.com
18:30:01 <krtaylor> sweston, the page created is very interesting, I did not realize there were that many systems actually reporting
18:30:36 <sweston> I know, I was surprised too
18:30:55 <krtaylor> sweston, actually that was one of my comment areas, that the page needs to be summarized somehow, initially we were thinking Radar-ish
18:31:13 <krtaylor> people like pretty colorful guages, etc
18:31:18 <sweston> so now that I have the ui framework in place, the next step is building the daemon that will hook into the ssh event stream
18:31:43 <sweston> krtaylor: yes, that's what I was thinking as well, but I don't have much to visualize right now
18:31:53 <krtaylor> sweston, yes, my second area of comment
18:32:01 <sweston> any suggestions for what might go well there?
18:32:15 <krtaylor> it is great to have something to poke at, this is excellent work sweston !
18:32:46 <sweston> krtaylor: yay! and, thanks
18:32:49 <krtaylor> sweston, yes, that would be a good discussion with jhesketh
18:32:55 <asselin> yes, sweston, very nice!
18:33:08 <sweston> asselin: thanks :-)
18:33:20 <krtaylor> it is finally coming together, we have talked about different approaches for months
18:33:45 <krtaylor> it takes someone to put together an initial plan, then everyone can jump on board
18:33:52 <krtaylor> thanks sweston
18:34:15 <krtaylor> anything else on this?
18:34:34 <krtaylor> alright onward
18:34:57 <krtaylor> #topic Deadlines & Deprecations
18:35:09 <krtaylor> I don't know of any new deadlines yet
18:35:12 <sweston> welcome.  yes, the hope was that once there is a testbed and repository that there will be more interest generated and more people will begin to contribute.
18:35:36 <sweston> ok, am done now, continue, please
18:35:40 <krtaylor> but I know some groups will have new deadlines as we get further into Kilo
18:35:48 <krtaylor> sweston, np
18:36:12 <krtaylor> might have some new ones from cinder maybe?
18:36:18 <krtaylor> we'll see
18:36:45 <krtaylor> I'll get those cores to come give us a status on testing
18:37:02 <krtaylor> anything else?
18:37:21 <krtaylor> #topic Highlighting a Program or Gerrit Account
18:37:49 <krtaylor> so, only thing here is the ongoing split patches
18:38:12 * krtaylor still needs to update his
18:38:57 <asselin> I can do another one. Any opinions on which is next?
18:38:58 <krtaylor> there has been a bunch of merges  - nice work asselin and mmedvede
18:39:07 <asselin> thanks
18:40:03 <mmedvede> thanks. I have another one I am working on, waiting for the spec to settle down
18:40:16 <asselin> also wondering if that should be more automated now...?
18:40:52 <asselin> there's 50 or so
18:40:52 <krtaylor> I don't see why not
18:41:27 <mmedvede> The split itself could be somewhat automated. But most of work seems to be coordinating the merges
18:41:42 <asselin> right
18:42:11 <sweston> we need continuous integration for continuous integration
18:42:12 <asselin> and I found that 'updating' a split is not a big deal, so we don't really need to freeze until we're ready to merge
18:42:49 <mmedvede> asselin: updating involves asking someone to force push, correct?
18:42:52 <asselin> and by updating, I mean re-subtree-ing a split
18:43:20 <asselin> right, pushing to the temp git hub location
18:43:43 <asselin> in fact, it could be a cron job
18:44:17 <asselin> or a post-job on the infra ci system
18:44:35 <sweston> or even a file, used as a semaphore
18:44:53 <asselin> sweston, ??
18:45:01 <krtaylor> it could, but I suspect that infra cores will want to be involved
18:45:06 <mmedvede> I think in  time between first and second merge, you would still need to make sure the new project is up to date (not the temporary github location)
18:45:10 <sweston> you create it when you are ready to push, once the system merges it, the file is removed
18:45:30 <mmedvede> So some sort of freeze is necessary
18:45:48 <krtaylor> sweston, I believe there was comments on that, and WIP was the answer, right?
18:46:09 <sweston> krtaylor: I believe so
18:46:32 <asselin> mmedvede, not sure. I'm wondering if we can minimize the freeze by keeping the temp in sync with master.
18:47:03 <mmedvede> krtaylor, sweston, that was due to us not marking commits clearly. If we do, we could get away without WIPing. But we need to be careful
18:47:13 <krtaylor> agreed
18:47:22 <sweston> yup
18:47:31 <mmedvede> asselin: I do not think the new project does update automatically from the temp
18:47:46 <mmedvede> if it did, then yes, would be much easier
18:48:05 <asselin> mmedvede, let me expalin my idea again more clearly.
18:48:39 <asselin> we create a new post-job that re-subtress the puppet modules in system-config to the temp git-hub location, so they're always in sync
18:49:08 <asselin> then, when we merge the project-config change the pulls in the temp github repo, it will be correct.
18:49:58 <mmedvede> asselin: that is what I thought you were saying. The problem is with the period between the first and the second merges. It can become out of sync
18:50:17 <sweston> asselin: wouldn't that potentially overwrite your changes?
18:50:41 <asselin> mmedvede, yes, true, but that time is short.
18:51:08 <asselin> sweston, no, when you re-tree, git is smart enough to just push the extra commits
18:51:22 <mmedvede> asselin: it is only short if there is a core that shephards the merge. There is at least 20 minutes between merges
18:51:23 <asselin> sweston, this is what happened when I did if for puppet-jenkins
18:51:39 <sweston> asselin: ah,
18:52:58 <sweston> well, I think it's a good idea.  ideas for forward movement?
18:53:21 <asselin> I can play around with it and see if I can get a patch proposed
18:53:27 <mmedvede> sweston: with more automation for splits?
18:53:46 <krtaylor> yes, otherwise it is a long process for another 40 patchsets
18:54:03 <sweston> mmedvede: yes, I think this is going to continue to slow you down substantially, until it is fixed
18:54:16 <asselin> ideally, we can do it quickly and get it done. like pulling off a band-aid
18:54:24 <krtaylor> lol
18:55:02 <sweston> asselin: yes, but in my experience people don't like it 'cause it hurts, :-)
18:55:10 <asselin> lol :)
18:55:13 <mmedvede> +1 on auto-subtreeing were possible (just keep in mind some history is lost with subtree split)
18:55:44 <krtaylor> ok, let's move on so we have time for questions, we can discuss this further in -infra
18:56:05 <krtaylor> mmedvede, that would be a good question, how much info lost is a problem
18:56:14 <krtaylor> with sub-tree split
18:56:27 <krtaylor> ok, we have 4 minutes
18:56:44 <krtaylor> no Third-party system review this week, those are coming
18:56:45 <asselin> I'm curious to know why no third party solution exists in -infra with so many 3rd party operators.
18:57:13 <krtaylor> asselin, not sure I understand
18:57:20 <sweston> asselin: me too.
18:57:31 <asselin> there's 100 ci systems according to sweston dashboard
18:57:47 <asselin> but 3rd party solutions I know of are jaypipes and a few forks from there
18:57:50 <sweston> asselin is talking about a project for third party automation
18:58:02 <clarkb> asselin: because very few third party operators actively participate with infra upstream
18:58:02 <krtaylor> if you mean this agenda item, it is just because I have not told someone that are presenting
18:58:07 <asselin> the rest must be private
18:58:14 <krtaylor> ah, there are other solutions
18:58:15 <clarkb> asselin: yes exactly
18:58:35 <sweston> clarkb: which is a shame :-(
18:58:36 <krtaylor> but, all agreed that they would be willing to share what they have created
18:58:44 <krtaylor> in our third-party session
18:59:21 <krtaylor> its like I said, it takes someone to push a proposal and then everyone can jump on board
18:59:31 <krtaylor> ok, 1 minute  :)
18:59:33 <sweston> krtaylor: +1
18:59:58 <krtaylor> we ran out of time for open discussion this week
19:00:02 <sweston> clarkb: are you omnipresent in all channels, btw?
19:00:08 <sweston> :-)
19:00:08 <asselin> krtaylor, ok thanks good info.
19:00:20 <krtaylor> if anyone has questions, lets continue in -infra channel
19:00:24 <sweston> thanks everyone!
19:00:24 <asselin> clarkb, thanks too
19:00:29 <krtaylor> good meeting!
19:00:30 <jroll> \o
19:00:39 <krtaylor> bye all
19:00:50 <krtaylor> #endmeeting