18:01:16 <krtaylor> #startmeeting third-party
18:01:17 <openstack> Meeting started Mon Nov 17 18:01:16 2014 UTC and is due to finish in 60 minutes.  The chair is krtaylor. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:01:18 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:01:20 <openstack> The meeting name has been set to 'third_party'
18:01:23 <ShillaSaebi> i think i got confused with time
18:01:34 <ShillaSaebi> ill have to catch up via the meeting minutes
18:01:40 <krtaylor> ShillaSaebi, I am sure you are not th only one :)
18:01:52 <ShillaSaebi> yeah forgot it was UTC
18:01:55 <krtaylor> anyone here for third-party CI?
18:01:56 <ShillaSaebi> we had a time change
18:02:03 <sarob> i just got back, so understand
18:02:06 * ctlaugh is here
18:02:06 <sweston> I am
18:02:06 <sarob> cheers
18:02:11 <nuritv> krtaylor:yes
18:02:32 <krtaylor> Hi everyone, welcome!
18:02:47 <nuritv> Hi
18:02:53 <luqas> hi
18:03:16 <krtaylor> #topic Welcome & Reminder of OpenStack Mission
18:03:25 <krtaylor> #info The OpenStack Open Source Cloud Mission: to produce the ubiquitous Open Source Cloud Computing platform that will meet the needs of public and private clouds regardless of size, by being simple to implement and massively scalable.
18:03:36 <krtaylor> and here is today's agenda:
18:03:50 <krtaylor> #link  https://wiki.openstack.org/wiki/Meetings/ThirdParty#11.2F17.2F14
18:04:13 <krtaylor> #topic Review of previous week's open action items
18:04:30 <krtaylor> so, we had none, time change and summit are to blame I suspect
18:04:41 <krtaylor> #topic Announcements
18:04:58 <krtaylor> none listed, anyone have a brief announcement?
18:05:29 <krtaylor> #topic OpenStack Program items
18:06:24 <krtaylor> I am still digesting all the content from summit, the session was great
18:07:32 <krtaylor> I have my takeaways, mainly  CI documentation, CI monitoring dashboard, and improving interaction and communication
18:08:04 <krtaylor> one of the actions from summit was to get an alternate meeting time
18:08:48 <krtaylor> I'll be sending out email with a few proposed times, although those voting are likely not attending now  :)
18:09:19 <krtaylor> any comments about the summit session?
18:09:57 <krtaylor> Ok, then next we have CI documentation improvements
18:10:19 <krtaylor> there were several people that volunteered at summit to help with CI documentation
18:10:30 <krtaylor> and email sent out
18:10:49 <krtaylor> but I have not seen anything else
18:11:08 <krtaylor> anyone have an update on that?
18:11:41 <nuritv> krtaylor: i am one of the volunteers, but i have no idea how to start
18:11:51 <krtaylor> btw, the answer to the question I posted on the agenda is no
18:12:20 <krtaylor> nuritv, fair enough, I'll help get that rolling
18:12:34 <nuritv> krtaylor: thanks!
18:12:39 <luqas> hi, I also volunteered but I have been very busy after the summit
18:12:44 <krtaylor> we probably need to organize that a bit, maybe a wiki, then divide up into a set of patches
18:13:09 <krtaylor> luqas, yes, understood
18:13:18 <krtaylor> maybe an etherpad, not wiki
18:13:24 <sweston> as far as the infra manual effort? what was the criteria for making the separation between ci docs and infra docs?
18:13:27 * krtaylor is still recovering from summit
18:14:06 <krtaylor> sweston, not sure, but the infra team wanted us to go fix CI docs in third-party.rst first
18:14:22 <sweston> krtaylor, i see
18:14:22 <krtaylor> then it would be rolled into the shiny new infra doc
18:14:29 <sweston> fair enough
18:14:56 <krtaylor> yeah, the reason was that we already had a place for it, so put it there
18:15:28 <krtaylor> I was a little concerned with style-guide stuff, but it makes sense, we also have an immediate need
18:16:09 <sweston> yup, agreed it's a good idea to keep it separate until we have it polished
18:16:27 <krtaylor> nuritv, luqas and others wanting to contribute, I'll send out email today to get it started
18:16:50 <krtaylor> #action krtaylor to send out email with etherpad to start off CI doc improvements
18:17:12 <luqas> krtaylor: ok
18:17:18 <nuritv> krtaylor: thanks
18:17:29 <krtaylor> ok, next is the CI monitoring dashboard
18:17:47 <krtaylor> I sent out email pulling together the few efforts I knew of after summit
18:18:02 <krtaylor> sweston, you agreed to drive that correct?
18:18:17 <sweston> krtaylor, correct
18:18:48 <sweston> krtaylor, what are our next steps?
18:19:01 <krtaylor> #link https://etherpad.openstack.org/p/Third-Party-CI-Dashboard-InitialPlanning
18:19:28 <krtaylor> sweston, the next step was to create a spec, so that we could all start the design process
18:19:36 <sweston> I have the .rst created for the infra spec ... but it's mostly skeleton, should that be posted to gerrit?
18:20:30 <krtaylor> yes, although I am not sure where cross-project specs should go
18:20:45 <sweston> this is my first spec, so extensive reviews and modifications will probably have to be made
18:20:52 <asselin> \o
18:21:48 <krtaylor> I guess we could always use openstack-infra/infra-specs
18:22:09 <sweston> krtaylor, ok, awesome, I'll post it after the meeting today
18:22:12 <krtaylor> sweston, lets ask about this in -infra after this meeting
18:22:24 <sweston> krtaylor, ok, fair enough
18:23:17 <sweston> I also have a few more updates
18:23:19 <krtaylor> #action sweston to post CI monitoring dashboard spec in proper project to be determined
18:23:32 <krtaylor> sweston, anything you want to discuss here?
18:24:19 <krtaylor> we need a repo location too, are we going to reuse radar?
18:24:24 <sweston> I have created the initial poc for the dashboard, and will be sending out a link in email for the github repository and the hosted server it is running on
18:25:13 <sweston> right now, it uses celery to schedule a task which runs every 5 minutes to get a list of ci servers from gerrit
18:25:14 <krtaylor> sweston, ok sounds good, the earlier in the process the better
18:25:55 <sweston> and i have the views and django framework up, I'll give all the goodies in the email I send out
18:26:54 <krtaylor> sweston, 5 mins should be fine,  you are backing the data so we can have historical graphing?
18:27:14 <krtaylor> or next steps :)
18:27:31 <sweston> I have created an events model which we will be storing the historical info in
18:28:02 <sweston> krtaylor, but the data is only stored in one place now
18:28:21 <sweston> what do you suggest for backing?
18:28:23 <krtaylor> sounds good, get the repo sent out asap so we can get other eyes on it
18:28:53 <sweston> ok, I will send it out today
18:28:54 <krtaylor> sweston, no preference, we can discuss in the spec reviews for those with an opinion
18:29:01 <krtaylor> sweston, excellent
18:29:12 <sweston> krtaylor, :-) sounds good
18:29:35 <krtaylor> ok, anything else?
18:29:50 <sweston> nothing from me, thanks, please continue
18:29:55 <krtaylor> let's move on then
18:30:07 <krtaylor> #topic Deadlines & Deprecations
18:30:26 <krtaylor> none listed here, although I was interested if any came out of summit
18:30:38 <krtaylor> anyone?
18:31:34 <krtaylor> next then
18:31:42 <krtaylor> #topic Highlighting a Program or Gerrit Account
18:32:12 <krtaylor> the only thing listed is the puppet module split out work
18:32:18 <krtaylor> that continues
18:32:33 <krtaylor> #link https://review.openstack.org/#/q/topic:module-split,n,z
18:32:49 <asselin> jenkins puppet module merger earlier today
18:32:54 <asselin> merged*
18:33:07 <mmedvede> saw that, yay!
18:33:13 * krtaylor still needs to update his patch
18:33:19 <krtaylor> nice asselin !
18:33:40 <sweston> asselin, I saw it as well, well done, sir
18:33:50 <asselin> still some 'details' that need to ironed out and the rest should hopefully go smoothly
18:34:12 <mmedvede> There are two spec patches that are ready to land as well
18:34:14 <asselin> trying to keep track of those details in the infr-spec, so please review those
18:34:15 <mmedvede> #link https://review.openstack.org/#/c/132129/
18:34:15 <mmedvede> #link https://review.openstack.org/#/c/129768/
18:34:37 <mmedvede> probably should ask in tomorrow infra meeting
18:34:40 <krtaylor> excellent, yet another way for us to contribute
18:34:47 <krtaylor> mmedvede, yes
18:35:05 <krtaylor> can someone put that on the infra agenda?
18:35:13 <asselin> yes, I'm not planning ot change those 2. Instead, add stuff to new reviews
18:35:25 <asselin> #link https://review.openstack.org/#/c/134393/
18:36:17 <krtaylor> ok, I should be there as well
18:36:34 <krtaylor> asselin, are you putting that on the agenda?
18:37:02 <asselin> I wonder if we can just poke them in -infra?
18:37:22 <asselin> I can add agenda item to decide on https://review.openstack.org/#/c/134393/1/specs/puppet-modules.rst
18:37:45 <mmedvede> asselin: yes, we can. I meant to do this today. Would save meeting time
18:37:57 <krtaylor> asselin, well maybe, if they dont need discussion across the broader team
18:38:17 <krtaylor> and it would save getting bumped to next week :)
18:38:25 <asselin> krtaylor, ok, I can add the agenda item. but will try to get it resolved today still
18:38:42 <krtaylor> sounds like a plan
18:38:52 <krtaylor> anything else?
18:39:54 <krtaylor> btw, I will be making good on my request for third-party systems to come to this meeting and share their experience, how they worked through problems and so on
18:40:03 <krtaylor> so, look for that next week
18:40:20 <krtaylor> ok, onward
18:40:29 <ctlaugh> ^^ excellent
18:40:34 <krtaylor> #topic CI system issues
18:41:13 <krtaylor> this is a new section of the meeting, for us to point out other systems that are having a problem, or to ask questions about a problem we are seeing with our own system
18:41:39 <krtaylor> the idea is to get us to be more self-regulating, as we discussed at summit
18:41:56 <krtaylor> any issues seen?
18:42:04 <krtaylor> anyone having a problem?
18:42:45 <krtaylor> mmedvede, we could bring up that we have seen lately
18:43:03 <mmedvede> we had a problem today when upstream created a new project (irc-meetings) and it did not properly replicate to their servers
18:43:39 <krtaylor> did that hit anyone else?
18:43:47 <mmedvede> It took about 2.5 hours for the new git repository to be properly created.
18:44:18 <mmedvede> This did manifest as nodepool image update failing on that repository
18:46:11 <krtaylor> ok, well, if no other concerns or issues, then I'll open the floor
18:46:22 <krtaylor> #topic Open Discussion
18:47:54 * krtaylor thinks everyone is still tired and busy from summit travel
18:48:33 <krtaylor> well, we have wound down the discussion rather quickly
18:48:49 <krtaylor> thanks everyone for attending today
18:49:01 <sweston> thanks
18:49:04 <krtaylor> I'll go ahead and end the meeting then
18:49:16 <krtaylor> bye everyone
18:49:33 <krtaylor> #endmeeting