18:00:47 <krtaylor> #startmeeting third-party
18:00:48 <openstack> Meeting started Mon Sep 29 18:00:47 2014 UTC and is due to finish in 60 minutes.  The chair is krtaylor. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:49 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:52 <openstack> The meeting name has been set to 'third_party'
18:00:53 <asselin> hi
18:00:56 <krtaylor> Hi all
18:01:14 <krtaylor> anyone else?
18:01:17 <sweston> o/
18:01:30 <luqas> o/
18:01:33 <rfolco> o/
18:01:59 <krtaylor> Hello!
18:02:19 <krtaylor> we have a light agenda today, which means we usually have a very full meeting  :)
18:02:26 <krtaylor> #topic Welcome & Reminder of OpenStack Mission
18:02:38 <krtaylor> #info The OpenStack Open Source Cloud Mission: to produce the ubiquitous Open Source Cloud Computing platform that will meet the needs of public and private clouds regardless of size, by being simple to implement and massively scalable.
18:03:02 <krtaylor> here is the agenda:
18:03:05 <krtaylor> #link https://wiki.openstack.org/wiki/Meetings/ThirdParty#09.2F29.2F14
18:03:20 <krtaylor> #topic Review of previous week's open action items
18:03:29 <krtaylor> none from last week
18:03:49 <krtaylor> #topic Announcements
18:04:08 <krtaylor> nothing here, but we did have a discussion last week on an interesting defect
18:04:21 <krtaylor> I though I'd have some time to look at it
18:04:28 <krtaylor> sweston, did you ?
18:05:00 <sweston> I will look at it today
18:05:18 <krtaylor> sweston, no pressure, just curious if you had
18:05:35 <sweston> not yet, but just getting started for the week ;-)
18:05:54 <krtaylor> here is the link for completeness: #link https://bugs.launchpad.net/zuul/+bug/1370105
18:05:55 <uvirtbot> Launchpad bug 1370105 in zuul "feature request: gerrit files option for pipeline triggers" [Wishlist,Triaged]
18:07:01 <krtaylor> #topic OpenStack Program items
18:07:05 <krtaylor> onward then
18:07:22 <krtaylor> I kept the summit prep item from last week
18:07:32 <krtaylor> since I added a few points
18:07:37 <krtaylor> here is the link:
18:07:48 <krtaylor> #link https://etherpad.openstack.org/p/kilo-third-party-items
18:08:19 <krtaylor> not all of that is fully though through, but there are some improvement ideas that I think fit the summit format well
18:08:31 <krtaylor> anteaya, are you around?
18:09:19 <krtaylor> well, if you all could go take a look, add ideas, comments
18:09:56 <krtaylor> I think we can come up with a few strong points to discuss, but we will have to prioritize with the other infra timeslots
18:10:08 <anteaya> I am
18:10:20 * krtaylor is not sure on the schedule to decide summit sessions
18:10:49 <anteaya> well there is more content here than last week
18:10:53 <krtaylor> anteaya, we were just touching on the summit planning etherpad
18:10:56 <anteaya> so that is heartening, thanks krtaylor
18:10:58 <anteaya> right
18:11:33 <krtaylor> I'd like to have a few points to take forward to infra meeting for design session
18:11:34 <anteaya> krtaylor: you had mentioned that some of your items required input from infra
18:11:41 <anteaya> is that still the case?
18:11:47 <anteaya> which points?
18:11:53 <krtaylor> yes, I am sure there are opinions there
18:11:59 <krtaylor> let me scan
18:12:29 <krtaylor> Realibility, how to check, how to report
18:12:49 <krtaylor> self policing
18:12:52 <anteaya> how does that require changes from infra?
18:12:53 <krtaylor> self service
18:13:18 <anteaya> these have been goals from the beginning
18:13:30 <krtaylor> changes would need to be made, whether for test, pipeline, webpage, etc
18:13:33 <krtaylor> yes
18:13:51 <anteaya> patches yes
18:13:56 <anteaya> and patches would be welcome
18:14:00 <krtaylor> yep
18:14:40 <krtaylor> we should be involved in the infra discussions that influence third-party CI
18:14:46 <anteaya> and patches can come anytime
18:15:05 <anteaya> we don't have to wait for summit if anyone wants to offer patches on any of these items
18:15:16 <anteaya> you are
18:15:28 <krtaylor> sure
18:15:33 <anteaya> and always welcome to add agenda items
18:15:44 <anteaya> but agenda items with patches are even better
18:15:50 <krtaylor> agreed
18:16:11 <anteaya> so let's see how many things we can knock off this list before summit
18:16:20 <anteaya> we don't need to wait on some things
18:16:24 <anteaya> for instance
18:16:33 <krtaylor> we all have CI responsibilities, easier if we all agree and work on an idea together, dropping a reporting system in one patch is not likely
18:16:56 <anteaya> if folks would be so kind as to ensure at least one other third party operator has checked their ci before they request to be enabled after being disabled
18:17:00 <anteaya> that would sure help me
18:17:09 <anteaya> up to you
18:17:16 <anteaya> that is what the mailing list is for
18:17:19 <krtaylor> yes, great idea
18:17:19 <anteaya> and the meetings
18:17:25 <anteaya> so people can discuss things
18:17:57 <krtaylor> if we can organize on that we can self-police and make all this better, improve the image that CI has in the community
18:18:12 <anteaya> lets use the term self-regulate
18:18:17 <anteaya> I think it is nicer
18:18:25 <krtaylor> hehheh, sure thats fine with me
18:18:25 <anteaya> and I agree
18:18:28 <anteaya> thanks
18:19:01 <krtaylor> the last section addresses the previous discussions we have had around operator vs developer
18:19:35 <krtaylor> I personally think that the CI operator should be fully involved in the community, have the ability to submit a patch
18:19:51 <krtaylor> not just turn it on and run away, but help make it all run better
18:20:11 <anteaya> I heartly agree
18:20:13 <krtaylor> not sure how to do that while not increasing any infra load
18:20:14 <sweston> krtaylor: +1
18:20:16 <anteaya> but how do we get there?
18:20:21 <anteaya> right
18:20:27 <krtaylor> yeah, thats the hard part
18:21:07 <anteaya> so that is a summit discussion topic
18:21:26 <anteaya> how do we get new ops following the workflow we know they need for success
18:21:26 <krtaylor> today we point to a requirements doc, but there is so much culture that has to be learned, opensource is a different thing that some are used to
18:21:35 <anteaya> not the one their managers assign them
18:21:46 <krtaylor> +1000
18:22:11 <anteaya> forcing them doesn't work
18:22:21 <anteaya> but not forcing them gets zero results of any kind
18:23:32 <anteaya> so yeah, we should discuss that one at summit
18:23:49 <krtaylor> good brainstorming topic for sure
18:23:52 <anteaya> since perhaps the discussion at summit _may_ be part of the solution
18:23:55 <anteaya> I don't know
18:24:21 <krtaylor> hm, true
18:24:59 <krtaylor> anteaya, do you know the schedule and mechanism for plan item discussion for infra, I assume we fall under that schedule
18:25:21 <anteaya> we will be in cross-project on the tuesday
18:25:25 <anteaya> not under infra
18:25:44 <anteaya> and no, other than I tell ttx we are ready to make good use of a spot if we are
18:25:52 <anteaya> and then I fight for space
18:25:58 <anteaya> by elbowing out others
18:26:08 <anteaya> so we had better have a strong plan in place
18:26:29 * krtaylor has strong elbows
18:27:07 <krtaylor> ok, I'll spend some more time discussing the items on this etherpad, and get it down to a few strong points
18:27:47 <krtaylor> #action krtaylor to refine third-party design summit session ideas in https://etherpad.openstack.org/p/kilo-third-party-items
18:28:02 <krtaylor> ok, anything else on this topic?
18:28:27 <krtaylor> #topic Deadlines & Deprecations
18:28:41 <krtaylor> nothing here, anything from anyone?
18:29:15 <krtaylor> #topic Highlighting a Program or Gerrit Account
18:30:24 <krtaylor> also nothing here, but I was going to add an agenda item to talk about the changes to project-config
18:30:42 <krtaylor> we can hit that in open discussion
18:30:56 <krtaylor> which leads me to
18:31:00 <krtaylor> #topic Open Discussion
18:31:11 <krtaylor> ok, open floor
18:31:40 <asselin> hi, last week I requested reviews for https://review.openstack.org/#/c/122896/ and I got plenty.
18:32:13 <asselin> one of them was to split the review into 2 however, so I'd like to request reviews on the "depends on" as well: https://review.openstack.org/#/c/123578/1
18:32:44 <krtaylor> asselin, good
18:32:51 <krtaylor> thanks mmedvede !  :)
18:33:10 <asselin> mmedvede, gave some very good feedback. thank you!
18:33:11 <krtaylor> asselin, I think it looks good
18:33:48 <krtaylor> asselin, anything else?
18:33:53 <asselin> that's it
18:34:13 <krtaylor> rfolco, adalbas - want to talk about project-config, we have some time with anteaya
18:34:50 <adalbas> krtaylor, sure, i have already spoken to her a bit in the -infra channel about it
18:34:52 <anteaya> well adalbas was in infra not long ago and might have gotten things straigtened out
18:35:07 <anteaya> adalbas: why don' you share with others what you learned
18:35:11 <krtaylor> yes
18:35:31 <rfolco> krtaylor, anteaya: I was trying to make a diagram to understand how project-config changes "broke" our runs
18:35:41 <asselin> (speaking of project-config, I updated my 3rd party repo to some changes there. https://github.com/rasselin/os-ext-testing/commit/3699ab0b53c5f9b137ec77e72b13212d5b6abf62)
18:35:51 <krtaylor> anteaya, for back story, we were just about to turn on reporting again, then project-config merged
18:35:59 <adalbas> krtaylor, anteaya, yes, i'm currently looking at the changes . so far, rfolco has cloned the new project-config in our puppet master and updated the config to delete the extra files
18:36:15 <anteaya> yep, there is no good time for changes anymore
18:36:20 <anteaya> everything breaks someone
18:36:39 <anteaya> but this is a change which will be beneficial in the long terms
18:36:40 <rfolco> anteaya, since we use a mix of upstream plus custom scripts/configs
18:36:41 <anteaya> term
18:36:55 <adalbas> anteaya, krtaylor : i see a few changes and the addition of project_config class to point to files and scripts
18:37:01 <krtaylor> asselin, excellent, it is working for you now?
18:37:41 <asselin> krtaylor, yes, so far so good, unless more stuff merged...
18:37:55 <adalbas> anteaya, my assumption is that, since our services are already configured, it should not break things because puppet failed. Puppet would just update things.
18:38:29 <adalbas> so i assume our main issue could be on devstack-gate and some script changes. would that be the right direction?
18:38:42 <anteaya> adalbas: I don't know anything about puppet
18:38:51 <anteaya> so I can't answer that question
18:39:05 <adalbas> anteaya, ok :)
18:39:22 <anteaya> but you are heading in the right direction
18:39:34 <anteaya> make changes, ask in -infra
18:39:50 <anteaya> share what you learn with other third party operators
18:40:01 <anteaya> a blog post would be nice if you feel up to it
18:40:23 <krtaylor> and maybe we can pick asselin 's experience too
18:40:32 <krtaylor> blog post ++
18:40:34 <anteaya> oh yes
18:40:51 <anteaya> asselin: you have great insights
18:40:54 <adalbas> cool. i'm also looking at asselin changes. good thing, altough i think the way we are doing things are pretty different
18:40:58 <anteaya> would be nice to share those too
18:41:07 <asselin> in my setup, I update, so it broke when I tried to make changes to the jobs
18:41:18 <adalbas> definitely
18:41:20 <asselin> but an already running setup should keep working
18:41:38 <anteaya> so maybe each blog your way and link to the other person's blog?
18:41:44 <krtaylor> it would be interesting to compare and contrast the different systems some day
18:42:22 <asselin> my setup tries to mimic -infra as much as possible....
18:42:49 <krtaylor> I have always thought it would help the infra team to know how some of the third-party systems work at a 50,00ft level
18:42:49 <anteaya> asselin: thank you for that
18:43:11 <anteaya> well it does help us to answer questions if we know what you are doing
18:43:20 <krtaylor> exactly
18:43:26 <anteaya> since then we have context for what you are asking
18:44:23 * krtaylor thinks of additions to our ci wiki page
18:45:04 <asselin> i'm interested to know how 3rd party can re-use project-config, or not?
18:46:09 <anteaya> good question
18:46:21 <krtaylor> asselin, is that a question for someone in particular, or?
18:46:27 <anteaya> well certainly the format of the files is something that others can use
18:46:39 <asselin> not sure who to ask.
18:46:53 <anteaya> and making config smaller is a goal towards making parts more consumable
18:47:02 <asselin> maybe -infra, but I thought I raise it here.
18:47:10 <anteaya> well I think the idea was take project-config out of config
18:47:22 <anteaya> then split config into consumable chunks
18:47:29 <anteaya> like individual puppet modules
18:47:41 <anteaya> so perhaps less direct consumption of project-config
18:47:54 <anteaya> and more that getting this out of the way makes the other work easier
18:49:07 <krtaylor> yeah, so the improvement would be changes to a smaller portion, I understand the end-goal
18:49:44 <asselin> I thought of it as the "private poritions" of 3rd party ci....
18:50:01 <asselin> ...so somehow copy the 'layout' with your own custom files.
18:50:06 <anteaya> yes
18:50:16 <anteaya> copy the format and point them to your own values
18:50:20 <asselin> and plug it into a common 3rd party ci setup and just uses those configurations.
18:50:21 <anteaya> whatever they may be
18:50:29 <anteaya> that is the goal yes
18:50:45 <asselin> so fork it? and put your stuff there?
18:50:49 <anteaya> though the plug it into a common 3rd party ci setup I believe still needs work
18:51:02 <anteaya> good question
18:51:14 <anteaya> asselin: do add to tomorrow's infra meeting
18:51:31 <asselin> or create a private branch, and keep rebasing/merging?
18:51:35 <asselin> anteaya, ok
18:52:51 <krtaylor> ok, we are winding down it looks like, anything else?
18:53:30 <krtaylor> hehheh, I thought we'd have our first 35 minute meeting
18:53:36 <anteaya> dreamer
18:53:46 <krtaylor> good discussions, thanks for everyone's input
18:53:56 <anteaya> good meeting krtaylor
18:54:07 <krtaylor> see you all in -infra
18:54:17 <krtaylor> #endmeeting