18:00:49 <anteaya> #startmeeting third-party
18:00:50 <openstack> Meeting started Mon Sep  1 18:00:49 2014 UTC and is due to finish in 60 minutes.  The chair is anteaya. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:51 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:53 <openstack> The meeting name has been set to 'third_party'
18:01:44 <anteaya> who is here?
18:01:49 <daya_k> hi
18:01:50 <luqas> hi
18:01:53 <trinaths> Hi
18:02:09 <anteaya> here is our agenda for today
18:02:12 <anteaya> #link http://lists.openstack.org/pipermail/openstack-dev/2014-August/042917.html
18:02:40 <anteaya> #topic Welcome & Reminder of OpenStack Mission
18:02:59 <anteaya> let's remember why we are here
18:03:03 <anteaya> #info The OpenStack Open Source Cloud Mission: to produce the ubiquitous Open Source Cloud Computing platform that will meet the needs of public and private clouds regardless of size, by being simple to implement and massively scalable.
18:03:24 <anteaya> #topic Review of previous week's open action items
18:03:40 <anteaya> #info third party team to review https://review.openstack.org/#/c/99990/
18:03:41 <daya_k> anteaya: is the link for agenda correct?
18:04:03 <anteaya> no
18:04:04 <kevinbenton> also here (sorry late)
18:04:13 <anteaya> here is the agenda
18:04:17 <anteaya> #link https://wiki.openstack.org/wiki/Meetings/ThirdParty#Agenda_for_next_meeting
18:04:28 <anteaya> I had something else in my clipboard
18:04:39 <anteaya> np, thanks for being here kevinbenton
18:05:11 <anteaya> so https://review.openstack.org/#/c/99990/ has some reviews but none from third party operators that I can see
18:05:27 <anteaya> it would be supportive to see some reviews from folks who attend this meeting
18:05:42 <anteaya> so let's have that for an action item for this week as well
18:05:55 <anteaya> #action third party team to review https://review.openstack.org/#/c/99990/
18:06:12 <anteaya> other action item
18:06:13 <daya_k> anteaya : i cannot see the benefit of this exercise, since i am more of a newcomer to the process itself. one thing i had suggested to fungi on irc was if the community could host some pre-built vm templates, it would give everyone a good headstart
18:06:16 <anteaya> #info anteaya to offer joa's work as config patches with joa as co-author by next meeting
18:06:26 <anteaya> I haven't done that
18:06:30 <daya_k> thats why i didnt review it either way.
18:06:38 <anteaya> daya_k: would you like to know the benefit of the exercise?
18:06:49 <anteaya> or would you like to talk about your suggestion to fungi?
18:06:52 <daya_k> yes, please.
18:07:05 <anteaya> the benefit is that this is the direction infra is going
18:07:11 <daya_k> he had liked the idea i think, but its not part of any specific agenda
18:07:33 <daya_k> ok, but how will it help ramp up new 3rd party systems
18:07:47 <anteaya> and since the mission of this group, see our goals, is to work with infra, this is inline with our reason for being here: https://wiki.openstack.org/wiki/Meetings/ThirdParty#Goals_for_Third_Party_meetings
18:08:24 <anteaya> how will this work ramp up new 3rd party systems?
18:08:28 <anteaya> is that the question?
18:09:02 <anteaya> daya_k: is that your question?
18:09:12 <daya_k> yes, i am not in a position to comment how it will help streamline the infra team's work itself, but i dont see how it will help someone like me who is setting up a new system
18:09:27 <anteaya> anyone able to answer daya_k's question?
18:09:30 <anteaya> besides me?
18:10:01 <anteaya> because this direction doesn't actually help infra
18:10:13 <anteaya> it actually takes time away from infra to do this work
18:10:24 <anteaya> noone is able to answer this question besides me
18:10:29 <anteaya> okay
18:10:52 <anteaya> since noone sees the point of reviewing this spec I can see why noone is reviewing this spce
18:11:28 <daya_k> anteaya: i thought the exercise was meant to streamline infra effort by modularizing the work, but if you say it wont help infra itself, then i am flummoxed
18:12:06 <anteaya> this is for consumers of third party modules
18:12:12 <anteaya> particulary third party ci
18:12:16 <ociuhandu> anteaya: if i got it right, this work should ease the maintenance of any third-party CI, that could use only the required modules
18:12:33 <anteaya> now the phrase "third party" doesn' appear in the spec itself, but that is who the work is for
18:12:41 <anteaya> ociuhandu: yay
18:12:49 * anteaya hands ociuhandu a gold star
18:12:56 <anteaya> ociuhandu: thank you for paying attention
18:12:58 <ociuhandu> anteaya: I am just looking at the document now, have to admit, missed that before
18:13:05 <anteaya> ociuhandu: do expand for the benfit of others
18:13:33 <daya_k> anteaya: so, today am i not able to pick up individual modules if an update is announced on the mailing lists? sorry, i havent done this exercise yet, so dont know
18:13:43 <ociuhandu> i think it’s excellent, so any third-party ci can take the the modules it needs
18:14:22 <ociuhandu> not having to deal with a monolithical block that might not suit their particular requirements and from that block figuring out how to “remove” pieces they do not use / can not use
18:14:22 <anteaya> ociuhandu: yay
18:14:30 <anteaya> ociuhandu: keep going
18:14:35 <anteaya> ociuhandu: you are exactly correct
18:15:26 <daya_k> ociuhandu: ok, if it helps achieve this, then yes, definitely thats a +1. so, does this mean, even the modules we have today will be broken into sub-components?
18:15:29 <ociuhandu> well, is it detalied enough now? :)
18:15:42 <daya_k> yes, thanks.
18:16:16 <anteaya> anyone else with any other questions about the benefit of the infra-spec https://review.openstack.org/#/c/99990/ to third party?
18:16:25 <anteaya> thank you, ociuhandu
18:16:49 <anteaya> okay I'll move on
18:16:52 <ociuhandu> daya_k: yes, if I got it right, it’s exactly about splitting those
18:17:12 <anteaya> #topic Announcements
18:17:33 <anteaya> #link http://lists.openstack.org/pipermail/openstack-dev/2014-August/042917.html
18:17:39 <anteaya> okay so looking at this email
18:18:12 <anteaya> all third party ci systems should have an entry on the wikipage for third party systems
18:18:29 <anteaya> #link https://wiki.openstack.org/wiki/ThirdPartySystems
18:18:45 <anteaya> anyone without an entry on the wikipage with have their system disabled
18:18:48 <anteaya> questions?
18:19:12 <anteaya> moving on
18:19:16 <anteaya> #topic OpenStack Program items
18:19:23 <anteaya> I have nothing here
18:19:28 <anteaya> does anyone have anything?
18:19:53 <anteaya> moving right along
18:20:00 <anteaya> #topic Deadlines & Deprecations
18:20:17 <anteaya> I have nothing here either
18:20:27 <anteaya> and I don't see any of the program reps here
18:20:33 <anteaya> anyone have anything to say?
18:20:43 <ociuhandu> anteaya: I have one question: How are selected the CI’s whose results appear on the right side of the patch page?
18:20:59 <ociuhandu> #link https://review.openstack.org/#/c/116268/
18:21:15 <ociuhandu> i see there Cisco CI, Huawey CI and Jenkins
18:21:18 <anteaya> ociuhandu: lets deal with that in open discussion?
18:21:24 <anteaya> which is coming up
18:21:32 <ociuhandu> sure, sorry
18:21:34 <anteaya> thanks
18:21:38 <anteaya> next topic then
18:21:45 <anteaya> #topic Highlighting a Program or Gerrit Account
18:21:51 <anteaya> or we could address it here
18:22:01 <anteaya> #link https://review.openstack.org/#/c/116268/
18:22:30 <anteaya> so ociuhandu if you click the button marked "Toggle CI"
18:22:41 <ociuhandu> yes, i know that part :)
18:22:47 <anteaya> you can see the comments of all the systems
18:22:51 <ociuhandu> was referring to the CI’s featured on top
18:23:13 <ociuhandu> the table on the right of the reviewers list
18:23:13 <anteaya> you can see that the two systems that are up on the top have comments in the same format as jenkins
18:23:19 <anteaya> so the parser picks them up
18:23:34 <anteaya> the systems that are not picked up have a different comment format than jenkins
18:23:36 <ociuhandu> ok, so the format has to be exactly the same
18:23:40 <anteaya> so the parser does not pick them up
18:23:43 <anteaya> ociuhandu: yes
18:23:47 <ociuhandu> thanks for the clarification
18:23:51 <anteaya> the parser has to be able to pick them up
18:23:59 <anteaya> and the parser is based on jenkins format
18:24:11 <anteaya> ociuhandu: welcome, thanks for the question
18:24:19 <anteaya> anyone else with questions on this item?
18:24:53 <anteaya> anyone else with questions or points about a specific gerrit account?
18:25:26 <anteaya> which brings us to the last topic of the day
18:25:32 <anteaya> #topic Open Discussion
18:25:43 <anteaya> anyone with anything they want to discuss?
18:26:48 <anteaya> motion to adjurn?
18:27:29 <daya_k> yes, should be ok. i'll review the puppet module proposal with a +1, thanks for clarifying
18:27:30 <anteaya> s/adjurn/adjourn
18:27:47 <anteaya> daya_k: thanks for asking, I didn't know this direction wasn't clear
18:27:59 <ociuhandu> I have no other questions for the moment, thanks
18:28:03 <anteaya> well if noone has anything else, I'll adjourn
18:28:09 <anteaya> ociuhandu: thanks
18:28:13 <daya_k> anteaya : i might have missed a meeting when this was discussed, but it helps
18:28:19 <daya_k> thanks
18:28:22 <anteaya> thanks for showing up everybody
18:28:28 <anteaya> have a good week
18:28:33 <anteaya> #endmeeting