18:00:13 <krtaylor> #startmeeting third-party
18:00:14 <openstack> Meeting started Mon Aug 11 18:00:13 2014 UTC and is due to finish in 60 minutes.  The chair is krtaylor. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:15 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:17 <openstack> The meeting name has been set to 'third_party'
18:00:28 <krtaylor> anyone here for third-party?
18:00:29 <anteaya> lyxus: patience my friend
18:00:32 <anteaya> lyxus: :D
18:00:43 <anteaya> o/
18:00:44 <lyxus> anteaya,!!
18:00:49 <lyxus> o/
18:00:53 <krtaylor> um, I started on time :)
18:00:55 <joa> krtaylor: yup :)
18:00:59 <anteaya> you did
18:01:43 <lyxus> krtaylor, I will find a lame excuse (NTP  is not working well on my computer)
18:01:50 <krtaylor> Hi everyone!
18:01:59 <joa> hi :)
18:02:05 <sweston> Hi!
18:02:19 <krtaylor> ok, let's get started
18:02:31 <krtaylor> here's the agenda:
18:02:34 <krtaylor> #link https://wiki.openstack.org/wiki/Meetings/ThirdParty#Agenda_for_next_meeting
18:02:53 <asselin__> hi
18:02:54 <krtaylor> and as a reminder to everyone
18:02:56 <krtaylor> #topic Welcome & Reminder of OpenStack Mission
18:03:06 <krtaylor> #info The OpenStack Open Source Cloud Mission: to produce the ubiquitous Open Source Cloud Computing platform that will meet the needs of public and private clouds regardless of size, by being simple to implement and massively scalable.
18:03:23 <krtaylor> alright, now that the formalities are out of the way
18:03:34 <krtaylor> #topic Review of previous week's open action items
18:03:55 <krtaylor> the terminology patch has had good reviews
18:04:02 <krtaylor> but not yet merged
18:04:13 <krtaylor> sweston, any comments?
18:04:35 <anteaya> let's change the topic on that patch to third-party
18:04:40 <sweston> yes, I will merge the patch this week
18:04:50 <anteaya> so it gets picked up like the rest
18:05:02 <krtaylor> sweston, ^^^ that would be really nice
18:05:03 <sweston> ok
18:05:05 <krtaylor> -t
18:05:10 <anteaya> sweston: well you can ask for it to be merged
18:05:20 <anteaya> but it is up to infra to merge it
18:05:33 <sweston> anteaya: understood
18:05:53 <anteaya> and reviewing infra patches is a good way to help your patch get reviewed
18:06:05 <anteaya> let me know if I can help you with that at all
18:06:43 <krtaylor> thanks anteaya, its so good to see you around here again
18:06:51 <anteaya> thanks good to be back
18:06:59 <krtaylor> ok, so, the next action was a carry over from the previous week, due to the infra meeting running over
18:07:00 <sweston> anteaya: yes, welcome back as well!!
18:07:08 <anteaya> you have done a great job keeping things moving along, all of you
18:07:11 <anteaya> well done
18:07:20 <krtaylor> thanks
18:07:35 <sweston> :-D
18:07:48 <krtaylor> so, re: templates - it was on the agenda for the last meeting, but I had to join late
18:08:01 <krtaylor> asselin__, are you around?
18:08:07 <joa> yay, templates
18:08:27 <krtaylor> when I got there it went off in a different direction, it switch to better documentation
18:08:28 <asselin__> yes, infra team would like to have the 3rd party work moved to infra.
18:08:45 <krtaylor> hm...it is
18:08:49 <anteaya> well to give some history, it came from infra
18:09:01 <anteaya> got forked and now is in several different states of notes
18:09:01 <asselin__> well...there's quite a few ppl using github.
18:09:09 <joa> also, the templates make sense being with infra (imho)
18:09:14 <krtaylor> oh, you are talking about jaypipes repo
18:09:21 <anteaya> so infra would like what is in infra attended to
18:09:24 <anteaya> which is great
18:09:25 <asselin__> we should move back to infra and have it there
18:09:35 <anteaya> since is answers the question of where should it live
18:09:49 <anteaya> right
18:10:03 <anteaya> so did you understand the steps to make that happen?
18:10:03 <krtaylor> but the discussion point was to have canned templates that would live in a dir in /config
18:10:24 <krtaylor> not sure how it went ot jaypipes repo and documentation
18:10:50 <asselin__> sorry...maybe I'm not fully understanding what is a canned template.
18:10:53 <anteaya> I think the larger issue is to have infra ci more consumable
18:11:22 <krtaylor> anyway, I think the bottom line was that we are going to try to improve the documentation with samples of the files inline, at least thats what I took away from the discussion
18:11:28 <anteaya> and the direction of making it more consumable is to have it in infra, and help with the work currently going on to make infra more consumable
18:11:45 <krtaylor> asselin__, a template that is well documented with examples, sorry for the confusion
18:11:59 <anteaya> actually if we could help with the splitting out of some of the puppet modules that would go a long way
18:12:02 <asselin__> my understanding / goal is to have a set of puppet scripts in infra that can be run/customized to run 3rd party
18:12:22 <krtaylor> yes, there are several people working to that goal
18:12:25 <anteaya> that is the point of the split of the puppet modules
18:12:34 <anteaya> krtaylor: who?
18:13:07 <krtaylor> I know ArxCruz is, and has a github repo on the subject
18:13:15 <asselin__> yes, 3rd party ci would use the split puppet modules, and contribute to areas where they need to be more generic/reusable.
18:13:23 <anteaya> great
18:13:26 <krtaylor> ArxCruz, are you here?
18:13:35 <anteaya> well doing the work in infra is kind of the point
18:13:44 <sweston> And I am working towards that as well
18:13:53 <anteaya> nibalizer and jesusaurus are working on it
18:14:10 <anteaya> so sweston perhaps you can find them and see how you can help
18:14:18 <anteaya> for starters reviews would be great
18:14:22 <krtaylor> ok, that seems like a great team to organize and drive the work
18:14:44 <anteaya> well the point is the team of two needs more help
18:14:51 <nibalizer> there is a spec now
18:14:56 <anteaya> so in addition to sweston, who can help?
18:14:58 <nibalizer> let me see if i can find it
18:14:59 <anteaya> yay nibalizer
18:15:02 <anteaya> thanks
18:15:07 <sweston> yes, I was going to suggest that there be some more formal structure to this
18:15:32 <krtaylor> nice, a puppet consumability team
18:15:36 <anteaya> sweston: thanks, we need a plan in addition to agreement
18:15:46 <nibalizer> https://review.openstack.org/#/c/99990/
18:15:49 <anteaya> krtaylor: that is fine but we need some members
18:15:59 <anteaya> #link https://review.openstack.org/#/c/99990/
18:16:01 <krtaylor> there is clarkb 's split spec, is that what you are thinking about?
18:16:02 <anteaya> thanks
18:16:35 <anteaya> nibalizer: what do you need right now to move forward?
18:16:36 <krtaylor> ah, ok, no thats different
18:16:43 <anteaya> reviews? what?
18:17:18 <nibalizer> oh wow this is openstack meeting
18:17:21 <nibalizer> i thought we were in infra
18:17:22 <sweston> I have a few more ideas regarding making puppet more consumable
18:17:27 <anteaya> nibalizer: glad you are here
18:17:30 <nibalizer> what we need is to get consensus
18:17:36 <nibalizer> then do an example mod
18:17:41 <nibalizer> then slam the rest out
18:17:49 <anteaya> nibalizer: consensus amougst whom
18:17:54 <nibalizer> we talked about this at the last infra meeting
18:18:01 <nibalizer> anteaya: infra cores mostly
18:18:07 <nibalizer> with myself and jesusaurus
18:18:09 <anteaya> nibalizer: and let's use gentle words in this space please
18:18:26 <anteaya> nibalizer: great, so third party folks, do review
18:18:38 <krtaylor> hehheh
18:18:38 <jesusaurus> anteaya: yes, reviews. we have a good idea of how we are going to move forward, but the spec still feels like its not very well fleshed-out to me
18:18:42 <anteaya> and stay in contact with nibalizer about the progress of this spec
18:19:05 <anteaya> jesusaurus: great thank you, so third party folks, we can review this spec
18:19:29 <anteaya> krtaylor: can you make that an action item pleease?
18:19:30 <krtaylor> will do
18:19:37 <nibalizer> along with making puppet more re-usable, we're working on getting a lot of the stuff that is hardcoded in the openstack_project module moved into a hiera directory
18:20:10 <anteaya> nibalizer: awesome, now many folks in third party might not have much familiarity with puppet
18:20:13 <nibalizer> i would expect those changes to be comming along very soon since we have a lot of agreement on how to do that and the patchset well like
18:20:23 <anteaya> nibalizer: so if you have any documenations suggestions, that would be great
18:20:24 <krtaylor> #action third-party review and sync in infra on https://review.openstack.org/#/c/99990/
18:20:26 <jesusaurus> and also working on moving things from other modules into the openstack_project module as appropriate
18:20:33 <anteaya> nibalizer: nice
18:20:42 <nibalizer> anteaya: as it lands, ill add documentation on 'what does this mean for me?' kind of questions
18:20:53 <nibalizer> explaining use and reasoning
18:20:57 <jesusaurus> ++
18:20:58 <anteaya> jesusaurus: thanks, if you could create an etherpad with easy steps, we can do our best to help
18:21:05 <anteaya> great
18:21:09 <krtaylor> ++
18:21:15 <anteaya> we want to help but we don't have much expertise here yet
18:21:33 <krtaylor> well, some have more than others
18:21:40 <anteaya> breaking things into small clearly actionable items would be great for us
18:21:43 <anteaya> krtaylor: yes
18:21:46 <krtaylor> but prob few expert level
18:22:00 <anteaya> well I have no puppet, so I am speaking for myself here
18:22:37 <krtaylor> ok, good discussion, anything else on that topic?
18:23:17 <sweston> I have one suggestion, has anyone else thought it would be a good idea to have some code tying the puppet modules together?
18:23:36 <krtaylor> sweston, expand
18:23:47 <anteaya> sweston: let's review what we have here first
18:23:59 <anteaya> and then have an item on next week's agenda
18:24:00 <jesusaurus> sweston: we will definitely need something like that in order to test multiple modules in an ecosystem
18:24:04 <anteaya> is that fair?
18:24:10 <krtaylor> agreed, sweston wait till open floor, lets move on
18:24:12 <joa> <- no idea, puppet noob
18:24:21 <krtaylor> then the next on last weeks - New Nova requirements, that was my action and I forgot about it
18:24:22 <sweston> I will wait for open floor, then
18:24:35 <sweston> krtaylor: please continue ;-)
18:24:46 <krtaylor> but as it turns out, that is prob ok, it hasnt been discussed in detail yet
18:25:21 <krtaylor> it would be good for anyone with nova drivers to get involved here
18:25:25 <krtaylor> #link  https://wiki.openstack.org/wiki/HypervisorSupportMatrix/Requirements
18:25:51 <krtaylor> I'd like to see a test to function breakdown, but that is later
18:26:07 <krtaylor> anyway, so we'll carry that action for another week
18:26:24 <krtaylor> ok, next
18:26:25 <krtaylor> #topic Announcements
18:26:34 <krtaylor> anyone with any announcements?
18:26:53 <anteaya> well I think mine are in announcements
18:27:24 <krtaylor> yes, anteaya
18:27:28 <krtaylor> you have the floor
18:27:36 <anteaya> okay
18:27:47 <anteaya> Difference between program and project (anteaya)
18:28:01 <anteaya> #link http://git.openstack.org/cgit/openstack/governance/tree/reference/programs.yaml
18:28:14 <anteaya> so there was a question last week
18:28:28 <anteaya> about the difference between programs and projects
18:28:38 <anteaya> so if we look at this file I linked
18:28:40 <krtaylor> no, it was me using the wrong term
18:28:44 <krtaylor> my bad
18:28:52 <anteaya> we see that programs at the larger group
18:28:56 <krtaylor> I "said" one when I meant the other
18:29:00 <anteaya> programs have projects
18:29:07 <anteaya> projects are repos
18:29:12 <anteaya> thought I would clarify
18:29:18 <krtaylor> yep, good for reference, I should be more crisp
18:29:22 <anteaya> jsut to ensure we were all on the same page
18:29:24 <anteaya> np
18:29:28 <anteaya> many are confused
18:29:40 <anteaya> and not everyone knows about this reference in the governance repo
18:29:53 <anteaya> which is our canonical repo for this kind of reference
18:29:56 <anteaya> so that's it
18:30:00 <anteaya> any questions?
18:30:04 <krtaylor> #link http://git.openstack.org/cgit/openstack/governance/tree/reference/programs.yaml
18:30:15 <anteaya> thanks
18:30:23 <anteaya> so next item
18:30:27 <anteaya> #info Sometime this week third party ci accounts will all be evaluated to ensure " CI" is on the end of the name (anteaya)
18:30:36 <anteaya> so we have a patch up
18:30:47 <anteaya> #link https://review.openstack.org/#/c/95743/
18:30:56 <anteaya> it changes the js in gerrit gui
18:31:16 <krtaylor> anteaya, are you doing that switch over?
18:31:17 <anteaya> it collects everything ending in " CI" at the end of the full name
18:31:26 <anteaya> and puts then in a seperate table
18:31:37 <anteaya> well I don't have gerrit permissions yet
18:32:00 <anteaya> so I have to co-ordinate with jeblair or SergeyLukjanov for the rename
18:32:10 <anteaya> but we want the patch in effect
18:32:18 <anteaya> so we need to rename the accounts
18:32:34 <krtaylor> agreed
18:32:38 <anteaya> this pass will probably just be sticking CI on the end of all the accounts
18:32:43 <anteaya> so the js will work
18:32:47 * krtaylor needs to review it
18:33:22 <anteaya> and since renaming all the things so the names reflect the activity of the account will take some time, it will probably be a seperate renaming
18:33:33 <krtaylor> anteaya,  is this happening with the rename format?
18:33:40 <krtaylor> or just appending -ci
18:33:41 <anteaya> I don't know yet, since i have to talk to jeblair about it and he is away today
18:33:48 <krtaylor> understood
18:34:01 <anteaya> we are appending " CI" to the full name of the account
18:34:19 <anteaya> and probably doing obvious changes like removing testing from the end if it is there
18:34:33 <krtaylor> sure, makes sense
18:34:43 <anteaya> that is the general gist
18:34:58 <krtaylor> anything else? questions anyone?
18:35:00 <anteaya> the likelihood someone will be upset exists but we need the js in place
18:35:10 <anteaya> so it is a risk I am willing to take
18:35:15 <krtaylor> anteaya, agreed
18:35:20 <anteaya> thanks
18:35:21 <krtaylor> it has to be managable
18:35:28 <anteaya> that's it from me
18:35:35 <krtaylor> thanks anteaya
18:35:44 <krtaylor> ok, onward
18:35:46 <anteaya> and my lunch pickup has arrived so I am out for the rest
18:35:54 <anteaya> I will read the logs when I am back
18:35:56 <anteaya> thanks
18:36:03 <joa> imho
18:36:08 <joa> for reviewing a patch
18:36:10 <krtaylor> thanks again anteaya
18:36:10 <joa> it's necessary
18:36:16 <joa> so kudos for that :)
18:36:27 <krtaylor> next
18:36:29 <krtaylor> #topic OpenStack Program Items
18:36:49 <krtaylor> quick reminder
18:37:03 <krtaylor> please tag and review third-party patchsets
18:37:12 <krtaylor> so we can keep track
18:37:19 <krtaylor> #link https://review.openstack.org/#/q/status:open+project:openstack-infra/config+branch:master+topic:third-party,n,z
18:37:38 <krtaylor> and now joa
18:37:43 <krtaylor> you have the floor
18:37:47 <joa> alright :)
18:38:14 <joa> Soo, as discussed two or three meetings back, I was, as a newcomer thinking about how to improve the current docs
18:38:26 <krtaylor> this was making small changes instead of one big one, right
18:38:50 <joa> So, I tried my hand at it after the meeting, putting my "feedback" into the newly created openstack-infra/manuals https://review.openstack.org/#/c/110651/
18:39:13 <krtaylor> #link https://review.openstack.org/#/c/110651/
18:39:15 <joa> Happened that jeblair from infra was afraid (rightly so) to have duplications of documentations through this
18:39:47 <joa> So it would be nice to pick whatever pieces I wrote and re-work the current third_party.rst in docs (if i'm not mistaken?)
18:40:19 <joa> most probably having some reworked into pointers to other documentation bits
18:41:01 <krtaylor> joa, it is somewhat related to the template docs discussion, and consumability in general
18:41:05 <joa> sure
18:41:23 <krtaylor> it is always easier to make incremental change
18:41:49 <joa> yeah, so the big question for everyone is: which bits deserve to be used to improve the current docs
18:42:20 <krtaylor> joa, maybe strip what is there and create an etherpad for the rest?
18:42:25 <krtaylor> or didnt you have one
18:42:29 * krtaylor goes looking
18:42:39 <joa> there was an etherpad as the source yes
18:42:54 <joa> still have the link at work, not here
18:43:46 <krtaylor> ok, if you want help with sections, we can discuss here next week, or propose a section and we'll review
18:43:52 <joa> about that, I need yourn inputs, to see which bits should be kept and which not
18:44:36 <krtaylor> ok, generalize a list of sections to keep /or not
18:45:03 <krtaylor> something we can understand quickly, and lets put it on the agenda for enxt week
18:45:07 <krtaylor> next
18:45:09 <joa> okay
18:45:26 <krtaylor> but it needs to be summarized into areas in question
18:45:53 <krtaylor> so we can understand and discuss in this time format, else infra or email works too
18:46:00 <joa> well taking jeblair's worries into account I'm sure some of the sections might only deserve a pointer to the right doc
18:46:27 <joa> (and then maybe improving the other areas on the way)
18:46:41 <joa> I might ping you on #infra then
18:46:47 <joa> to have some discussions before the next meeting
18:46:48 <krtaylor> sure
18:46:58 <krtaylor> thats fine
18:47:37 <joa> ok, then i'm done :)
18:47:53 <krtaylor> #action joa and krtaylor to discuss doc improvement sections to focus on
18:48:06 <krtaylor> alright
18:48:09 <krtaylor> #topic Deadlines & Deprecations
18:48:31 <krtaylor> any deadlines to communicate?
18:49:09 <krtaylor> I believe cinder was going to have everyone accounted by today
18:49:34 <krtaylor> they have mid-cycle this week I believe
18:49:47 <joa> Well, there was this deadline around today
18:50:02 <krtaylor> we might get a report next week
18:50:08 <krtaylor> joa, for cinder?
18:50:15 <joa> but as far as I've discussed with DuncanT, it was first and foremost in order to push vendore to have a CI (yeah)
18:50:34 <hemanthravi> should neutron third-party failures be discussed in the weekly neutron meeting?
18:50:37 <joa> as for myself, I miss some configuration bits but i'm almost there, for instance;
18:51:22 <krtaylor> hemanthravi, they can be discussed here, wait until open floor at the end
18:51:50 <krtaylor> ok, lets move on then
18:51:56 <krtaylor> #topic Highlighting a Program or Gerrit Account
18:52:13 <krtaylor> this is quick since there was not any added to the agenda :)
18:52:33 <krtaylor> ok so...
18:52:39 <krtaylor> #topic Open Discussion
18:53:03 <krtaylor> lyxus, did you have something?
18:53:23 <krtaylor> hemanthravi, this is the place, anything?
18:53:29 <hemanthravi> one convergence ci is failing due to a change and is logged as a bug https://bugs.launchpad.net/neutron/+bug/1353309
18:53:31 <uvirtbot> Launchpad bug 1353309 in neutron "l3 agent is failing with unsupported version endpoint does not support rpc version 1.3" [High,Confirmed]
18:54:35 * krtaylor reads
18:54:46 <hemanthravi> the bug needs to be fixed for the ci to stop failing
18:55:24 <krtaylor> hemanthravi, can you expand on your test environment?
18:55:54 <hemanthravi> we have a plugin that runs against our third-party controller
18:56:10 <krtaylor> are there systems at different install levels maybe? icehouse/havana?
18:56:33 <hemanthravi> the setup launches a vm, deploys the code using devstack and runs through the tests
18:56:42 <hemanthravi> the devstack script is failing
18:58:14 <krtaylor> hemanthravi, this may be something to bring up in -neutron
18:58:20 <krtaylor> since we are running out of time
18:58:27 <hemanthravi> ok, will do thanks
18:58:40 <krtaylor> 2 minutes
18:58:45 <krtaylor> quick question?
18:59:19 <krtaylor> ok, that this weeks meeting then
18:59:25 <krtaylor> thanks everyone
18:59:43 <sweston> thanks!
18:59:52 <krtaylor> #endmeeting