18:00:59 <krtaylor> #startmeeting third-party
18:01:00 <openstack> Meeting started Mon Aug  4 18:00:59 2014 UTC and is due to finish in 60 minutes.  The chair is krtaylor. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:01:01 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:01:03 <openstack> The meeting name has been set to 'third_party'
18:01:20 <krtaylor> anyone here for the third-party meeting?
18:01:33 <luqas> o/
18:01:36 <asselin_> hi
18:01:39 <sweston> o/
18:01:48 <krtaylor> hi luqas sweston
18:01:58 <banix> krtaylor: hi
18:02:01 <sweston> hi krtaylor
18:02:04 <daya_k> hi
18:02:06 <mjturek> krtaylor, hi
18:02:28 <krtaylor> nice, looks like a good group this week
18:02:45 <krtaylor> welcome everyone
18:02:55 <krtaylor> here is the agenda for today's meeting:
18:03:04 <krtaylor> #link https://wiki.openstack.org/wiki/Meetings/ThirdParty#Agenda_for_next_meeting
18:03:44 <krtaylor> alright, as a part of our proper meeting etiquette
18:03:49 <krtaylor> #topic Welcome & Reminder of OpenStack Mission
18:04:01 <krtaylor> #info The OpenStack Open Source Cloud Mission: to produce the ubiquitous Open Source Cloud Computing platform that will meet the needs of public and private clouds regardless of size, by being simple to implement and massively scalable.
18:04:14 <krtaylor> #topic Review of previous week's open action items
18:04:24 <krtaylor> ok, so we had a few actions last week
18:04:45 <krtaylor> we queued sweston 's terms patch discussion
18:05:25 <krtaylor> sweston, I havent seen a bunch of activity there
18:05:29 <krtaylor> anteaya, you here?
18:05:51 <krtaylor> but I did post the terms review url
18:05:51 <sweston> yup, an update:  I submitted the patch on July 25th, only one person has provided feedback.
18:06:02 <sweston> https://review.openstack.org/#/c/109800/
18:06:19 <krtaylor> sweston, actuall 2 now
18:06:23 <krtaylor> actually
18:06:50 <sweston> oh, yes I see the review from Sergey
18:06:59 <krtaylor> y, goodness
18:07:24 <krtaylor> so the next two items were for the infra meeting, discussion topics
18:07:42 <krtaylor> we were on the agenda, I was there and I believe asselin_ was too
18:07:50 <krtaylor> but the meeting ran over
18:08:05 <krtaylor> and they didnt get to the entire agenda
18:08:38 <krtaylor> we are on the agenda again for this week, we'll table that for another week then
18:09:10 <krtaylor> although the recheck is resolving itself in comments on the patch
18:09:39 <krtaylor> I think that covers actions from last meeting, did I miss anything?
18:09:52 * asselin_ added infra meeting to calendar
18:10:06 <krtaylor> #topic Announcements
18:10:19 <krtaylor> anyone have any program announcements for third-party?
18:10:49 <asselin_> sorry, what's a "program annoucement"?
18:10:56 <krtaylor> nova mid-cycle was last week, but I'll save mine for next topic
18:11:05 <krtaylor> asselin_, any projects
18:11:18 <krtaylor> projects ~= programs
18:11:38 <krtaylor> I'm not sure exactly the terminology for what is a project and what is a program
18:11:52 <krtaylor> so I'll simplify - any announcements?  :)
18:12:04 <sweston> I have something I'd like to mention.  I'm starting a public puppetmaster service for folks, if they are interested in having their Zuul and Jenkins master hosted.
18:12:53 <krtaylor> sweston, nice, this would be to drive other ci systems?
18:12:56 <sweston> additional discussion is welcome when we get to open discussion
18:13:00 <sweston> yes
18:13:09 <daya_k> congrats sweston
18:13:09 <krtaylor> interesting
18:13:23 <sweston> jenkins slaves can be wherever the third party ci network is
18:13:39 <sweston> they will connect via reverse ssh tunnel into the master
18:14:00 <sweston> daya_k: thanks ;-)
18:14:10 <krtaylor> is this hosted on a public cloud/service?
18:14:23 <sweston> yes, it will be
18:14:50 <krtaylor> sweston, I bet you will get a lot of interested systems
18:14:53 <sweston> I am looking for testers right now to work out some of the details
18:15:32 <sweston> krtaylor: yes, I this will take all of the manual configuration and setup out of the picture
18:15:59 <beecee> sweston: what costs would be involved?
18:16:11 <smcginnis> sweston: We were looking for something like that when we were setting up. Very interested to see how it turns out.
18:16:55 <sweston> beecee: I am still working that out.  It will depend on several factors, but it will be minimal, just to cover the cost of the hosting provider.
18:17:03 <krtaylor> this is a good place to get it out there, I can mention it in the weekly newsletter summary for third-party too if you wish
18:17:36 <krtaylor> sweston, I'll ping you later this week when I am writing the summary
18:17:42 <sweston> smcginnis: excellent.  I can follow up with you in IRC if you are interested in being one of the testers
18:17:49 <sweston> krtaylor: that sounds great
18:18:02 <sweston> krtaylor: thank you :-)
18:18:13 <krtaylor> ok, any other announcements?
18:18:43 <krtaylor> let's move on then
18:18:54 <krtaylor> #topic OpenStack Program Items
18:19:47 <krtaylor> I added an agenda item to let everyone know about the new proposal for nova features
18:20:15 <krtaylor> requirements for hypervisor feature coverage
18:20:50 <krtaylor> that came out of the nova mid-cycle meetup
18:20:54 <krtaylor> #link https://wiki.openstack.org/wiki/HypervisorSupportMatrix/Requirements
18:21:11 <sweston> krtaylor: what release is this targeted for?
18:21:18 <krtaylor> that will be something to watch and/or get involved in
18:21:57 <krtaylor> sweston, I have not had a chance to find out anything else, I was just told about it a few days ago
18:22:22 <sweston> krtaylor: ok
18:22:23 <krtaylor> maybe we can get someone from nova to come talk about it at a future meeting
18:23:28 <krtaylor> #action krtaylor to see if nova rep can expand on the new feature requirements table
18:23:43 <krtaylor> ok, next
18:24:04 <krtaylor> I added a usual reminder to everyone to keep the third-party patches moving along
18:24:24 <krtaylor> I see a bunch of third-party tagged got merged
18:24:51 <krtaylor> its actually kinda sparse now, but you can always review mine :)
18:24:59 * krtaylor does a shameless plug
18:25:10 <krtaylor> #link https://review.openstack.org/#/q/status:open+project:openstack-infra/config+branch:master+topic:third-party,n,z
18:25:35 <krtaylor> remember to set the topic of patchsets for third-party
18:25:55 <krtaylor> git review -t third-party
18:26:07 <krtaylor> that way we can track them easier
18:26:29 <krtaylor> that looks like all the program items
18:27:19 <krtaylor> we are moving quickly today, but I know better than to say we'll finish early  :)
18:27:25 <krtaylor> #topic Deadlines & Deprecations
18:27:38 <krtaylor> any new deadlines?
18:27:43 <krtaylor> I havent heard any
18:27:57 <krtaylor> any approaching? Neutron? Cinder?
18:28:48 <jungleboyj> krtaylor: The Cinder deadline ... if you want to call it that is approaching.
18:29:00 <krtaylor> hi jungleboyj
18:29:10 <krtaylor> what is that date?
18:29:16 <jungleboyj> krtaylor: Hey, I came in late and sat in the back.
18:29:34 <krtaylor> hehheh
18:29:48 <jungleboyj> krtaylor: Our goal was to have everyone accounted for by 8/11.  When we start our mid-cycle meet-up.
18:30:09 <krtaylor> next Monday, ok, thats good to know
18:30:58 <jungleboyj> krtaylor: I haven't checked the updated status of everything.
18:31:28 <jungleboyj> krtaylor: A lot of people are still struggling, so I expect this will be a topic of discussion next week.
18:31:40 <krtaylor> jungleboyj, will that be before the mid-cycle or a part of it?
18:31:41 <krtaylor> right
18:31:54 <krtaylor> ok, any neutron folks here?
18:31:54 <jungleboyj> krtaylor: Part of it.
18:32:37 <krtaylor> thanks jungleboyj
18:32:44 <krtaylor> let's move on then
18:32:50 <krtaylor> #topic Highlighting a Program or Gerrit Account
18:33:01 <jungleboyj> krtaylor: Welcome.
18:33:01 <krtaylor> well, we didnt have any today
18:33:32 <krtaylor> if I had planned a bit better I would have talked about where we were, I'll add that to next week
18:33:51 * krtaylor tries to figure out how to make Monday's flow better
18:34:22 <krtaylor> alright then, I'll open the floor
18:34:26 <krtaylor> #topic Open Discussion
18:35:02 <krtaylor> any questions, comments, or other items that werent on the agenda?
18:35:03 <asselin_> for those using jaypipes's 3rd party ci repo, 2 fixes got merged into the private -data repo. https://github.com/jaypipes/os-ext-testing-data/commit/59b22a350a75e647a6680e6e14bd089e4be91124
18:35:23 <asselin_> disable start messages & update the recheck regex
18:35:33 * krtaylor looks
18:35:50 <luqas> I am experiencing channel interruption errors in jenkins with the slave using nodepool
18:35:55 <daya_k> has anyone tried uploading logs to swift through their zuul system? if i add a [swift] section to zuul.conf, zuul server does not start at all.
18:36:00 <luqas> http://paste.openstack.org/show/90050/
18:36:43 <sweston> asselin_: nice!
18:36:46 <asselin_> luqas, sorry haven't seen that
18:36:53 <krtaylor> asselin_, good, and that is also in discussion right now, recheck syntax for third-party systems
18:37:07 <luqas> looks like the nodepool slaves are being reused before being marked offline
18:37:34 <asselin_> luqas, which repo are you using ? jaypipes, mine, or your own?
18:37:39 <krtaylor> daya_k, I am not sure that works yet, we are using a helper script
18:37:46 <luqas> asselin_ I had to ask here :-)
18:38:12 <luqas> our own
18:38:19 <sweston> daya_k: I am uploading logs through the Jenkins scp plugin.  I can give you some tips, if you'd like.
18:38:26 <daya_k> krtaylor, ok, so the current prevalient mecahnism is scp then
18:38:26 <asselin_> daya_k, I'm using zuul & uploading logs, but not using swift...that's optional.
18:38:45 <asselin_> daya_k, https://github.com/rasselin/os-ext-testing/blob/master/puppet/install_log_server.sh
18:38:49 <daya_k> sweston, ok, thanks, the problem is i want to use a softlayer acccount which needs swift
18:38:53 <krtaylor> rfolco joined - daya_k was asking about how we upload to swift
18:39:08 <krtaylor> daya_k, we are using softlayers swift service
18:39:18 <daya_k> asselin thanks
18:39:23 <krtaylor> but with a helper script as a publisher
18:40:04 <krtaylor> rfolco was working to get the zuul swift upload working
18:40:14 <rfolco> daya_k, yes we use swift api to upload logs to Softlayer storage object
18:40:49 <sweston> rfolco: are you using a publisher script as well?
18:40:58 <daya_k> krtaylor: rfolco, i tried creating the swift section in zuul.conf but the server wont start. , commented out publisher
18:41:08 <krtaylor> sweston, rfolco and I are the same :)
18:41:25 <sweston> krtaylor, hehe, ok
18:41:33 <rfolco> daya_k, the zuul plugin is another thing
18:42:06 <rfolco> we're moving to zuul plugin soon, when our tests finish with v1.0 auth
18:42:18 <krtaylor> sweston, we currently us the publisher jenkins plugin for each job, to fire off the log collection and upload to swift
18:42:27 <krtaylor> daya_k, ^^^
18:42:33 <asselin_> luqas, are you usig the zmq jenkins plugin?
18:42:43 <daya_k> rfolco krtaylor, thanks i'll try to emulate
18:42:58 <luqas> asselin_ don't think so
18:43:18 <asselin_> luqas, you need to use that and sync the port in jenkins with this line: https://github.com/rasselin/os-ext-testing/blob/master/puppet/modules/os_ext_testing/templates/nodepool/nodepool.yaml.erb#L10
18:43:45 <asselin_> luqas, install it here: https://github.com/rasselin/os-ext-testing/blob/master/puppet/modules/os_ext_testing/manifests/master.pp#L127
18:43:57 <luqas> asselin_ cool let me check it
18:43:59 <krtaylor> daya_k, I pushed a cleaned up patch for it, but rfolco has gone beyond that to include expiration and .gz decoding from the softlayer web service
18:44:54 <asselin_> luqas, you'll need something like this too: https://github.com/rasselin/os-ext-testing/blob/master/puppet/modules/os_ext_testing/files/zuul/openstack_functions.py#L32
18:45:14 <rfolco> I can share the script in a blog post when I finish testing it, but the zuul plugin should be the right approach to follow
18:45:18 <krtaylor> rfolco, maybe you can push your new script, cleaned up first
18:45:27 <sweston> krtaylor: this one, here? https://review.openstack.org/#/c/102655/
18:45:35 <asselin_> luqas, and finally: call the script to mark it single-use. https://github.com/rasselin/os-ext-testing-data/blob/master/etc/zuul/layout.yaml#L53
18:45:41 <asselin_> luqas, easy :)
18:45:53 <krtaylor> sweston, yes, but don't use that one
18:46:03 <krtaylor> rfolco's new one is much better
18:46:14 <sweston> krtaylor, ok
18:46:14 <luqas> asselin_ yay! thanks a lot
18:46:30 <jaypipes> asselin_: for https://github.com/jaypipes/os-ext-testing-data/pull/3, I still need you to remove the stuff specific to your env (particularly: https://github.com/jaypipes/os-ext-testing-data/pull/3/files#diff-faca01be436d8e38462612b12acd8df9R24)
18:46:35 <krtaylor> clarkb was really interested in it at one point, but I think the zuul approach is the way forward
18:47:08 <krtaylor> hi jaypipes
18:47:13 <krtaylor> that reminds me
18:47:21 <asselin_> jaypipes, most of that got split to the other pull request you merged.
18:47:26 <luqas> asselin_ the zmq jenkins plugin is the: Event Publisher (via ZMQ PUB SUB) ?
18:47:57 <krtaylor> daya_k, is it your system that is reporting merge failures?
18:48:14 <jaypipes> asselin_: so should I abandon this PR?
18:48:16 <daya_k> krtaylor: yes, it was, i think i got it fixed though, havent seen any today
18:48:21 <asselin_> jaypipes, I'll take a look at getting the other stuff merged....
18:48:24 <jaypipes> kk
18:48:41 <krtaylor> daya_k, ok, great!
18:49:05 <rfolco> krtaylor, daya_k sweston: well, its not a matter of better or worse. The zuul swift plugin should be the official way to upload to swift. Our script is under testing (with expiration and metadata included), and we should move to zuul plugin soon. The reason we didn't move yet is the auth 2.0 support, Softlayer just supports v.1 auth.
18:50:02 <krtaylor> rfolco, re: v 1 auth, how is that being fixed?
18:50:02 <daya_k> krtaylor: i will monitor some more. but seeing a lot of requirements related failures,  (Could not find a version that satisfies the requirement oslo.messaging>=1.4.0.0a3 (from pycadf==0.5.1.14.ged95886) (from versions: 1.3.0)
18:50:30 <sweston> rfolco: ok
18:51:10 <rfolco> krtaylor, ArxCruz, did you send a patch for v2 ?
18:51:13 <ArxCruz> sweston: daya_k krtaylor rfolco actually, the plugin support 1.0, just doesn't have the config in puppet to enable 1.0, the default was 2.0, I already send a patch for that
18:51:17 <ArxCruz> for 1.-
18:51:18 <ArxCruz> 1.0
18:51:58 <rfolco> true, its Softlayer that won't support v2
18:52:07 <rfolco> so we have to enable v1 auth
18:52:08 <krtaylor> ArxCruz, can you post that link here, some good reviewers lurking
18:52:18 <ArxCruz> krtaylor: it's already merged :)
18:52:50 <rfolco> we just didn't have time to re-test it I guess
18:52:59 <krtaylor> ArxCruz, I see that now
18:53:01 <krtaylor> excellent
18:53:07 <ArxCruz> yup
18:54:10 <krtaylor> 6 minutes, anything else?
18:54:32 <krtaylor> looks like conversation is settling down
18:54:53 <krtaylor> we can call it then, and move any further to openstack-infra
18:55:00 <sweston> good discussion today!!
18:55:20 <krtaylor> thanks everyone, another good one!
18:55:29 <daya_k> thanks!
18:55:30 <luqas> thanks!
18:55:30 <krtaylor> #endmeeting