18:00:27 <krtaylor> #startmeeting third-party
18:00:28 <openstack> Meeting started Mon Jul 28 18:00:27 2014 UTC and is due to finish in 60 minutes.  The chair is krtaylor. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:29 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:32 <openstack> The meeting name has been set to 'third_party'
18:00:46 <krtaylor> Hi all, who's here for the third-party meeting?
18:00:52 <mkoderer> hi there
18:01:01 <AndChat|641136> Hi
18:01:03 <asselin> hi
18:01:08 <joa> hi
18:01:11 <krtaylor> hi, welcome
18:01:15 <daya_k> hi
18:01:41 <krtaylor> sweston, here today?
18:01:53 <krtaylor> anteaya, you around?
18:02:13 <krtaylor> well, lets get started maybe they will show up
18:02:23 <krtaylor> joa, you are here for a little while?
18:02:40 <joa> yup, I chose to go home for the meeting so i'll be here all the way
18:03:06 <krtaylor> ok, well, I have given up saying "this might be a short meeting"
18:03:10 <krtaylor> joa, great
18:03:10 <joa> :p
18:03:29 <krtaylor> welcome everyone!
18:03:38 <krtaylor> here is the agenda for today's meeting:
18:03:48 <krtaylor> #link https://wiki.openstack.org/wiki/Meetings/ThirdParty#Agenda_for_next_meeting
18:04:03 <krtaylor> not a full agenda, but we always have more time for open questins
18:04:07 <krtaylor> and questions
18:04:21 <asselin> ok, i have a question for the end: how to disable jenkins start messages
18:04:41 <krtaylor> asselin, great, bring that up at the end
18:04:45 <krtaylor> #topic Welcome & Reminder of OpenStack Mission
18:04:55 <joa> I might cover that in my subject :p
18:04:58 <krtaylor> #info The OpenStack Open Source Cloud Mission: to produce the ubiquitous Open Source Cloud Computing platform that will meet the needs of public and private clouds regardless of size, by being simple to implement and massively scalable.
18:05:04 <krtaylor> joa true!
18:05:15 <krtaylor> #topic Review of previous week's open action items
18:05:45 <krtaylor> sweston had an action to push a terminology patch, I'll ping him later about that
18:06:04 <krtaylor> we need to get some of those items discussing
18:06:26 <krtaylor> #link https://etherpad.openstack.org/p/ThirdPartyVotingTerms
18:06:39 <krtaylor> just for reference, any comments pre-patch welcomed
18:08:00 <krtaylor> I dont see any other actions
18:08:04 <krtaylor> onward then
18:08:07 <krtaylor> #topic Announcements
18:08:19 <krtaylor> anyone have any third-party announcements?
18:08:37 <joa> what do you mean by announcements ?
18:09:04 <krtaylor> anything that you'd like other third-party teams to know
18:09:19 <joa> oh. Well, my subject will cover a fez things about setting up a CI
18:09:27 <joa> but I woudldn't put it as an announcements
18:09:48 <krtaylor> like, it is really early, but, anteaya and I are planning a meetup for mid-cycle in Kilo
18:09:57 <anteaya> o/
18:10:00 <krtaylor> no specifics yet, just early planning stage
18:10:04 <krtaylor> hey anteaya
18:10:07 <joa> a wild anteaya appears :)
18:10:11 <anteaya> yes
18:10:18 <joa> okay
18:10:23 <krtaylor> hehheh
18:10:45 <krtaylor> so with no other announcements...
18:10:47 <krtaylor> #topic OpenStack Program Items
18:11:20 <krtaylor> joa, we had your easing item here
18:11:33 <joa> yup
18:11:41 <joa> want me to start on it ?
18:11:49 <krtaylor> joa, would you like to frame that discussion for others not familiar
18:11:55 <joa> Yeah;, sure
18:12:15 <joa> The big picture is that as a newcomer in the openstack community
18:12:29 * krtaylor checks the pastebin
18:12:34 <joa> I had to setup a 3rd-party CI for my company (Scality), for cinder
18:12:54 <joa> Thing is, I'm an administration-hater
18:12:59 <joa> and newbie at that :)
18:13:12 <joa> So I kind of encountered a lot of issues while trying to understand and setup the CI
18:13:24 <joa> and I thought of giving feedback to help others in my case
18:13:33 <joa> so I got a few ideas written in the pastebin
18:13:33 <krtaylor> everyone I have met doing this are more dev than ops
18:13:40 <joa> I'm a dev :D
18:13:43 <krtaylor> #link  http://paste.openstack.org/show/86125/
18:13:46 <krtaylor> me too
18:13:53 <joa> but we're currently starting to engage in openstack
18:14:01 <joa> soo I'm kinda alone for the moment
18:14:10 <joa> and we do not have a lot of resources for this yet
18:14:46 <joa> To complete a bit my pastebin
18:14:51 <mpaolino> Hello third-party folks, I'm going to work at a CI as well (for Snabbswitch)
18:15:02 <mpaolino> I started with a patch to devstack
18:15:06 <mpaolino> https://review.openstack.org/#/c/108714/
18:15:17 <mpaolino> reviews and comments are welcome ;-)
18:15:18 <joa> When I reached a simple CI setup, I wrote the following etherpad, that I'll try to put into  the newly created manual repository (that anteaya pointed me to)
18:15:23 <krtaylor> hi mpaolino, one minute, there will be open floor at the end of the meeting
18:15:34 <mpaolino> sure, np!
18:15:42 <joa> So, for later reading you might be interested to look at that : https://etherpad.openstack.org/p/Setting_up_a_3rd-party_CI___Issues_encountered
18:15:56 <joa> this is part of my 'improving third_party.rst"
18:16:04 <krtaylor> #link https://etherpad.openstack.org/p/Setting_up_a_3rd-party_CI___Issues_encountered
18:16:25 <joa> so my idea follows two main lines:
18:16:42 <joa> 1- Improving manuals/docs/howtos to be clear even for newbies like I am
18:17:13 <joa> 2- Improving the available configuration files (I used jaypipe's which were a bit outdated, and despite that it was a great help)
18:17:30 <krtaylor> joa, thats great, there are a lot of opportunities to share experiences and best practices here
18:17:33 <joa> the good thing would be (imho) to make use of the infra/config repository
18:18:12 <daya_k> can i propose, pre-built master and slave vm templates, that folks can download and get started?
18:18:45 <krtaylor> joa, see already help in this area
18:18:55 <krtaylor> daya_k, sure!
18:19:03 <asselin> joa, I think that's a great idea. I've been working on a fork of jaypipes stuff, but it seems it would be nice if it were in infra/config...special place for all3rd party ci
18:19:26 <krtaylor> maybe a templates area?
18:19:27 <daya_k> i went thru a lot of pain getting them to just working, including bad ssh configs, incorrect permissions on the zuul directories, these can all be avoided.
18:19:30 <joa> asselin: I'm actually thinking of giving enough pointers for people to pick what they need in infra/config
18:19:49 <joa> like: Okay for this; you need that pipeline. etc.
18:19:53 <krtaylor> yes, and lots of comments inline
18:20:04 <joa> then the guy can pick the pipeline definitions he needs and all that stuff
18:20:20 <joa> then, picking from infra/config would ensure that it's up-to-date
18:20:23 <asselin> joa, I'd like a simple script to do it all...kindof like devstack...and anyone can get 3rd party ci working.
18:20:25 <anteaya> we can bring up the location at the infra meeting tomorrow, if someone will represent that at the meeting
18:20:37 <joa> asselin: yeah why not
18:20:47 <anteaya> keep in mind, stackforge might be the selected location, I don't know what others think yet
18:21:03 <krtaylor> joa asselin lets start with templates, then we can automate, that would be really nice
18:21:04 <joa> The important part is that it must be an obvious reference
18:21:23 <joa> otherwise it defeats its purpose
18:21:42 <asselin> joa +1
18:22:19 <anteaya> anyone willing to take this idea to the infra meeting tomorrow
18:22:24 <krtaylor> anteaya, I don't see what we can have some templates in /config although I don't get to decide such matters
18:22:26 <anteaya> and ask where this work should live?
18:22:38 <anteaya> right, neither do I
18:22:46 <anteaya> but I think we should discuss with infra
18:22:49 <krtaylor> joa, would you like to do that?
18:22:53 <anteaya> so we all agree on the home for it
18:23:04 <joa> krtaylor: let me check the meeting's time
18:23:30 <joa> mhh a bit late on my side sadly
18:23:31 <anteaya> https://wiki.openstack.org/wiki/Meetings/InfraTeamMeeting
18:23:40 <asselin> Tuesday 1900 UTC
18:23:44 <anteaya> 1900 utc tomorrow
18:23:57 <anteaya> add an agenda item same as you do for third party agenda
18:24:12 <anteaya> anyone else able to make that meeting and ask the question?
18:24:25 <anteaya> I will be boarding a plane so it won't be me
18:24:34 * krtaylor check calendar
18:24:53 <krtaylor> I can if noone else will be there
18:25:04 <krtaylor> asselin, you want it?
18:25:18 <asselin> I just checked my calendar and have a conflict for the 1st half
18:25:29 <asselin> I can be there for the 2nd
18:25:43 <joa> it might be enough, no ?
18:25:51 <krtaylor> not sure when it would come up
18:25:59 <joa> right
18:26:01 <asselin> yes
18:26:09 <beecee> krtaylor: I will be having similar experiences to joa from an ops perspective once I get my build hardware installed next week and will be at tomorrow's meeting, but being very new I don't want to be raising it ;)
18:26:19 <krtaylor> asselin, let's do it this wayI will if you aren't there
18:26:39 <asselin> ok, we can request it in the 2nd half.
18:26:58 <krtaylor> beecee, great, feel free to review the initial doc patch and we'll fix some of the pain
18:27:09 <anteaya> you can add it to the end of the agenda and tell jeblair your timing
18:27:18 <krtaylor> #action asselin and krtaylor  to attend Infra meeting and propose /config location for template configuration files
18:27:18 <anteaya> so he knows when he is chairing the meeting
18:27:25 <anteaya> great, well done
18:27:38 <krtaylor> asselin, can you add the agenda item?
18:27:45 <asselin> krtaylor, sure
18:27:53 <krtaylor> asselin, thanks
18:28:25 <krtaylor> good, joa anything else you want to say on that subject?
18:28:38 <joa> Well, mayhbe just summing the ideas, as a summary ?
18:28:44 <joa> otherwise i'm good :)
18:29:13 <krtaylor> joa, that will be a good place to start
18:29:18 <krtaylor> alright then
18:29:32 <krtaylor> I have to throw in my weekly plug for begging reviews
18:29:44 <krtaylor> #link https://review.openstack.org/#/q/status:open+project:openstack-infra/config+branch:master+topic:third-party,n,z
18:30:03 <anteaya> thank you
18:30:04 <krtaylor> please go review these and other third-party infra related
18:30:14 <krtaylor> lets get these moving
18:30:32 <anteaya> this one is new and needs some awareness: https://review.openstack.org/#/c/109565/
18:30:40 <anteaya> it involves the recheck syntax
18:31:06 <krtaylor> yes, important one
18:31:14 <anteaya> actually it might be worth someone adding an item to the infra agenda to clarify exactly what recheck scenaarios need to be supported by third party
18:31:50 <anteaya> sdague makes a valid point but brings up a scenario that bobball comments on
18:32:03 <anteaya> would be good to have an infra discussion about that and get some clarity
18:32:23 <anteaya> someone willing to do that at tomorrow's infra meeting?
18:32:36 <krtaylor> #action krtaylor to ask sdague for discussion in infra meeting on recheck syntax clarification
18:32:40 <krtaylor> yes :)
18:32:43 <joa> Soo the idea is to change the current recheck yntax specific toa  third-party ?
18:32:51 <anteaya> krtaylor: actually just ask infra
18:32:58 <joa> (or allow third parties to be free about how they command their CIs ?)
18:33:11 <krtaylor> basically put rechecks in their own namespace
18:33:13 <anteaya> sdague usually picks up his produce box at that time, so isn't usually in attendance for that meeting
18:33:17 <joa> ok
18:33:29 <krtaylor> anteaya, good info
18:33:37 <krtaylor> I'll add to agenda then
18:33:43 <krtaylor> and discuss
18:33:44 <anteaya> the motivation is to clear the third party syntax out of what infra needs from recheck
18:34:06 <anteaya> if that means more flexibility for third party that is fine, but we have to follow a syntax format
18:34:20 <anteaya> and discuss a grammar with input from infra and qa
18:34:35 <beecee> would that mean existing 3rd party systems would need to update what syntax they accept?
18:34:36 <joa> ok
18:34:40 <krtaylor> #action krtaylor to add recheck syntax clarification discussion to infra agenda
18:34:41 <anteaya> beecee: yes
18:34:54 <anteaya> beecee: but we need to decide what format that would take first
18:35:03 <beecee> anteaya: gotcha
18:35:07 <anteaya> so participate in teh conversation and don't make any changes yet
18:35:08 <anteaya> thanks
18:35:46 <krtaylor> anything else?
18:35:50 <anteaya> not from me
18:35:52 <krtaylor> lets move on then
18:35:52 <asselin> (I updated the agenda. Please update/fix https://wiki.openstack.org/wiki/Meetings/InfraTeamMeeting#Agenda_for_next_meeting)
18:36:07 <krtaylor> asselin, thanks!
18:36:13 <krtaylor> #topic Deadlines & Deprecations
18:36:23 <krtaylor> anything to communicate here?
18:36:40 <krtaylor> I haven't heard any third-party related
18:37:09 <anteaya> asselin: edited, added the word templates, since templates are the item under discussion
18:37:36 <krtaylor> ok, so the next had no item
18:37:46 <krtaylor> #topic Highlighting a Program or Gerrit Account
18:38:11 <krtaylor> which leave more time for open discussion
18:38:14 <krtaylor> #topic Open Discussion
18:38:47 <asselin> anyone know how to disable jenkins start messages?
18:38:55 <joa> yup
18:39:02 <joa> so the thing is
18:39:13 <joa> it's part of the definition of the pipeline in zuul's layout (afair)
18:39:35 <joa> if you just comment out the start and finish blocks
18:39:38 <joa> it's deactivated
18:39:47 <joa> relatively simple but you have to dig through it to get it
18:39:50 <anteaya> joa: have you a code sample?
18:40:00 <joa> that's why I'd like my first draft of the doc to have it.
18:40:03 <anteaya> or could you put one on paste.openstack.org
18:40:08 <asselin> so comment this out:     start:
18:40:08 <asselin> gerrit:
18:40:08 <asselin> verified: 0
18:40:10 <joa> anteaya: sadly, no access to my CI server from home :(
18:40:16 <anteaya> joa: understood
18:40:18 <joa> yup
18:40:25 <joa> asselin: that's it
18:40:45 <asselin> joa ok thanks will try that out
18:40:51 <joa> you're welcome
18:41:07 <anteaya> nice work
18:41:07 <luqas> I do have a sample
18:41:08 <joa> that's party of the configurations bits that I wish to see obviously explained
18:41:10 <krtaylor> nice
18:41:11 <luqas> #    start: #      gerrit: #        verified: 0
18:41:15 <luqas> ups
18:41:19 <anteaya> thanks luqas
18:41:27 <luqas> paste bin better?
18:41:29 <anteaya> joa: makes sense, and I agree
18:41:40 <anteaya> luqas: yes, for anything more than one line
18:41:45 <anteaya> but it is okay
18:41:49 * krtaylor thinks of a FAQ again
18:41:52 <joa> anteaya: I'll try to cover that in my first draft :) might be long to come though
18:42:03 <anteaya> joa: break it up in pieces
18:42:12 <anteaya> it will take a while to review all the pieces
18:42:13 <krtaylor> ++
18:42:18 <luqas> http://paste.openstack.org/show/88745/
18:42:19 <anteaya> make it easy for the reviewers
18:42:31 <anteaya> thanks luqas
18:42:35 <anteaya> better format there
18:42:38 <krtaylor> always better in smaller chunks
18:42:44 <luqas> these lines in /etc/zuul/layout.yaml
18:42:46 * anteaya nods
18:42:51 <joa> anteaya: should I make multiple different changes or simply multiple patchsets in one change ?
18:43:03 <anteaya> make one patchset first
18:43:07 <anteaya> and lets see
18:43:15 <anteaya> just get something up so we can start from there
18:43:22 <joa> alright
18:43:40 <anteaya> for code we like 400 lines or less per patch
18:43:49 <krtaylor> and don't forget to set topic to third-party
18:43:53 <anteaya> for docs, it is nice to have something around 80 lines at a time
18:44:04 <anteaya> but that might be my personal preference
18:44:23 <anteaya> yup, nice to have them all available under the same topic:
18:44:41 <joa> krtaylor: oh ok
18:44:50 <krtaylor> anteaya, speaking of, are you stuck on any of yours? how can we help?
18:44:50 <asselin> btw, I looking at http://ci.openstack.org/stackforge.html & it seems like a good place for 3rd party ci
18:45:11 <anteaya> krtaylor: I think most are okay, mostly I was waiting for infra-core to return from oscon
18:45:22 <anteaya> I hope to see mine merged this week sometime
18:45:25 <krtaylor> anteaya, understood
18:45:32 <anteaya> will ping if I need more eyes, and thanks
18:45:41 <krtaylor> I'll refresh my reviews
18:46:02 <anteaya> kk
18:46:08 <krtaylor> mpaolino, anything else you want to say about that patch you posted here earlier?
18:46:25 <mpaolino> yes sure, sorry if I interrupted you before ;)
18:46:35 <mpaolino> basically I started developing a patch for devstack, to enable the possibility to use (automatically) the latest version of qemu and libvirt from tar releases
18:46:53 <mpaolino> My use case is a CI server that tests Openstack features related to snabbswitch (www.snabb.co), which has qemu 2.1 and libvirt 1.2.6 as dependencies
18:47:04 <anteaya> mpaolino: have you discussed your patch with anyone in qa?
18:47:05 <mpaolino> the link is : https://review.openstack.org/#/c/108714/
18:47:15 <anteaya> like dtroyer or sdague?
18:47:25 <mpaolino> actually not yet, but I would like to
18:47:37 <anteaya> yeah, I'd recommend that first
18:47:51 <anteaya> adding patches with new dependencies usually doesn't go over well
18:48:08 <mpaolino> I think this may be of interest also for some other folks here in the third party group, so I would love to have receive comments from you guys, since are experts in CI maybe I believe your comments may be precious
18:48:11 <anteaya> since we have a pretty strong depencency process we follow
18:48:46 <mpaolino> s/have receive/receive
18:48:53 <asselin> there should be a way to configure devstack & not add any dependencies.
18:48:55 <anteaya> I'd start off spending some time in #openstack-qa and learning the process of introducing new dependencies
18:49:12 <anteaya> and the third party space includes women as well
18:49:15 <anteaya> not just guys
18:49:28 <mpaolino> ok I'll try to contact dtroyer or sdague, is there any suggested way to do it?
18:49:28 <asselin> the script is full of hooks and ways to override variables. if one or two are missing, should be easy to get that accepted.
18:49:44 <anteaya> asselin: that approach would probably have a greater chance of being recieved
18:50:05 <anteaya> mpaolino: yes, join #openstack-qa
18:50:13 <anteaya> and lurk for a bit
18:50:25 <anteaya> then ask about the process to add dependencies
18:50:41 <mpaolino> :)
18:50:48 <krtaylor> mpaolino, I'd need to look at  it closer, yes -infra and -qa will help alot
18:51:29 <krtaylor> mpaolino, there is other ways to change the setup of the testing environment after devstack too, but I need more specifics
18:51:50 <krtaylor> but start with a -qa join
18:52:03 <mpaolino> ok
18:52:25 <krtaylor> nine minutes, anything else on open discussion?
18:52:32 <beecee> krtaylor: wait
18:52:32 <mpaolino> with dependencies you meant a dependency with dev-stack, am I right?
18:52:41 <anteaya> any dependency
18:52:50 <mpaolino> I see
18:52:53 <anteaya> we have a process for dependencies
18:53:05 <anteaya> learning the process goes a long way to further your happiness
18:53:10 <krtaylor> ++
18:53:38 <beecee> krtaylor: can the 3rd party pages be updated with links to the formal policy announcements for 3rd party testing?  I'm wanting something to show my managers as to why I'm diverting machines to this to keep our driver in the tree
18:53:59 <anteaya> what do you mean by formal policy announcements?
18:54:04 <krtaylor> hehheh, I understand your pain
18:54:23 <joa> beecee: for which project do you wwant to do this ?
18:54:29 <krtaylor> beecee, we are in the process of defining the unwritten requirements
18:54:47 <joa> for instance, I know that cinder maintains a grid of the third-party drivers, with  their "CI" status
18:54:50 <krtaylor> there are global requirements and project specific requirements for third-party testing
18:55:06 <krtaylor> joa, nova does as well
18:55:08 <beecee> krtaylor: yes there are, but they aren't all in the same place
18:55:29 <krtaylor> beecee, yes, we talked about a links page to point to them all
18:55:42 <beecee> krtaylor: cool, then I just need to put them there.
18:55:46 <beecee> point
18:55:54 <krtaylor> but usually one CI system is only interested in one projects requirements, hence the problem
18:56:10 <krtaylor> beecee, feel free to add to third-party.rst
18:56:13 <anteaya> what are formal policy announcements?
18:56:38 <krtaylor> beecee, see the link I posed earlier for other changes to third-party.rst for reference
18:57:12 <krtaylor> beecee, policy = requirements for testing drivers?
18:57:40 <luqas> regarding the merging policy, is it automatically set for merge after a number of +2 reviews?
18:57:41 <beecee> krtaylor: yes, but more where the justification for that policy occurred
18:57:56 <anteaya> luqas: no, a core needs to set workflow to +1
18:58:03 <anteaya> luqas: it is a manual process
18:58:14 <luqas> ok, thanks anteaya
18:58:15 <anteaya> beecee: what are you looking for here?
18:58:19 <krtaylor> beecee, alot of the justification came from weeks and weeks of maillist and irc discussion
18:58:20 <anteaya> luqas: np, good question
18:58:53 <beecee> krtaylor: yeah, and I'm coming in late to the party
18:58:55 <anteaya> beecee: yes, if your managers aren't reading the ml and the channel and meeting logs, it will be tough to condense it so they understand
18:59:05 <anteaya> beecee: everyone has to start somewhere
18:59:09 <anteaya> we are out of time
18:59:12 <beecee> anteaya: that's my current problem, I'm playing catch up ;)
18:59:22 <anteaya> beecee: let's continue to try to get you what you need
18:59:30 <anteaya> I'm not sure what that is yet though
18:59:50 <krtaylor> beecee, it is a tough problem, lets move to -infra
18:59:58 <beecee> krtaylor: ok
19:00:05 <krtaylor> thanks everyone, another good meeting!
19:00:15 <krtaylor> #endmeeting