18:00:22 <krtaylor> #startmeeting third-party
18:00:23 <openstack> Meeting started Mon Jul 21 18:00:22 2014 UTC and is due to finish in 60 minutes.  The chair is krtaylor. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:24 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:26 <openstack> The meeting name has been set to 'third_party'
18:00:43 <krtaylor> Hi everyone
18:00:45 <krtaylor> Who is here for third-party meeting?
18:00:47 <lukego> Hoi
18:00:50 <luqas> o/
18:00:51 <hemanthravi> hi
18:00:51 <ignacio-scopetta> o/
18:00:53 <bmwiedemann> me
18:00:55 <smcginnis> Listening in.
18:00:59 <adalbas> hi
18:01:02 <daya_k> hi
18:01:04 <jungleboyj> o/
18:01:18 <bookwar> hi
18:01:31 <akerr> o/
18:01:34 <krtaylor> jungleboyj, thanks!
18:01:40 <dougwig> o/
18:01:44 <jungleboyj> krtaylor: Welcome.
18:01:52 <krtaylor> welcome everyone!
18:02:14 <krtaylor> looks like we have a good group today
18:02:20 <krtaylor> here is the agenda for today's meeting:
18:02:29 <krtaylor> #link https://wiki.openstack.org/wiki/Meetings/ThirdParty#Agenda_for_next_meeting
18:02:36 <sweston> o/
18:02:53 <krtaylor> #topic Welcome & Reminder of OpenStack Mission
18:03:05 <krtaylor> #info The OpenStack Open Source Cloud Mission: to produce the ubiquitous Open Source Cloud Computing platform that will meet the needs of public and private clouds regardless of size, by being simple to implement and massively scalable.
18:03:20 <krtaylor> alright on to business then
18:03:31 <krtaylor> #topic Review of previous week's open action items
18:04:14 <krtaylor> sweston, any movement on the terminology proposal?
18:04:37 <sweston> krtaylor: just what has already gone out to the mailing list.
18:04:42 <bmwiedemann> ERROR vs FAILURE is a particularly interesting one
18:04:51 <krtaylor> I missed a bit of that discussion due to terrible mail filtering, trying to catch up on that today
18:05:09 <omrim> Hello
18:05:24 <sweston> krtaylor: there wasn't a whole lot, other than my and anteaya's input.
18:05:31 <krtaylor> sweston, would it help to net out some of the discussion on the etherpad?
18:05:45 <krtaylor> #link https://etherpad.openstack.org/p/ThirdPartyVotingTerms
18:05:57 <krtaylor> that pad could be reused
18:06:31 <sweston> krtaylor: it's all there, already
18:06:43 <anteaya> o/
18:07:15 <krtaylor> sweston, then do you want to push a patchset for it?
18:07:37 <krtaylor> then we can decide/vote and get it in the third-party.rst
18:07:40 * mestery lurks
18:07:41 <sweston> krtaylor: yup
18:07:54 <krtaylor> or I can take an action to do that if you wish
18:08:11 <sweston> krtaylor: I would be happy to push the patchset
18:08:11 <akerr> so Failure is used to also indicate something went wrong when running the test?  There's not a separate Error?
18:08:48 <krtaylor> #action sweston to draft a patch for initial terminology
18:08:58 <krtaylor> thanks sweston
18:09:07 <sweston> krtaylor: you bet
18:09:17 <krtaylor> akerr, that is what we are discussing
18:09:46 <akerr> krtaylor: where is this discussion?  I guess my mail filters failed as well
18:10:09 <krtaylor> akerr, openstack-dev
18:10:24 <krtaylor> it has been mostly tagged third-party
18:10:39 * krtaylor wishes we could all agree to use one tag
18:11:00 <krtaylor> akerr, see the above link for the etherpad too
18:11:05 <akerr> hmm ok, I'll have to figure out where they all went.  My last third-party email is from July 6
18:11:15 <sweston> akerr: krtaylor actually, I posted it to openstack-infra, but all input so far is documented in the etherpad.
18:11:31 <akerr> ok, I'll just put feedback into the etherpad
18:11:34 <anteaya> krtaylor: who has been using a tag other than third-party?
18:12:07 <anteaya> the email issue is a dmarc issue if I have my acronyms straight
18:12:12 <sweston> akerr: please do
18:12:14 <anteaya> nothing to do with tagging emails
18:12:21 <krtaylor> sweston, ah, thats why I missed it then (mine popped up in a weekly global search
18:12:36 <jungleboyj> krtaylor: , the terms seem a little convoluted but I suppose it is just a matter of getting used to them as I don't have a better suggestion.
18:12:57 <krtaylor> jungleboyj, agreed, we can make them crisp
18:13:23 <sweston> yes, initial drafts tend to be ambiguous
18:13:25 <jungleboyj> krtaylor: Main concern is that people will see success and ignore that that doesn't really mean 'Passed'.
18:13:46 <jungleboyj> krtaylor: That is an education thing though, I guess, that the cores will have to ehlp with.
18:14:01 <anteaya> we should get the terminalolgy correct
18:14:10 <anteaya> since there is a big revolving door here
18:14:10 <krtaylor> jungleboyj, that was a problem I see with how we are commenting today
18:14:15 <anteaya> and getting bigger
18:14:18 <krtaylor> anteaya, exactly
18:14:26 <bmwiedemann> I find the "Success" meaning unintuitive - it just means, the test was run
18:14:36 <sweston> anteaya, krtaylor +1
18:14:39 <bmwiedemann> and not that it succeeded
18:14:58 <krtaylor> lets get it defined then we can draft recommendation on what goes where to describe what
18:14:58 <anteaya> bmwiedemann: agreed to separate out, something ran from build succeeded
18:15:43 <krtaylor> bmwiedemann, thats what started all this - a good run may be a bad test result
18:16:09 <krtaylor> note: I didnt use the word vote
18:16:21 * anteaya applaudes
18:16:37 <bmwiedemann> krtaylor: but IMHO it then was a "Run" - not a "Success"
18:16:51 <krtaylor> anyway, I think it is a good start, we can put a stake in the ground
18:17:02 <anteaya> let's get something up, yes
18:17:04 <jungleboyj> Could the 'run' or 'executed' be used to indicate it ran successfully but more analysis may be necessary versus 'Success' which means you are done.
18:17:10 <anteaya> more discussion will happen as a result
18:17:32 <anteaya> see I would like to get away from success entirely
18:17:48 <anteaya> build succeeded is more what I would like to see
18:18:13 <anteaya> laggy hotel wifi
18:18:25 <krtaylor> thats why we need a formal vote aka patch, all the terms mean something different to each person
18:18:26 <jungleboyj> anteaya: +1  That would make more sense.
18:18:32 <daya_k> how about complete/incomplete, success/failure - 4 states each with its own detailed info
18:18:32 <akerr> I guess I'm confused why you need to indicate a successful "run" if all it states is the test ran and gives no indication of the outcome.  The fact the entry is there should be enough to indicate a run.  Error would mean an unsuccessful run, Failed means successful run with bad outcome and Passed means successful run with good outcome
18:18:41 <sweston> or maybe, more definitively, tests ran successfully
18:19:17 <anteaya> akerr: what determines failed in your structure?
18:19:45 <anteaya> akerr: meaning who are what decides a run meets your failed criteria
18:19:56 <akerr> anteaya: test runners like testr can distinguish between error and fail, if it exits with a bad code its error
18:20:09 <akerr> the test writer would need to know if the test errored
18:20:20 <anteaya> okay, fair enough so error could be defined
18:20:22 <krtaylor> I think it needs states defining possibilities, regardless if the CI system can reach that state or not
18:20:37 <anteaya> I like the idea of possibilities
18:20:59 <krtaylor> lets enumerate all states and what to call them
18:21:29 <anteaya> sounds good
18:21:29 <krtaylor> sweston, you have the torch, it should be an interesting stream of comments  :)
18:21:50 <sweston> krtaylor:  excellent, that is a beautiful start.
18:22:04 <krtaylor> thats all I had on old business
18:22:10 <krtaylor> did I miss anything?
18:22:27 <krtaylor> onward
18:22:29 <krtaylor> #topic Announcements
18:22:39 <krtaylor> does anyone have any announcements?
18:23:08 <krtaylor> I'll take that as no
18:23:13 <krtaylor> #topic OpenStack Program Items
18:23:16 <hemanthravi> krtaylor: one convergence ci had failures and these have been resolved
18:23:27 <bmwiedemann> I could announce that SUSE plans to run openSUSE devstack tempest as third-party CI
18:23:34 <hemanthravi> krtaylor: update kyle's etherpad at https://etherpad.openstack.org/p/neutron-thirdparty-juno
18:23:38 <hemanthravi> with this info
18:24:16 <krtaylor> hemanthravi, good progress!
18:24:34 <krtaylor> bmwiedemann, that is also really good news
18:24:53 <krtaylor> bmwiedemann, do you have any details yet?
18:25:21 <bmwiedemann> just a rough plan yet and it is certainly still a month away
18:25:48 <krtaylor> bmwiedemann, understood, it takes a while to get everything underway
18:26:04 <bmwiedemann> also it is vacation time in Europe
18:26:11 <krtaylor> ok, well, then on to program items
18:26:38 <krtaylor> anteaya, do you want to take us through some mid-cycle highlights?
18:26:43 <anteaya> sure
18:26:50 <anteaya> #link https://etherpad.openstack.org/p/Qa_Infra_Meetup_2014
18:27:06 <anteaya> so qa and infra had a meetup last week in darmstadt germany
18:27:13 <anteaya> we got a lot of work done
18:27:19 <anteaya> it is outlined on the etherpad
18:27:30 <anteaya> focusing on what was accomplished for third-party
18:28:05 <anteaya> we agreed I can get gerrit permissions to create new third-party accounts, but right now the feature set isn't there for me to edit them
18:28:20 <anteaya> but we are working on getting the code merged upstream to do so
18:28:46 <anteaya> one large item is that the host for the sprint is deutsche telekom
18:29:03 <anteaya> which consumes third-party products for use with openstack
18:29:15 <anteaya> so we talked and they will be joining the third party space
18:29:22 <krtaylor> great
18:29:27 <anteaya> learning how to read logs, what expectations to have from tests
18:29:45 <anteaya> what a broken build means and how to work with the ci team to get the build working again
18:30:00 <anteaya> how to attend and participate in meetings, how to review and so on
18:30:25 <krtaylor> I'm sure you pointed them here
18:30:26 <anteaya> basically how to contribute and work with what we currently have happening with an eye on helping us improve
18:30:30 <anteaya> oh yes
18:30:38 <bmwiedemann> :-)
18:30:42 <anteaya> now they have to dance with legal for a bit
18:30:52 <krtaylor> ah, understood
18:30:52 <anteaya> so after that we will start to see them around
18:31:17 <anteaya> I'll be guiding them through, so any questions please let me help you
18:31:37 <anteaya> so we keep our mutually beneficial collaborative environment we all have created
18:31:50 <sweston> sounds awesome!! we could use you in silicon valley :-)
18:31:58 <anteaya> also new patchsets on my third-party patches
18:32:09 <anteaya> sweston: I'm willing to visit, and will never move there
18:32:12 <anteaya> sweston: :D
18:32:24 <anteaya> I think those are the highlights
18:32:37 <anteaya> if anyone has questions now or later, do ask
18:32:41 * krtaylor looks at huge meetup etherpad
18:32:51 <anteaya> we were busy
18:33:02 <sweston> anteaya :D
18:33:07 <krtaylor> anteaya, thanks!
18:33:52 <krtaylor> ok, so next is ease setup for newcomers, but not sure if joa could make it
18:34:25 <bmwiedemann> https://review.openstack.org/107655 goes in that direction - needs core reviewer
18:34:35 <krtaylor> we may have to push that to next week, there was some indication that joa would not be here this week
18:34:54 <anteaya> krtaylor: yes, that was my understanding
18:35:37 <krtaylor> bmwiedemann, that is interesting but needs a better commit message  :)
18:35:47 <krtaylor> I'll take a look after the meeting
18:35:59 <bmwiedemann> thanks. suggestions welcome.
18:36:18 <anteaya> bmwiedemann: please use the topic:third-party
18:36:26 <krtaylor> that is a goo bridge to the next topic, everyone, please review the patches proposed
18:36:48 <krtaylor> good
18:36:51 <krtaylor> #link https://review.openstack.org/#/q/status:open+project:openstack-infra/config+branch:master+topic:third-party,n,z
18:37:48 <bmwiedemann> the filter seems to not match on my review... can't it filter by filename?
18:38:06 <anteaya> bmwiedemann: it matches on topic
18:38:19 <krtaylor> bmwiedemann, that search is specific to topic
18:38:30 <anteaya> so when you change it to topic:third-party it will pick it up
18:38:44 <krtaylor> bmwiedemann, I'll have to try that, not sure if it can
18:38:58 <krtaylor> any discussion on those patches?
18:39:21 <krtaylor> alright, we'll move on then
18:39:37 <krtaylor> #topic Deadlines & Deprecations
18:39:52 <krtaylor> any new deadlines to communicate to the group?
18:40:12 <anteaya> it can filter on filename but part of teh point is is decideing on a convetion and sticking to it, which wwe have done and are doing
18:40:47 <anteaya> part of learning to be part of the third-party group
18:41:02 * krtaylor needs to remember to set third-party as the patch topic
18:41:16 <anteaya> yep
18:41:32 <krtaylor> #topic Highlighting a Program or Gerrit Account
18:41:37 <lukego> I would like to get voting enable for the Tail-f CI account. Summary of the status:
18:41:38 <lukego> Running again since June 10th. Initially it ran on the sandbox and more recently on Neutron (commenting w/o voting rights). I have been monitoring it ~daily and correcting/retriggering if an operational issue crops up. The changes it has posted results on are listed under https://review.openstack.org/#/dashboard/9695. The logs from the ~ 500 recent runs are under http://openstack-ci.tail-f.com:81/html/ci-logs/.
18:41:39 <lukego> Last week on the 3rd party meeting we reviewed its output and found two issues. The first is that it used an IP address instead of a hostname for logs, and I have corrected that now. The other is that it should run more test cases, and I am currenly working on that. (I aim to setup the expanded test coverage in a staging environment to get a feel for it before taking it live.)
18:41:45 <lukego> (pardon the paste. remarks prepared earlier :-))
18:41:59 <krtaylor> wow
18:42:05 <anteaya> I think  jungleboyj is up next
18:42:15 <anteaya> according to the agenda we are all following
18:42:28 <krtaylor> lukego, hang on for open discussion
18:42:40 <lukego> (Sorry, I saw it as a Gerrit account that shoudl be highlighted)
18:42:47 <anteaya> or in future, add yourself to the agenda
18:43:07 <jungleboyj> :-)
18:43:14 <krtaylor> ok, so jungleboyj has been so kind to agree to give us an update on cinder CI rollout
18:43:17 <lukego> jungleboyj: humble apologies :)
18:43:30 <jungleboyj> lukego: No problem.
18:43:59 <jungleboyj> krtaylor: How large a scope do you want?  I only have high level view of Cinder in general.
18:44:18 <anteaya> anything is a start
18:44:23 <krtaylor> jungleboyj, you define, you might mention any areas that need help too
18:44:52 <jungleboyj> Ok, so at the highest level, DuncanT_away has started collecting up information from the driver owners on their progress.
18:45:12 <anteaya> yay
18:45:22 <anteaya> way to go DuncanT_away
18:45:37 <jungleboyj> Anyone who hasn't reported they are working on this face having a patch pushed up removing their driver if they don't respond by 7/24.
18:45:54 <jungleboyj> Everyone else needs to be providing regular updates.
18:46:19 <jungleboyj> It seems EMC is in the lead for implementation at the moment.  They have had CI running intermittently in the last couple of weeks.
18:46:31 <anteaya> jungleboyj: okay, that would be information we would like announced under deadlines and deprecations every week from now on
18:46:54 <jungleboyj> anteaya: Ok.
18:47:01 <anteaya> and since that date is 2 days away, information of this nature should be announced on a weekly basis, going forward please
18:47:04 <krtaylor> although that is before next meeting
18:47:26 <krtaylor> jungleboyj, that has been brought up in the cinder meetings though
18:47:35 <jungleboyj> krtaylor: Yes.
18:47:43 <krtaylor> ok, good
18:47:46 <anteaya> but part of the point of this space is to keep third party ci informed of deadlines
18:47:48 <jungleboyj> we have been discussing this there for quite some time.
18:47:58 <anteaya> espcially deadlines with deprecation attached to it
18:48:16 <jungleboyj> We are expecting that people will have their CI's running reliably by the time we have our meet up on 8/11.
18:48:21 <anteaya> and I'm glad you have been putting this information in cinder meeting logs
18:48:39 <anteaya> jungleboyj: great, I don't but I won't rain on your parade
18:48:42 <krtaylor> excellent, keep us in the loop
18:48:52 <anteaya> jungleboyj: let's hope I'm wrong
18:49:02 <jungleboyj> anteaya: :-)
18:49:07 <anteaya> :D
18:49:16 <jungleboyj> anteaya: Need to put a stake in the sand somewhere.
18:49:30 <anteaya> jungleboyj: I'm all for that
18:49:57 <jungleboyj> As for details from IBM ...
18:50:17 <jungleboyj> We have accounts created for everything but XIV and DS8k.
18:50:23 <jungleboyj> Need those requests to get pushed through.
18:50:51 <anteaya> jungleboyj: have you made the requests?
18:50:56 <jungleboyj> storwize has been able to trigger off the gerrit stream but is seeing a memory leak of some sort that causes the VM to be useless after a run or two.
18:51:08 <jungleboyj> Anyone familiar with a problem like that?
18:51:28 <jungleboyj> anteaya: Yes, there should have been a request from Eddie Lin for ds8k and Alon Marx for XIV.
18:51:37 * anteaya checks infra ml
18:51:39 <jungleboyj> on 7/16 and 7/13 respectively.
18:51:53 <krtaylor> jungleboyj, the VM isnt created new for each test run?
18:52:02 <sweston> jungleboyj: sounds like an issue I encountered with trying to re-use slave nodes
18:52:18 <krtaylor> its not reall meant to be re-used
18:52:22 <jungleboyj> krtaylor: sweston If it hurts, don't do that?
18:52:27 <anteaya> jungleboyj: http://lists.openstack.org/pipermail/openstack-infra/2014-July/001577.html
18:52:30 <krtaylor> hehheh
18:52:52 <anteaya> jungleboyj: http://lists.openstack.org/pipermail/openstack-infra/2014-July/001575.html
18:52:59 <anteaya> jungleboyj: you are good to go
18:53:14 <sweston> krtaylor: yes, they are certainly not meant to be re-used :-)
18:53:18 <jungleboyj> anteaya: Great.  Thank you.  I will pass those along.  May have just been missed.
18:53:24 <anteaya> jungleboyj: np
18:53:33 <krtaylor> jungleboyj, it's always good practice to start a fresh vm for each pass
18:53:36 <jungleboyj> sweston: krtaylor Ok, I will pass that info along and make sure everyone is aware.
18:54:08 <krtaylor> jungleboyj, anything else?
18:54:20 <jungleboyj> Otherwise, each backend drivers has run the required tempest test cases and is working on getting their master/slave nodes set up.
18:54:23 <anteaya> jungleboyj: thanks for sharing the info
18:54:45 <jungleboyj> mostly done there and have all the hardware in Tucson to eventually house this in one place.
18:54:52 <jungleboyj> So, we are making good progress.
18:55:04 <anteaya> jungleboyj: do the cinder third-party ci folks know they can attend meetings and add agenda items if they have issues?
18:55:12 <jungleboyj> anteaya: You are welcome and thank you for the account updates.
18:55:16 <anteaya> jungleboyj: :D
18:55:27 <krtaylor> jungleboyj, thanks for giving us the Cinder update!
18:55:38 <jungleboyj> anteaya: I will put that on this week's agenda for the weekly meeting.  It has been mentioned but could use another plug.
18:55:45 <anteaya> jungleboyj: thanks
18:55:51 <jungleboyj> krtaylor: My pleasure.
18:55:56 <krtaylor> yes, please have any cinder teams use this group as a resource
18:56:07 <jungleboyj> Will do.
18:56:10 <krtaylor> ok, almost out of time
18:56:18 <krtaylor> #topic Open Discussion
18:56:20 <lukego> Question: How should I follow up on the above?
18:56:25 <krtaylor> lukego, you are up
18:56:27 <anteaya> lukego: read http://ci.openstack.org/third_party.html#permissions-on-your-third-party-system
18:56:38 <anteaya> this body had no mandate
18:56:46 <anteaya> we can vote on nothing
18:56:51 <anteaya> we are not elected
18:57:04 <anteaya> what we can do is talk amoungst ourselves and share information
18:57:09 <lukego> anteaya: Thanks for the link
18:57:16 <anteaya> acourding to the third party meeting goals
18:57:20 <anteaya> lukego: thanks for asking
18:57:41 <anteaya> but when it comes to status changes, you need to address the program you want permissions from
18:57:46 <krtaylor> lukego, the project would have to determine if permissions could be changed
18:58:00 <anteaya> we can evaluate logs and a system, but it is the project that has the decision
18:58:34 <krtaylor> lukego, get on their weekly meeting agenda and ask for a change in permissions
18:58:36 <lukego> understood. I misunderstood and thought I should get a formal blessing here first. thanks for clearing up
18:58:38 <anteaya> we can help you but forward a strong ci history and presentation
18:58:46 <anteaya> if that is what you would like assistance with
18:58:52 <anteaya> np
18:58:58 <anteaya> glad you are on the right track now
18:59:10 <anteaya> also it gave me a chance to state some things
18:59:21 <anteaya> in case anyone thought we have a mandate, which we don't
18:59:32 <krtaylor> lukego, it certainly doesnt hurt that you are here and involved
18:59:45 <hemanthravi> what should go in the ci history for voting perm request
18:59:48 <krtaylor> I would hope that would send the right message
19:00:11 <anteaya> hemanthravi: well some history for one
19:00:25 <krtaylor> hemanthravi, that is up to the project, hopefully we will be able to have a pointer to that soon
19:00:34 <anteaya> like you have been active for more thatn 2 weeks
19:00:45 <anteaya> we can expand that at a furture meeting
19:00:52 <anteaya> out of time
19:00:54 <krtaylor> yes, we must
19:00:59 <hemanthravi> thanks
19:01:05 <krtaylor> thanks everyone for attending!
19:01:08 <sweston> thanks!
19:01:14 <krtaylor> #endmeeting