18:00:35 <krtaylor> #startmeeting third-party
18:00:36 <openstack> Meeting started Mon Jul  7 18:00:35 2014 UTC and is due to finish in 60 minutes.  The chair is krtaylor. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:37 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:39 <openstack> The meeting name has been set to 'third_party'
18:00:54 <krtaylor> Hi everyone
18:01:00 <krtaylor> Who is here for third-party meeting?
18:01:09 <Svedrin> I am :)
18:01:23 <krtaylor> Svedrin, thanks, I saw the agenda item
18:01:24 <sweston> I ...
18:01:35 <ArxCruz> Me
18:01:38 <adalbas> I
18:01:48 <krtaylor> cool!
18:01:54 <krtaylor> so let's get started then
18:02:00 <krtaylor> here is the agenda:
18:02:16 <krtaylor> #link https://wiki.openstack.org/wiki/Meetings/ThirdParty#Agenda_for_next_meeting
18:02:31 <krtaylor> #topic Welcome & Reminder of OpenStack Mission
18:02:57 <krtaylor> a reminder for the mission
18:02:59 <krtaylor> #info The OpenStack Open Source Cloud Mission: to produce the ubiquitous Open Source Cloud Computing platform that will meet the needs of public and private clouds regardless of size, by being simple to implement and massively scalable.
18:03:15 <fawadkhaliq> hello all!
18:03:18 <krtaylor> #topic Review of previous week's open action items
18:03:23 <krtaylor> hello
18:03:50 <krtaylor> we had 3 actions from last week
18:04:25 <krtaylor> one was mine for a patch for suggestions for how to meet requirements
18:04:41 <krtaylor> I did not get that done, due to the holiday in the US
18:05:15 <krtaylor> the other was kevinbenton starting the thread for time to complete testing
18:05:37 <krtaylor> that is done and getting good discussion in ml
18:06:16 <krtaylor> a reminder to everyone, please tag discussions [third-party] when posting to openstack-dev ml
18:06:24 <sweston> krtaylor: is there a patch already created in Gerrit for the documentation?
18:06:55 <krtaylor> sweston, there are the two patches anteaya has, but I have not created one yet for my action
18:07:06 <krtaylor> there was another action, though
18:07:19 <sweston> krtaylor: ok, just checking to make sure I have the right search parameters :-)
18:07:22 <krtaylor> oh, communicate cinder and neutron timelines
18:07:53 <krtaylor> sweston, #link https://review.openstack.org/#/q/status:open+project:openstack-infra/config+branch:master+topic:third-party,n,z
18:08:01 <krtaylor> hm
18:08:02 <krtaylor> #link https://review.openstack.org/#/q/status:open+project:openstack-infra/config+branch:master+topic:third-party,n,z
18:08:22 <krtaylor> all, please review these patches
18:08:57 <krtaylor> the time line communication action was not assigned, did that come up in cinder and neutron weekly meetings?
18:09:15 <krtaylor> do we have cinder and neutron represented?
18:09:24 <krtaylor> sweston, you are neutron right?
18:10:19 <krtaylor> well, I'll take an action to make sure that happens this week
18:10:36 <sweston> krtaylor: I started a discussion with anteaya
18:10:59 <sweston> krtaylor: I need to speak with her to follow up on the next steps
18:11:02 <krtaylor> #action krtaylor to verify communication of cinder and neutron time lines
18:11:10 <sweston> krtaylor: so I can take that one
18:11:14 <krtaylor> sweston, yes, please do
18:11:38 <krtaylor> I think that covers previous week's items
18:12:00 <krtaylor> #topic Announcements
18:12:11 <krtaylor> does anyone have any announcements?
18:12:17 <sweston> krtaylor: awesome,  can you post a new action
18:12:32 <sweston> krtaylor: so it is reflected  in the minutes?
18:13:02 <krtaylor> sweston, yes, and I assigned it so I'll make sure it gets done to both projects
18:13:15 <sweston> krtaylor: ok, great.  thanks.
18:13:16 <krtaylor> sweston, oh, for you
18:13:17 <krtaylor> yes
18:13:24 <sweston> krtaylor: yes
18:13:41 <krtaylor> #action sweston to communicate timelines
18:13:51 <krtaylor> ok, lets move on
18:14:08 <krtaylor> #topic OpenStack Program Items
18:14:22 <krtaylor> any OpenStack program items?
18:14:29 <krtaylor> news from projects?
18:14:51 <krtaylor> well, I posted this earlier
18:14:53 <krtaylor> #link https://review.openstack.org/#/q/status:open+project:openstack-infra/config+branch:master+topic:third-party,n,z
18:15:31 <krtaylor> please review these patches, let get them done, I'll ping anteaya when she is back to get them closed out
18:15:52 <sweston> ok
18:15:55 <krtaylor> any discussion now on these?
18:16:22 <luqas> krtaylor: maybe I can move mine into your requirements/recommendations
18:16:43 <sweston> krtaylor: not ar this time, but I may have some additions later on how to do third party ci with puppet
18:16:51 <krtaylor> luqas, yes, I did see that in the email thread
18:16:57 <sweston> :%s/ar/at/g
18:17:04 <krtaylor> sweston, please patch, that's well needed
18:17:36 <sweston> krtaylor: ok, I can create a topic branch for it
18:17:45 <luqas> krtaylor: ok, so we'll see where it fits better
18:17:50 <krtaylor> luqas, if you want, I'll roll that up in my patch
18:18:05 <luqas> krtaylor: that would be nice too
18:18:14 <krtaylor> luqas, or you can patch and I'll wait for the merge, whatever you prefer
18:18:45 <luqas> were do you think it reads better?
18:19:16 <krtaylor> luqas, I am less worried about it being perfect right now, we can always refactor
18:19:34 <krtaylor> there is so much to document here
18:19:52 <luqas> krtaylor: ok, will patch it then we'll see
18:19:54 <sweston> krtaylor: correction, I guess that would be same topic, new subject
18:20:24 <krtaylor> the challange is going to be to get it recorded, then we can worry about how consumable it is
18:20:36 <krtaylor> sweston, I don't follow
18:20:57 <sweston> krtaylor: never mind, just thinking out loud.
18:21:00 <krtaylor> sweston, oh, for the patch, yes
18:21:11 <sweston> krtaylor: yup
18:21:17 <krtaylor> ok, ever onward
18:21:19 <krtaylor> #topic Deadlines & Deprecations
18:21:32 <krtaylor> anything to communicate here?
18:21:41 <krtaylor> new deadlines?
18:21:57 <krtaylor> other than the cinder/neutron?
18:22:13 <krtaylor> I guess we will see in the next cycle for other projects
18:22:56 <krtaylor> next item then
18:23:01 <krtaylor> #topic Highlighting a Program or Gerrit Account
18:23:42 <krtaylor> s0nea, Svedrin - you are up to discuss openATTIC
18:24:17 <s0nea> ok, yes... hi all. we a trying to set up a ci testing system for our openattic project
18:24:25 <s0nea> and i think we need a little help
18:24:38 <s0nea> anteaya, told me that here is the right place to ask for
18:25:13 <krtaylor> s0nea, can you give us a very short overview of openattic?
18:25:35 <s0nea> we already received a service account and followed up the guide http://www.joinfu.com/2014/02/setting-up-an-openstack-external-testing-system-part-2/ up to section Test the dsvm-tempest-full Jenkins job
18:26:04 <fawadkhaliq> s0nea: can you please share what are you targeting that you need help with. If I can, I will.
18:26:47 <krtaylor> s0nea, I think there are several of us here that have background here, as well as the gurus from my team :)
18:27:20 <ArxCruz> s0nea: I have a little experience to setup CI, I can help you. I also writing some posts about how to setup a 3rd Party CI like o-infra at http://blog.arxcruz.net/
18:27:20 <s0nea> ok fine, krtaylor :)
18:27:32 <krtaylor> what is the goal? what are you stuck on?
18:27:43 <s0nea> ok, the first point is, that after clicking in jenkins on the play button, it only ran about 300 tests... ist that normal?
18:28:16 <s0nea> is there an option we need to enable to run more tests?
18:28:17 <krtaylor> ArxCruz,  yeah a "little" experience :)
18:28:43 <ArxCruz> :)
18:28:47 <krtaylor> s0nea, we'd need more info
18:29:28 <krtaylor> s0nea, did you get passed/failed/skipped? are you skipping by passing regex?
18:29:47 <s0nea> krtaylor, no, i think all works fine
18:30:08 <s0nea> it said success at the end of the test
18:30:17 <krtaylor> s0nea, what project/component?
18:30:19 <s0nea> but it reported a few errors in logs
18:31:15 <s0nea> i'm talking about the dsvm-tempest-full job
18:31:51 <krtaylor> s0nea, ok, a google search shows that it is software defined storage, that is some of the background needed
18:32:01 <s0nea> ah yes... ok
18:32:09 <s0nea> we wrote cinder driver
18:32:14 <krtaylor> ah, ok, that helps
18:32:53 <s0nea> for using our storage tool as blockstorage
18:33:36 <krtaylor> s0nea, this may be something better suited for an -infra discussion, we may need to see logs (pastebin)
18:34:18 <krtaylor> find us there, ArxCruz and I can help for sure, looks like fawadkhaliq  volunteered also
18:34:20 <s0nea> ok... you want see the log of the dsvm-tempest-full job?
18:34:43 <krtaylor> s0nea, it would help, tail and post to pastebin
18:34:55 <krtaylor> post link and we'll discuss
18:35:00 <s0nea> ok... no problem
18:36:38 <krtaylor> ok, is ther any questions for s0nea
18:36:41 <krtaylor> there
18:37:05 <krtaylor> s0nea, it would be nice to learn more about your environment too
18:37:06 <sweston> no, I agree, we need more info to help.
18:37:34 <krtaylor> s0nea, maybe when you get it working you can come back and discuss how you got everything to work?
18:37:46 <sweston> if the logs are not available now for paste, then s0nea might like to know where we can look for the link
18:38:11 <s0nea> krtaylor, yes, sure
18:38:47 <krtaylor> #link http://paste.openstack.org/
18:38:47 <s0nea> here is the paste: http://paste.openstack.org/show/85606/
18:39:01 <krtaylor> ok, cool!
18:39:23 <krtaylor> so lets move that discussion to -infra and move along
18:39:40 <krtaylor> #topic Open Discussion
18:39:51 <krtaylor> so I'll open the floor
18:40:08 <krtaylor> last week we discussed terminology at length
18:40:35 <krtaylor> I suggested that writing these terms down would be good, it started a nice ML discussion
18:41:26 <krtaylor> I am hoping to see some agreement on things like success, failure, passed, etc
18:42:05 <krtaylor> so that's what I had, needed to be a formal topic for this week's meeting, but ran out of time at the end of last week
18:42:05 <sweston> awesome.  what do you think the next step is?
18:42:19 <sweston> ah, ok
18:42:32 <krtaylor> sweston, I think a proposal for the terms, on the ML, then a patch
18:42:41 <krtaylor> maybe to a terms section of the doc
18:42:51 <sweston> krtaylor: cool.  would you like to team up on that?
18:42:52 <krtaylor> but I am flexible on it
18:42:58 <krtaylor> sweston, +1
18:43:24 <krtaylor> sweston, do you want to post a proposal?
18:43:37 <sweston> krtaylor, +1.  Yes.
18:43:44 <sweston> krtaylor: to the ML?
18:43:49 <krtaylor> excellent
18:43:52 <krtaylor> yes, please
18:44:11 <sweston> krtaylor: I can do that.
18:44:36 <sweston> krtaylor: I might have some questions for you after I google around a bit
18:44:47 <krtaylor> #action sweston to propose terminology for test completion criteria, success, fail, pass, etc
18:44:49 <ArxCruz> s0nea: need to check your localrc, I'm pretty sure it's running only 300 tests because you're disabling something in your localrc
18:44:54 <krtaylor> sweston, absolutely
18:45:01 <sweston> krtaylor: kk
18:45:17 <krtaylor> ArxCruz, thx for the quick look!
18:45:37 <ArxCruz> s0nea: also you're running smoke tests, not the full tempest
18:45:38 <s0nea> oh that was fast, thank you ArxCruz :)
18:46:56 <krtaylor> is there any other topics for discussion?
18:47:14 <sweston> I do not have any
18:47:39 <krtaylor> I think in general we need to get some of these outstanding doc patches finished up and start looking at requirements
18:47:57 <krtaylor> but that will wait until anteaya is back
18:48:23 <krtaylor> ok, well I guess we can finish early then, anyone?
18:48:59 <krtaylor> well, we'll finish early for once!
18:49:01 <Svedrin> krtaylor, can we just ping one of you guys when we have questions?
18:49:25 <krtaylor> Svedrin, sure, find one of us in #openstack-infra
18:49:31 <Svedrin> ok will do, thanks :)
18:49:52 <krtaylor> last call
18:50:03 <krtaylor> thanks everyone!
18:50:17 <s0nea> yes, thank you all for your support :)
18:50:21 <krtaylor> #endmeeting