14:01:36 <sgordon> #startmeeting telcowg
14:01:36 <openstack> Meeting started Wed Dec  2 14:01:36 2015 UTC and is due to finish in 60 minutes.  The chair is sgordon. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:37 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:40 <openstack> The meeting name has been set to 'telcowg'
14:01:51 <sgordon> #link https://etherpad.openstack.org/p/nfv-meeting-agenda
14:01:54 <sgordon> #topic roll call
14:01:55 <sgordon> \o/
14:02:02 <adrian-hoban> Hello
14:02:05 <shamail> hi
14:02:05 <cloudon> hi
14:02:42 <sgordon> hi all
14:02:50 <sgordon> #topic Product WG Integration
14:03:35 <sgordon> so i see shamail is here, we had discussed offline during the week that he had some concerns about disbanding of the working group
14:03:55 <shamail> yes, thanks for adding this topic to the agenda
14:04:36 <sgordon> #info Discuss Shamal's concerns about disbanding: Beacon for newcomers to OpenStack from the telco industry, Could help us get OPNFV use-cases in a centralized repository (telco > product > projects) to allow better tracking of overall status, Broader telecommunication use cases than just NFV
14:04:48 <shamail> In the last Telco WG meeting it was discussed that this group be disbanded and continue to make progress on relevant topics either directly through Product WG and OPNFV
14:05:30 <shamail> I think that is definitely a great approach but, at the same time, I am worried that if there is no "telco" WG in OpenStack then newer telcos/people might not find a good way to engage
14:06:11 <shamail> It isn't readily apparent that "if you are interested in NFV then go participate in PWG or OPNFV" and those folks might not find us and we might not find them
14:06:32 <sgordon> my perspective is that newer folks are typically engaging either directly in OPNFV, or in specific projects of interest (neutron, tacker, etc.)
14:06:33 <adrian-hoban> shamail: I didn't think we were disbanding. I thought we were moving to leverage from the benefits of a larger discussion group that the Product WG brings
14:06:54 <adrian-hoban> sgordon: +1
14:07:13 <shamail> agreed as well sgordon
14:07:14 <sgordon> the opnfv folks typically dont see the value of the flow outlined above, which effectively becomes opnfv > telco > product > projects
14:07:32 <sgordon> as they are doing requirements doc on the opnfv side in their requirements projects
14:07:56 <adrian-hoban> And, the chain gets even longer if you think of the ETSI-NFV starting point
14:08:00 <shamail> The value I see in that approach is that it makes it easier to get context on requirements for someone who isn't directly involved with OPNFV
14:08:01 <sgordon> if there is to be "one true place" for requirements to land in openstack it is probably more likely the productwg repository than here
14:08:12 <sgordon> yeah
14:08:29 <sgordon> the challenge is while i meet people who arent directly involved with opnfv who raise that concern
14:08:36 <sgordon> they aren't engaging here either :)
14:08:44 <shamail> that's fair
14:09:11 <sgordon> we definitely get a big up tick in folks around summits but in between it is fairly lonely in here
14:09:33 <sgordon> (and at the summits arguably we can merge in with the opnfv BOFs etc)
14:09:54 <adrian-hoban> I assume we'll have a dedicated place to land Telco items under the Product WG umbrella
14:10:07 <shamail> How much effort would it be to keep the "lights on" by even moving to an "email only" type of model for the WG?
14:10:34 <shamail> adrian-hoban: kind of... in reality, all user stories in PWG land in the same place but they will be associated with which market(s) orginiated the need
14:10:51 <sgordon> i think the challenge there is most of the emails are me summarizing the meetings
14:10:56 <shamail> so while it won't be a dedicated landing spot, it will be a centralized one with identification of telco/NFV related items
14:11:02 <adrian-hoban> shamail: ok
14:11:06 <sgordon> the reality of it is if we want real work done we need real people to do it
14:11:20 <sgordon> so atm for example the use case docs are primarily being worked on by calum and myself
14:11:37 <shamail> Yep, and that is already starting to happen through how new people are engaging (as you said... OPNFV or projects)
14:11:52 <cloudon> agree on lack of engagement but think there's value in this group playing a feeder role to discuss and bash use cases into shape before submitting to PWG
14:12:00 <sgordon> adrian-hoban, the other end of that is there is a page in the opnfv wiki i want to be more active in maintaining listing BPs etc (sound familiar?)
14:12:07 <shamail> cloudon: +1
14:12:29 <adrian-hoban> sgordon: sure does :-)
14:12:40 <shamail> The foundation is doing a content push on NFV, I wonder if that would help the participation here?
14:12:50 <shamail> Of course, we wouldn't know until Jan/Feb
14:14:49 <sgordon> unclear, i think in the end we intentionally made the call to action more generic
14:14:59 <sgordon> as the future of this group was in flux when we were reviewing
14:15:02 <adrian-hoban> Getting back to why we started this group. We wanted a place to discuss telco items, to help harmonize on telco specific requests going into the core projects, and to help what at the time was a new use case for OpenStack to be better understood.
14:15:05 <cloudon> also, while the OPNFV folks may not see the value of an opnfv > telco > product > projects flow, we do need something to encourage engagement, as what I see at the moment is too much opnfv > projects -> WTF?
14:15:27 <sgordon> adrian-hoban, an important aspect of that was at the time OPNFV didn't yet exist
14:15:37 <shamail> I think basically keeping telco WG alive will require some duplication of work (e.g. list of BPs already exist on OPNFV but could we track them via this team too within the community?)  I see value in this group continuing to exist (even if the activities are less defined) versus not having a telco/NFV WG inside OpenStack itself at all
14:15:41 <sgordon> chris and others were trying to get it set up but helped us bootstrap this in the meantime
14:15:50 <adrian-hoban> sgordon: Yes, and NFV was relatively new
14:16:01 <sgordon> right
14:16:13 <sgordon> people had ideas that eventually became tacker, bgpvpn, etc
14:17:08 <Haidee> does anyone from the PWG attend this WG?
14:17:20 <shamail> cloudon: +1, I think you summarized it well... we might see requirements and activities based on OPNFV but the OpenStack community doesn't have context without this group
14:17:35 <sgordon> shamail, without active membership the tracking is still going to fall to a fall number of folks for limited ROI though
14:17:54 <shamail> Haidee: not on a regular basis... I don't mind attending though.
14:17:54 <sgordon> that's why i am looking to focus my efforts on doing it on the opnfv side where there are more active people to share the load
14:18:25 <shamail> sgordon: makes sense
14:18:59 <cloudon> Steve, what do you think can be done in opnfv to encourage more interaction with the community full stop, regardless of whether it's telco, product or projects?
14:19:00 <sgordon> i do understand the desire to keep the lights on, but i feel like we've been doing that for a while
14:19:08 <sgordon> a number of core folks have dropped in the last month or so
14:19:20 <sgordon> what's left is basically those who are here
14:19:50 <shamail> Understoof
14:19:54 <shamail> Understood*
14:20:00 <sgordon> cloudon, that is a broader challenge - i think the approach taken is still very much one of reviewing on the opnfv side and then going directly to blueprints
14:20:21 <sgordon> and for the members with active technical contributors on both sides, which there are many of, this is working pretty well
14:20:35 <shamail> Should I try to schedule something with Chris and Heather on this topic (encouraging OPNFV interaction with OpenStack community)?
14:20:40 <sgordon> level of success does vary project by project though
14:21:21 <sgordon> shamail, it is probably worth revisiting
14:21:32 <shamail> Okay
14:21:44 <sgordon> i know that the folks from the openstack foundation who were at opnfv summit did have some conversations along these lines
14:22:01 <sgordon> and we have had openstack community members brief the technical steering committee in the past
14:22:13 <shamail> nice
14:22:31 <sgordon> what is required is two way engagement
14:23:21 <shamail> I also think the point cloudon raised about " value in this group playing a feeder role to discuss and bash use cases into shape" is valid too
14:23:40 <sgordon> it is, but the opnfv requirements projects see themselves as same
14:23:50 <sgordon> which is where some of the early contributions have gone
14:24:21 <adrian-hoban> sgordon: Agreed, and where it has worked best is when the relevant OpenStack community was engaged early in BP related discussions
14:24:39 <shamail> Alright, i'll try to set something up with the OPNFV folks to discuss two-way engagement.
14:24:53 <shamail> Unless if you want to do that sgordon (might be easier for you)?
14:25:49 <sgordon> shamail, i am happy for you to set it up - as above i am fairly happy at this point to actively do my part
14:25:59 <shamail> Thanks!
14:26:30 <shamail> I'll report back to this team once I am able to make contact.
14:27:52 <sgordon> #action shamail to set up discussion with OPNFV folks to discuss engagement model
14:28:17 <sgordon> #topic Product WG Integration - Complex Instance Placement Updates
14:28:24 <sgordon> #link https://review.openstack.org/#/c/251442/
14:28:39 <sgordon> cloudon, not sure if you had seen it but arkady had some feedback on the above update
14:28:52 <cloudon> Yup, just saw that today and have added some comments...
14:29:13 <cloudon> ...think I misread the opening para when I first reviewed - have suggested some alternative text
14:30:02 <sgordon> ok
14:30:12 <sgordon> i guess that is on me to try update then
14:30:18 <sgordon> what about wrt the second para?
14:30:30 <sgordon> #action sgordon to update complex instance placement use case integrating feedback
14:31:10 <cloudon> think my suggested text would cover that but will look again
14:32:09 <adrian-hoban> cloudon: I'll try to get some comments in today too
14:33:24 <sgordon> ok
14:33:34 <sgordon> the others i will get to after this one is merged
14:33:44 <sgordon> (sec segregation, sbc)
14:33:56 <sgordon> #topic other business
14:34:00 <sgordon> any other business?
14:35:17 <gjayavelu> I see we have telcowg-usecases-core group, would it be better to copy this group in BP/spec, patches review to notify and get attention from this group?
14:35:42 <gjayavelu> that way, we have engagement at individual BPs
14:35:54 <sgordon> which bp/spec are you referring to?
14:36:03 <sgordon> for the instance placement one i did actually send out an email i believe
14:36:22 <gjayavelu> in general all, and https://review.openstack.org/#/c/251442/ too
14:36:24 <gjayavelu> oh ok
14:37:11 <gjayavelu> I'm new to the group, what is the best way you suggest to track these bps?
14:37:36 <sgordon> #link https://review.openstack.org/#/q/project:openstack/openstack-user-stories+status:open,n,z
14:37:50 <sgordon> #link https://review.openstack.org/#/q/project:openstack/telcowg-usecases+status:open,n,z
14:37:55 <sgordon> are the two dashboards to follow
14:38:12 <gjayavelu> ok
14:40:22 <gjayavelu> i put a spec for review https://review.openstack.org/#/c/237805/, which is part of Telco requirement from vmware
14:41:20 <gjayavelu> this is along the lines of placement
14:41:36 <sgordon> right, so it looks like it is awaiting reviews from the project team itself (in this case nova)
14:41:57 <sgordon> as their specs deadline is fast approaching (tomorrow I believe?) they are doing their best to cut through the review backlog
14:42:05 <sgordon> but invariably not everything will make it
14:42:11 <gjayavelu> yes, how would we track such specs under Telco?
14:43:00 <sgordon> it depends on its origins, as it doesn't appear to be driven by a submitted use case we don't really have anything to track it from
14:43:24 <sgordon> it does seem like it relates to the complex instance placement proposal but wasnt an identified gap as yet
14:43:29 <sgordon> probably would need to be added
14:45:13 <gjayavelu> I'm kinda relating back to the discussion earlier about keeping or disbanding the group..
14:46:02 <sgordon> #link https://wiki.opnfv.org/community/openstack
14:46:12 <sgordon> that is where the opnfv driven BPs are linked from
14:46:29 <sgordon> but again that is where they have gone through the requirement documentation phase in one of the requirements projects
14:47:44 <gjayavelu> oh ok..may be it was my lack of understanding about the opnfv- openstack relation.
14:48:07 <gjayavelu> as a newbie i never guessed this workflow.
14:48:15 <sgordon> both in opnfv and here a lot of the work is around documenting the use cases
14:48:24 <sgordon> which are in turn used to identify gaps/requirements
14:48:33 <sgordon> which finally are used as the basis for specs/blueprints
14:48:42 <sgordon> so the tracking is effectively by use case
14:49:08 <shamail> I have to drop off, take care everyone.  o/
14:50:17 <gjayavelu> the point i'm trying to make is that, how could new contributors (openstack) be directed with this process? if we maintain this wg, can others get enlightened like what i learned today :)
14:51:53 <sgordon> i believe they would land in opnfv or the product wg
14:52:24 <sgordon> basically from my side it takes a non-negligible amount of time to "keep the lights on" as requested earlier
14:52:42 <sgordon> doing that in the hope that a new person turns up every now and again seems pretty inefficient
14:52:51 <gjayavelu> ok
14:53:03 <sgordon> versus coalescing into those other groups where there are more people to spread the load
14:53:46 <gjayavelu> ok
14:54:47 <sgordon> alright thanks all for the discussion regardless
14:55:01 <sgordon> we will continue to reconvene weekly for now while we sort out moving the work items across
14:55:07 <sgordon> #endmeeting