14:00:24 <sgordon> #startmeeting telcowg
14:00:25 <openstack> Meeting started Wed Sep 23 14:00:24 2015 UTC and is due to finish in 60 minutes.  The chair is sgordon. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:26 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:29 <sgordon> #link https://etherpad.openstack.org/p/nfv-meeting-agenda
14:00:30 <openstack> The meeting name has been set to 'telcowg'
14:00:32 <sgordon> #topic roll call
14:00:34 <sgordon> hola!
14:00:38 <aveiga> hello
14:00:39 <cloudon> hi
14:01:24 <DaSchab> hi
14:01:43 <sgordon> #topic BGP use case
14:02:01 <sgordon> #info Still need a volunteer to take BGP use case as a "guinea pig" to turn into RFEs/backlog
14:02:12 <sgordon> (i have had a crack at the vIMS one, will get to that in a second)
14:02:57 <sgordon> #action sgordon to contact Mathieu directly
14:03:05 <sgordon> #topic vIMS usecase
14:03:12 <sgordon> #link https://bugs.launchpad.net/openstack-telcowg/+bug/1498922
14:03:13 <openstack> Launchpad bug 1498922 in openstack-telcowg "Tracker: Virtual IMS Core" [Undecided,New] - Assigned to Stephen Gordon (sgordon)
14:03:18 <sgordon> #link https://review.openstack.org/#/c/224325/
14:03:48 <sgordon> i took the vIMS use case and raised a Nova backlog spec for the affinity gap (N+k pools) - see the review link above
14:04:00 <sgordon> i know cloudon had already provided a comment on there but more reviews likely welcome
14:04:46 <cloudon> Steve, did you make a change a short time ago? Couldn't see any delta
14:05:08 <sgordon> i removed the WIP flag
14:05:24 <cloudon> ah, ok
14:06:59 <sgordon> ok
14:07:06 <sgordon> #topic Open Reviews
14:07:12 <sgordon> #link https://review.openstack.org/#/q/status:open+project:stackforge/telcowg-usecases,n,z
14:07:26 <sgordon> i will put aside those that have had -1s forever
14:07:42 <sgordon> i am going to make an attermpt to contact the authors again and then potentially abandon
14:07:42 <aveiga> sgordon: what's Monty's change for?
14:07:50 <sgordon> aveiga, great question!
14:07:58 <sgordon> secret infra stuff
14:08:02 <aveiga> I figured
14:08:05 <sgordon> Change ignore-errors to ignore_errors
14:08:05 <sgordon> Needed for coverage 4.0
14:08:09 <sgordon> in .coveragerc
14:08:17 <sgordon> which tbh i couldnt tell you what it does ;p
14:08:19 <aveiga> would be nice if he explained t he change...
14:08:32 <aveiga> I assume it's part of the "migrate stackforge" stuff
14:08:40 <sgordon> https://pypi.python.org/pypi/coverage/4.0a1
14:09:00 <aveiga> ah! that's more useful
14:09:01 <sgordon> i suspect it's broader than that
14:09:09 <sgordon> and is just that every project has this rc file
14:09:17 <sgordon> and thus has been hit with a patch if it uses the old syntax
14:09:28 <sgordon> https://review.openstack.org/#/q/owner:mordred%2540inaugust.com+status:open,n,z
14:09:37 <sgordon> seems to contain a lot of them
14:10:05 <sgordon> #link https://pypi.python.org/pypi/coverage/4.0a1
14:10:11 <sgordon> #link https://review.openstack.org/#/q/owner:mordred%2540inaugust.com+status:open,n,z
14:10:18 <sgordon> #link https://review.openstack.org/#/c/225904/
14:10:53 <sgordon> #link https://review.openstack.org/#/c/199654/
14:11:05 <sgordon> i can see aveiga just +2'd that template update so that is off the list
14:11:24 <sgordon> which leaves the outstanding review with no negative feedback..
14:11:34 <sgordon> #info SBC review open with no -1/-2
14:11:36 <sgordon> #link https://review.openstack.org/#/c/176301/
14:11:55 <sgordon> it has +2 from myself and DaSchab
14:12:02 <sgordon> so at this point can actually be approved
14:12:13 <DaSchab> SBC is okay, but maybe needs some +1
14:12:25 <sgordon> yeah
14:12:41 <sgordon> the other part is somebody has to be ready to then pick it apart and try turn into RFEs/backlog specs
14:12:42 <aveiga> yes, I was hoping to get some internal feedback on that from my voice team before I +w it
14:12:53 <sgordon> yeah, makes sense
14:12:59 <sgordon> i would be happy to see some more comments on it
14:13:12 <cloudon> yup, comments welcome
14:13:23 <sgordon> #info wait for some further comments on the SBC use case to confirm it is on the right path
14:13:36 <sgordon> #topic Meeting schedule
14:13:55 <sgordon> so this has been an ongoing issue, but last week the *only* person there for the later meeting time slot was myself
14:14:08 <sgordon> so at this point im looking to consolidate on this time slot each week
14:14:30 <DaSchab> makes sense
14:14:34 <cloudon> +1
14:15:02 <sgordon> #action sgordon to mail list and update wiki listing early slot as the only meeting time going forward
14:16:20 <sgordon> one last thing that i had failed to put in the etherpad but just remembered...
14:16:36 <sgordon> #topic productwg - Capacity/Quota Management User Stories
14:16:53 <sgordon> this actually came up in the product working group but thought might be relevant to some people here
14:17:19 <sgordon> one of the user stories we have been asked to try and nail down is around capacity and quota management (there is a separate but related task around vm lifecycle management)
14:17:32 <sgordon> just wondering if anyone here would be interested in contributing to that discussion
14:18:16 <aveiga> that's pretty vague
14:18:43 <sgordon> it is indeed
14:18:51 <sgordon> hence the need to define it ;)
14:19:00 <sgordon> #link https://github.com/openstack/openstack-user-stories/blob/master/user-stories/draft/capacity_management.rst
14:19:35 <sgordon> tl;dr sounds a lot like reservations
14:19:49 <aveiga> ah
14:20:13 <aveiga> so they're really looking for guaranteed availability of a quota?
14:20:20 <sgordon> seems that way yeah
14:20:34 <sgordon> i mention it here because i know this was on the original ETSI NFV gap analysis
14:20:41 <sgordon> wondering if anyone has concrete use case info
14:20:48 <aveiga> that's going to be extremely tricky, especially considering that some VMs may have affinity/anti-affinity hints
14:20:51 <cloudon> seems broader than that.. for example the ref to supporting ephe#meral VMs
14:21:29 <sgordon> aveiga, yeah - for now we're just focused on the use case, i dont debate that it's non-trivial to solve
14:24:55 <sgordon> ok
14:25:03 <sgordon> let's call it there for now
14:25:18 <margaret__> In OPNFV we have a project which is trying to also address similar resource management requests.
14:25:21 <sgordon> i will keep reporting back to this group on the product wg stuff to see if it becomes clearer/more relevant for you
14:25:35 <sgordon> margaret__, this isn't NFV specific, it's part of the product working group
14:26:05 <margaret__> I know - but just to let you know we are thinking of addressing parts of it from an NFV perspective in OPNFV
14:26:23 <margaret__> We get into versions of NIC, dpdk, ovs...
14:26:52 <margaret__> cpu pinning...
14:27:08 <sgordon> that seems to be putting the horse ahead of the cart when there is no designed capability for reserving capacity period
14:27:12 <sgordon> even at the basic levels
14:27:55 * sgordon mixes up his metaphor nicely
14:27:56 <margaret__> well we can help shape the blueprint as we talk through the whole perspective..
14:28:07 <sgordon> yeah thats really where i am going
14:28:22 <sgordon> is that requirements project engaging with the openstack community (e.g. product wg) on this
14:28:28 <sgordon> or in a vacuum?
14:28:58 <margaret__> I'm not sure. I can ask our tsc on this - chris price
14:29:12 <margaret__> Is there going to be a Telco WG meeting in Tokyo?
14:29:27 <margaret__> I was suggesting to the OPNFV crowd that we should attend.
14:29:45 <sgordon> every time i hear "we are thinking of addressing parts of it from an NFV perspective in OPNFV" what I think is "we are making up our own way of doing things irrespective of consulting the relevant community":
14:30:09 <DaSchab> +1
14:30:22 <sgordon> the concern being that if e.g. the product wg comes up with requirements and circulates them in the absence of opnfv engagement then what opnfv requires wont actually be there
14:30:49 <sgordon> yes we have been given a 40 min slot
14:30:51 <margaret__> More of a set of telcom folks discussing what our real needs are - vs each company coming up with their view of needs and they are all over the place.
14:30:55 <sgordon> i believe 2pm on the tuesday
14:31:20 <sgordon> #link http://mitakadesignsummit.sched.org/event/b060647ccd40868b30ef2ab5cab76fda#.VgK3tbOf7lY
14:31:44 <margaret__> ok - there is a BOF slot that OPNFV took and I don't know the time - but it is Tuesday.
14:33:09 <sgordon> #action sgordon to email opnfv list highlighting that someone from the promise project probably needs to be engaged in the product wg discussion around capacity management
14:34:34 <margaret__> ok I just sent email to chris on overall the different OPNFV projects need to engage with the product WG on the different topics
14:34:51 <sgordon> yeahhh
14:35:04 <sgordon> i am only highlighting capacity management as that is the one i am most directly engaged with
14:35:12 <sgordon> there are a couple of others that are likely also of interest
14:35:31 <sgordon> #link https://wiki.openstack.org/wiki/ProductTeam
14:35:34 <margaret__> yes I know. which is why I sent it to chris as chair.
14:35:38 <sgordon> #link https://docs.google.com/spreadsheets/d/1d1ZKuZ6gsiG6CXXrfONBwAGGHA8SYINbYC9BSPBKllI/edit#gid=1956934401
14:37:00 <sgordon> margaret__, full list is in that google doc
14:37:19 <sgordon> there are drafts for some of them here:
14:37:24 <sgordon> #link https://github.com/openstack/openstack-user-stories/tree/master/user-stories/draft
14:38:08 <margaret__> ok thanks.
14:39:49 <sgordon> alright
14:39:53 <sgordon> thanks all for your time
14:39:56 <sgordon> #endmeeting