14:02:06 <sgordon> #startmeeting telcowg
14:02:07 <openstack> Meeting started Wed Jul  1 14:02:06 2015 UTC and is due to finish in 60 minutes.  The chair is sgordon. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:02:11 <openstack> The meeting name has been set to 'telcowg'
14:02:11 <sgordon> #chair mkoderer
14:02:12 <openstack> Current chairs: mkoderer sgordon
14:02:24 <mkoderer> hi folks
14:02:27 <sgordon> #link https://etherpad.openstack.org/p/nfv-meeting-agenda
14:02:30 <mkoderer> sorry I was late
14:02:46 <sgordon> np
14:02:48 <cloudon> hi
14:02:49 <aveiga_> hello
14:03:10 <sgordon> for the benefit of others - it's actually the canada day holiday at my end, so mkoderer has kindly agreed to run the meeting
14:03:29 <mkoderer> #topic roll call
14:03:34 <aveiga> o/
14:03:35 <mkoderer> so whos around?
14:03:38 <smazziotta> Hu
14:03:40 <smazziotta> Hi
14:03:42 <cloudon> hi
14:04:03 <mkoderer> ok cool
14:04:07 <mkoderer> #topic Reviews
14:04:24 <mkoderer> #link https://review.openstack.org/#/q/project:stackforge/telcowg-usecases+status:open,n,z
14:04:51 <mkoderer> are there any special reviews that we should discuss today?
14:05:12 <mkoderer> I guess the most important one is:
14:05:15 <mkoderer> #link https://review.openstack.org/#/c/178347/
14:05:27 <mkoderer> e2e workfolow for this group
14:05:51 <mkoderer> can we get some more reviews on that document
14:07:13 <mkoderer> any other review that somebody wants to bring up?
14:07:59 <cloudon> if yuri's around, would be good to know if I've addressed his feedback on https://review.openstack.org/#/c/179142/
14:09:11 <mkoderer> cloudon: he's not online.. I could give him a call that he should ping you later
14:09:40 <cloudon> ta.  shouldn't be anythign controversial.  would be good to get it to merge state.
14:10:13 <mkoderer> cloudon: yep I will have a look to it too
14:10:23 <cloudon> thx
14:10:42 <mkoderer> I think we need to get some more use-cases to the merged state
14:10:57 <mkoderer> #action mkoderer review on https://review.openstack.org/#/c/179142/
14:11:29 <mkoderer> ok cool
14:11:34 <cloudon> ditto on https://review.openstack.org/#/c/176301/ - think I've addressed all outstanding comments
14:12:10 <mkoderer> cloudon: ok cool
14:12:49 <mkoderer> I will also ask Ralf to push a new version of https://review.openstack.org/#/c/169201/
14:14:32 <mkoderer> #topic Operators mid-cycle
14:14:42 <mkoderer> #link http://lists.openstack.org/pipermail/openstack-operators/2015-June/007491.html
14:15:56 <mkoderer> ok so we have a ops mid cycle happening
14:16:11 <mkoderer> we need to have some idea's about topics that we want to contribute
14:17:01 <mkoderer> so make sure that you put your ideas to the etherpad
14:17:21 <mkoderer> #topic Open discussion
14:18:02 <mkoderer> it's quite silent today :)
14:18:19 <aveiga> mkoderer: it's a big holiday week this side of the pond ;)
14:18:38 <mkoderer> aveiga: ok I see :)
14:18:46 <smazziotta> I was still lokking at the previous topic.. is the ops mid cycle date and location decided ?
14:19:11 <aveiga> smazziotta: no, as they're still working it out
14:19:23 <aveiga> I think Tom mentioned logistics are still under consideration
14:20:05 <smazziotta> ok thanks
14:21:26 <mkoderer> ok folks, unless we have other topics I would close this meeting
14:21:33 <smazziotta> In the open topic discussion. It is a long time I have not attended this team. have we discussed if NFV Orchestration is a valid use case ? or how do we want ti handle it ?
14:22:02 <mkoderer> smazziotta: NFV orchestartion is a valid use case
14:22:41 <mkoderer> smazziotta: but the current state is still an etherpad and not use-case review
14:22:55 <mkoderer> #link https://etherpad.openstack.org/p/telco_orchestration
14:24:06 <mkoderer> smazziotta: but anyway I think we need to build a group of intressted parties here
14:24:49 <adityav> I have a question about the VNF bring up use case
14:25:06 <adityav> Are there any thoughts about how we could handle images which are not cloud init enabled?
14:25:42 <mkoderer> adityav: sgollub is not around
14:26:03 <adityav> ahh - okay. apologies.
14:26:06 <mkoderer> adityav: but that's a valid questions
14:26:07 <smazziotta> mkoderer: regarding NFV orchestration...you know that we are interested. my main interest is to standardise the VNF descriptor and the onboarding on VNF. we need to define open API so that we can have opensource and closedsource implementation of an NFVO
14:26:21 <mkoderer> adityav: I remeber that he has some ideas about it
14:26:28 <adityav> If we have virtual routers as VNFs, then most likely these images will not be cloud init enabled.
14:27:09 <mkoderer> smazziotta: yep, and I am trying to form a team to work excatly on this topic :)
14:27:30 <mkoderer> smazziotta: I am currently have a look to Murano to see what we could use there
14:27:35 <smazziotta> please bring me to the party :-)
14:27:52 <aveiga> adityav: there are ways around this, but are dependant on the VNF image
14:28:05 <jaypipes> gah, sorry guys, late again...
14:28:13 <aveiga> in general, the stance has been if it uses cloud-init it's supported.  If it doesn't, it should work but you're on your own
14:28:22 <cloudon> smazziotta: +1
14:28:31 <mkoderer> smazziotta: sure, currently I am trying to get interal resources :)
14:29:02 <mkoderer> but sure, everybody is invited to join
14:29:44 <mkoderer> aveiga: not sure how it works with netconf/yang
14:30:02 <aveiga> mkoderer: pass data at boot time in user scripts
14:30:16 <aveiga> or bake it into the image, then have something in the image request config
14:30:27 <aveiga> there are ways :)
14:30:32 <adityav> aviega: Although the networking aspect (DHCP and such) would be very valid, non- cloud init use cases are a reality and there might be vendors who have VNFs which are not cloud init compatible at all. I was hoping we could have another mechanism of configuration port bring up which we can document
14:31:07 <aveiga> adityav: they'd have to use dhcp or metadata or config-drive.  That's all OpenStack currently supports
14:31:08 <adityav> In our deployments, we used netconf over cli to good effect. :)
14:31:13 <aveiga> if you have an alternative, propose it
14:32:35 <mkoderer> adityav: netconf over cli.. how does it work? manually?
14:33:37 <adityav> mkoderer: cli over netconf. typo there. We have an ssh connection established and then use xmls in which cli commands are sent in for configuration
14:34:18 <cloudon> but that requires SSH up and running - so network, key exchange etc. - how does that happen?
14:34:26 <adityav> but yes, manually
14:35:07 <adityav> cloudon: we built pre built images with ssh enabled and assigned floating ips.
14:35:49 <mkoderer> adityav: uh... this is something our security team won't allow at all ;)
14:36:40 <mkoderer> adityav: you need at least a mechanism to bake a ssh key into your image
14:37:18 <adityav> mkoderer: agreed
14:38:54 <mkoderer> adityav: but anyway put your comment to the review if you like
14:39:08 <adityav> mkoderer: will do
14:39:16 <mkoderer> ok nice :)
14:40:05 <mkoderer> smazziotta: regarding NFV orchestration -  I hope I can focus on that topic during the next weeks
14:40:46 <mkoderer> all right
14:41:04 <mkoderer> anything else?
14:42:05 <smazziotta> mkoderer: no from my side
14:42:23 <mkoderer> thanks to all :)
14:42:30 <adityav> thank you :)
14:42:37 <mkoderer> happy holiday sgordon and all others :)
14:42:42 <mkoderer> #endmeeting