14:00:44 <sgordon> #startmeeting telcowg
14:00:44 <openstack> Meeting started Wed Jun 17 14:00:44 2015 UTC and is due to finish in 60 minutes.  The chair is sgordon. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:45 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:48 <openstack> The meeting name has been set to 'telcowg'
14:00:50 <jaypipes> o/ morning
14:00:50 <sgordon> #link https://etherpad.openstack.org/p/nfv-meeting-agenda
14:00:55 <sgordon> #topic roll call
14:00:57 <sgordon> \o/
14:01:04 <adrian-hoban> Hello
14:01:05 <cloudon> hi
14:01:06 <jaypipes> \_o_/
14:01:15 <pcarver> hi
14:01:22 <bryan_att> Hi
14:01:42 <sgordon> #topic open reviews
14:01:57 <sgordon> soo the only thing that i think has been updated in the last week is the workflow proposal
14:02:03 <sgordon> #link https://review.openstack.org/178347
14:02:13 <sgordon> #info workflow proposal updated to incorporate feedback
14:02:25 <sgordon> i updated it this AM to try and incorporate all the feedback on it
14:02:36 <jaypipes> cool, thank you steve
14:02:40 <sgordon> #action steveg to fix markup issues
14:02:56 <sgordon> looks like i still have some RST gremlins to correct, i will look at that straight after the meeting
14:03:05 <jaypipes> sure, np
14:03:30 <sgordon> #info session border controller updates awaiting feedback
14:03:32 <sgordon> #link https://review.openstack.org/#/c/176301/
14:03:47 <sgordon> cloudon had updated this one but looks like no positive/negative feedback as yet
14:03:58 <cloudon> all feedback welcome
14:04:05 <cloudon> though positive more so than negative
14:04:20 <sgordon> #info vnf bring-up use case awaiting feedback
14:04:22 <sgordon> #link https://review.openstack.org/#/c/190080/
14:04:34 <sgordon> and similarly with the above review created out of the working group session we had at summit
14:05:20 <sgordon> does anyone know ralf trezeciak's irc nick?
14:05:42 <jaypipes> no, sorry I don't
14:05:46 <sgordon> i ask because....
14:06:02 <sgordon> #info service chaining use case likely needs to be iterated upon in response to feedback
14:06:06 <sgordon> #link https://review.openstack.org/#/c/169201/
14:06:22 <sgordon> only 60 odd comments to keep him busy ;)
14:07:44 <jaypipes> heh, yeah
14:07:46 <sgordon> #info virtual IMS core use case has some inline feedback to action
14:07:49 <sgordon> #link https://review.openstack.org/#/c/179142/
14:07:58 <sgordon> cloudon, ^ happy if i give that AI to you
14:08:07 <cloudon> yup, will do
14:08:19 <sgordon> #action cloudon to integrate virtual IMS core feedback
14:09:01 <sgordon> matrohon, are you around?
14:10:07 <sgordon> #info BGP based IP VPNs attachment use case
14:10:11 <sgordon> #link https://review.openstack.org/#/c/171680/2
14:10:15 <sgordon> #undo
14:10:16 <openstack> Removing item from minutes: <ircmeeting.items.Link object at 0x8cdac50>
14:10:16 <sgordon> #undo
14:10:17 <openstack> Removing item from minutes: <ircmeeting.items.Info object at 0x9b75210>
14:10:25 <sgordon> #info BGP based IP VPNs attachment use case has inline feedback for action
14:10:27 <sgordon> #link https://review.openstack.org/#/c/171680/2
14:10:45 <sgordon> #action matrohon integrate feedback for BGP based IP VPNs attachment use case
14:10:52 <sgordon> something i wanted to raise, as i go through these
14:11:07 <sgordon> as we probably need to get away from using the abbreviations in the naming of these
14:11:35 <sgordon> assuming that at least some reviewers arent going to actually know what is meant until we explain it in the spec text
14:11:42 <sgordon> s/spec/use cases/
14:12:41 <sgordon> #info sgordon raises concern about use of abbreviations in use case proposal titles
14:14:02 * sgordon takes silence as overwhelming agreement
14:14:02 <sgordon> ;)
14:14:15 <sgordon> #topic open discussion
14:15:02 <sgordon> alright, does anyone have anything else they would like to raise this week
14:15:16 <sgordon> i really want to get the workflow thing nailed down asap so we can put one of these through it
14:17:03 <sgordon> well then ;)
14:17:10 <bryan_att> sgordon, this looks really useful to help people get engaged. i'll take a look and comment.
14:17:25 <sgordon> bryan_att, thanks muchly
14:17:47 * sgordon will leave the meeting open another minute or two in case anyone else pops their head up
14:19:15 <adrian-hoban> sgordon: Just looked through the workflow again
14:19:42 <matrohon> hi
14:20:03 <adrian-hoban> Should it include some of the process differences between projects? E.g. Neutron RFE?
14:20:13 <sgordon> i dont believe so
14:20:35 <sgordon> the intent is simply to maintain a bug tracking the relevant artifacts in the other projects
14:20:47 <sgordon> be they bug, blueprint, spec, rfe, napkin, etc.
14:21:21 <sgordon> we just wanted a way to link everything being done to the relevant gap and vice versa
14:22:02 <adrian-hoban> ok
14:22:59 <bryan_att> sgordon: one question. the workflow says to use "git commit" should that be "git commit --signoff" (do you require this flag)?
14:23:08 <sgordon> we do not
14:24:04 <bryan_att> do you require anything special in the commit message?
14:24:21 <sgordon> we do require a Change-ID
14:25:02 <bryan_att> but no issue reference, e.g. from Jira?
14:25:23 <sgordon> not in these use case submissions
14:25:33 <sgordon> other projects like e.g. nova may require it
14:25:48 <sgordon> though typically it's not an absolute requirement, but highly recommended
14:26:10 <bryan_att> are the use cases rendered somewhere, e.g. to review them in html output form?
14:26:14 <sgordon> i guess we could make it an expectation that the person proposing the use case also raise the initial tracker bug
14:26:17 <sgordon> not currently
14:26:23 <sgordon> mkoderer was looking into doing that with infra
14:26:39 <sgordon> similar to how specs.openstack.org is rendered
14:27:15 <bryan_att> i'm working on a webapp to allow editors to review their changes for correct syntax and presentation etc, this is for OPNFV but may be useful to others
14:27:58 <bryan_att> i will share when its ready
14:29:00 <sgordon> kk
14:30:08 <sgordon> alrighty
14:30:12 <sgordon> let's wrap it up then
14:30:15 <sgordon> thanks all for your time
14:30:17 <sgordon> #endmeeting