19:01:52 <sgordon> #startmeeting telcowg
19:01:52 <openstack> Meeting started Wed Jun 10 19:01:52 2015 UTC and is due to finish in 60 minutes.  The chair is sgordon. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:53 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:01:56 <openstack> The meeting name has been set to 'telcowg'
19:02:01 <sgordon> #link https://etherpad.openstack.org/p/nfv-meeting-agenda
19:02:06 <sgordon> #topic roll call
19:02:10 <sgordon> hi all
19:02:23 <cloudon> hi
19:02:43 <sgordon> i am on the end of a fairly bad satellite internet connection this week so be warned that i am likely to be a little laggy and/or may drop (fingers crossed)
19:03:14 <sgordon> #topic open reviews
19:03:25 <sgordon> #link https://review.openstack.org/#/q/project:stackforge/telcowg-usecases+status:open,n,z
19:03:28 <cloudon> i am on the end of a broadband fibre but still be warned i am likely to be laggy and/or may drop...
19:03:42 <sgordon> haha
19:04:23 <sgordon> so there have been updates on most of the open items in the last day or so
19:04:30 <sgordon> #link https://review.openstack.org/#/c/179142/2/usecases/Virtual_IMS_Core.rst
19:04:43 <sgordon> #info new comments from yuriy on vIMS use case
19:05:04 <sgordon> #link https://review.openstack.org/#/c/169201/6/usecases/service_chaining.rst
19:05:18 <sgordon> #info 60 comments on service chaining use case
19:05:34 <sgordon> not sure if ralf is here
19:06:06 <sgordon> but need some iteration to incorporate that feedback
19:06:55 <sgordon> #action ralf to update service chaining use case to incorporate feedback
19:07:15 <sgordon> #link https://review.openstack.org/#/c/190080/1/usecases/vnf_bringup.rst
19:07:28 <sgordon> #info dan golub proposed vnf bring up use case
19:07:47 <sgordon> this is a new one which iirc is recording the output of one of the breakouts in the summit working session
19:09:30 <sgordon> #action all review vnf bringup proposal
19:10:13 <sgordon> #info cloudon rev'd session border controller use case
19:10:15 <sgordon> #link https://review.openstack.org/#/c/176301/3
19:10:25 <sgordon> #all review updated session border controller use case
19:10:28 <sgordon> ok
19:10:40 <sgordon> so that is the open use case reviews, which brings me to workflow
19:10:52 <sgordon> #topic workflow proposal
19:10:54 <sgordon> #link https://review.openstack.org/#/c/178347/
19:11:37 <sgordon> jay and kyle added some feedback on this during the week that i need to integrate
19:11:43 <sgordon> but generally seems like we're on the right track
19:12:20 <sgordon> and cloudon's feedback needs to be pulled in there as well :)
19:12:45 <sgordon> i will likely get to that by start of next week so should be able to discuss further during the better attended meeting slot
19:13:00 * sgordon takes a breath
19:18:31 <sgordon> cloudon, did you have anything you wanted to raise today
19:18:43 <sgordon> since you seem to be my only other participant in this time slot :)
19:19:02 <cloudon> interested to get your feedback from Vancouver on OPNFV
19:19:35 <cloudon> believe you met my colleague Colin Dancer - we're trying to contribute to multi-site in way that is OpenStack-friendly
19:19:48 <cloudon> e.g. contributing use cases in the format we're using here
19:19:57 <cloudon> any particular thoughts/steer?
19:21:35 <sgordon> we're still doing the dance working out exactly how we work together
19:22:12 <sgordon> but certainly interacting with opnfv projects directly to help steer is a good way to do this
19:22:35 <sgordon> and i did also during the discussion i facilitated during opnfv day highlight the template
19:22:45 <sgordon> (have previously brought this up on the opnfv m/l as well)
19:23:12 <sgordon> as this seems like the convergence point where if we're both funneling things in in the same format things will work out
19:23:23 <cloudon> did you get the sense OPNFV folk were engaging with that?
19:23:47 <cloudon> we're certainly seeing... mixed awareness
19:24:50 <sgordon> it's fair to say there is a wide spectrum of opinions on how that should / shouldnt work ;)
19:25:43 <cloudon> indeed
19:25:59 <cloudon> well, we'll try and do our bit and hopefully encourage best practice
19:26:16 <sgordon> i would say that there were a decent number of people in the room who werent aware of the telcowg
19:26:42 <sgordon> those that spoke up, once i'd done the elevator pitch, were *eventually* positive
19:26:57 <sgordon> but there were a *lot* of comments/criticisms before we got to that point
19:27:35 <cloudon> any sense of productive alternatives being pitched, or just an expectation OPNFV could (choose words carefully) upstream what they wanted?
19:28:10 <sgordon> the latter is still the expectation as i understand it
19:28:41 <cloudon> hmm.  reality awaits.
19:28:52 <sgordon> the concern i and a few other telcowg participants raised at the opnfv day session was that at the moment it's not just use case discussions happening in opnfv
19:29:15 <sgordon> but that by the time it comes to openstack there is an anointed solution
19:29:17 <sgordon> so to speak
19:30:12 <cloudon> Yup - lot of code being written without necessarily much awareness of what it takes to get stuff upstreamed
19:31:06 <sgordon> yeah, so we discussed that and highlighted the concern that this might pose difficulties in getting the code eventually merged
19:31:07 <cloudon> in the end, projects will learn the hard way I guess
19:31:16 <sgordon> as there is a lot of re-explaining to do
19:31:34 <sgordon> probably, all we can (and must) do from this end is try and proactively explain the concern
19:31:53 <sgordon> and highlight where there is the most danger ;)
19:32:18 <cloudon> any views that onus should be on OpenStack community to reach out other than other way round (*not* endorsing that personally you understand...)
19:33:54 <sgordon> i think ideally it's a bit of both
19:34:46 <sgordon> it also varies by project
19:34:53 <sgordon> some are intrinsically openstack specific
19:35:12 <sgordon> and (i would argue most but hey)
19:35:52 <sgordon> so the question is how much of that discussion really belongs outside the openstack community at all
19:36:15 <sgordon> separate ml/, meetings, etc. post a communication challenge
19:36:45 <sgordon> (i try to keep up with the opnfv tech list, i know a few other stackers who do too, but it's tough to get to all of the meetings)
19:37:01 <cloudon> full time job...
19:37:25 <sgordon> indeed
19:37:37 <sgordon> alright, i think i will give us 20 minutes back here ;)
19:37:55 <cloudon> cheers
19:39:58 <sgordon> #endmeeting