14:00:10 <mkoderer> #startmeeting telcowg
14:00:11 <openstack> Meeting started Wed Jun  3 14:00:10 2015 UTC and is due to finish in 60 minutes.  The chair is mkoderer. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:14 <openstack> The meeting name has been set to 'telcowg'
14:00:21 <mkoderer> #link https://etherpad.openstack.org/p/nfv-meeting-agenda
14:00:27 <mkoderer> #topic roll call
14:00:31 <aveiga_> o/
14:00:33 <mkoderer> hi folks :)
14:00:43 <sc68cal> o/
14:01:23 <mkoderer> ok seems to be a very small group today
14:02:07 <mkoderer> sgordon isn't available today
14:02:12 <ian_ott> hi
14:02:18 <cloudon> hi
14:02:37 <mkoderer> #topic Summit Re-cap
14:02:46 <mkoderer> #link https://etherpad.openstack.org/p/YVR-ops-telco
14:03:14 <mkoderer> we need to assure that the topics we discssed are somehow addressed
14:03:32 <aveiga_> +1, can't let good ideas rot on an etherpad
14:04:11 <jaypipes> morning all...
14:04:25 <mkoderer> jaypipes: hi :)
14:04:58 <mkoderer> so do we have anything special regarding "review process" to discuss?
14:05:23 <aveiga_> I know the breakouts had a lot of talk around specific uses
14:05:34 <mkoderer> aveiga_: yep correct
14:05:48 <aveiga_> maybe we should get some action items around picking each topic and either matching it to (and expanding) a usecase or writing a new one
14:05:53 <ian_ott> yes, the breakout sessions were good, not sure the outcomes made it to the etherpad or how to keep those discussions going
14:06:14 <ian_ott> aveiga_: so the breakouts become use cases
14:06:24 <aveiga_> ian_ott: they sort of are already
14:06:34 <ian_ott> true enough
14:06:40 <aveiga_> they're topically broken into different network "tools"
14:06:58 <ian_ott> but, then we would have a review of the use case to make it crisp
14:07:08 <aveiga_> yes, using gerrit as usual
14:07:20 <ian_ott> makes sense, thanks
14:07:36 <aveiga_> then it's a) tracked b) broekn into separate functions and c) can get committed and then bugs/specs come out of it
14:07:37 <mkoderer> the etherpad is a bit messy IMO
14:08:14 <mkoderer> I guess the first topic was about orchestration?
14:08:51 <aveiga_> yup
14:09:23 <mkoderer> there was a good comment on the etherpad
14:09:40 <mkoderer> "... but not only is there job to explain req to OpenStack, also task to bring carriers closer together in approach"
14:10:05 <mkoderer> I think we need to build a group of intressted Telcos and work on a detail design for it
14:10:37 <mkoderer> I already talked to the Murano team during a design summit session
14:10:55 <mkoderer> so there are offically ETSI NFV brainwashed
14:11:30 <jaypipes> heh :)
14:12:09 <mkoderer> ok this was the breakout session I was active
14:12:57 <mkoderer> any other session that was intressting
14:13:09 <mkoderer> aveiga_: which one did you join?
14:13:18 <aveiga_> mkoderer: both VLAN and MPLS
14:13:29 <aveiga_> I tried to steer them into defining the issue in terms of the usecase, as well
14:13:40 <jaypipes> aveiga_: how did that work out? :)
14:13:42 <aveiga_> most of our bullet points there are either requirements or perceived flaws
14:13:51 <aveiga_> pretty well, actually
14:14:37 <mkoderer> aveiga_: ok cool
14:15:38 <mkoderer> aveiga_: ok are you planning to write use-cases about those topics?
14:16:09 <aveiga_> I think so
14:16:13 <mkoderer> +1
14:16:18 <aveiga_> so give me the AI to write up those two
14:17:05 <mkoderer> #action aveiga_ use case proposal for "VLAN" and "MPLS"
14:17:16 <aveiga_> thanks :)
14:17:52 <mkoderer> ok, any other topics that we were we need AI's :)
14:18:21 <mkoderer> I see the topic "Fault management"
14:18:34 <mkoderer> anyone around that was part of this group?
14:18:58 <mkoderer> at least someone is writing stuff to the etherpad currently :)
14:19:54 <mkoderer> ok let's move to the next point
14:20:03 <adrian-hoban> I'm looking at the etherpad, but not adding stuff right now
14:20:21 <mkoderer> adrian-hoban: ok, I think it's jaypipes :)
14:20:41 <adrian-hoban> Actually, re the fault item
14:21:13 <adrian-hoban> There are some proposals coming through from OPNFV on this.
14:21:22 <adrian-hoban> They were reviewed at teh summit
14:21:54 <adrian-hoban> Doctor was the project code name
14:22:00 <mkoderer> adrian-hoban: yeah I remember some discussions
14:22:00 <jaypipes> adrian-hoban, mkoderer: yes, that's me :)
14:22:12 <adrian-hoban> IIRC it did not have a use case definition
14:22:57 <mkoderer> ok we might link the OPNFV effort to it then
14:23:12 <adrian-hoban> Should it have a use case, or do you guys think it has it already progress past the need for one?
14:23:43 <jaypipes> are you guys familiar with the Tacker project?
14:23:52 <aveiga_> adrian-hoban: this WG isn't a requirement to get things into OpenStack. That said, if we had a case that tracked theirs, it might prevent duplication of effort
14:23:59 <adrian-hoban> Jaypipes: Yes
14:24:04 <mkoderer> jaypipes: yep
14:24:07 <jaypipes> kk
14:24:16 <jaypipes> any thoughts on it?
14:24:25 <jaypipes> I haven't had a chance to look much into it, unfortunately.
14:24:58 <aveiga_> so this keeps coming up whenever we have discussions on service chaining and vnf management
14:25:10 <aveiga_> I'll reiterate, but I don't know if it will help
14:25:21 <aveiga_> it's great to have a VNF manager that is OpenStack aware
14:25:25 <cloudon> Goal (AIUI) of having an OpenStack component capable of acting as a VNFM is good one, IMO
14:25:46 <cloudon> Heat lacking in that regard (e.g. healing)
14:25:48 <aveiga_> the bit I'm worried about is when the the VNF is chained to an external network function (like MPLS tags pushed/popped by a hardware router)
14:26:01 <aveiga_> and when there's devices in the chain that are outside of OpenStack's control
14:26:28 <adrian-hoban> jaypipes: Here's the Intel position on Tacker: "Intel started the Tacker effort to investigate the deployment of service VMs with OpenStack with a blueprint from Intel Labs at the Hong Kong summit. We brought together interested parties and delivered a proof-of-concept.
14:26:31 <adrian-hoban> With this enabling work completed, Intel is now focusing on contributing to another range of projects across OpenStack. Intel has a long-term commitment to the OpenStack project and is actively collaborating with the community on extensions for Enterprise, Cloud and Telco use cases.”
14:26:54 <mkoderer> adrian-hoban: you are active in tacker, right?
14:28:08 <mkoderer> I will try to attend to their meetings
14:28:20 <adrian-hoban> mkoderer: Intel was active in Tacker. It started as a Service VM exploration. From our perspective, we completed that investigation
14:28:45 <mkoderer> adrian-hoban: ok I see
14:29:39 <mkoderer> #topic Critical Reviews
14:29:46 <mkoderer> #link https://review.openstack.org/#/q/project:stackforge/telcowg-usecases+status:open,n,z
14:30:09 <mkoderer> do we have a review/use-case were we want to have a discussion today?
14:30:25 <jaypipes> mkoderer: of those 5, which is the most important to review?
14:30:59 <mkoderer> jaypipes: I know that SFC is quite instressting for many ppl
14:31:03 <mkoderer> #link https://review.openstack.org/#/c/169201/
14:31:17 <jaypipes> mkoderer: k, I will try to review that one in the next couple days.
14:31:23 <mkoderer> but we have similar efforts in OpNFV though
14:31:51 <mkoderer> very important is also: https://review.openstack.org/#/c/178347/
14:31:53 <mkoderer> but it
14:32:01 <mkoderer> but it's still a WiP
14:32:12 <aveiga_> I actually think that WIP is the more important one for feedback
14:32:28 <aveiga_> it's going to set the way we go from accepted use case to getting things done
14:32:34 <mkoderer> aveiga_: yep.. +1
14:32:53 <jaypipes> k, I'll get a review on that one this week, too.
14:33:21 <mkoderer> it's currently quite open what we do with merged use-cases
14:33:41 <aveiga_> yup, and the more input the better on that one
14:33:51 <mkoderer> so having a process is key
14:34:35 <mkoderer> #action jaypipes review on https://review.openstack.org/#/c/178347/ and https://review.openstack.org/#/c/169201/
14:34:38 <mkoderer> :)
14:34:47 <jaypipes> :)
14:35:30 <mkoderer> ok any other review we want to discuss today?
14:36:13 <jaypipes> mkoderer: just a quick note to request feedback on my question on that etherpad if anyone has some time..
14:36:58 <mkoderer> jaypipes: ok so your comments on "Fault management"?
14:37:01 <aveiga_> jaypipes: you mean the multisite/availability one?
14:37:10 <jaypipes> aveiga_: yes please.
14:37:18 <jaypipes> mkoderer: yes please :)
14:37:37 <mkoderer> ok :)
14:37:56 <mkoderer> #topic Open discussion
14:38:04 <jaypipes> Also, not sure if aveiga_ said he would earlier, but can we get a summary email to the ML that discusses the results/outcome of the VLAN and the MPLS breakouts?
14:38:22 <aveiga_> hrm, I think I can do that
14:38:29 <jaypipes> thx aveiga_!
14:38:30 <aveiga_> mkoderer: action me, please :)
14:38:49 <mkoderer> jaypipes: but if aveiga_ writes a use-case everybody is invited to review
14:38:58 <jaypipes> of course.
14:39:22 <aveiga_> it won't hurt to have both
14:39:30 <aveiga_> not all the ML readers are watching our repo for use cases
14:39:49 <mkoderer> #action aveiga_ sum up outcome of VLAN and MPLS breakout session for the ML
14:41:15 <mkoderer> all right, any thing else?
14:43:29 <mkoderer> seems we are done for today
14:43:34 <mkoderer> thanks all!
14:43:43 <aveiga_> thanks for running the meeting, mkoderer!
14:43:43 <mkoderer> #endmeeting