14:00:13 <sgordon> #startmeeting telcowg
14:00:14 <openstack> Meeting started Wed Mar 25 14:00:13 2015 UTC and is due to finish in 60 minutes.  The chair is sgordon. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:15 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:17 <openstack> The meeting name has been set to 'telcowg'
14:00:19 <sgordon> #link https://etherpad.openstack.org/p/nfv-meeting-agenda
14:00:25 <sgordon> #topic roll call
14:00:29 <sgordon> hi all
14:00:37 <sgordon> who is around for the telco working group meeting?
14:01:10 <cloudon> hi
14:01:25 <vks> hi
14:01:40 <DaSchab> hi
14:01:43 <gmatefi> hi
14:02:06 <ian_ott> hi
14:02:06 <sgordon> #topic AIs from last week
14:02:23 <mkoderer> hi
14:02:26 <sgordon> i dont see dcw around so will carry their action item over
14:02:32 <sgordon> #action dcw to draft SIP load-balancing use-case for wiki/etherpad initially, will need assistance with git submission
14:02:43 <sgordon> #info sgordon was to email list asking to divide up other existing use cases for git submission
14:02:46 <sgordon> so that didnt happen
14:03:04 <sgordon> the three i believe we need to convert from wiki/etherpad to RST are:
14:03:05 <sgordon> VPN Instantiation
14:03:05 <sgordon> Session Border Controller
14:03:05 <sgordon> Access to physical network resources
14:03:23 <sgordon> i can take access to physical network resources to convert
14:03:30 <sgordon> any other volunteers?
14:03:41 <mkoderer> we need an wiki2rst tool :)
14:03:42 <cloudon> I can do SBC, but maybe not for next week
14:03:45 <DaSchab> i can help to transfer a usecase from wiki to gerrit
14:03:50 <sgordon> #action sgordon to convert "access to physical network resources" to RST
14:03:56 <matrohon> I'm volunteering for the VPN Instantiation :)
14:04:03 <vks> i can take one
14:04:10 <sgordon> #action cloudon to convert SBC to RST
14:04:14 <vks> but someone need to tell me process:)
14:04:20 <sgordon> #action matrohon to convert VPN Instantiation
14:04:25 <sgordon> that covers the three i had
14:04:33 <sgordon> i suspect we have a couple of others linked in etherpads
14:04:37 <sgordon> so let me get back to you on that vks
14:04:39 <sgordon> :)
14:04:46 <mkoderer> I already ported the session border controller I guess
14:04:50 <vks> ok after meeting of t fine with u
14:05:03 <mkoderer> just needs to be refresehs with the new structrue
14:05:04 <sgordon> #link https://wiki.openstack.org/wiki/TelcoWorkingGroup/UseCases#Work_In_Progress
14:05:08 <sgordon> mkoderer, +1
14:05:11 <sgordon> thanks for that
14:05:16 <DaSchab> "access to physical network resources" could also be done by the author. i already contacted him
14:05:23 <sgordon> DaSchab, ah cool
14:05:26 <sgordon> :)
14:05:47 <sgordon> #info Author of access to physical network resources use case can also be converted by the author
14:06:11 <DaSchab> ...if not i will take care of it
14:06:16 <sgordon> so on that WIP page there were a couple of others in various states
14:06:26 <sgordon> Service Chaining, Orchestration, all the fun ones
14:06:27 <vks> sgordon, i remember a telco orchestration use use case
14:06:35 <sgordon> ;)
14:06:42 <mkoderer> vks: yep this is not yet done :)
14:06:43 <sgordon> service chaining is an important one
14:06:54 <vks> ok will take
14:07:04 <sgordon> as there was already some interest on the dev list on revisiting this in the neutron design summit
14:07:09 <mkoderer> sgordon: we will do service chaining hopefully today :)
14:07:09 <sgordon> as we head into Liberty
14:07:20 <sgordon> having concrete use cases will help guide that discussion
14:07:40 <sgordon> #action mkoderer and/or vks to convert service chaining use case to RST
14:07:58 <sgordon> perhaps mkoderer can do the initial conversion and then vks can help with comments/updates?
14:08:07 <sgordon> since i know mkoderer is familiar with the process already
14:08:07 <ybabenko> hi
14:08:12 <vks> sgordon, fine
14:08:21 <sgordon> ok
14:08:24 <mkoderer> ybabenko: will do it .. I am just the teacher :)
14:08:26 <sgordon> thanks all for the help with that
14:08:31 <sgordon> many hands make light work and all that
14:08:40 <mkoderer> we will cordinate later :)
14:08:48 <sgordon> #topic use case reviews
14:08:50 <sgordon> https://review.openstack.org/#/q/status:open+project:stackforge/telcowg-usecases,n,z
14:08:50 <ybabenko> hi, we plan to place the draft today or tomorrow on gerrit
14:09:08 <sgordon> still some updates on the vIMS and security segregation reviews
14:09:10 <sgordon> #link https://review.openstack.org/#/q/status:open+project:stackforge/telcowg-usecases,n,z
14:09:13 <sgordon> reviews welcome!
14:09:36 <mkoderer> we need more reviewers!
14:09:43 <sgordon> for anyone not sure how to review i put some notes together here:
14:09:45 <sgordon> #link https://wiki.openstack.org/wiki/TelcoWorkingGroup/UseCases#Reviewing_Use_Cases
14:09:53 <sgordon> need some guinea pigs to see what i missed :)
14:09:55 <adrian-hoban> I'll get my reviews in today
14:10:12 <sgordon> excellent
14:10:19 <mkoderer> if you have any questions to the process just contact me or sgordon
14:10:24 <sgordon> +1
14:10:28 <adrian-hoban> Sure thing
14:10:39 <sgordon> between us and aveiga there is someone to ask in #openstack-nfv most of the time
14:11:06 <sgordon> #info contact aveiga, sgordon, or mkoderer in #openstack-nfv if you are having issues submitting/reviewing use cases
14:11:18 <sgordon> #topic use case template
14:11:25 <sgordon> there were some minor updates to the template this week
14:11:30 <sgordon> mainly some syntax examples
14:11:48 <sgordon> i also have to add a user stories/personas section per the discussion at the mid-cycle
14:12:00 <sgordon> #action sgordon to add user stories/personas section to the template
14:12:21 <mkoderer> sgordon: what is it about?
14:12:41 <sgordon> so the suggestion was we need to actually define the user
14:12:55 <sgordon> or more accurately probably the users or actors that are relevant
14:13:00 <sgordon> as there may be multiple
14:13:30 <mkoderer> sgordon: ok do we have to change the existing use cases for that?
14:14:14 <sgordon> mkoderer, my personal opinion is it's not mandatory
14:14:15 <margaret__> mkoderer: let me know if you want to understand the VPN use case since i wrote it :-)
14:14:22 <mkoderer> IMHO this can be optional? or we have a "general" definition for personas
14:14:24 <sgordon> but would be nice
14:14:46 <sgordon> that is i dont think we can retrospectively say "your use case sucks because it doesnt include this thing we hadn't thought of"
14:14:47 <sgordon> :)
14:14:58 <ybabenko> margaret__: can you provide us your comment on SFC use-case?
14:15:07 <matrohon> margaret__ : I took the action to translate the VPN use case in RST
14:15:11 <margaret__> Sure I need to look at it
14:15:23 <ybabenko> margaret__: that would be helpful :)
14:15:30 <matrohon> margaret__ : you surely can help me :)
14:15:38 <margaret__> matrohon: let me know if you want to have a call to talk about the VPN use case
14:16:04 <margaret__> my email is mchiosi@att.com
14:16:23 <matrohon> margaret__ : thanks, I'll email you
14:17:40 <sgordon> fwiw at margaret__'s prompting i had also put the template forward in the opnfv group
14:17:48 <sgordon> to try and ensure we're speaking the same language
14:18:09 <mkoderer> the same template would ease up sharing alot
14:18:32 <margaret__> I think folks are fine with using the same template
14:18:34 <sgordon> indeed
14:18:47 <sgordon> i think everyone is pretty onboard with at least trying to use the same format
14:18:59 <vks> sgordon, +1
14:18:59 <matrohon> concerning VPN use cases, what do you think about trying to sum up work in progress in openstack, in the RST?
14:19:06 <margaret__> We are all tired of re-inventing the wheel :-)
14:19:07 <sgordon> thread here for those interested:
14:19:08 <sgordon> #link http://lists.opnfv.org/pipermail/opnfv-tech-discuss/2015-March/thread.html#1525
14:19:34 <sgordon> matrohon, i think we have a section for that
14:19:40 <mkoderer> matrohon: we have a "gap analysis" section for it
14:20:03 <sgordon> under "Affected By"
14:20:08 <matrohon> sgordon : great!
14:20:17 <sgordon> "If you are aware of any work in progress that will affect this use case,
14:20:18 <sgordon> please list it here.  Include links to a spec or blueprint or bug report
14:20:18 <sgordon> where applicable."
14:20:31 <sgordon> so you can put in the use case both what's already in progress
14:20:35 <sgordon> and what's outstanding as a gap
14:20:44 <matrohon> ok, I've to get more familiar with the template :)
14:21:11 <mkoderer> ok so back to topic :)
14:21:26 <sgordon> the final topic *I* had was the other meeting time
14:21:30 <sgordon> #topic meeting time
14:21:57 <sgordon> due to low attendance i want to move it somewhat earlier without going back to completely ignoring west coast US...
14:22:04 <sgordon> the gap im looking at atm is 1900 UTC - 3 PM EDT, Midday PST, 8 PM CET
14:22:13 <sgordon> (again, for the other time slot)
14:22:44 <sgordon> i will send a mail on this though since people who can only make the other slot - if they exist - will not be in this session in all likelihood
14:22:57 <sgordon> #action sgordon propose 1900 UTC - 3 PM EDT, Midday PST, 8 PM CET for other meeting time slot
14:23:17 <DaSchab> thats a bad time for people from asia, i guess
14:23:25 <sgordon> yeah
14:23:27 <vks> sgordon, 1800UTC
14:23:34 <vks> DaSchab, correct
14:23:52 <mkoderer> so idea is to stick to two different alternating slots?
14:23:56 <sgordon> vks, suggesting 1800 UTC instead of 1900 UTC?
14:24:05 <sgordon> mkoderer, that is an open question as well
14:24:22 <sgordon> i would be open to consolidating on just one but if we do that it probably has to be later than this slot
14:24:35 <vks> sgordon, for asia region 1900 UTC will be bit late
14:24:56 <mkoderer> I personally like this slot :)
14:25:03 <DaSchab> do we have currently people from asia working in the telcowg?
14:25:07 <sgordon> yeah this slot typically works better for me too
14:25:10 <sgordon> so im biased
14:25:10 <matrohon> mkoderer : me too :)
14:25:21 <sgordon> the maint thing is that with the the 2200 UTC slot we have now
14:25:28 <sgordon> it's basically me or anthony talking to ourselves
14:25:32 <sgordon> low to no attendance
14:25:34 <vks> mkoderer, +1
14:25:48 <margaret__> We may get more folks if we move the slot from asia. But to be fair there are alot of other projects they are engaged in fighting for the same time slots :-)
14:26:02 <sgordon> yes indeed
14:26:25 <sgordon> even from an openstack perspective there is a fair glut of meetings (even with four meeting rooms) at the ideal times
14:26:27 <margaret__> For OPNFV we have alot of asia - china mobile, huawei, ZTE, docomo, south korea
14:26:36 <mkoderer> 19 UTC works for me much better then 22 UTC... so +1 for it
14:26:52 <sgordon> let me take it to the list
14:26:53 <cloudon> +1 to 19 UTC
14:26:56 <sgordon> i think there are two proposals here
14:27:03 <sgordon> either a) move the alternate to 1900 UTC
14:27:10 <sgordon> or b) consolidate on this time slot
14:27:46 <sgordon> #action sgordon to post meeting timeslot proposal to list - either (a) move alternate meeting to 1900 UTC or (b) consolidate on the earlier time slot
14:27:51 <sgordon> #topic other business
14:28:10 <sgordon> so, does anyone have something else they would like to raise?
14:28:23 <dcw> sorry i was a little late in joining the meeting today
14:28:30 <dcw> i submitted a use-case - what’s next?
14:28:33 <sgordon> i apologize my attention is somewhat split today as im dealing with another meeting
14:28:36 <sgordon> dcw, excellent
14:28:41 <sgordon> dcw, do you have a link
14:28:51 <mkoderer> dcw: thanks for that
14:28:54 <dcw> https://wiki.openstack.org/wiki/TelcoWorkingGroup/UseCases
14:29:21 <sgordon> ahh SIP Load-Balancer-as-a-Service
14:29:22 <mkoderer> dcw: MNO/MVNO Use Case?
14:29:30 <dcw> yes, SIP LBaas
14:29:31 <sgordon> #info dcw added SIP Load-Balancer-as-a-Service to wiki page
14:29:33 <mkoderer> ah ok
14:30:00 <sgordon> #link https://wiki.openstack.org/wiki/TelcoWorkingGroup/UseCases#SIP_Load-Balancing-as-a-Service
14:31:04 <sgordon> dcw, so do you want some assistance converting that to RST format?
14:31:13 <sgordon> i believe this was what we discussed last week
14:31:33 <dcw> i ca have a go - just wanted some early feedback if i was on the right track
14:31:54 <dcw> in terms of the content and style
14:32:08 <mkoderer> dcw: the review process works well for early feedback too
14:32:20 <margaret__> LB should start getting absorbed into the NFV platform and not a separate entity
14:32:39 <margaret__> In fact maybe the SDN controller should perform this...
14:32:44 <sgordon> dcw, it looks good on face value - as part of the review we can further tease out gaps
14:33:06 <dcw> okay, i’ll try my hand at a git submission
14:33:46 <mkoderer> dcw: if you have any issue with that contact us on #openstack-nfv
14:33:49 <sgordon> #action dcw will work on converting to RST In git
14:33:55 <sgordon> +1 again feel free to ask if you need help
14:34:12 <margaret__> What is the process on reviewing submissions? just update the etherpad?
14:34:29 <ybabenko> margaret__: git
14:34:31 <mkoderer> margaret__: it's the usual openstack review process
14:34:36 <sgordon> https://wiki.openstack.org/wiki/TelcoWorkingGroup/UseCases#Reviewing_Use_Cases
14:34:55 <sgordon> like i said, looking for guinea pigs to see what steps i missed if any
14:35:04 <mkoderer> margaret__: the etherpads and wiki entries are outdatet when we have started the review process
14:35:44 <mkoderer> sgordon: I guess it would be a good idea to remove them
14:36:02 <sgordon> yeah with a pointer to the review entry
14:36:03 <margaret__> ok
14:36:28 <dcw> agreed, it confusing to have three versions
14:36:38 <sgordon> #info once you have moved a use case to git, update the etherpad/wiki with the link (replacing the content)
14:37:01 <mkoderer> we also need to publish the rst/html use cases somewhere
14:37:11 <mkoderer> I need to talk to openstack infra about it
14:37:27 <mkoderer> specs.openstack.org would be a quick solution
14:37:53 <sgordon> yeah
14:37:58 <sgordon> agree
14:37:59 <mkoderer> but "specs" is a bit misleading
14:38:07 <sgordon> right
14:38:20 <mkoderer> we could also talk to other user groups... may they want define use cases too
14:38:26 <sgordon> do you know if the api working group publishes somewhere?
14:38:27 <mkoderer> like enterprise group etc..
14:38:35 <sgordon> they are the main group using a similar process today
14:38:46 <sgordon> yes i actually put forward the template in WTE
14:39:13 <mkoderer> jaypipes_: ^ any clue?
14:39:37 <mkoderer> I think the api group doesn't have any use cases to publish?
14:39:50 <mkoderer> not totally sure :)
14:39:50 <sgordon> not exactly
14:40:20 <mkoderer> ok .. I will talk to jay later and ask him :)
14:40:28 <matrohon> I wonder what is the next step for those specs? should a patch, that partially implements a Telco spec, have a link to the spec in the commit msg?
14:40:30 <sgordon> they have their own repo
14:40:35 <sgordon> i thought they were publishing from it
14:40:45 <jaypipes_> mkoderer: not entirely sure... will get back to you on that (I always just go look at the formatted RST docs on github...)
14:40:54 <sgordon> matrohon, so in theory the use cases we build here
14:41:04 <sgordon> are ultimately to be used as the use case justification for a design spec
14:41:13 <sgordon> that is the idea anyway
14:41:46 <matrohon> sgordon : fine, seems reasonable
14:41:51 <sgordon> hopefully what we are creating is more detailed/accurate use cases to facilitate this
14:42:08 <mkoderer> jaypipes_: thx for that
14:42:50 <mkoderer> sgordon: matrohon: I guess we need at least one use case that goes trough the process and optimize it then
14:43:12 <sgordon> +!
14:43:15 <sgordon> +1 even
14:43:22 <ybabenko> mkoderer: let us take security zones?
14:43:50 <mkoderer> ybabenko: for me this use case is simple enought to test it :)
14:43:53 <ybabenko> in the end this will be mandatory req for any ISP
14:44:30 <sgordon> how are we defining "take" here
14:44:38 <sgordon> since i believe the use case is up for review
14:44:39 <sgordon> :)
14:44:50 <sgordon> #link https://review.openstack.org/#/c/163399/
14:44:57 <ybabenko> sgordon: what do you mean by take?
14:45:07 <sgordon> im actually asking you
14:45:28 <sgordon> from my point of view in terms of actually teasing it out from here the more the merrier
14:45:35 <mkoderer> sgordon: the idea to foucs on that review since it's a quite simple one
14:45:42 <sgordon> ok i agree with that
14:46:00 <sgordon> i think this one is very generally easy to understand for people without a telco background too
14:46:31 <ybabenko> sgordon: I see ... we should pick a use-case which is common for majority of folks here (ISP, NSP, etc).
14:47:15 <sgordon> agree
14:47:47 <mkoderer> any other topic?
14:48:20 <sgordon> appreciate all the discussion today folks
14:48:36 <sgordon> and also the many who volunteered for AIs!
14:48:41 <sgordon> :)
14:48:46 <sgordon> #endmeeting