14:02:54 <steveg> #startmeeting telcowg
14:02:55 <openstack> Meeting started Wed Feb 25 14:02:54 2015 UTC and is due to finish in 60 minutes.  The chair is steveg. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:56 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:02:58 <openstack> The meeting name has been set to 'telcowg'
14:03:10 <steveg> #link https://etherpad.openstack.org/p/nfv-meeting-agenda
14:03:16 <steveg> #topic roll call
14:03:21 <aveiga> hello
14:03:21 <vks> hi
14:03:22 <amitry> hello
14:03:25 <cloudon> hi
14:03:28 <steveg> o/
14:03:46 <steveg> mkoderer, around?
14:04:19 <ian_ott> hello
14:04:28 <steveg> #topic action items from last week
14:04:40 <steveg> #info aveiga was to take first stab at an RST template for use cases
14:04:49 <steveg> there is a draft in the gerrit system now
14:04:51 <aveiga> and that I did
14:04:58 <steveg> (yes we have a repo, for anybody who missed it last week)
14:05:00 <steveg> #link https://review.openstack.org/#/c/158028/
14:05:08 <aveiga> it's marked WIP at the moment because there are some outstanding questions
14:05:48 <steveg> right
14:05:55 <aveiga> I know we were using these use cases to identify gaps in OpenStack functionality. SO I included a section for those submitting to include known gaps.  Should we remove this, as it may be confusing?
14:06:17 <steveg> so i had a crack at importing cloudon's vIMS use case into this format
14:06:26 <steveg> and i found it hard to differentiate between gaps and requirements
14:06:40 <aveiga> steveg: I think they will overlap
14:06:43 <steveg> in part perhaps that is the ordering though
14:06:49 <steveg> in that gaps is listed before requirements
14:06:57 <aveiga> ah, ok
14:07:02 <steveg> so im identifying the gaps before i've really defined what i require
14:07:05 <steveg> if that makes sense
14:07:10 <aveiga> I had intended the gaps to mostly be requirements that aren't implemented
14:07:15 <steveg> right exactly
14:07:24 <steveg> i only understand that now we are discussing it
14:07:27 <steveg> i missed this earlier
14:07:35 <steveg> but i think the ordering impacted how i came at it
14:07:36 <aveiga> I might need to reorder/clarify those sections
14:07:37 <vks> i have pointed some gaps in the doc
14:07:41 <aveiga> I'll take another stab at it
14:08:04 <vks> https://etherpad.openstack.org/p/telco_orchestration
14:08:41 <steveg> the other AI was...
14:08:50 <steveg> #info sgordon was to import existing use case proposals as gerrit reviews
14:09:07 <steveg> as i said i decided to just start with the vIMS case to try out the template
14:09:10 <steveg> #link https://review.openstack.org/#/c/158997/
14:09:25 <steveg> as once we finalize the template we will need to rework somewhat
14:09:28 <aveiga> steveg: do you really want to do that before the template is finalized?
14:09:30 <aveiga> ah, ok
14:09:32 <aveiga> :)
14:09:33 <steveg> exactly
14:09:43 <steveg> i just tried one to see if it kicked out any obvious holes in the template
14:09:58 <steveg> the change is also marked as dependent on the template one
14:10:26 <steveg> so all in all the quicker we can all provide feedback and iterate on aveiga's draft the better
14:10:45 <steveg> i would really like to get this nailed down in the next week so that i can put together some examples for the ops mid cycle to work through
14:11:28 <vks> steveg , u re referrinng this ? https://review.openstack.org/#/c/158028/
14:11:29 <steveg> did anyone else have a chance to look at it this week? i know mkoderer had commented on it as well
14:11:29 <cloudon> Agree on reqs preceding gaps; should there be a section referencing existing bps?
14:11:34 <steveg> vks, yes
14:11:49 <aveiga> cloudon: yes, that's been identified to add BPs
14:11:50 <steveg> cloudon, i believe that was one of mkoderer's comments on the review
14:12:10 <aveiga> I've been out of pocket for two days, so I have reviews to catch up on
14:13:43 <steveg> aveiga, yes - i was also out of pocket for a few days this last week
14:14:17 <steveg> any other feedback on the template would be much appreciated either in the meeting today or ideally in the review :)
14:14:56 <aveiga> +1 to reviewing as it's easier to follow up on
14:14:57 <ian_ott> i will do a review by Monday
14:15:21 <vks> when we will be starting implementation
14:15:22 <vks> ?
14:15:35 <steveg> thanks ian_ott
14:15:48 <aveiga> vks: we haven't even finished a gap analysis. Implementation is a ways out
14:15:56 <steveg> vks, depends how you define it, implementation of features from previous cycles is ongoing
14:16:05 <steveg> but we are trying to take a more use case focused approach
14:16:09 <aveiga> we need to find gaps, write specs for them, and then get them approved into milestones for the applicable projects
14:16:19 <steveg> instead of leading with a solution
14:16:38 <steveg> the latter has led to a lot of confusion in the broader openstack community as to why certain features are being requested
14:16:41 <vks> aveiga, well i was talking about prototype
14:16:46 <steveg> and we need to be able to clearly illustrate this
14:17:05 <vks> as vIMS gaps got  analysed. I think so
14:18:38 <mkoderer> hi folks
14:18:39 <steveg> vks, i am not sure it's as clear
14:18:41 <mkoderer> sry I am late
14:18:56 <steveg> last time we discussed vIMS there seemed to be some diverging opinions on whether it was the right scope or not
14:19:20 <aveiga> also there is no document covering the gap analysis yet
14:19:30 <aveiga> which is the point of the template including that section
14:19:42 <aveiga> the idea being that it can be submitted blank, but will be filled in before specs are generated
14:19:51 <vks> ok will look into that, sry i attend only alt meetings only
14:19:56 <steveg> i mean if you look at the requirements list for that use case, it is intentionally "this already works" because the scope was limited somewhat
14:20:21 <mkoderer> aveiga: gap analysis is quite important IMHO
14:20:38 <aveiga> mkoderer: yes, but we aren't expecting the use case submitter to be able to cover it
14:20:57 <aveiga> we should be able to review the use cases after submission and add those sections when we have the proper info
14:20:57 <mkoderer> aveiga: yep, may be we need the document later on
14:21:07 <mkoderer> aveiga: or we put it onto a different set of documents
14:21:17 <aveiga> mkoderer: that was my other qestion on the template
14:21:24 <aveiga> do we do a separate doc for it or not
14:21:43 <aveiga> I think including it is good for folks who already did some preliminary analysis
14:21:52 <aveiga> but I could be wrong
14:22:08 <steveg> i think a lot of people already have some preliminary idea
14:22:25 <steveg> i think keep it in the same doc
14:22:35 <steveg> but we can update it as we do the analysis
14:22:41 <ian_ott> steveg: +1 to same doc
14:22:50 <cloudon> My $0.02: raiser should create use case with reqs fully fleshed out and ideally at least an attempt at gaps, but key purpose of review by this group is to identifythe gaps and match (where possible) to existing bps
14:22:53 <aveiga> that's what I had intended, but I may need to add clarifying text
14:23:04 <steveg> #info more feedback required on use case template https://review.openstack.org/#/c/158028/3
14:23:07 <aveiga> cloudon: +1
14:23:20 <steveg> #info order of gaps/requirements will change in template
14:23:57 <steveg> #info gaps will stay in use case document but updated as further gap analysis for use case is done, do not need gap analysis to be complete at submission time (that is what this group wants to help with!)
14:24:16 <aveiga> steveg: I -1'd with that info
14:24:24 <steveg> ta
14:25:27 <steveg> #topic all need to identify use cases for mid cycle discussion
14:25:35 <steveg> i think it is perhaps too early for the above?
14:25:49 <steveg> what i would aim to do once we get the template nailed is put all of those submitted so far on the wiki/etherpads
14:26:06 <steveg> into work in progress submissions like i did with the vIMS one (will probably appreciate some help on this)
14:26:39 <mkoderer> steveg: how should we expand the core reviewes team?
14:26:48 <steveg> mkoderer, great question
14:26:53 <aveiga> steveg: I'll work with you on the use cases
14:27:06 <steveg> mkoderer, i dont have a strong opinion at the moment
14:27:29 <mkoderer> steveg: IMHO ppl that are active in the review process can be voted
14:27:37 <steveg> mkoderer, +!
14:27:38 <steveg> +1
14:28:42 <steveg> #info will expand core group on telcowg-usecases to include active reviewers
14:28:48 <vks> steveg, i will also work on use case
14:28:50 <cloudon> steveg, for those of us not hugely familiar with how to use gerrit, is there a simple OpenStack primer you could point us at?
14:29:07 <steveg> cloudon, i am going to try and knock something up for the ops mid cycle on the wiki
14:29:12 <mkoderer> cloudon: we should plan a webinar for that
14:29:14 <cloudon> thanks
14:29:15 <ian_ott> steveg: i can help with use case submissions as well
14:29:16 <steveg> there is a generic how to contribute document for openstack
14:29:25 <steveg> but it's not required to go through all those steps
14:29:27 <steveg> just to review
14:29:33 <vks> +1 for webinar
14:29:33 <mkoderer> jaypipes mentioned that he's planning something :)
14:29:36 <steveg> so i want to cut it down to the bare minimum for this purpose
14:29:38 <steveg> yes
14:29:41 <aveiga> https://wiki.openstack.org/wiki/Gerrit_Workflow
14:29:50 <steveg> we discussed last week the idea of doing a runthrough at the mid-cycle
14:29:54 <steveg> and then recording something
14:30:00 <aveiga> but that gets into the weeds since we don't really unit test the use case docs
14:30:06 <steveg> aveiga, right
14:30:25 <steveg> #action steveg with aveiga's help to import existing use case docs to gerrit once template finalized
14:30:29 <mkoderer> aveiga: btw could you +A https://review.openstack.org/#/c/158215/
14:30:33 <jaypipes> mkoderer: :)
14:30:41 <mkoderer> I renamed spec into usecases
14:30:52 <steveg> #action steveg to produce cut down workflow walkthrough by ops mid cycle
14:31:10 <aveiga> mkoderer: done
14:31:28 <aveiga> steveg: so is that a good segue to the meetup topic? :-P
14:31:37 <steveg> yes
14:31:49 <steveg> #topic philly ops mid cycle
14:31:55 <steveg> #link https://etherpad.openstack.org/p/PHL-ops-telco
14:32:10 <steveg> so the draft agenda i had started throwing together is basically the same as last week
14:32:21 <steveg> except that andrew and anthony added their names to it ;)
14:32:40 <steveg> if others are attending the ops mid cycle please add your name too so i have a rough idea of group size
14:32:51 <steveg> at this stage i believe we will get one of the small rooms for 90 mins
14:32:57 <steveg> not clear on which day it will be yet
14:33:15 <aveiga> steveg: if you'd like some assistance, I can help you work on slides/content for the review process
14:33:50 <steveg> that would be appreciated, i will throw up a deck on google we can start filling in
14:33:56 <aveiga> ok
14:34:15 <steveg> #action steveg to create blank deck to start putting workflow content in
14:36:41 <steveg> any other things people wish to discuss today?
14:37:17 <cloudon> would welcome other contributions to https://etherpad.openstack.org/p/telco_orchestration
14:37:31 <cloudon> especially if you disagree with me...
14:37:44 <mkoderer> cloudon: we should rewrite it that it matches the use case structure
14:37:50 <mkoderer> cloudon: and bring it to review
14:37:52 <ian_ott> we have some telco specific bugs we just opened related to numa zones affinity and live migration, they might be blue prints, who are the best people to engage and how?
14:37:52 <aveiga> cloudon: I think we'd like to see that get into the repo as soon as the template is done
14:38:12 <steveg> ian_ott, got some links?
14:38:30 <ian_ott> https://bugs.launchpad.net/nova/+bug/1289064
14:38:31 <openstack> Launchpad bug 1289064 in OpenStack Compute (nova) "live migration of instance should claim resources on target compute node" [Medium,In progress] - Assigned to Alex Xu (xuhj)
14:38:40 <ian_ott> https://bugs.launchpad.net/nova/+bug/1417667
14:38:41 <openstack> Launchpad bug 1417667 in OpenStack Compute (nova) "migration/evacuation/rebuild/resize of instance with dedicated cpus needs to recalculate cpus on destination" [Medium,Confirmed]
14:39:11 <vks> cloudon, I have put some comments there
14:39:48 <ian_ott> we are wanting to work on them and get them addressed for telco space
14:40:25 <steveg> #link https://bugs.launchpad.net/nova/+bug/1289064
14:40:26 <openstack> Launchpad bug 1289064 in OpenStack Compute (nova) "live migration of instance should claim resources on target compute node" [Medium,In progress] - Assigned to Alex Xu (xuhj)
14:40:28 <cloudon> am happy to rework  into repo once template done & steveg's gerrit-101 or webinar is there to help me...
14:40:30 <steveg> #link https://bugs.launchpad.net/nova/+bug/1417667
14:40:31 <openstack> Launchpad bug 1417667 in OpenStack Compute (nova) "migration/evacuation/rebuild/resize of instance with dedicated cpus needs to recalculate cpus on destination" [Medium,Confirmed]
14:41:20 <ian_ott> steveg: yes that is one
14:41:46 <steveg> ian_ott, on face value they look like bugs
14:42:06 <steveg> (or at least the generic problems that are the root cause do)
14:42:13 <ian_ott> steveg: thanks
14:42:35 <steveg> i see nikola and chris have been active on those bugs
14:42:43 <steveg> who have both been poking the numa stuff a lot of late
14:43:06 <ian_ott> yes i work with chris
14:44:44 <steveg> ok
14:45:08 <steveg> they dont look stalled at the moment, let's discuss again if there is no forward progress
14:45:26 <steveg> ok
14:45:31 <steveg> anything else to raise?
14:46:41 <ian_ott> thanks sound good, we are planning to work on them
14:47:02 <steveg> ok cool
14:47:13 <steveg> thanks all for your time!
14:47:18 <steveg> #endmeeting