18:00:17 <JayF> #startmeeting tc
18:00:17 <opendevmeet> Meeting started Tue Mar 26 18:00:17 2024 UTC and is due to finish in 60 minutes.  The chair is JayF. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:17 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:17 <opendevmeet> The meeting name has been set to 'tc'
18:00:22 <JayF> Welcome to the weekly meeting of the OpenStack Technical Committee. A reminder that this meeting is held under the OpenInfra Code of Conduct available at https://openinfra.dev/legal/code-of-conduct.
18:00:24 <JayF> Today's meeting agenda can be found at https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee.
18:00:27 <JayF> #topic Roll Call
18:00:28 <JayF> o/
18:00:31 <rosmaita> o/
18:00:34 <frickler> \o
18:00:36 <slaweq> o/
18:00:44 <gmann> o/
18:00:56 <gouthamr> o/
18:01:14 <jamespage> o/
18:01:43 <dansmith> o/
18:01:58 <JayF> #info There are no absences noted in the TC agenda.
18:02:10 <JayF> I'm going to give a couple more minutes for the remaining TC members to arrive.
18:02:59 <spotz[m]> o/
18:04:03 <JayF> Going to move on with the rest of the agenda.
18:04:20 <JayF> There were no action items last TC meeting; going to hop over that agenda item
18:04:25 <JayF> #topic Gate Health Check
18:04:42 <JayF> Thanks again to slaweq for the email to the list about rechecks, it's generating a lot of healthy discussion and visibility into gate issues.
18:04:54 <JayF> Anything specific to note about the gate this week?
18:05:12 <dansmith> nothing from me (because no data, unfortunately)
18:05:27 * frickler hasn't seen much either
18:05:36 <JayF> Fair enough :)
18:05:39 <slaweq> nothing from me
18:05:46 <JayF> #topic Implementation of Unmaintained branch statuses
18:05:50 <gmann> nothing specific from my side except setup for stable/2024.1 and master is going on so granade, devstack jobs will be testing the correct branches soon
18:05:58 <JayF> ack ty gmann
18:06:08 <slaweq> just please review https://review.opendev.org/q/topic:%22rechecks-docs%22 when You will have few minutes
18:06:21 <JayF> #undo
18:06:21 <opendevmeet> Removing item from minutes: #topic Implementation of Unmaintained branch statuses
18:06:28 <JayF> #link https://review.opendev.org/q/topic:%22rechecks-docs%22
18:06:33 <JayF> Thanks :)
18:06:35 <JayF> #topic Implementation of Unmaintained branch statuses
18:06:38 <slaweq> small adition about rechecks reasons in dics
18:06:42 <gmann> slaweq: +1 on adding it in zuul comment. good idea
18:07:10 <slaweq> gmann it was actually Sean's idea
18:07:17 <frickler> we merged some more unmaintained transition changes earlier, I'm deleting affected branches now
18:07:28 <gmann> yeah, i saw thanks to sean too:)
18:07:48 <JayF> thanks frickler, and I'll note I saw on releases.opendev.org this morning it is starting to look really nice
18:08:21 <JayF> er, releases.openstack.org
18:08:57 <JayF> Anything else on this topic?
18:09:33 <JayF> #topic 2024.2 Dalmatian TC Election
18:09:54 <JayF> As all of us are aware, we were unable to execute election results due to affiliation policy issues.
18:10:09 <JayF> I'd like to thank Red Hat employees, and Sylvain, for figuring this out internally so we can keep a diversely affiliated TC.
18:10:21 <JayF> #link https://review.opendev.org/c/openstack/governance/+/913912
18:10:24 <jamespage> seconded
18:10:27 <JayF> #link https://review.opendev.org/c/openstack/governance/+/914024
18:10:38 <JayF> The first governance link is just for the minutes, noting that we have a -1 on the election results.
18:10:52 <JayF> The second one is a resolution, authored by me, documenting the adjudication of the election.
18:11:16 <JayF> Please do vote on 914024, the clock starts today so we can merge and seat the new TC just before next week's meeting.
18:11:37 <JayF> Any comments or concerns for the meeting?
18:12:21 <rosmaita> just that we will probably face this issue again, so would be good to have discussions at the PTG
18:12:23 <gouthamr> JayF: i want to note that it was a harrowing process for having to do this - like bauzas mentioned, we hope there's a codified process worked out for this.. and are determined to help achieve it.
18:12:36 <noonedeadpunk> o/
18:12:55 <JayF> Agreed, and that is a stellar segue into...
18:12:58 <JayF> #topic TC vPTG 2024.2
18:13:03 <gmann> #link https://etherpad.opendev.org/p/apr2024-ptg-os-tc#L46
18:13:04 <JayF> #link https://etherpad.opendev.org/p/apr2024-ptg-os-tc
18:13:24 <spotz[m]> I think this is already on the PTG agenda if not we'd like some time to through out ideas and governance for the future
18:13:29 <gmann> rosmaita: link for ^^ as you mention about the PTg discussion over this topic
18:13:40 <rosmaita> \o/
18:13:49 <JayF> It's my intention to map topics to timeslots this afternoon/tomorrow, and send an email out to the list about it. If you have topics to present beyond what is already on the etherpad, please put them in -- even just a placeholder subject line -- for scheduling purposes.
18:15:13 <JayF> Anything else about PTG or scheduling?
18:16:07 <slaweq> I still need to  finish and propose analysis of the latest user survey. I plan to do it next week. I am not sure if you maybe wants to add something about it to the PTG agenda
18:16:22 <JayF> I think it's wise to have a spot to talk about it separately
18:16:31 <JayF> I'll put in a placeholder for you, thanks slaweq
18:16:41 <slaweq> thx
18:16:54 <JayF> #topic Open Discussion
18:17:00 <JayF> I have one item for this from me
18:17:12 <JayF> I will not be here next week, completely OOO/PTO and away from computers as much as possible.
18:17:48 <JayF> I would like to ask someone to take on ensuring 914024 is merged a week from today, as long as it's valid to merge, and coordinating the update of governance results as well.
18:18:16 <JayF> Additionally, just ensuring that gmann is still willing to chair the meeting next week as I will be away
18:18:56 <gmann> sure, its video one right
18:19:05 <JayF> It is.
18:19:13 <clarkb> I did a fair bit of work to clear out debian buster, opensuse leap 15.2, and centos 7 from nodepool and our mirrors. The next cleanup is ubuntu xenial though I don't think I'll have time to look into that until next week. This has opened up space for ubuntu noble mirroring and images if anyone is interested in pushing that along. First step is probably jobs to build and test the
18:19:15 <clarkb> image in diskimage builder. Then we add the mirror then image builds to nodepool.
18:19:15 <gmann> ok, I will chair.
18:19:16 <rosmaita> i can watch that patch
18:19:27 <rosmaita> once it merges, i think my tc term will be over?
18:19:38 <JayF> Yes
18:19:51 <JayF> #info JayF (chair) PTO next week
18:19:52 <rosmaita> works for me if no one has any objection
18:20:01 <JayF> #action gmann To chair TC meeting next week
18:20:20 <JayF> #action rosmaita will merge 914024 if eligible and see to it new TC is seated before next TC meeting
18:20:28 <JayF> Any other items for open discussion?
18:21:27 <JayF> Last call before I close the meeting
18:21:43 <rosmaita> question about the timing ... when can i merge 914024?  I guess at 0:00 UTC 2 April 2024?
18:22:42 <JayF> If we're doing it down to the second, I restored the patch at 9:23am PST. I would not object to it merging anytime on that Tuesday to make life simpler.
18:22:43 <gmann> rosmaita: did not calculate time but "tox -e check-review-status" will surly give you the right answer for eligibility of merging
18:23:03 <fungi> which probably means tc election results announcement happening the day before release day, best case
18:23:32 <JayF> ++ I trust the script for everything(*) (there are some exceptions; this isn't one)
18:24:03 <gmann> yeah, that is very helpful.
18:24:26 <JayF> Anything else?
18:24:49 <rosmaita> script says "earliest: 2024-03-29 18:30:02"
18:25:35 <rosmaita> so everyone go over and vote as soon as the meeting is over, and we can merge it friday
18:26:02 <rosmaita> unless "earliest" means something else?
18:26:14 <JayF> earliest means that, but this also means the script doesn't consider abandon/restore
18:26:19 <JayF> which is convienient in this case
18:26:22 <rosmaita> :D
18:26:32 <frickler> convenient, but debatable?
18:26:51 <JayF> If I were landing it, I'd let any single TC member's objection push me to "7 days from when it was restored" which is that April 2, around 9:23a pst
18:27:33 <JayF> frickler: yeah, that's kinda what I'm getting at with ^
18:28:07 <frickler> yes, after going through so many loops in order to do the right thing, this should be handled correctly, too, imo
18:28:24 <JayF> rosmaita: so I'd suggest waiting until noonish eastern time a week from today
18:28:46 <dansmith> #bikeshedding
18:29:16 <rosmaita> ok, it was restored at 12:23PM EDT, so that will be the merge target
18:29:20 <JayF> sounds good
18:29:26 <JayF> thanks all
18:29:28 <JayF> #endmeeting