18:00:56 <JayF> #startmeeting tc
18:00:56 <opendevmeet> Meeting started Tue Jan 16 18:00:56 2024 UTC and is due to finish in 60 minutes.  The chair is JayF. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:56 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:56 <opendevmeet> The meeting name has been set to 'tc'
18:01:03 <JayF> #topic Roll Call
18:01:07 <rosmaita> o/
18:01:09 <slaweq> o/
18:01:10 <jamespage> o/
18:01:12 <knikolla> o/
18:01:15 <JayF> Welcome to the weekly meeting of the OpenStack Technical Committee. A reminder that this meeting is held under the OpenInfra Code of Conduct available at https://openinfra.dev/legal/code-of-conduct.
18:01:17 <dansmith> o/
18:01:20 <JayF> Today's meeting agenda can be found at https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee.
18:01:22 <gmann> o/
18:01:44 <frickler> \p
18:01:54 <JayF> No noted absences on today's agenda. I'll give a few moments for everyone to arrive.
18:03:03 <spotz[m]> o/ was reading the backlog
18:03:31 <JayF> Awesome!
18:03:31 <JayF> #topic Follow up on tracked action items
18:03:38 <JayF> #info JayF emailed list about Monasca situation, attempted to get discussion started
18:03:57 <JayF> Thanks to Julia for engaging, there was not any other discussion. I have a topic for this later so will leave discussion for then. (similar for the next two.
18:04:11 <JayF> #info slaweq emailed Monasca volunteer about options for maintaining Monasca
18:04:20 <spotz[m]> I agree with you both, didn't feel like I had anything new to add so didn't
18:04:26 <slaweq> I reached out to the person who wants to maintain it
18:04:34 <JayF> I was included on this email, thanks slaweq -- we can talk details in the dedicated agenda item for inactive caracal projects.
18:04:37 <slaweq> and he's fine with moving it to the x/ namespace
18:05:02 <JayF> gmann: Were you able to get in contact with the volunteer to maintain Senlin?
18:05:08 <gmann> slaweq: do you know if they can initiate the process to move to x/ namespace. from our side we can retire the project and rest they should do.
18:05:20 <fungi> did you ask him to pick a namespace to use for it rather than the catch-all "x/" dumping-ground we're trying to avoid putting more projects in?
18:05:25 <gmann> I mean they should not be having expectation that we setup it to x/ or whatevere new namespace for thwm
18:05:36 <JayF> fungi: gmann: Please table details of this discussion until the dedicated agenda  item
18:05:59 <JayF> I would like to ensure this topic does not monopolize the majority of the meeting, so put it last :)
18:06:13 <JayF> gmann: What about the action item for Senlin volunteers?
18:06:28 <gmann> I contacted him but not response, I will try to reachout on IRC this week
18:06:50 <JayF> #info gmann reached out to volunteer to maintain Senlin via email; no response. Will try again over next week.
18:06:53 <JayF> #topic Gate Health Check
18:06:59 <JayF> Anything notable about the gate this week?
18:07:14 <dansmith> about the same,
18:07:25 <dansmith> getting some extra eyes on the guest kernel crashes has been great
18:08:08 <JayF> I'm very interested to see what the root cause of that ends up being. :)
18:08:25 <frickler> just a heads up that updated eventlet has made it into u-c, so watch out for possible regressions
18:08:44 <rosmaita> thanks for the warning!
18:09:06 <JayF> If you do see any of those regressions, if you wanna ensure I-personally see the bug I can ensure it g
18:09:07 <fungi> and huge thanks to everyone who worked on salvaging and reviving eventlet!
18:09:10 <gmann> to version 0.34.3 #link https://review.opendev.org/c/openstack/requirements/+/904147
18:09:16 <JayF> **gets escalated to the downstream GR-OSS engineer working on Eventlet
18:09:36 <fungi> hopefully our thanks get escalated to them too ;)
18:10:30 <JayF> My manager starts our 1:1s with "Stop saying nice things about the eventlet project" now ;)
18:10:36 <JayF> Going to move on topics :D
18:10:42 <JayF> #topic Implementation of Unmaintained Branch Statuses
18:10:51 <JayF> I think we're still in waiting period, but I think I saw some docs patches moving for this?
18:11:04 <JayF> Is there anything here worth mentioning?
18:11:08 <gmann> #link https://review.opendev.org/c/openstack/project-team-guide/+/897505
18:11:14 <gmann> you mean this sone ^^
18:11:16 <frickler> there are patches in the release automation halfway merged already
18:11:16 <gmann> one
18:11:45 <frickler> #link https://review.opendev.org/q/topic:%22relmgt-unmaintained-state%22
18:12:01 <rosmaita> knikolla: do you want me to take over https://review.opendev.org/c/openstack/project-team-guide/+/897505 ?
18:12:35 <knikolla> rosmaita: yes, i would appreciate that, thank you.
18:12:50 <rosmaita> np, i've been meaning to ask but keep forgetting
18:12:52 <gmann> frickler: thanks for links
18:13:36 <JayF> Sounds like we're making progress, thanks for the comments and insights on that change frickler.
18:13:41 <JayF> Is there anything else on this topic before we move on?
18:14:57 <JayF> #topic Inactive Projects for Caracal
18:15:09 <JayF> It is past C-2, inactive projects will not be in Caracal release. Would we like to take further action in Caracal to adjudicate any of these?
18:15:27 <frickler> well "will not be in release" isn't automatic
18:15:38 <frickler> I talked with the release team on friday
18:15:40 <JayF> frickler: ah, what action do we need to take to ensure that happens?
18:16:11 <frickler> we agreed that elodilles will create a patch to drop the deliverables files for the affected repos
18:16:16 <gmann> well, project have still chance to get them release by fixing their CI or so but release team will not handle that until they are in Inactive state
18:16:33 <frickler> since none of them have had releases yet
18:16:40 <gmann> frickler: but do we need to drop the files? at least untill they are retired ?
18:16:43 <JayF> For Monasca, we had some chat around the action item one -- I had some concerns around how we communicated with that volunteer. I'm worried we might have given the impression that the "x/" namespace is open for new projects, which is not what I believe fungi has been communicating, and they might have the impression that TC is going to do the infra-work needed to setup the new home.
18:16:52 <frickler> I doubt that the release team would necessarily check our inactive list
18:17:07 <gmann> elodilles: frickler ^^ about deliverables file drop, can we wait until they are retired?
18:17:43 <gmann> frickler: i see, may be marking them in projects.yaml with some status so that release tooling can automate the Inactive projects list
18:17:49 <frickler> iiuc the existence of these files is essentially saying "this is a part of the caracal release", so IMO no
18:18:01 <gmann> "release-management: inactive"
18:18:04 <fungi> i have tried to reiterate a few times, including last meeting, that the x/ namespace was where we dumped all the projects that got evicted from the openstack/ namespace during the original migration when their maintainers didn't get back to us with a preference for what namespace their repos should go into
18:18:31 <fungi> the idea is that projects using opendev would have their own namespaces though, and just treating x/ as a preferred dumping ground runs counter to that
18:18:32 <JayF> I do think TheJulia's comment on the list around this is valuable: we might need to explore what "inactive" looks like for a project, and if it's a place for something to stay for longer than a couple of months before being retired. Basically I'm wondering if we should challenge the assumption that inactive projects should be retired in short order (versus making that a place for unreleased collaboration to happen).
18:19:29 <gmann> on Monasca, I think we should clear the next step to them 1. It will be retired from OpenStack - TC can do 2. moving to new namespace, please contact opendev team for appropriate new namespace
18:19:52 <fungi> and also, yes, to re-raise gmann's earlier concern, we should expect the new monasca maintainer to propose a change that creates the repos they want in opendev, not just preemptively do it for them on the assumption that they'll actually maintain them
18:20:00 <JayF> I am mostly +1 on that plan, with the caveat the TC should probably clarify what #2 means.
18:20:11 <JayF> (to the maintainer in communications; I mean)
18:20:14 <gmann> yeah
18:20:20 <slaweq> gmann I agree and I will follow up with this new volunteer
18:20:26 <gmann> thanks slaweq
18:20:36 <fungi> opendev doesn't really "pick" namespaces for projects either. we just expect the maintainers of those projects to let us know what namespace they want to make as part of the repository creation changes
18:20:40 <slaweq> fungi so should they contact e.g. You to create namespace for the Monasca project and move it there?
18:20:48 <gmann> fungi: ++
18:21:11 <knikolla> fungi: could just monasca/monasca work?
18:21:15 <fungi> slaweq: no. maybe i'm being unclear
18:21:24 <fungi> knikolla: yep, that's a great example
18:21:30 <frickler> and that requires them to learn about how opendev works in general, first, I'd say
18:21:58 <fungi> slaweq: what i'm saying is that we have documentation for project maintainers who want to create projects in opendev. the new monsasca maintainers should read and follow that documentation
18:22:06 <fungi> frickler: precisely
18:22:23 <knikolla> it's pretty good documentation, i've followed it a couple of times :)
18:22:27 <slaweq> fungi ok, can You maybe share link to this document? Or do I need to look for it?
18:22:40 <fungi> https://docs.opendev.org/opendev/infra-manual/
18:22:50 <frickler> also once again, monasca project is a lot of repos, none of them is named monasca
18:22:50 <knikolla> https://docs.opendev.org/opendev/infra-manual/latest/creators.html
18:22:51 <slaweq> fungi++ thx
18:22:51 <JayF> https://docs.opendev.org/opendev/infra-manual/latest/creators.html is usually what I'd link people
18:23:24 <JayF> #info For projects being retired out of OpenStack that may want to continue life in an OpenDev namespace, https://docs.opendev.org/opendev/infra-manual/latest/creators.html will be a good guide.
18:23:39 <slaweq> so something like "monasca/<repo_name>" for each of the repositories would be good I think. At least I will propose something like that to them
18:23:40 <fungi> yeah, in this case it sounds like the new monasca maintainer volunteer probably would benefit from reading about more than just project creation
18:23:51 <gmann> frickler: on inactive project deliverables file thing, i think you have good point about "file exist means there might be expectation of release or release team will do release at some point". I agree on that and if project want to release they can add file again depends on release team deadlines.
18:24:37 <JayF> So for Monasca, the path forward from an OpenStack TC perspective is: 1) Elod is removing the deliverable files for these inactive projects from Caracal. 2) slaweq is reaching out to Monasca-future maintainers, will ensure they get documentation and basic guidance on next steps for maintaining Monasca once we retire it
18:24:41 <jamespage> https://review.opendev.org/c/openstack/sunbeam-charms/+/905756
18:24:50 <JayF> 3) is going to be remaining actions to retire monasca; is someone taking those actions?
18:25:22 <slaweq> I can send patches to retire it
18:25:25 <JayF> Is there something I missed and/or is that understanding flawed?
18:25:27 <gmann> ++
18:25:38 <jamespage> ignore me multifailing
18:25:41 <fungi> sounds fine from the opendev side of things
18:26:26 <JayF> slaweq: I'm going to mark this as to be followed up on in like, a month? I don't think there's a need to ask you to turnaround this in a week, if that's OK?
18:26:40 <JayF> #action slaweq (Due: 4 weeks) To retire Monasca and notify interested maintainers of OpenDev documentation and process for creating a new project out of the ashes of the retired OpenStack Monasca.
18:26:48 <gmann> for other Inactive projects, we can just leave them as Inactive in this cycle and see the progress. In next cycle anyways if project stay Inactive then we discuss about their retirement.
18:27:06 <slaweq> sure, sounds good for me
18:27:10 <slaweq> thx JayF
18:27:12 <frickler> gmann: yes, except that iiuc with C-2 adding new files for caracal is no longer allowed, so would have to happen for the next cycle only
18:27:43 <JayF> So for remainder of projects: 1) elod will remove their deliverable files for Caracal 2) Otherwise they remain inactive; we will revisit during next PTG(?)
18:27:44 <gmann> yeah, release deadlines are anyways they need to respect
18:28:12 <JayF> There are no release deadlines. Inactive projects are excluded from the release once C-2 has passed. https://governance.openstack.org/tc/reference/emerging-technology-and-inactive-projects.html#timeline
18:28:37 <JayF> So the projects that are inactive will not be a part of Caracal, even if they are eligible to be re-activated for D-and-later releases.
18:28:40 <gmann> release deadline from release team we have. I think there are deadlines for each release model
18:29:12 <gmann> that anyways communicated by the release team on ML also so projects maintaners should be aware of those
18:30:21 <JayF> #info TC consensus is to not take immediate action on remaining inactive projects. Will revisit during PTG.
18:30:44 <JayF> Moving on to next topic?
18:31:00 <JayF> #topic 2024.1 TC Tracker
18:31:07 <JayF> #link https://etherpad.opendev.org/p/tc-2024.1-tracker
18:31:21 <JayF> Anything from the TC Tracker worth noting in today's meeting?
18:31:34 <gmann> nothing from me
18:31:35 <JayF> I don't see any updates.
18:31:45 <JayF> #topic Open Discussion and Reviews
18:31:59 <JayF> #link https://review.opendev.org/q/status:open+repo:openstack/governance
18:32:05 <JayF> We have a small number of open reviews.
18:32:13 <JayF> Is there any topics for Open Discussion today?
18:32:21 <frickler> I saw https://review.opendev.org/c/openstack/skyline-apiserver/+/904549 today, which makes me a bit worried about the path of that project
18:32:48 <frickler> this also relates to the emerging projects' adoption timeline mentioned above
18:33:22 <gmann> yeah, i think we have not checked/monitored those timeline for Skyline
18:35:10 <gmann> as per timelines, they needs to be fully qualified for official project in Caracal cycle.
18:35:44 <JayF> > If project is not able to become an official OpenStack project within that timeframe, TC will discuss with the team if more time is required for the project to meet the Requirements for new OpenStack Project applications or will retire the project.
18:35:56 <JayF> It sounds like we can offer them an exception via discussion if it's deemed valuable to do so.
18:36:13 <JayF> I'm not sure one way or the other, but I do think it'd be crummy of us to retire them in C-2 after not having significant discussions.
18:36:30 <gmann> maybe we can add it it next PTG discussion about how close they are and if more time is required
18:36:31 <JayF> Unless someone else has a significant interest, I'll reach out to the skyline team and see what intentions/investments/etc are for the future?
18:36:51 <JayF> ++ That is exactly what I was going to suggest, we get a rapport going so we're prepared to have a more formal chat nex tPTG
18:37:18 <frickler> +1
18:37:47 <spotz[m]> +1
18:37:50 <JayF> #action JayF to reach out to Skyline team and inquire about future plans for project; potential to "graduate" from Emerging
18:38:17 <JayF> Anything additional for open discussion?
18:41:05 <JayF> I'm going to call the meeting then. Thanks everyone! Have a good day o/
18:41:07 <JayF> #endmeeting