18:00:17 <knikolla> #startmeeting tc
18:00:17 <opendevmeet> Meeting started Tue May 23 18:00:17 2023 UTC and is due to finish in 60 minutes.  The chair is knikolla. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:17 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:17 <opendevmeet> The meeting name has been set to 'tc'
18:00:21 <knikolla> #topic Roll Call
18:00:23 <knikolla> o/
18:00:25 <dansmith> o/
18:00:33 <knikolla> Hi all, welcome to the weekly meeting of the OpenStack Technical Committee
18:00:45 <knikolla> A reminder that this meeting is held under the OpenInfra Code of Conduct available at https://openinfra.dev/legal/code-of-conduct
18:00:49 <knikolla> Today's meeting agenda can be found at https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee
18:01:13 <jamespage> o/
18:01:17 <gmann> o/
18:01:18 <noonedeadpunk> o/
18:01:30 <knikolla> Thanks JayF for covering for me last week. Just got back from PTO today and don't have any upcoming expected absences for the rest of the cycle.
18:01:35 <JayF> o/
18:01:42 <spotz_> o/
18:01:51 <slaweq> o/
18:02:53 <knikolla> #topic Follow up on past action items
18:03:06 <knikolla> I don't see any action items logged from the previous meeting
18:03:18 <knikolla> Is that correct?
18:03:32 <jamespage> I think so - it was quite a quick one
18:03:45 <gmann> yeah, no action item #link https://meetings.opendev.org/meetings/tc/2023/tc.2023-05-16-18.00.html
18:04:14 <knikolla> Thanks jamespage, Hopefully this one can be a quick one as well :)
18:04:24 <knikolla> #topic Broken docs due to inconsistent release naming
18:04:27 <knikolla> #link https://review.opendev.org/c/openstack/openstack-manuals/+/881290
18:04:30 <knikolla> This merged, thanks fungi for working on it while I was gone.
18:05:05 <gmann> one thing still to fix, release notes page is linked to #link https://releases.openstack.org/2023.1/index.html
18:05:21 <noonedeadpunk> I checked some common problem things and things looked very good to me
18:05:23 <gmann> maybe we need to redirect https://releases.openstack.org/antelope/index.html to ^^
18:05:34 <noonedeadpunk> yes, except that
18:05:46 <knikolla> Good catch gmann, I can pick that up later today.
18:05:58 <knikolla> Thanks noonedeadpunk for doing some testing.
18:06:16 <gmann> thanks, rest all are correct
18:06:35 <knikolla> #topic Gate health check
18:06:42 <knikolla> Everyone's favorite topic :) any updates?
18:07:02 <slaweq> I didn't saw any new issues last week
18:07:16 <dansmith> things seem to be going pretty decent lately. hoping the cirros bump helps with guest kernel crashes and doesn't introduce other troubles
18:07:30 <knikolla> \o/
18:07:32 <gmann> yeah, it was fine
18:08:05 <gmann> tested cirros new image in nova, neutron etc and did not notice any issue but let's ss
18:08:06 <knikolla> #topic Python 3.8 support and testing
18:08:06 <gmann> see
18:08:16 <dansmith> gmann: yep
18:08:39 <gmann> horizon change for that is also up
18:08:45 <gmann> #link https://review.opendev.org/c/openstack/horizon/+/883953
18:08:57 <gmann> there are some failure but horizon PTL is on top of it
18:09:07 <knikolla> awesome, thanks gmann
18:09:26 <dansmith> cool, I will be looking for guest crashes in the logs in open search the rest of the week to see if we notice a drop
18:09:46 <gmann> ++, thanks.
18:09:59 <dansmith> one other thing of note I guess
18:10:13 <dansmith> is the mysql memory savings merged as a default now
18:10:17 <knikolla> #topic Gate health check
18:10:22 <gmann> I think yes
18:10:28 <dansmith> so people may notice some impact there (hopefully not) but be on the lookout
18:10:38 <gmann> #link https://review.opendev.org/c/openstack/devstack/+/883863
18:10:48 <dansmith> there was also a thing in -cinder recently where they saw an OOM with a c-bak job (which is known to be heavy)
18:10:59 <knikolla> I prematurely switched the topic in a moment of silence, apologies.
18:11:02 <dansmith> so clearly didn't make a huge difference in memory usage for them I guess
18:12:10 <fungi> on friday, ihar mentioned an oom killing the database process on a devstack job for stable/yoga
18:12:20 <gmann> I think c-bak job can reduce enabling the things (services etc) and test only backup test ?
18:12:47 <dansmith> fungi: right, that's what caused us to push the default, but it won't affect stable/ unless someone backports it or a targeted change for that job
18:12:52 <dansmith> gmann: agree
18:13:16 <fungi> noted
18:13:32 <fungi> so if anyone else points it out in stable jobs, it's fixed in master for now
18:13:42 <dansmith> yeah, and actually,
18:13:56 <dansmith> backporting even the job flag to yoga would require backporting the actual devstack support for it
18:13:56 <gmann> and it can be enabled per job on stable/
18:14:05 <gmann> yeah
18:14:06 <dansmith> unless that happened and I didn't realize it
18:14:34 <dansmith> (nope)
18:14:39 <gmann> you added in 2023.1 or zed?
18:14:45 <gmann> or yoga?
18:14:59 <dansmith> it got backported to zed but not yoga
18:15:05 <gmann> k
18:15:08 <dansmith> https://github.com/openstack/devstack/blob/stable/zed/lib/databases/mysql#L166
18:15:24 <fungi> thanks, so seeing it happen on stable/yoga jobs shouldn't be surprising for now
18:15:29 <dansmith> nope
18:15:47 <dansmith> and it was on the job for which we added the flag in the first place because it's so heavy.. i.e. nova-ceph-multistore
18:15:55 <dansmith> so very unsurprsing
18:15:55 <slaweq> do we want to backport it to yoga (and maybe older branches) then?
18:16:18 <gmann> at least yoga can be good seeing xena going to EM soon
18:16:23 <dansmith> we can if we need to.. yoga is going out of support right so it's kinda meh for job maintenance IMHO
18:16:42 <dansmith> I thought it was yoga not xena that was transitioning no?
18:16:56 <slaweq> but if backport is easy and can help saving infra resources (less rechecks) then IMO we should do it
18:17:00 <gmann> it is Xena in progress #link https://review.opendev.org/c/openstack/releases/+/881254
18:17:09 <dansmith> ah no I see, okay
18:17:23 <dansmith> slaweq: fine, fine, I'll do it :D
18:17:25 <gmann> yoga going to EM might have time of a release or so
18:17:26 <knikolla> Yoga is going in EM in November.
18:17:36 <gmann> yeah
18:17:48 <slaweq> dansmith thx a lot
18:18:37 <noonedeadpunk> I think I'm blocking xena-em right now
18:19:15 <noonedeadpunk> but had to focus on merging things in time for trailing release of 2023.1
18:19:28 <gmann> k
18:20:05 <knikolla> So we should backport the memory fix to Yoga given that it still has ~4 months to go.
18:20:30 <dansmith> yeah I'm doing
18:20:39 <dansmith> so action-item me so I look useful
18:20:43 <knikolla> errr, 5. bad math.
18:21:20 <noonedeadpunk> fwiw, in OSA we spot 0 difference in ram consumption after applying the same settings
18:21:20 <knikolla> #action dansmith backport memory reduction patch for devstack to yoga and look useful doing it.
18:21:23 <fungi> we don't count august, i'm petitioning to have it removed from the calendar
18:22:09 <knikolla> fungi: i'm with you on that.
18:22:15 <fungi> years should be a prime number of months long (just like weeks are a prime number of days)
18:22:23 <fungi> and august seemed disposable
18:22:48 <JayF> fungi: Just drop all the Caesar-based months and lets get a nice even 10 ;)
18:24:14 <knikolla> JayF: lol, a new metric system for months
18:24:19 <knikolla> anything else on gate?
18:24:26 <dansmith> not from me
18:24:27 <gmann> nothing from me
18:24:50 <knikolla> great!
18:24:52 <knikolla> #topic Python 3.8 support and testing
18:25:13 <knikolla> There are two changes in flight
18:25:14 <knikolla> #link https://review.opendev.org/c/openstack/governance/+/882165?usp=search
18:25:19 <knikolla> #link https://review.opendev.org/c/openstack/governance/+/882154?usp=search
18:25:48 <knikolla> anything that would be useful to discuss in high-bandwidth?
18:26:01 <gmann> As tooz py3.8 drop is reverted, I proposed release for tooz so that we can remove the constraints hack #link https://review.opendev.org/c/openstack/releases/+/883955
18:26:31 <knikolla> ah, cool.
18:26:34 <knikolla> thanks gmann.
18:26:42 <noonedeadpunk> I failed to check patches previous week
18:27:11 <noonedeadpunk> They're really high in the to-do list though
18:27:29 <knikolla> That's alright. Feedback seems minor so should move pretty quickly once you get around to them.
18:27:33 <knikolla> Thanks for putting in the time.
18:27:42 <knikolla> Anything else on the topic?
18:28:47 <knikolla> #topic Recurring tasks check - Bare 'recheck' state
18:29:03 <slaweq> recheck stats are updated today
18:29:12 <slaweq> all seems to be fine
18:29:31 <dansmith> qa people today noted they had zero bare rechecks in the last week :)
18:29:46 <gmann> \o/
18:29:47 <slaweq> I want to modify my script to get some sort of summary about recheck reasons now and start checking those
18:29:53 <knikolla> Nice!
18:30:12 <JayF> Heh. I should maybe stop wording mine as pleas to Zuul then ;)
18:30:31 <knikolla> That seems really useful, thanks slaweq.
18:30:49 <knikolla> It seems that we can remove this recurring check from the regular meeting agenda until such work has been done?
18:30:56 <slaweq> JayF yeah, proably :D
18:31:08 <slaweq> knikolla I agree
18:31:09 <spotz_> hehe
18:31:21 <slaweq> if there will be anything worth to discuss, I will bring it up here
18:31:35 <slaweq> but we don't need to have it weekly in the agenda probably
18:31:56 <knikolla> #success No need to have a recurring item to check the statistics for "bare rechecks"
18:31:59 <opendevstatus> knikolla: Added success to Success page (https://wiki.openstack.org/wiki/Successes)
18:32:30 <knikolla> #topic Open Reviews
18:32:41 <knikolla> #link https://review.opendev.org/q/projects:openstack/governance+is:open
18:32:56 <knikolla> (open reviews and open discussion if anything has any items they want to bring up)
18:33:26 <jamespage> if anyone wanted to ask me any more questions around the proposal of sunbeam as a new project happy to answer here
18:33:49 <jamespage> the name has now been through legal review and got an OK
18:34:54 <knikolla> Thanks jamespage. I am about to press +W on the proposal.
18:35:13 <spotz_> What's the difference between this and charms?
18:35:26 <dansmith> I think it's covered in the proposal right?
18:35:46 <jamespage> yeah quite a bit of detail in the commit message about why we want to split the two apart
18:36:02 <knikolla> ++
18:36:13 <gmann> yeah
18:36:20 <JayF> spotz_: that's been asked about 4 different ways in the gerrit review. The projects are extremely close, but I didn't find that a good enough reason to -1 when the existing charms PTL agrees it should be split.
18:36:41 <jamespage> I think that's the most verbose commit message I've ever written :)
18:36:55 <spotz_> Yeah I saw that, just reminds me of all the ansible related stuff we had going for a while
18:37:34 <knikolla> For verbose commit messages I'm about to write an essay in one that you're all probably going to have to suffer through.
18:37:42 <jamespage> lol
18:37:49 <gmann> jamespage: ++, nice detail there
18:38:22 <jamespage> thx
18:39:34 <knikolla> I pushed it through, thanks jamespage.
18:39:55 <jamespage> thankyou knikolla and thanks for the reviews all!
18:40:10 <knikolla> Also of note, for those attending vancouver, we have a TC + Community Leaders interaction, which I'm tracking topics proposed for at
18:40:12 <knikolla> #link https://etherpad.opendev.org/p/tc-leaders-interaction-2023-vancouver
18:40:16 <knikolla> I'll send out an email later today
18:40:46 <knikolla> It's only a bit over an hour, so will have to keep it short.
18:41:43 <knikolla> And with that, unless there's something else, I can give you all back 20 minutes.
18:41:52 <spotz_> Thanks all
18:41:53 <slaweq> \o/
18:41:59 <slaweq> thx all
18:42:48 <knikolla> #endmeeting