#openstack-tc: tc

Meeting started by knikolla at 18:00:39 UTC (full logs).

Meeting summary

  1. Roll call (knikolla, 18:00:58)
  2. Follow up on past action items (knikolla, 18:02:25)
  3. Gate health check (knikolla, 18:02:52)
    1. https://etherpad.opendev.org/p/gate-health-2023 (knikolla, 18:06:46)

  4. Broken docs due to inconsistent release naming (knikolla, 18:11:59)
    1. https://review.opendev.org/c/openstack/openstack-manuals/+/881290?usp=dashboard (knikolla, 18:12:20)
    2. https://etherpad.opendev.org/p/docs-issues-2023 (knikolla, 18:17:10)

  5. Following new release naming convention by packagers (UCA/RDO) (knikolla, 18:19:12)
    1. https://governance.openstack.org/tc/resolutions/20220524-release-identification-process.html (gmann, 18:28:58)
    2. https://governance.openstack.org/tc/reference/release-naming.html (gmann, 18:29:16)
    3. ACTION: noonedeadpunk to propose a patch to reference that makes the recommendation for downstream packagers to use the version name rather than codename. (knikolla, 18:34:53)

  6. Schedule of removing support for Python versions by libraries - how it should align with coordinated releases (tooz case) (knikolla, 18:35:54)
    1. https://governance.openstack.org/tc/reference/runtimes/2023.2.html (gmann, 18:42:00)
    2. https://governance.openstack.org/tc/reference/project-testing-interface.html (bauzas, 18:48:16)
    3. ACTION: noonedeadpunk write the words for "The Smith Plan(tm)" (the script of the movie about changing PTI and saving the world from the dangers of getting rid of py38) (knikolla, 18:53:42)
    4. https://etherpad.opendev.org/p/the-smith-plan (noonedeadpunk, 18:56:37)
    5. ACTION: gmann send an email on ML asking project/release team to hold dropping the py38 until we get the pti change merged (knikolla, 18:57:57)


Meeting ended at 18:59:25 UTC (full logs).

Action items

  1. noonedeadpunk to propose a patch to reference that makes the recommendation for downstream packagers to use the version name rather than codename.
  2. noonedeadpunk write the words for "The Smith Plan(tm)" (the script of the movie about changing PTI and saving the world from the dangers of getting rid of py38)
  3. gmann send an email on ML asking project/release team to hold dropping the py38 until we get the pti change merged


Action items, by person

  1. gmann
    1. gmann send an email on ML asking project/release team to hold dropping the py38 until we get the pti change merged
  2. noonedeadpunk
    1. noonedeadpunk to propose a patch to reference that makes the recommendation for downstream packagers to use the version name rather than codename.
    2. noonedeadpunk write the words for "The Smith Plan(tm)" (the script of the movie about changing PTI and saving the world from the dangers of getting rid of py38)


People present (lines said)

  1. gmann (67)
  2. knikolla (65)
  3. dansmith (53)
  4. fungi (39)
  5. noonedeadpunk (38)
  6. bauzas (33)
  7. slaweq (11)
  8. jamespage (6)
  9. spotz_ (6)
  10. clarkb (5)
  11. spotz (5)
  12. coreycb (4)
  13. opendevmeet (3)
  14. JayF (3)
  15. rosmaita (2)


Generated by MeetBot 0.1.4.