16:01:02 <knikolla[m]> #startmeeting tc
16:01:02 <opendevmeet> Meeting started Wed Mar  1 16:01:02 2023 UTC and is due to finish in 60 minutes.  The chair is knikolla[m]. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:02 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:02 <opendevmeet> The meeting name has been set to 'tc'
16:01:26 <knikolla[m]> tc-members, please join on Zoom for weekly meeting
16:01:33 <knikolla[m]> #topic Roll call
16:01:36 <gmann> o/
16:01:37 <JayF> o/
16:01:38 <knikolla[m]> o/
16:01:43 <dansmith> o/
16:01:49 <noonedeadpunk> Would be great to have link as can't find it in mail
16:01:54 <JayF> https://us06web.zoom.us/j/87108541765?pwd=emlXVXg4QUxrUTlLNDZ2TTllWUM3Zz09
16:01:59 <JayF> from https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee
16:02:00 <bauzas> \o (sitting in the cave)
16:02:06 <knikolla[m]> #link https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee#Next_Meeting
16:02:18 <knikolla[m]> #link https://us06web.zoom.us/j/87108541765?pwd=emlXVXg4QUxrUTlLNDZ2TTllWUM3Zz09
16:02:32 <fungi> (it's also linked from the agenda, which is linked from the meetings.opendev.org schedule page)
16:05:05 <knikolla[m]> #topic Follow up on past action items
16:05:33 <gmann> #link https://meetings.opendev.org/meetings/tc/2023/tc.2023-02-22-16.00.html
16:12:32 <knikolla[m]> #topic Gate health check
16:12:34 <gmann> #action gmann to prepare etherpad for grenade skip upgrade job testing process/data and send email asking required projects to add job
16:14:25 <dansmith> rosmaita: https://review.opendev.org/c/openstack/tempest/+/875500
16:14:34 <dansmith> rosmaita: https://review.opendev.org/c/openstack/tempest/+/874700
16:14:42 <knikolla[m]> #link https://review.opendev.org/c/openstack/tempest/+/875500
16:14:45 <knikolla[m]> #link https://review.opendev.org/c/openstack/tempest/+/874700
16:16:37 <spotz[m]> Having connection issues
16:17:03 <knikolla[m]> no worries spotz
16:20:26 <dansmith> rosmaita: https://review.opendev.org/c/openstack/tempest/+/873653
16:20:48 <knikolla[m]> #link https://review.opendev.org/c/openstack/tempest/+/873653
16:21:01 <bauzas> was enabled in nova ceph job https://review.opendev.org/c/openstack/nova/+/874664
16:21:02 <knikolla[m]> #link https://review.opendev.org/c/openstack/nova/+/874664
16:22:35 <knikolla[m]> #topic Discussion on uwsgi alternative and if we should define wsgi standard server in PTI
16:22:50 <spotz[m]> I can’t get back in. I’ll keep trying
16:23:01 <knikolla[m]> #link https://lists.openstack.org/pipermail/openstack-discuss/2023-February/032345.html
16:23:28 <bauzas> dansmith: fwiw, I did run logsearch on our previous job runs we have and I can say it definitely fixes the oom issue :)
16:23:43 <knikolla[m]> #link https://lists.openstack.org/pipermail/openstack-discuss/2023-February/032369.html
16:30:48 <bauzas> well,
16:31:10 <bauzas> we only really care of WSGI servers that support paste pipelines
16:31:17 <bauzas> that's our real requirement
16:37:11 <JayF> > if you attempt to import uwsgi and receive an ImportError you’re not running under uWSGI.
16:37:13 <JayF> Seems like if we can run any tests at all without uwsgi, we don't have a hard dep on it.
16:37:18 <JayF> #link https://uwsgi-docs.readthedocs.io/en/latest/PythonModule.html
16:37:32 <jamespage> its not widely used
16:37:35 <jamespage> #link https://codesearch.opendev.org/?q=import%20uwsgi&i=nope&literal=nope&files=&excludeFiles=&repos=
16:38:03 <jamespage> and largely looks opportunistically imported
16:38:31 <JayF> https://opendev.org/airship/armada/src/branch/master/armada/handlers/metrics.py#L152 is an example of a hard dep, but it's not an openstack project
16:38:39 <JayF> but that's the pattern to look out for, an import uwsgi w/o a try
16:38:47 <jamespage> agreed
16:38:48 <JayF> might be worth just emailing the list and mentioning this explicitly
16:40:36 <knikolla[m]> #topic Discussion of "Add guidelines about naming versions of the OpenStack projects"
16:46:40 <bauzas> I honestely think this notation is bad "The OpenStack 2023.1 (Nova 27.0.0)" https://review.opendev.org/c/openstack/nova/+/875380/3/releasenotes/notes/antelope-prelude-4a99907b00e739f8.yaml#3
16:47:04 <bauzas> I'd rather say 'The OpenStack Nova 2023.1 release does this."
16:47:11 <dansmith> me too
16:47:39 <opendevreview> Dmitriy Rabotyagov proposed openstack/governance master: Switch project and OpenStack versions in releases  https://review.opendev.org/c/openstack/governance/+/875942
16:51:48 <opendevreview> Dmitriy Rabotyagov proposed openstack/governance master: Switch project and OpenStack versions in releases  https://review.opendev.org/c/openstack/governance/+/875942
16:59:55 <JayF> https://docs.openstack.org/releasenotes/ironic/zed.html specifically says "Zed Series (a.b.c - x.y.z.)" on the header. With the new guidelines, it'd be "OpenStack 2023.1 (Ironic a.b.c - x.y.z)".
17:00:08 <knikolla[m]> #endmeeting