15:00:10 <gmann> #startmeeting tc
15:00:10 <opendevmeet> Meeting started Thu Nov 25 15:00:10 2021 UTC and is due to finish in 60 minutes.  The chair is gmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:10 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:10 <opendevmeet> The meeting name has been set to 'tc'
15:00:17 <gmann> #topic Roll call
15:00:19 <gmann> o/
15:00:30 <strigazi> o/
15:00:42 <belmoreira> o/
15:00:42 * strigazi saw the agenda and joined
15:00:48 <gmann> USA folks (4 TC ) are on Thanksgiving holiday
15:00:54 <gmann> strigazi: hi
15:00:55 <ricolin> o/
15:02:38 <gmann> seems only 3 TC.
15:02:39 <yoctozepto> o/
15:02:43 <yoctozepto> seems 4
15:02:45 <gmann> +1
15:03:19 <gmann> let's start
15:03:26 <gmann> #link https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee#Agenda_Suggestions
15:03:30 <gmann> today agenda ^^
15:03:47 <spotz> o/
15:04:01 <gmann> #topic Follow up on past action items
15:04:08 <spotz> And apparentlly I need to update my calendar for an hour earlier
15:04:28 <gmann> spotz: +1
15:04:36 <gmann> one action item from previous meeting
15:04:37 <gmann> gmann, ricolin_ to schedule adhoc meeting for pain point discussions
15:04:46 <belmoreira> spotz :)
15:05:03 <gmann> ricolin: did you find some slot for this ?
15:05:05 <mnaser> Partial 5 :)
15:05:40 * mnaser joining in from 37000 ft
15:05:48 <gmann> +1, mnaser :)
15:05:58 <ricolin> gmann, didn't schedule any meeting, I though we gonna use TC meeting for it?
15:06:29 <gmann> ricolin: yeah, initially we planned that but doing in a adhoc special meeting like we did for RBAC can be more productive
15:06:32 <gmann> what you say?
15:06:55 <belmoreira> +1
15:06:58 <ricolin> okay, let's schedule some time next week
15:07:50 <gmann> +1, next week works fine. thanks
15:08:01 <gmann> I will keep it open till then
15:08:11 <gmann> #action ricolin_ to schedule adhoc meeting for pain point discussions
15:08:22 <gmann> #topic Gate health check
15:08:27 <belmoreira> it would be good if we involve the PTLs. A doodle with the TC members and PTLs would be great
15:08:47 <gmann> belmoreira: +1. that will be great
15:09:09 <gmann> in RBAC also we did same and having more member from community along with TC were very helpful
15:10:18 <gmann> on gate health
15:11:05 <gmann> I saw one failure occurring in few projects not other (not sure why).  sphinx error ni SQLAlchemy1.4.27 - TypeDecorator
15:11:23 <gmann> this one, #link https://review.opendev.org/c/openstack/keystone/+/818652/1
15:12:03 <gmann> I have not debugged much on this whether it is issue on  SQLAlchemy side or in our code doc string
15:12:26 <gmann> if anyone knows about it please let us know. it is happening in tacker, heat, keystone afaik
15:13:28 <gmann> other thing is zuul config error
15:13:34 <gmann> Fixing Zuul config error in OpenStack
15:14:01 <gmann> you might have seen email from clarkb #link http://lists.openstack.org/pipermail/openstack-discuss/2021-November/025797.html
15:14:23 <gmann> I have created a etherpad to track this for openstack  #link https://etherpad.opendev.org/p/zuul-config-error-openstack
15:14:59 <gmann> so that we fix it and do not forget. I will help on this sometime next week but if any other TC would like to help fixing those will be great
15:15:34 <gmann> yoctozepto: does this solve all kolla error or you need to fix few more #link https://review.opendev.org/c/openstack/kolla-ansible/+/798205
15:15:55 <yoctozepto> gmann: we are EOLing the old branches
15:16:29 <yoctozepto> I updated the etherpad
15:17:03 <gmann> yoctozepto: perfect, thanks
15:17:19 <gmann> yoctozepto: please add patch link also.
15:17:58 <yoctozepto> yeah, looking for it
15:18:06 <gmann> thanks
15:18:08 <gmann> any other thing to discuss on Gate health ?
15:18:51 <spotz> not me
15:18:57 <gmann> #topic Updates on community-wide goal
15:19:01 <gmann> RBAC goal
15:19:03 <gmann> #link https://review.opendev.org/c/openstack/governance/+/815158
15:19:40 <gmann> we discussed more bits around domain admin requirement in Yoga or not. lbragstad has uploaded the latest version
15:20:27 <gmann> dansmith: and I are more involved in the same discussion so kind of co-authors. it will be great if other tc-members can have a look into that and vote
15:20:46 <gmann> we have to merge it ASAP as yoga milestone-1 is already passed
15:21:17 <mnaser> I have to admit the contents seem very intense
15:21:46 <mnaser> And to be honest I trust in you and da smith so I may be tbh giving a RC+2 that’s delegated based on my trust in the folks who’ve worked on it
15:21:58 <mnaser> So I don’t hold things up too much
15:22:26 <spotz> I'll give it a read through llater though I've been following the discussions in channel
15:22:38 <gmann> thanks
15:23:30 <gmann> other proposed goal is 'Proposed community goal for FIPS compatibility and compliance'
15:23:32 <gmann> #link https://review.opendev.org/c/openstack/governance/+/816587
15:23:58 <gmann> I did not get chance to review, will try to do sometime next week
15:24:55 <gmann> #topic Magnum project health
15:25:13 <mnaser> Yeah nothing on that in terms of knowledge or context
15:25:27 <mnaser> Okay so about that subject
15:25:36 <strigazi> I would appreciate some context and why I was not contacted before
15:25:53 <strigazi> Or invited to this meeting for example
15:26:07 <gmann> sure
15:26:30 <mnaser> strigazi: sorry, I tried to ping on irc but no response — but the situation as I saw it was that I believe you are the only active core for magnum
15:27:08 <mnaser> Feilong and brtrkr (sp?) both left their orgs and said magnum is not a focus at their new employment
15:27:29 <mnaser> Hongbin doesn’t seem to have been doing any reviews lately which kinda leaves things up for you only
15:27:44 <mnaser> And even then I guess there’s not enough cores to merge things to start with
15:28:01 <gmann> #link https://review.opendev.org/q/project:openstack%252Fmagnum
15:28:10 <gmann> open reviews in magnum
15:28:33 <mnaser> fwiw, this wasn’t a meeting to start taking action but more of raise awareness inside tc and try to see what action items we come up with (ie someone reach out to spyros) — rather than “let’s fix it”
15:28:35 <strigazi> Wouldn't a better approach be to ping me if I need help? via the mailing list?
15:28:59 <mnaser> That would be a productive action item of this exact discussion :)
15:29:18 <gmann> strigazi: I think idea here was who all are active. and now we have more clarity that you are only one there
15:29:41 <gmann> I think ML is best way to contact then IRC ? that also work fine
15:29:41 <mnaser> This was put here because I brought it up and this was a good time for the tc to be around and know that situation for us to figure out a plan
15:29:59 <mnaser> Sorry if it came off as trying to do things behind you or anything. It’s just an early stage discussion.
15:30:03 <strigazi> I am one core, but we are 4-5 ppl dedicated to magnum at CERN
15:30:56 <gmann> strigazi: with one core, do you still have require 2 core for merging any patch or just one ?
15:30:56 <mnaser> I understand
15:31:06 <mnaser> gmann read my mind :)
15:31:21 <strigazi> We require one, best practice 2
15:31:59 <strigazi> At this state we can move fwd with one I guess
15:32:09 <strigazi> If that's ok with you as well
15:32:34 <mnaser> I’m in no position for this but I’d suggest adding other cores
15:32:38 <strigazi> I keep in mind to get a +1 from reviewers outisde CERN as well
15:32:41 <spotz> If there are more people working on it are any of them possible cores?
15:33:12 <strigazi> Jake Yip has enough knowledge
15:33:16 <mnaser> There are a few contributors I’ve seen pushing in +1s
15:33:24 <strigazi> and they are active
15:33:27 <gmann> yeah, if there are more people interested and eligible, having more core will help
15:33:40 <strigazi> I can ask around
15:33:53 <strigazi> and report in 2-3 weeks
15:34:06 <gmann> great.
15:34:07 <mnaser> I do think strigazi is the best core when it comes to knowledge and understanding of project but doesn’t hurt to have a few more in case you’re off or anything like that
15:34:15 <spotz> There might even be people who do +1s from outside CERN who would be thrilled to be asked
15:34:51 <gmann> mnaser: agree
15:35:13 <spotz> +2
15:35:24 <strigazi> spotz: at the moment I know only jake yip well enough and can vouch for them
15:35:41 <spotz> strigazi: Ok it's a start for sure to get you help
15:36:03 <gmann> let's wait for strigazi checks on more core and meanwhile it is all fine on strigazi plan to do one core (which is you) merging things
15:36:11 <ricolin> strigazi, maybe Catalyst Cloud will be interested to send another person into community?
15:36:28 <mnaser> yeah if single core merge is ok, then it’s not that much of an issue
15:36:29 <strigazi> ricolin: they said they'll be in touch when they have someone
15:36:48 <ricolin> strigazi, got it
15:36:53 <mnaser> but I was concerned is there’s not even enough cores to merge things if there was a 2 +2 rule
15:37:06 <gmann> yeah
15:37:14 <gmann> this stats two core only #link https://github.com/openstack/magnum/blob/master/CONTRIBUTING.rst
15:37:44 <mnaser> Anyways, I appreciate your work strigazi — I didn’t raise this because I didn’t think you weren’t contributing or doing your stuff — but it was more since there wasn’t as much people to help
15:37:45 <strigazi> gmann: is the best practice
15:38:03 <strigazi> gmann: the link you shared
15:38:10 <strigazi> mnaser: no worries
15:38:30 <mnaser> Sorry if it came off weird, but we’d probably actually have started to send an ML message as an action to the discussion once the tc was made aware
15:38:58 <gmann> strigazi: yeah, actually many new people might be checking that but anyways plan of chekcing new core possibility sounds good
15:39:13 <strigazi> let's do like this then, since there is interest, I can do a reviews/clean up of the backlog and looks for cores
15:39:34 <strigazi> let's do like this then, since there is interest, I can do reviews and a clean up of the backlog and look for cores
15:39:49 <gmann> +1, sounds good
15:40:01 <mnaser> yeah — we’re doing a big push for magnum here to try and make the experience more smooth with the edge cases so we’ll be submitting quite a few things here and there
15:40:04 <spotz> +1
15:40:19 <belmoreira> +1
15:40:38 <mnaser> (and while they’re all up streamed I feel bad running locks patches — since the community won’t benefit it out of the box and might get a bad taste)
15:40:54 <mnaser> Thanks for that though strigazi — much appreciated
15:41:10 <mnaser> and if you need to reach the tc I hear one of them is next door :P
15:41:20 <gmann> strigazi: really appreciate your updates/plan and taking charge of project again as PTL too.
15:41:34 <gmann> +1. anything else on this topic ?
15:41:54 <strigazi> mnaser: :) he works from home today otherwise literally next door
15:42:10 * strigazi waves to belmoreira from the office
15:42:11 <belmoreira> strigazi thanks for joining the meeting
15:42:27 <mnaser> I feel like that’s a good productive wrap up on the topic
15:42:53 <yoctozepto> indeed
15:42:58 <gmann> agree. thanks belmoreira also.
15:43:02 <strigazi> mnaser: if you want discuss a bigger push on magnum, we could do it in the ML or storyboard :)
15:43:20 <mnaser> strigazi: will do :)
15:43:30 <tobias-urdin> great to see the topic was covered and some more clarity spread around it
15:43:32 <tobias-urdin> :)
15:44:10 <gmann> #topic Adjutant need PTLs and maintainers
15:44:22 <gmann> Adjutant till need maintainer or PTL
15:44:33 <gmann> this is last I heard on ML  #link http://lists.openstack.org/pipermail/openstack-discuss/2021-November/025786.html
15:44:39 <mnaser> I think there’s as someone from Verisign
15:44:50 <mnaser> Who was waiting fir a sort of approval or something
15:44:50 <gmann> Braden, Albert, yeah
15:45:19 <gmann> yeah, I will get in touch with them and check the status. meanwhile I will keep it in agenda
15:46:00 <gmann> #topic Pain Point targeting
15:46:32 <gmann> this we already discussed to start discussion as adhoc meeting sometime next week
15:46:44 <gmann> ricolin: belmoreira anything else you would like to cover today ?
15:46:48 <gmann> on this topic
15:46:53 <ricolin> not from me
15:47:10 <belmoreira> looking forward for the meeting
15:47:26 <gmann> cool
15:47:39 <gmann> #topic Open Reviews
15:47:42 <gmann> #link https://review.opendev.org/q/projects:openstack/governance+is:open
15:47:54 <gmann> 8 open reviews
15:48:06 <gmann> RBAC, FIPs we already talked about
15:48:42 <gmann> this is goal cleanup as per new structure, appreciate the review on this #link https://review.opendev.org/c/openstack/governance/+/818845
15:49:43 <gmann> for kolla repo, mnaser can you check this project-config patch #link https://review.opendev.org/c/openstack/project-config/+/819326
15:49:44 <spotz> All links open to look at later
15:49:50 <gmann> spotz: thanks
15:50:21 <gmann> I think that is all from me today. anything else from anyone
15:50:48 <gmann> next meeting will be on Dec 2nd video call.
15:51:32 <spotz> Looks like tentatively there will be an OPS Meetup the Friday after Summiit hosted at Deutsche Telekon
15:51:55 <gmann> spotz: in June 2022 summit right?
15:52:01 <belmoreira> that's great!
15:52:10 <spotz> gmann: Yeah on 6/10 the Friday
15:52:20 <gmann> ok, sounds great.
15:53:01 <gmann> and Thanks to everyone on Thanksgiving day! and safe flight to mnaser (thanks for joining from 37000 feet :))
15:53:10 <gmann> let's close for today
15:53:15 <mnaser> Thanks guys. Take care :)
15:53:25 <belmoreira> thank you all
15:53:49 <gmann> #endmeeting