14:01:02 <mnaser> #startmeeting tc
14:01:03 <openstack> Meeting started Thu Sep  3 14:01:02 2020 UTC and is due to finish in 60 minutes.  The chair is mnaser. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:04 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:07 <openstack> The meeting name has been set to 'tc'
14:01:13 <mnaser> #topic rollcall
14:01:15 <mnaser> o/
14:01:16 <njohnston> o/
14:01:17 <gmann> o/
14:01:48 <belmoreira> o/
14:02:10 <ricolin> o/
14:02:17 <diablo_rojo> o/
14:02:42 <mnaser> so we have 6 which gives us quorum
14:04:01 * ttx takes a seat in the back
14:04:22 <mnaser> i guess that's pretty much it.
14:04:27 <mnaser> #topic Follow up on past action items
14:04:44 <mnaser> #link tc-members to follow up and review "Resolution to define distributed leadership for projects"
14:04:54 <mnaser> #undo
14:04:55 <openstack> Removing item from minutes: #link tc-members
14:04:56 <knikolla> o/
14:04:59 <mnaser> #link http://eavesdrop.openstack.org/meetings/tc/2020/tc.2020-08-06-14.00.html
14:05:09 <mnaser> tc-members to follow up and review "Resolution to define distributed leadership for projects"
14:05:29 <mnaser> there is pending comments here to be addressed: https://review.opendev.org/#/c/744995/
14:05:36 <mnaser> i think we've mostly reviewed it but waiting for revisions
14:05:55 <mnaser> next: mnaser schedule session with sig-arch and k8s steering committee
14:06:06 <gmann> only concern i have is to have 'single point of contact for TC' in new model.
14:06:31 <mnaser> i didn't do that yet because k8s world was busy with virtual kubecon so held that off until all that slowed down
14:06:41 <njohnston> yes, and on that I think we have a genuine difference of opinion, so please weigh in with your thoughts everyone
14:06:44 <mnaser> yeah, i think at least gmann comment should be addressed before being merged
14:07:14 <mnaser> next up: gmann continue to audit and clean-up tags
14:07:23 <mnaser> we have an item on the agenda about this to discuss this in a little bit
14:07:29 <gmann> yeah
14:07:30 <mnaser> so we can discuss that there, but it started/progressed
14:07:45 <mnaser> mnaser propose change to implement weekly meetings - https://review.opendev.org/#/c/749279/ done
14:07:56 <ttx> +1
14:08:03 <mnaser> oh just to make sure we dont miss them for next time
14:08:07 <mnaser> #action tc-members to follow up and review "Resolution to define distributed leadership for projects"
14:08:10 <mnaser> #action mnaser schedule session with sig-arch and k8s steering committee
14:08:19 <mnaser> ok, next up is njohnston and mugsie to work on getting goals groomed/proposed for W cycle
14:08:38 <njohnston> I have been trying to get in contact with mugsie to no avail since mid August
14:08:59 <mnaser> ah
14:09:09 <njohnston> Perhaps we could pick another person so we could get these determinations made?
14:09:29 <mnaser> njohnston: maybe worth reaching out to another volunteer in that case, perhaps on the ML we can ask?  i don't want us to try and find someone to pair with now because we don't really have everyone here
14:09:36 <mnaser> perhaps and office hour thing to bring up
14:09:43 <njohnston> +1
14:09:52 <gmann> +1
14:10:00 <mnaser> #action njohnston to find someone to work with on getting goals groomed/proposed for W cycle
14:10:16 <mnaser> next up: belmoreira start discussion around openstack user-facing apis & clis -- i believe the discussions have started on the ML a few weeks ago
14:10:31 <mnaser> (but this is also on the agenda)
14:10:38 <mnaser> so maybe we can keep that for the agenda item? :>
14:11:05 <belmoreira> yes
14:11:26 <mnaser> and also the final action item was gmann to merge changes to properly retire projects which also is an agenda item we can update on
14:11:33 <mnaser> #topic OpenStack User-facing APIs and CLIs (belmoreira)
14:11:57 <belmoreira> The discussion started few weeks ago in the ML
14:12:15 <belmoreira> and also some private msgs
14:12:25 <belmoreira> but honestly, there isn't a lot of progress here!
14:12:47 <mnaser> belmoreira: anything actionable to try and drive this more forward or just.. "not enough minerals" ?
14:12:56 <belmoreira> with the mailing list discussion it's clear that some projects/and people are "disappointed" with openstack client
14:13:16 <belmoreira> I was expecting that the openstack client team would take over the discussion but we didn't see that...
14:14:02 <belmoreira> actually I'm looking for your opinion on this
14:14:18 <ttx> yeah i fear that the most vocal in the "openstackclient team" have been away from OpenStack community for a while
14:14:48 <ttx> so the fight is noble but we are missing troops to drive it through the last hills
14:15:24 <ttx> while the python-*clients are maintained by their original teams and continue moving forward
14:15:59 <knikolla> does this seem warranting a pop-up team?
14:16:38 <fungi> i think it warrants people actually pitching in on osc
14:16:41 <gmann> i think that was the plan but belmoreira looking for few discussion/positive response over ML first
14:16:42 <ttx> Ideally it would need peopel to step up in openstackclient itself
14:16:49 <diablo_rojo> I think if we want the openstack client to replace the projects clients and the osc team needs TC support to drive it, I think so?
14:16:50 <belmoreira> knikolla, I think it's more complex than that
14:16:56 <diablo_rojo> (plus actual hands to do the work)
14:17:06 <fungi> if there are volunteers for a pop-up team, then those people should work on osc
14:17:07 <knikolla> i see, that makes sense. i haven't checked on the osc team status lately.
14:17:17 <gmann> and no big objection for projects otherwise pop-up team can end up in same situation we have been till now
14:17:43 <belmoreira> unless projects are fully commit with that, it will be very difficult.
14:17:53 <gmann> true
14:18:15 <njohnston> For projects that are supportive of the osc effort, it's a non-issue.  The problem is projects that have not fully bought in to the osc concept, and there is neither will inside the project nor sufficient capacity outside it to get them over the hump
14:19:13 <gmann> should we write somewhere the list of project do not want/or need help and then start adhoc meeting with those to move forward
14:19:31 <fungi> right, basically it needs people who are not involved in some of those service projects to reimplement their clients for them in osc/sdk because they're not interested in doing that themselves
14:19:44 <gmann> every time ML discussion end up with no actual outcome
14:19:49 <openstackgerrit> wu.chunyang proposed openstack/governance master: kolla-cli: deprecation - Mark kolla-cli as Deprecated  https://review.opendev.org/749746
14:20:06 <belmoreira> what I was thinking is if we can promote some sessions  in the PTG for this
14:20:27 <mnaser> yeah, i'm a bit at a loss at this point
14:20:34 <mnaser> if there's no one doing the work
14:20:44 <diablo_rojo> belmoreira, maybe a forum session?
14:20:45 <mnaser> i don't know if we can make it happen
14:21:01 <fungi> i think unless there are people with, for example, sufficient interest in getting glance support in osc/sdk to write the implementation themselves, this isn't going to happen no matter how much of a priority the tc says it is or who tracks the progress on it
14:21:11 <diablo_rojo> I think it would be good to have a clear picture of where each project is at, in an etherpad or something
14:21:13 <knikolla> do we have a document describing the gaps between osc and the various clients?
14:21:21 <knikolla> (apologize if there is one and i haven't looked)
14:21:46 <ttx> It's also a great area to get your feet wet in openstack development. Not very complex or coming with a lot of baggage, and gives you a horizontal view
14:21:56 <knikolla> ++ ttx
14:21:58 <belmoreira> knikolla that's a good point
14:22:07 <ttx> But yes at the very least we should have a plan that we would execute if only we had the resources
14:22:07 <mnaser> will documenting the gaps get them done
14:22:27 <ttx> then we can point newcomers at it aggressively
14:22:38 <ttx> make it a help-needed thing or whatever the name is today
14:22:46 <mnaser> we've documented many times the things that need to be done and they never ended up happening.  i'm almost at a point of saying if we took the efforts documenting these things to actually implementing them, we MIGHT have actually done something, lol
14:22:52 <fungi> documenting the gaps *might* guide otherwise available developers/organizations to places where they can provide the most benefit, but only *if* those people exist
14:22:52 <gmann> and we can get new contributors from intern etc in this if we have some expertise to drive it
14:23:12 <mnaser> if you took the $hours_to_review_and_draft_and_market the help needed docs and all the revisions and what not..
14:23:12 <ttx> Because last it was discussed, it got lost on resources need, before agreeing that it was a good idea
14:23:17 <knikolla> i also started contributing at a client first, before going into the service codebase.
14:23:45 <belmoreira> txx this also requires the openstackclient team collaboration. I personally have several patches that don't get any attention for months
14:23:46 <ttx> like we discuss "it's not ready for us to move to it yet" rather than a roadmap
14:23:54 <gmann> yeah, client, API or testing software are always better way to understand any software
14:23:56 <njohnston> this could be a good place for student help, because OSC work doesn't need a full working devstack install on a laptop, it just needs the code and the ability to get to a working OSC install elsewhere
14:24:27 <gmann> njohnston: agree
14:24:28 <ttx> belmoreira: yes, that team needs a reboot -- it's always been oldtimers with a savior complex assigning themselves to the area in need of ressources
14:24:29 <fungi> i agree that client development is a great introduction. it doesn't have as much of the cognitive overhead of async/thread calls and stuff
14:25:04 <ttx> But the last two/three oldtimers we attached to it are not very present anymore
14:25:26 <knikolla> and they were overly attached when they were
14:25:45 <fungi> it's the sort of project people wind up spearheading around the time they're already about to burn out or move on
14:25:51 <diablo_rojo> I attended the OSC stuff at the last PTG and plan to again at the upcoming one.
14:25:51 <njohnston> "openstack devs don't die, they work on osc"
14:25:59 <ttx> so I would definitely support aggressively passing the keys to whoever signs up to implement the plan, whatever it is
14:26:14 <ttx> Having a clear plan will make it less crazy to hand the keys over
14:26:34 <gmann> i think multi cycle goal can get more attention form projects to help
14:27:15 <gmann> like only goal for cycle for these projects
14:27:25 <mnaser> i hate to be the skeptic in the room
14:27:26 <belmoreira> ttx by a plan you mean first documenting the gaps?
14:27:32 <ttx> The other option would be to find a way to spread the load across existing teams, but our framework does not lend well to that
14:27:38 <ttx> belmoreira: yes
14:28:00 <mnaser> i think we're trying to do all sorts of work but ignoring the fact that, realistically, no one is jsut going to show up and do the work just because it's documented
14:28:16 <diablo_rojo> belmoreira, the OSC team might already have a lot of that data collected
14:28:16 <mnaser> i'd be happy to be correct for a scenario where we documented work to be done and someone showed up, picked it up and did it
14:28:46 <ttx> mnaser: I would be fine putting one of the students we end up having regularly to work on a documented plan with +2a
14:28:48 <diablo_rojo> I will have an intern shortly to help pick some things up
14:28:49 <knikolla> but also not documenting it is not helping. i am skeptical as well, but we can't just not do anything.
14:28:55 <diablo_rojo> but they will need direction
14:29:05 <ttx> But not so much without a clear plan
14:29:06 <diablo_rojo> so a documented list of things to do would be massively helpful
14:29:12 <ttx> diablo_rojo: ++
14:29:21 <mnaser> if we _actually_ have someone ready to work on this, then its' another story
14:29:32 <knikolla> i'd be happy to help belmoreira on documenting and pushing this. i realize i haven't signed up for much.
14:29:42 <diablo_rojo> I will have one, possibly two interns for the school year
14:29:53 <gmann> that will be good help
14:29:57 <njohnston> diablo_rojo: that's wonderful!
14:29:57 <belmoreira> I can work documenting the gaps
14:30:13 <mnaser> so belmoreira and knikolla ?
14:30:26 <gmann> and then start targetting the project by project instead if whole things at once
14:30:28 <diablo_rojo> belmoreira, cool, like I said, I would check with the OSC team to make sure they dont already have something started
14:30:49 <knikolla> ++
14:30:50 <smcginnis> There are various Google Spreadsheets/ ethercalcs out there for some projects that can give a jump start
14:30:53 <belmoreira> diablo_rojo great
14:30:57 <smcginnis> I'll see if I can find my cinderclient one.
14:31:00 <mnaser> #action belmoreira/knikolla figure out logistics of a document with gaps within osc
14:31:26 <knikolla> ^ highly parallel.
14:31:33 <belmoreira> :)
14:31:49 <diablo_rojo> I'll be around for auxiliary help belmoreira and knikolla
14:31:50 <belmoreira> how about the forum session?
14:32:01 <diablo_rojo> I think that would be a good idea too
14:32:03 <gmann> +1 on forum session
14:32:06 <knikolla> ++
14:32:09 <ricolin> +1
14:32:15 <mnaser> i know someone who might help us very easily schedule a forum session
14:32:16 <diablo_rojo> Maybe to go over the documented gaps and make sure nothings missing?
14:32:22 <diablo_rojo> LOL
14:32:33 <knikolla> the forum can also then lead into the ptg and a possible osc onboarding session.
14:32:37 <mnaser> #action diablo_rojo help schedule forum session for OSC gaps
14:32:39 <knikolla> which is the next week.
14:33:01 <diablo_rojo> knikolla, yes it can, that would be a great plan :)
14:33:18 <mnaser> cool.  can we switch contexts in the due to time? :>
14:33:25 <mnaser> i think we've progressed a ton in this small discussion
14:33:34 <diablo_rojo> Yeah sure.
14:33:43 <mnaser> #topic W cycle goal selection start
14:33:55 <mnaser> for this, i don't think there's much to discuss give njohnston has struggled to establish comms
14:34:19 <mnaser> and we have an action item to follow up on this next meeting
14:34:36 <njohnston> yep
14:34:45 <mnaser> #topic Completion of retirement cleanup (gmann)
14:34:46 <gmann> njohnston: i can help you if you do not  find anyone, consider me as default last option :)
14:34:52 <mnaser> #link https://etherpad.opendev.org/p/tc-retirement-cleanup
14:34:56 <njohnston> gmann: Thanks!
14:35:01 <gmann> retired repos cleanup are merged for README.rst consistency.
14:35:06 <mnaser> #link https://review.opendev.org/#/c/745403/
14:35:15 <mnaser> yeah it looks like only networking-l2gw is the only one left?
14:35:21 <gmann> The only project left is networking-l2gw and its tempest plugin which needs to move to other namespace than openstack/.
14:35:24 <gmann> yeah
14:35:32 <mnaser> nvm, 2 minutes ago https://review.opendev.org/#/c/749579/
14:35:44 <gmann> we are almost close to complete it too. import to the new location is done and now openstack retirement is in progress which are these 3 patches  https://review.opendev.org/#/c/749579/ https://review.opendev.org/#/c/749580/ https://review.opendev.org/#/c/738040/
14:36:01 <gmann> yeah now last on project config side
14:36:13 <mnaser> neat. cool, from tc side the governance exception revert should pass
14:36:13 <gmann> i hope we can complete it today
14:36:22 <gmann> yeah
14:36:22 <mnaser> so we can merge that and have super tidy retired repos \o/
14:36:52 <gmann> yeah, importing to new location was little more work but it is done now.
14:37:14 <mnaser> cools
14:37:22 <mnaser> next-up..
14:37:25 <mnaser> #topic Audit and clean-up tags (gmann)
14:37:25 <gmann> all users projects of networking-l2gw are moved to new location also
14:37:35 <mnaser> #link https://review.opendev.org/#/c/749363/
14:37:42 <mnaser> so ttx had some comments this morning about that ^
14:37:51 <gmann> ttx: reviewed it today and also chatted in IRC
14:39:08 <gmann> ttx said to work as follow up on defining the definition of bylaw term "The “OpenStack TC Approved Release” as resolution
14:39:47 <gmann> ttx: should i remove it from tag page or t is fine to merge it now and fix in follow up if needed ?
14:40:02 <ttx> fine to merge it as is
14:40:08 <gmann> ok
14:40:32 <mnaser> yeah i think its fine too
14:40:33 <gmann> other thing is to notify to BoD, once it is merged i can notify to projects on openstack-discuss
14:40:41 <gmann> but should we notify to BoD also?
14:41:24 <mnaser> i mean, it's probably something that we can give a heads up about
14:41:41 <mnaser> but it's something we should deal with ourselves, as in, it's our call
14:42:31 <gmann> i am ok with either way
14:43:48 <mnaser> ok well
14:43:50 <mnaser> that's pretty much it i think
14:43:54 <mnaser> #topic open discussion
14:45:25 <mnaser> anything? :)
14:45:29 <gmann> nothing from me.
14:46:23 <knikolla> i would appreciate reviews on https://review.opendev.org/722399
14:46:29 <diablo_rojo> Nothing from me
14:47:17 <mnaser> #endmeeting