14:00:12 <mnaser> #startmeeting tc
14:00:13 <openstack> Meeting started Thu Aug  6 14:00:12 2020 UTC and is due to finish in 60 minutes.  The chair is mnaser. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:15 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:17 <openstack> The meeting name has been set to 'tc'
14:00:21 <mnaser> #topic rollcall
14:00:23 <gmann> o/
14:00:24 <mnaser> o/
14:00:26 <belmoreira> o/
14:00:28 <knikolla> o/
14:00:31 <diablo_rojo> o/
14:00:35 <jungleboyj> o/
14:00:52 <mnaser> 6/11 means we're good
14:01:01 <mnaser> if i did math correctly
14:02:10 <mnaser> right, i guess we can get going
14:02:16 <mnaser> #topic Follow up on past action items
14:02:19 <jungleboyj> :-)
14:02:29 <mnaser> evrardjp & njohnston to start writing resolution about how deconstructed PTL role
14:02:35 <mnaser> does anyone know if there's anything about this?
14:02:40 <mnaser> as both are not present right now
14:02:43 <evrardjp> there is
14:02:45 <diablo_rojo> I thought I saw a paqtch last night
14:02:46 <evrardjp> something up
14:02:56 <mnaser> oh neat
14:02:56 <evrardjp> please review
14:03:14 <diablo_rojo> #link https://review.opendev.org/#/c/744995/
14:03:19 <evrardjp> sorry I was away last week, so I didn't prepare this meeting correctly
14:03:24 <gmann> #link http://lists.openstack.org/pipermail/openstack-discuss/2020-August/016336.html
14:03:26 <mnaser> tc-members ^ please dig into this
14:03:27 <gmann> ML also
14:04:23 <jungleboyj> Interesting.  I will take a look.
14:04:38 <mnaser> #action tc-members to follow up and review "Resolution to define distributed leadership for projects"
14:04:46 <mnaser> next up
14:04:48 <mnaser> mnaser to find owner to start using facing API pop-up team over ML
14:04:54 <mnaser> diablo_rojo: helped me with this
14:05:07 <mnaser> perhaps could fill in here? :)
14:05:26 <belmoreira> yes, I can help on this
14:06:24 <mnaser> cool
14:06:31 <mnaser> so afaik belmoreira has volunteered to help get this started and progressed
14:06:32 <belmoreira> I replied to the TC PTG summary, that I would like to own this. Will start discussing in the ML soon
14:06:37 <mnaser> awesome.  thank you
14:06:46 <evrardjp> thank you belmoreira :)
14:06:46 <mnaser> next up, gmann update goal selection docs to clarify the goal count
14:06:54 <diablo_rojo> I'll also probably be around to help and support belmoreira :)
14:06:55 <belmoreira> for sure I will need your guidance on this
14:07:07 <jungleboyj> belmoreira: Thanks!
14:07:20 <belmoreira> thanks diablo_rojo
14:07:20 <gmann> goal doc update is merged #link https://review.opendev.org/#/c/739150/
14:08:32 <mnaser> geat
14:08:35 <mnaser> great*
14:08:42 <mnaser> next up
14:08:43 <mnaser> gmann start discussion around reviewing currenet tags
14:08:52 <mnaser> i think this was revolving the actual tc tags
14:09:04 <gmann> yeah
14:09:26 <diablo_rojo> Yeah that sounds right.
14:09:27 <gmann> first is tc:approved-release. manila patch to claim tc:approved-release tag is merged so i can start removal of tc:approved-release as first step
14:10:08 <gmann> and next will be assert:supports-zero-downtime-upgrade where we do not have any projects having this tag and i think no testing way also
14:10:26 <jungleboyj> ++
14:10:37 <jungleboyj> If it isn't be used shouldn't keep it around.
14:10:46 <diablo_rojo> There's still zaneb's open patch on adding the k8s tag as well.
14:10:49 <mnaser> yeah, that seems good
14:10:56 <mnaser> i'm hoping to get the k8s people involved into that one.
14:11:03 <mnaser> but we didn't get a lot of info in the etherpad
14:11:05 <gmann> we need to either have some testing framework if that is doable otherwise remove
14:11:05 <zaneb> mnaser: to what end?
14:11:07 <jungleboyj> mnaser: ++
14:11:24 <mnaser> zaneb: https://etherpad.opendev.org/p/kubernetes-cross-community-topics is what we had
14:11:46 <jungleboyj> Wonder if I should put out another call to the ML on that one?
14:11:56 <mnaser> we already have traction and a response from them
14:11:59 <zaneb> so is that session scheduled?
14:12:15 <mnaser> it's up to us to do that, i haven't done it because not much has been filled
14:12:18 <mnaser> i'll go ahead and do it anyways
14:12:28 <gmann> +1
14:12:31 <mnaser> #action mnaser schedule session with sig-arch and k8s steering committee
14:12:42 <evrardjp> I think holidays, plus the fact that the call was close to a release didn't help. Maybe we can be lenient on waiting an answer?
14:12:51 <mnaser> #action gmann continue to audit and clean-up tags
14:12:58 <mnaser> they did already answer, they're waiting for us :)
14:13:03 <evrardjp> ha
14:13:06 <evrardjp> my bad, sorry.
14:13:08 <zaneb> from my perspective we have more than enough expertise here to answer the question, and I would expect that very few of the sig-arch folks know anything about openstack
14:13:17 <jungleboyj> mnaser:  When you have it scheduled would be good to send an ML note and encourage people to look at the etherpad again.
14:13:42 <mnaser> will do
14:13:55 <mnaser> and perhaps we should share knowledge with them and explain to them that nova = ec2 and hear their feedback on things
14:14:05 <mnaser> it doesn't hurt, instead of us going about our way and doing things in a silo
14:14:09 <zaneb> of course starting a regular dialog with them would be valuable for other reasons
14:14:14 <mnaser> ++
14:14:19 <gmann> true
14:14:29 <mnaser> so that they do eventually know what's going on here :)
14:14:36 <mnaser> i'll schedule it
14:14:41 <jungleboyj> :-)
14:14:49 <mnaser> next up, "mnaser propose change to implement weekly meetings" -- i did not do this, i do think we need this
14:15:37 <gmann> i think we should decide it fast as m-2 is already passed for this cycle.
14:16:46 <mnaser> it's been a bit of an annoyance because there was already a resolution to drop weekly meetings
14:17:09 <mnaser> so i kinda don't want to go through the whole process only to hear a "no" --  i think it will help our engagement cause things have been quiet lately
14:17:16 <diablo_rojo> I thought the agreement was that we were settling on changing the times of office hours first.
14:17:16 <mnaser> anyhow, i'll keep this here for me
14:17:24 <mnaser> #action mnaser propose change to implement weekly meetings
14:17:28 <jungleboyj> diablo_rojo: ++
14:17:29 <diablo_rojo> And seeing how that goes for now
14:17:43 <jungleboyj> We know that mnaser  loves meetings.
14:17:49 <mnaser> true -- and that's taken us a whole month unfortunately
14:17:51 <diablo_rojo> And then maybe formalizing one of them a bit more, but on rotation because timezones.
14:18:03 <diablo_rojo> mnaser, we've had all the results for a week ;)
14:18:03 <jungleboyj> diablo_rojo: Did we get a result from that?
14:18:04 <mnaser> and this is why we need to meet more often because ML is just not getting the right engagement
14:18:08 <knikolla> do we have new time candidates?
14:18:10 <mnaser> ok, it took 3 weeks :)
14:18:20 <gmann> yeah
14:18:35 <mnaser> yes, we do -- so i'll work with diablo_rojo on picking the most popular times
14:18:43 <jungleboyj> ++
14:18:45 <mnaser> for "diablo_rojo start discussion on ML around potential items for OSF funded intern" -- i think this one was already done
14:18:54 <diablo_rojo> Even still, we have them now and can move forward with the plan we agreed on last time rather than jumping ahead?
14:18:55 <gmann> to continue office hour or converting one of them to meeting?
14:19:10 <diablo_rojo> mnaser, it is, I thought i had removed that, did you not refresh the wiki? ;)
14:19:27 <mnaser> diablo_rojo: i go over action items from last meeting -- aka http://eavesdrop.openstack.org/meetings/tc/2020/tc.2020-07-02-14.00.html
14:19:33 <diablo_rojo> gmann, yeah that was what we agreed on last time I thought.
14:19:42 <diablo_rojo> OHHH my bad
14:19:45 <diablo_rojo> got it
14:19:56 <mnaser> whatever we end up doing needs to be consistent, i don't really mind what we call it
14:20:06 <mnaser> as long as we have quorum in that period of time, i'd be happy for a start
14:20:15 <mnaser> next we have "njohnston and mugsie to work on getting goals groomed/proposed for W cycle"
14:20:19 <gmann> i think there is no agreement on weekly meeting yet. we said to re-schedule the office hour to see how that can be more active
14:20:36 <mnaser> i'll hold on to the weekly meeting idea then
14:20:47 <gmann> humm
14:21:02 <gmann> and we might finish the cycle while deciding itself :)
14:21:45 <mnaser> anyone know anything on the 2 points above?
14:21:47 <mnaser> as they're not present
14:22:11 <gmann> on goal, I did not see ML or start collecting the ideas.
14:22:20 <mnaser> i'll keep it on the list then
14:22:21 <mnaser> #action njohnston and mugsie to work on getting goals groomed/proposed for W cycle
14:22:30 <mnaser> finally "tc and co to help finish properly and cleanly retiring projects" -- i don't think this progressed much
14:22:35 <mnaser> but we do have a topic for discussion of this later
14:22:40 <mnaser> so i dont think we can dive too deep into it
14:22:46 <mnaser> any other action items we need to follow up on that are not on the agenda?
14:24:36 <diablo_rojo> None I can think of.
14:25:52 <mnaser> #topic OpenStack User-facing APIs and CLIs (belmoreira)
14:25:56 <mnaser> belmoreira: all yours :)
14:26:32 <belmoreira> As discussed long ago in the PTG it would be great if we have a consistent CLI
14:26:48 <belmoreira> Let's interact with the different teams to understand the problems and missing pieces
14:26:53 <belmoreira> I'm happy to help
14:26:58 <gmann> +1
14:27:07 <knikolla> ++
14:27:17 <jungleboyj> ++
14:27:33 <belmoreira> Will start with an email to the ML for the discussion
14:27:45 <mnaser> i think that's a really good step
14:28:11 <diablo_rojo> Yeah I think it would be good to get a state of the union update since the PTG from the SDK/CLI team too
14:28:32 <gmann> artem is trying it since long, and was ready to volunteer for champion for goal also if we select., he can also definitely help
14:29:00 <gmann> belmoreira: will you propose the pop-up team also along with ML?
14:29:41 <diablo_rojo> Yes definitely a good resource. His input will be really valuable.
14:29:50 <jungleboyj> ++
14:29:52 <gmann> yeah
14:29:54 <njohnston> o/
14:30:19 <belmoreira> gmann Initially I was just thinking in start the discussion. I think that will come naturally after
14:30:38 <gmann> ok, make sense.
14:30:49 <mnaser> sounds good
14:30:50 <fungi> the way i've viewed the relation between pop-up teams ang goals is that the end result of a pop-up team (its dissolution criteria) would often be selection of a cycle goal
14:31:02 <mnaser> #action belmoreira start discussion around openstack user-facing apis & clis
14:31:55 <diablo_rojo> fungi, selection and not completion of the goal?
14:32:25 <fungi> the pop-up teams members would likely become goal champions, but the pop-up team doesn't really need to exist once the entire community is on board with getting the work done
14:33:34 <knikolla> hmm, interesting point of view. i've thought of the pop-up team's role as also assisting the various project teams, either through reviews and such.
14:34:13 <gmann> yeah that is correct. it is both. helping on getting the things started and then propose goal when most of projects are ready
14:34:24 <mnaser> i thin kwe can carry over the discussion into office hours
14:34:33 <mnaser> i encourage belmoreira in this effort and happy to chime in when needed
14:34:34 <gmann> yeah
14:34:38 <mnaser> next up we have
14:34:39 <mnaser> #topic W cycle goal selection start
14:34:48 <mnaser> i think we haven't had any progress on this, right?
14:34:56 <gmann> njohnston is here in case he has any
14:35:50 <fungi> (as far as "continuing discussions during office hours" keep in mind that the osf monthly community meeting is happening at the same time as today's office hour)
14:36:19 <njohnston> I have an action item to reach out to mugsie to get the review started this week
14:36:31 <gmann> note; we do have one goal (rootwrap) in proposed directory.
14:39:42 <mnaser> ok, so i guess we will stick to the same action item listed above earlier
14:39:51 <gmann> +1
14:40:48 <mnaser> #topic Completion of retirement cleanup (gmann)
14:41:02 <mnaser> #link https://etherpad.opendev.org/p/tc-retirement-cleanup
14:41:08 <mnaser> we probably haven't really done anything on this so far
14:41:27 <gmann> we did :)
14:41:32 <gmann> one is osf repos-
14:41:53 <mnaser> well that's good, that's a small dent
14:41:57 <fungi> yep, project rename maintenance happened
14:42:04 <mnaser> oh wow
14:42:05 <gmann> after interop repos, transparency-policy is also now in osf namespace and cleanup of osf repo is now merged
14:42:11 <mnaser> that's an awesome amount of patches up
14:42:17 <gmann> #link https://review.opendev.org/#/c/739291/1
14:42:43 <mnaser> ok so we can land gmann changes
14:42:46 <gmann> and for other README and gitreview cleanup i have pushed all the required patches
14:42:51 <gmann> #link https://review.opendev.org/#/q/topic:cleanup-retirement+(status:open+OR+status:merged)
14:43:11 <mnaser> that's amazing
14:43:26 <gmann> networking-l2gw is in progress which is little complex #link https://review.opendev.org/#/q/topic:complete-retirement-networking-l2gw+(status:open+OR+status:merged)
14:43:42 <mnaser> tc-members: do we just want to agree to let gmann land their own changes?
14:43:51 <fungi> it's worth a mention that, as frickler pointed out in here just before the meeting, we don't actually need to rename/convert markdown readmes to rst if we make the docs redirect just go to the root of the retired repository, since gitea will render either readme format there too
14:43:55 <mnaser> unless you'd rather someone else do it, then i think lets just single core get it over with
14:44:16 <mnaser> fungi: right except we wouldn't have the job that checks for retirements, or it would have a long list of exceptions
14:44:21 <gmann> yeah, we had chat with frickler this morning on these
14:44:25 <mnaser> this is a good way to just make it consistent properly for good
14:44:33 <gmann> but i feel for consistency we should do
14:44:34 <gmann> yeah
14:45:02 <gmann> only repo left, i think not yet initiated is openstack/python-dracclient
14:45:42 <mnaser> i'd be ok with letting gmann just merge it themselves
14:45:56 <fungi> yep, the consistency point is still a good one for simplifying the check job (at least if we consider having the check job look for either readme.rst ro readme.md additional complication)
14:45:56 <njohnston> +1
14:46:36 <diablo_rojo> +1
14:47:07 <mnaser> gmann: are you comfortable with that?
14:47:13 <gmann> mnaser: i am ok
14:47:17 <mnaser> anyhow, you can recheck my patch and see if it's unhappy after a few merges
14:47:22 <mnaser> so we don't end up merging a lot that are missing a fix
14:47:34 <gmann> yeah that is the plan
14:47:57 <mnaser> perfect
14:48:03 <gmann> and for openstack/python-dracclient, should we leave this to ironic team to decide the next step?
14:48:10 <mnaser> #action gmann to merge changes to properly retire projects
14:48:15 <mnaser> gmann: yeah, i think that's the right thing to do
14:48:24 <gmann> ok.
14:51:17 <mnaser> well
14:51:19 <mnaser> i think that's it?
14:53:04 <gmann> yeah, i think so.
14:55:01 <mnaser> cool,
14:55:03 <mnaser> thanks everyone
14:55:05 <mnaser> #endmeeting