14:00:07 <evrardjp> #startmeeting tc
14:00:08 <openstack> Meeting started Thu Dec  5 14:00:07 2019 UTC and is due to finish in 60 minutes.  The chair is evrardjp. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:09 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:11 <openstack> The meeting name has been set to 'tc'
14:00:18 <evrardjp> #topic roll call
14:00:22 <ricolin> o/
14:00:23 <njohnston> o/
14:00:24 <evrardjp> #link https://media.giphy.com/media/2YtTdoSEl4m4/giphy.gif
14:01:03 <ttx> o/
14:01:09 <diablo_rojo> o/
14:01:11 <zaneb> oh hey, this is happening :)
14:01:37 <ttx> exciting
14:01:46 <evrardjp> yes indeed
14:01:54 <jungleboyj> O/
14:01:58 <evrardjp> one missing for quorum
14:01:59 <evrardjp> woot
14:02:02 <evrardjp> we have quorum!
14:02:21 <evrardjp> just in case: tc-members the meeting has started!
14:02:36 <evrardjp> let's first start with the follow up action items from previous meeting
14:02:42 <evrardjp> #link https://media.giphy.com/media/xUA7b2z8NcgvyIthGU/giphy.gif
14:02:58 <evrardjp> :)
14:03:00 <evrardjp> #topic follow up previous action item (ricolin): SIG guideliness
14:03:01 <jroll> \o
14:03:22 <evrardjp> I meant guidelines ofc
14:03:31 <ricolin> evrardjp, we already got a patch up for that and looks might get landed anytime soon
14:03:31 <ricolin> https://review.opendev.org/#/c/695366
14:03:46 <evrardjp> nothing else to do than reviewing?
14:04:27 <ricolin> I assume only needs final approve. And will try to provide it to new SIG and see if that guideline helps
14:04:56 <ricolin> that all
14:04:58 <evrardjp> ok. Do you want to report here if that helped, at the next meeting?
14:05:06 <evrardjp> or do you want to give a little more time?
14:05:29 <ricolin> report what?
14:05:32 <evrardjp> In the latter, I will scratch that action item, and I will have that as a "longer term" action item
14:05:47 <evrardjp> report on whether it helps or not :)
14:05:55 <ricolin> evrardjp, yes
14:05:57 <ricolin> sure
14:05:59 <evrardjp> ok
14:06:03 <evrardjp> let's move on then
14:06:06 <evrardjp> #topic follow up previous action item (ttx): large scale sig
14:06:31 <ttx> The group was created and had its first meeting
14:06:49 <evrardjp> that's good news!
14:06:52 <ttx> #link https://wiki.openstack.org/wiki/Large_Scale_SIG
14:07:03 <evrardjp> is the initial attendance as expected?
14:07:04 <ttx> Two short-term objectives have been defined
14:07:12 <ttx> - Scaling within one cluster, and instrumentation of the bottlenecks there
14:07:19 <ttx> - Document large scale configuration and tips &tricks
14:07:36 <ttx> yes, pretty good turnout, essentially APAC and Europe for now
14:08:00 <ttx> Now we'll see if the excitement holds
14:08:14 <evrardjp> sounds good
14:08:15 <ttx> I'll help drive it until it can fly by itself
14:08:33 <ttx> Next meeting in two weeks
14:08:34 <evrardjp> maybe jroll could help on the America's side?
14:08:36 <evrardjp> ok
14:08:52 <evrardjp> do you want to do a status report in a few months?
14:08:54 <cloudnull> o/
14:09:04 * ricolin expect Line team will shows up in Large scale SIG:)
14:09:07 <ttx> Well for now it is a bit convenient not to have anyone from teh US from a meeting org perspective, so I'm not exactly chasing more down
14:09:15 <evrardjp> I see
14:09:22 <ttx> LINE, YAhoo!Japan, CERN, China Mobile...
14:09:37 <evrardjp> :)
14:09:43 <ttx> StackHPC
14:09:50 <ttx> OVH
14:09:56 <evrardjp> yeah definitely europe/apac
14:10:08 <evrardjp> report next month to see how this flies?
14:10:22 <ttx> I like that those were not necessarily very invested upstream before
14:10:25 <ttx> So we'll see
14:10:29 <ttx> sure
14:10:32 <evrardjp> that's good news indeed :)
14:10:59 <evrardjp> I will keep the topic for next month if you don't mind
14:11:06 <ttx> wfm
14:11:09 <evrardjp> that looks important to keep an heartbeat on
14:11:13 <evrardjp> ok next
14:11:15 <evrardjp> is gmann there?
14:11:29 <evrardjp> or mnaser?
14:12:08 <evrardjp> I will skip the two topics of them for now, moving to ricolin again then :)
14:12:11 <evrardjp> #topic ricolin report on multi-arch sig and other sigs
14:13:20 <ricolin> For multi-arch we got a great number of people shows their interest on, which means there's definitely value to form it asap
14:13:31 <evrardjp> nice to hear
14:13:53 <evrardjp> would that be joined by the power folks, combined by the people you know focusing on ARM?
14:14:05 <ricolin> rigth now we have Linaro to provide around 10 server, which might get online early next year
14:14:17 <jungleboyj> Nice.
14:14:25 <evrardjp> nice indeed
14:14:31 <ricolin> still looking for more:)
14:14:46 <ricolin> evrardjp, that's good idea, I should ask them
14:14:48 <evrardjp> did you ping tonyb for his opinion on this? He might be able to provide you contacts
14:15:11 <ricolin> evrardjp, yes, he also replied the ML too
14:15:14 <ricolin> #link http://lists.openstack.org/pipermail/openstack-discuss/2019-November/010970.html
14:15:20 <evrardjp> awesome!
14:15:24 <ricolin> he's onboard!
14:15:25 <evrardjp> I missed this, sorry
14:15:28 <evrardjp> amazing
14:15:29 <ricolin> NP
14:15:33 <evrardjp> oh yeah I remember now
14:15:48 <evrardjp> ok cool
14:16:03 <evrardjp> is there anything else that we should be aware or that we can help, regarding SIGs?
14:16:13 <evrardjp> (not necesarily the multi-arch one)
14:16:14 <ricolin> I will take action to contact to Infra team to see if we got more ARM server in our Nodepool
14:16:30 <ricolin> We got two thing going on in SIGs
14:16:40 <evrardjp> that might be good to discuss with mnaser about that too, as he is already very involved in infra
14:17:01 <mnaser> eh, timezones are confusing.  hi, i'm here.
14:17:02 <evrardjp> (he is kinda our liaison to deal with the static hosting story that I wanted to chat here)
14:17:03 <ricolin> One is we're tagging SIGs to match their current state https://review.opendev.org/#/c/695625/
14:17:09 <ricolin> #link https://review.opendev.org/#/c/695625/
14:17:31 <ricolin> another is the combine of self-healing SIG and auto-scaling SIG discussion
14:17:46 <ricolin> #link http://lists.openstack.org/pipermail/openstack-discuss/2019-November/010989.html
14:17:55 <mnaser> turns out most of static hosting was actually done by andreas, i'm working on figuring out the next steps.
14:18:14 <evrardjp> mnaser: yeah we'll come to that soon, we're finishing the report on what's going on in sigs
14:18:50 <evrardjp> (if there is more to say)
14:18:57 <ricolin> nope
14:19:08 <ricolin> that's all
14:19:12 <evrardjp> haha ok
14:19:25 <evrardjp> thanks for the work there ricolin
14:19:30 <ricolin> also ttx been promote to meta-sig core
14:19:35 <evrardjp> oh great!
14:20:10 <evrardjp> do we need to track the merger of those sigs (self healing and auto scaling) ?
14:20:23 <evrardjp> I suppose you could do a little summary at next meeting?
14:20:34 <evrardjp> (you = ricolin or ttx)
14:20:48 <ricolin> I will do it since I'm driving that atcion too
14:20:54 <evrardjp> ok perfect
14:21:03 <evrardjp> nice to see progress there!
14:21:30 <evrardjp> ok let's go to one of the many topics for mnaser then
14:21:37 <evrardjp> #topic mnaser report on the infra liaison
14:21:43 <evrardjp> what's happening with the static hosting?
14:22:02 <evrardjp> is there more to say than what you said above?
14:22:06 <mnaser> there's not much to report, turns out andreas has done a lot of the work and we were blocked for a while with the afs volume being pending creation and some infra patches pending to merge
14:22:16 <mnaser> so there's not much progress but we've also been blocked for waiting for a bit too
14:23:05 <evrardjp> can anyone around here help on that, or is there tribal knowledge that will be prevent people from this team to step up?
14:23:14 <evrardjp> or any other blocker
14:23:24 <evrardjp> I am just curious on how to help this forward
14:23:45 <mnaser> it was blocked on the infra team because of afs things and job creation (i.e. openstack/project-config patches)
14:23:55 <mnaser> they didn't have the infrastructure ready for us (yet)
14:24:00 <evrardjp> oh I see
14:24:33 <evrardjp> I will keep this in the topics for next meeting, so we track if it's still blocked on infra side, ok for you?
14:24:41 <mnaser> sure
14:25:03 <evrardjp> in the meantime, I suppose you're pinging on this to track the status update?
14:25:26 <mnaser> i'm sorry, i don't follow
14:25:34 <evrardjp> (just to know that both teams aren't waiting for each other at some point)
14:25:48 <mnaser> no, i'm not pinging the infra team, afaik they just finished their work a day or two ago
14:25:51 <evrardjp> "oh but we did that, you can go ahead now"
14:26:05 <evrardjp> I see
14:26:19 <evrardjp> so this work can be unblocked soon then?
14:26:30 <mnaser> hopefully
14:26:31 <evrardjp> (sorry if I ask stupid questions, it's because I am not sure to have full context)
14:26:32 <evrardjp> ok
14:26:33 <evrardjp> cool
14:26:38 <evrardjp> let's talk about that next meeting
14:26:43 <mnaser> it's being taken care of :)
14:26:55 <evrardjp> yeah, sorry for checking! :p
14:27:11 <evrardjp> ok next
14:27:21 <evrardjp> #topic mnaser report on sync with swift team
14:27:25 <evrardjp> I had this topic pending
14:27:29 <mnaser> i think that should have been removed a while back
14:27:34 <evrardjp> it was on py3, I think we can remove
14:27:38 <evrardjp> ok
14:27:41 <evrardjp> sounds good
14:27:59 <evrardjp> next
14:28:00 <evrardjp> #topic ttx report on Technical vision reflection update
14:28:15 <evrardjp> #link https://media.giphy.com/media/Y4tXwMTNHStfxDxduD/giphy.gif
14:28:22 <ttx> I have not started that yet. I hope to get it going early January
14:28:34 <evrardjp> ok
14:28:37 <ttx> so that I can report about it at next meeting
14:28:51 <ttx> I might start it end of December tho
14:29:11 <evrardjp> that would be good, if you want to discuss about it in January
14:29:16 <evrardjp> holidays and stuff :)
14:29:32 <evrardjp> ok
14:29:59 <evrardjp> next
14:30:02 <evrardjp> #topic mnaser summary of the maintain issue with Telemetry
14:30:26 <mnaser> it seems like catalyst picked up ceilometer work and ran away with it
14:30:28 <evrardjp> I still have that in the topics, it was discussed in the PTG, continued over ML
14:30:30 <mnaser> like, literally, ran away with it
14:30:41 <mnaser> other projects suggested working together to leverage their backends
14:30:55 <mnaser> and the current roadmap for ceilometer is "add the api again, add mongodb support again, go back in time"
14:31:18 <jroll> :/
14:31:19 <evrardjp> I remember a tweet pointing to that ML thread indede
14:31:24 <evrardjp> yes.
14:31:35 <mnaser> https://storyboard.openstack.org/#!/story/2006893
14:31:51 <mnaser> https://storyboard.openstack.org/#!/story/2006894v
14:32:06 <evrardjp> mnaser: did we start a conversation with them, to engage into not running back in time? :p
14:32:24 <mnaser> i tried to politely steer the convo in the ML
14:32:39 <evrardjp> #link https://storyboard.openstack.org/#!/story/2006894
14:32:42 <evrardjp> #link https://storyboard.openstack.org/#!/story/2006893
14:32:46 <jroll> fwiw, I know we discussed putting metrics directly in prometheus at some point, I did some poking at that, and the python client is... not awesome. gets weird with multithread/process wsgi runners, and doesn't do any sort of quantile metrics (I was surprised this is up to the client, not the server)
14:32:52 <mnaser> and i think i got a "this is what the ceilometer team is doing."
14:33:01 <jroll> but just a data point, we'd need to do some work there first
14:33:08 <mnaser> and then there was a few other proposals from other teams like monasca to integrate
14:33:34 <evrardjp> jroll: this was the next topic as a smooth transition :)
14:33:39 <mnaser> that were ignored, i asked for an update on what was the final decision, no answer, yoctozepto did as well (2 days ago) -- nothing. http://lists.openstack.org/pipermail/openstack-discuss/2019-December/011337.html
14:33:44 <evrardjp> mnaser: :/
14:33:50 <jroll> aha, I shall wait
14:34:11 <mnaser> http://lists.openstack.org/pipermail/openstack-discuss/2019-November/011236.html
14:34:14 <mnaser> asked on nov 28
14:35:05 <evrardjp> I see it didn't really result in new stance
14:35:11 <mnaser> http://lists.openstack.org/pipermail/openstack-discuss/2019-November/010972.html
14:35:35 <mnaser> that is where it starts to feel concerning tbh
14:35:51 <mnaser> "we're going to maintain and support our use case"
14:36:13 <jroll> I wonder if they're unwilling to support monasca/etc, or just saying it works well
14:36:16 <mnaser> yes i get it, this is open source, no one is entitled, but we also ask people to do whats best for openstack, not whats best to maintain your legacy piece of code
14:36:23 <evrardjp> isn't that fair though? Are they refusing code from others?
14:36:27 <jroll> wonder if lxkong is around
14:36:32 <mnaser> its probably late there
14:36:34 <jroll> yeah
14:36:42 <zaneb> 3.30am
14:36:52 <evrardjp> jroll: agreed, that's basically my question
14:36:59 <mnaser> anyways, i don't want to sit and send emails to the entire ML every other day if there's no reasonable outcome that that the tc has any influence obn
14:37:04 <ricolin> I don't think that means they will refusing others
14:37:19 <mnaser> if you're going to invest all that time
14:37:20 <zaneb> on one hand, it's fair to say that if nobody else is contributing, they'll contribute what they want to contribute
14:37:23 <evrardjp> mnaser: not being an official project is the only thing we can do, but this is not something I want to arrive to right now
14:37:33 <evrardjp> and that's only if it's not open to contributions
14:37:37 <mnaser> might as well as invest it in the right way
14:37:39 <ricolin> zaneb, true
14:37:49 <mnaser> zaneb: yeah personally im torn on that
14:37:58 <zaneb> on the other hand, who is going to show up and contribute when they're making it clear that they're only interested in maintaining their legacy stuff from 5 years ago?
14:38:01 <mnaser> "do the right thing if you're gonna do the work anyways" vs "anything better than nothing"
14:38:11 <evrardjp> zaneb: yes indeed
14:38:58 <evrardjp> also if it works for them, could that work for others? just curious
14:39:18 <zaneb> I think we should discuss with them whether they could continue to meet their goals as an unofficial project
14:39:29 <evrardjp> zaneb: it will not be the only project to be single vendor in openstack :p
14:39:41 <mnaser> adding the api back is a serious change in direction
14:40:02 <zaneb> because I don't see that they're getting great benefit from it being in OpenStack, and for other people it's only creating confusion
14:40:23 <ttx> evrardjp: we could also force a PTL change, but that's also nuclear and it's not as if we had likely candidates
14:40:32 <evrardjp> I agree, but as TC we probably shouldn't intervene on the project, but helping on the ecosystem, and I haven't seen evidence it's not helping the ecosystem as a whole right now
14:40:47 <zaneb> if they're ok with it leaving OpenStack officially, then our job is relatively easy
14:40:56 <jungleboyj> Yeah.
14:41:05 <zaneb> if not then we have some hard discussions to have
14:41:13 <jungleboyj> Is there a precedent for forcing at PTL change?
14:41:17 <evrardjp> I don't want to go there though -- I know it's a radical change for users, but is it for a bad thing for the ecosystem?
14:41:25 <ricolin> I been promised by telemetry PTL of a status report, we should ask some questions to them to clarify the current status
14:41:35 <mnaser> lets not go down the forced PTL change route discussion
14:41:44 <zaneb> yes, let's not
14:41:45 <jungleboyj> mnaser:  ++
14:41:47 <gmann> o/, sorry i missed the time change thing.
14:41:50 <evrardjp> ricolin: good idea, and if it still benefits everyone in the community would be a nice question
14:41:52 <njohnston> mnaser++
14:41:56 <jungleboyj> Ok, wanted to make sure that others felt that way.
14:42:06 <evrardjp> mnaser: agreed
14:42:21 <mnaser> we're discussing the issue much more than trying to gather an update
14:42:28 <mnaser> does anyone wanna come up with some next steps
14:42:34 <evrardjp> ricolin: just did
14:42:51 <evrardjp> well
14:42:55 <mnaser> ok, so ricolin has an action item of getting a status update, id hope before the next meeting cause that would mean a month of work (in maybe) not the ideal direction.
14:42:55 <evrardjp> between the lines :)
14:43:17 <evrardjp> ok you want a status update before next meeting
14:43:27 <evrardjp> that sounds good, can we discuss this at next week's office hours?
14:43:29 <mnaser> i dont want one, i think it would be beneficial, because a month is a long time
14:43:34 <evrardjp> that's fair
14:44:14 <ricolin> Wondering if there's any other resources/info. we need from them?
14:44:43 <ricolin> besides status update
14:44:50 <evrardjp> ricolin: I guess what would matter for mnaser would be having a good chat of what's going on, why the decision -- while people seem so eager to not do that
14:45:05 <evrardjp> wow my english is terrible
14:46:04 <evrardjp> I think users need answers on the direction taken, to know how they can contribute or not. And if it's not the direction that some people want to take, ensuring that the voices are heard
14:46:10 <ricolin> evrardjp, it's better than your chinese:)
14:46:12 <mnaser> given my constant complaints about magnum (which ended up cleaning up a lot of it's stuff), i did really end up feeling pretty awful in the whole thing because it pushes people
14:46:35 <mnaser> and the employer of this PTL is the same as the magnum one at the time, so id rather sit and talk from the sidelines
14:46:45 <evrardjp> ok
14:46:58 <ttx> I wonder if someone should not raise the situation again (not mnaser) to show that the concern is a TC concern
14:47:16 <mnaser> i assume that s/not/now/
14:47:36 <ttx> now raise, not mnaser yes
14:48:07 <ricolin> I will take that action tomorrow and asking for the status report too from PTL:)
14:48:09 <evrardjp> ricolin: I can do that with you, as my chinese is awful :p
14:48:18 <evrardjp> let's sync on that
14:48:25 <ricolin> yes, definitely
14:48:27 <ttx> it can only help if the person is close to teh APAC tz, so +1
14:48:39 <ricolin> ttx evrardjp sweet!
14:48:55 <evrardjp> #action ricolin evrardjp talk with PTLs about the direction of telemetry (see meeting log for detailed AP)
14:49:08 <evrardjp> #topic mnaser report on oslo metrics project
14:49:18 <evrardjp> jroll: you also wanted to say a few words about this?
14:49:41 <jroll> I'll let mnaser speak first, I just have some recent experience with prometheus here
14:49:52 <mnaser> i didn't progress on this, i think bnemec is not as involved in openstack-y things and he spoke with the LINE team, maybe ttx can help with the intro/sharing of the code :<
14:50:18 <jroll> was LINE using prom, IIRC?
14:50:24 <mnaser> yeah
14:50:28 <mnaser> i think?
14:50:31 <jroll> cool, I'd love to see the code
14:50:33 <bnemec> Yeah, we talked in Shanghai. We're waiting on them to propose the new library and make the code available.
14:50:41 <evrardjp> ok
14:50:48 * ttx checks notes
14:50:48 <jroll> as I mentioned before, the official python client for prom has some problems that make it not ideal for usage in openstack
14:50:56 <jroll> but they seem relatively solvable
14:50:59 <ricolin> they got a presentation for their structure, back in summit
14:51:16 <evrardjp> jroll: can you push from your side to see the code, so I can ask you in a month how is this going?
14:51:19 <evrardjp> that would be amazing
14:51:31 <ricolin> bnemec, is there any update from them now?
14:51:32 <ttx> yes, os.metrics instrumenting oslo.messaging to send to Prometheus
14:51:43 * ricolin knows it still early to ask
14:52:05 <jroll> evrardjp: I have no contacts there, all I could do is ask on the ML, not sure if that's helpful
14:52:13 <evrardjp> argh
14:52:22 <bnemec> I don't think they're using prometheus from the OpenStack side, they're just exporting metrics in a way it can consume.
14:52:56 <evrardjp> jroll: maybe bnemec has :p
14:53:11 <evrardjp> and he seems just here
14:53:22 <evrardjp> :D
14:53:23 <bnemec> They did a presentation during the forum. Can probably contact those folks.
14:53:29 <evrardjp> awesome!
14:53:49 <evrardjp> I think if you can contact them, and introduce to jroll that would be the first step
14:54:10 <gmann> jroll: you can reach out to dinesh (he used to be on irc, i can check his irc name)
14:54:15 <jroll> I don't want intros, only code
14:54:16 <jroll> heh
14:54:31 <evrardjp> fair
14:54:35 <jroll> I am happy to reply in an email chain about how excited I am to see the code, if that will motivate them
14:54:37 <evrardjp> but those ppl can give you links
14:54:54 <evrardjp> ok let's settle for that then
14:55:28 <evrardjp> #action jroll to use his email client to see code
14:55:33 <evrardjp> ahem ahem
14:55:36 <jroll> -.-
14:55:53 <evrardjp> oh come on, that was hilarious.
14:56:01 <ttx> "."
14:56:04 <fungi> tough crowd
14:56:15 <evrardjp> ok we have so many things
14:56:18 <evrardjp> let's continue
14:56:29 <evrardjp> #topic gmann report on community goals for U/V/py2 drop/rolling to py3/goal select process schedule
14:56:30 <ttx> good thing we have an office hour to go deeper
14:56:39 <jungleboyj> *sad_trombone.wav*
14:56:46 <evrardjp> jungleboyj: :)
14:56:57 <evrardjp> I will give you gifs
14:57:00 <evrardjp> #link https://media.giphy.com/media/3oEhn3lV6Yk1Ku6WRi/giphy.gif
14:57:01 <gmann> Ussuri goal update: 1. py2 drop - this is going on, many services has merged the patches and other are in progress. This is in good progress. 2. PTl and Contributor guide- goal is not yet merged - https://review.opendev.org/#/c/691737/
14:57:20 <evrardjp> oh wait, a better python drop
14:57:22 <evrardjp> #link https://media.giphy.com/media/zzkFADpR7k2NG/giphy.gif
14:57:30 <gmann> I have only one concern left there is to have template for PTL guide so that projects can maintain the conssitency
14:57:37 <gmann> consistency
14:57:44 <evrardjp> diablo_rojo: ^
14:58:18 <jungleboyj> gmann:  ++
14:58:24 <diablo_rojo> gmann, I think that there were concerns that having as its own separate document might be too time consuming for a small amount of people
14:58:41 <gmann> because not all read the expectation till we have the defined template . for example projects does not read the py drop schedule and start dropping the py2 from python client lib also and i have to -1 them every time
14:58:44 <diablo_rojo> I also think that there may not be that much different than needs to be mentioned?
14:59:04 <diablo_rojo> Also that its fine living in CONTRIBUTING.rst because being a PTL is form of contribution
14:59:18 <evrardjp> gmann: arrgh
14:59:33 <gmann> diablo_rojo: i think common PTL guide we have currently does not reflect all PTL works.
14:59:38 <diablo_rojo> (I think I also wrote all/most of this in the review of the template yesterday)
14:59:58 <diablo_rojo> gmann, no? Well that should probably get updated with all the common work that PTLs do them
15:00:10 <diablo_rojo> Only the project specific stuff should live in the template
15:00:14 <evrardjp> ok let's talk one topic at a time, now talking about the U - PTL goal part
15:00:17 <gmann> ok, we can discuss that in office hour.
15:00:26 <evrardjp> we are in the office hour basically :)
15:00:27 <diablo_rojo> Lol sorry
15:00:30 <gmann> :)
15:01:04 <gmann> V goal-  zuulv3 goal is under review which we decided to have as pre-selected as V cycle
15:01:24 <evrardjp> ok that's good
15:01:25 <gmann> goal schedule - I am going to propose the schedule up by today.
15:01:31 <evrardjp> thanks
15:01:38 <gmann> that's all from my side
15:01:44 <evrardjp> for all those points (before we circle back to the problems), do you need any help?
15:02:05 <gmann> we are good on these.
15:02:09 <evrardjp> ok
15:02:26 <gmann> we will discuss more on PTL goal next in office hour
15:02:42 <evrardjp> you mean next week?
15:02:53 <evrardjp> or is my agenda broken?
15:03:05 <gmann> today
15:03:08 <evrardjp> or after the meeting
15:03:09 <evrardjp> ok
15:03:11 <evrardjp> got it
15:03:14 <gmann> yeah after meeting
15:03:22 <evrardjp> sounds good, I need to accelerate then
15:03:47 <evrardjp> #action gmann discuss about the issues in the U goals at the next office hours
15:03:50 <evrardjp> #topic jungleboyj update on the blog post about the analysis of the Foundation user survey
15:04:09 <jungleboyj> :-)  I have this in my sprint plan for the week.
15:04:13 <evrardjp> jungleboyj: are you there? Do you have an eta? :p
15:04:15 <evrardjp> woot
15:04:17 <evrardjp> awesome
15:04:26 <jungleboyj> So, should have something for this next week.
15:04:31 <evrardjp> I am writing that down for next meeting
15:04:38 <jungleboyj> evrardjp:  Sounds good.
15:04:46 <evrardjp> mugsie: are you there?
15:04:53 <evrardjp> it's for the next topic which also takes time
15:04:55 <evrardjp> #topic mugsie update on release naming progress
15:05:30 <evrardjp> I want to put this to bed
15:05:35 <evrardjp> it's been far too long
15:05:36 <smcginnis> ++
15:05:49 <jungleboyj> evrardjp: ++
15:05:57 <evrardjp> I thought we reached consensus during PTG, but I was wrong
15:06:01 <ttx> What's the standing objection at this point ? Not enough votes?
15:06:24 <evrardjp> gmann: thinks it's not respecting opinions of the people, if I am not mistaken
15:06:52 <evrardjp> which leads to me to think it's possible to invert the things: tc proposes names and community votes
15:07:09 <evrardjp> instead of the opposite: community propose names and tc votes
15:07:18 <evrardjp> though it will still make the life of the voting complex
15:07:22 <smcginnis> I liked the community proposed named better.
15:07:28 <smcginnis> *names
15:07:42 <jungleboyj> smcginnis:  Agreed.
15:07:44 <mnaser> smcginnis: +9million
15:07:51 <zaneb> evrardjp: that would be a ton more work for the TC
15:07:53 <evrardjp> me too, as it was also transparent for which tc member has voted, so it was still transparent for members
15:07:57 <jungleboyj> I thought that that is the important thing.
15:08:01 <evrardjp> ok
15:08:07 <evrardjp> so we are all in agreement again
15:08:19 <evrardjp> I am glad. Let's vote in majority for this and make it
15:08:26 <gmann> only issue I have is let community decide the final name and anything else is all fine to me(who choose the name etc)
15:08:31 <zaneb> speaking with my community member hat on, the fun part is looking for names
15:08:38 <ttx> zaneb: yes
15:08:48 <mnaser> wait what are we voting in majority for?
15:08:48 <jungleboyj> zaneb: ++
15:08:51 <zaneb> voting is boring and the outcome is usually terrible no matter who chooses it
15:09:04 <fungi> also conducting a vote of the entire community has a lot of rough edges
15:09:07 <jungleboyj> We may get some heat for the votes, but that is part of the work of leadership.
15:09:09 <smcginnis> zaneb: ++
15:09:13 <ttx> mnaser: community propose names and tc votes
15:09:17 <smcginnis> Could care less about voting on it.
15:09:23 <ttx> mnaser: I know you disagree :)
15:09:41 <mnaser> ill make my own little twitter poll
15:09:43 <smcginnis> Community elects TC, TC picks the name.
15:09:51 <mnaser> and then the community can have my vote if im on tc
15:09:51 <ttx> mnaser: sure, that works too
15:09:51 <mnaser> :P
15:09:57 <smcginnis> And the community can lobby for their preferences.
15:10:05 <gmann> that is what current proposal in review is so what is difference
15:10:20 <evrardjp> yeah people circled to the current proposition
15:10:23 <ttx> We should definitely try to pick the community's consensus rather than our personal preference
15:10:24 <evrardjp> because they like it
15:10:30 <ttx> if they differ
15:10:41 <jungleboyj> Makes sense.
15:11:14 <evrardjp> I think we'll never get a full "I agree on this proposal" and this sounds the best we ever had on the topic
15:11:31 <evrardjp> I propose we continue with the current proposal
15:11:32 <jungleboyj> evrardjp:  ++
15:11:33 <ttx> I want it changed before we get to W
15:11:42 <evrardjp> ok
15:11:48 <ttx> and this one fills the bill. Not my preferred option, but I can live with it
15:11:55 <jungleboyj> Yeah.  We need to move foward.
15:12:07 <evrardjp> I am sorry if it doesn't please some people here, but it's the one that gets the most ppl "ok"
15:12:14 <evrardjp> it's the "compromis a la belge"
15:12:26 <evrardjp> noone is really happy with it, but it works on average
15:12:32 <jungleboyj> I beg your pardon?  ;-)
15:12:32 <evrardjp> ok let's move on
15:12:48 <gmann> ttx: if i understand your comment. you mean to get vote from community on that review ?
15:13:00 <gmann> or get their opinion via ML
15:13:40 <ttx> gmann: try to pick a name that seems to be supported by the community, rather than your own unique preference
15:14:02 <ttx> i.e. not a time to be original, more a time to try to sense what would please / represents the community
15:14:02 <gmann> ohk
15:14:03 <evrardjp> it involves tc members talking to the community
15:14:14 <ttx> Which is somethign we did every time we bent the rules in the old system
15:14:26 <ttx> like to propose "Train"
15:14:28 <mnaser> i hate to be that guy, but (to my disagreement) we mentioned those meetings are status updates, not full on discussions on what we want to do.  i'm not opposed to changing the theme but just want to be aware of time
15:14:32 <gmann> which is very difficult :) this is kind of getting their vote in different way
15:14:35 * mnaser doesnt want to walk out but also has $things
15:14:47 <evrardjp> fair
15:14:52 <evrardjp> you're right mnaser
15:14:54 <jroll> mnaser: ++
15:14:55 <ttx> ok, moving on let's close tat meeting
15:14:56 <evrardjp> let's move on
15:15:06 <mnaser> this is healthy office hours discuss imho
15:15:13 <mnaser> s/discuss/discussion/
15:15:14 <evrardjp> #topic ttx update on a possible merge tc/uc
15:15:16 <ttx> Not started yet, expecting to start the discussion in January after the ops meetup. Will report next meeting.
15:15:20 <evrardjp> mnaser: agreed
15:15:23 <evrardjp> ok
15:15:33 <evrardjp> #topic evrardjp report on the concepts repo
15:15:48 <evrardjp> crazy ideas*
15:15:57 <evrardjp> not done, I will work on it during my holidays next week
15:16:07 <evrardjp> #topic extra topics
15:16:14 <evrardjp> #info evrardjp patches pending
15:16:20 <evrardjp> we have plenty of patches pending, please vote
15:16:27 <evrardjp> like plenty plenty
15:16:44 <evrardjp> #info mnaser summary on the stable branch policy discussion since summit
15:17:42 <evrardjp> (this is the last item for the report, we can close the meeting afterwards -- I have at least two topics to talk in office hours -- the tc election dates, and a reflection)
15:17:56 <mnaser> we seem to have come to some sorts of consensus, i am finding time to draft up a change to openstack/governance soon, the consensus seems to be "stable teams are kept as is, stable cores can add other stable cores"
15:18:05 <evrardjp> ok
15:18:08 <evrardjp> sounds good
15:18:23 <evrardjp> no report next month, as I suppose you'll draft up the change, ok?
15:18:30 <jungleboyj> Sounds good to me.
15:18:36 <evrardjp> thanks everyone!
15:18:40 <jungleboyj> Thanks!
15:18:43 <zaneb> can we have one volunteer to retroactively vote for https://review.opendev.org/681266 for compliance?
15:18:44 <evrardjp> #endmeeting