14:00:49 <ttx> #startmeeting tc
14:00:50 <openstack> Meeting started Thu Jul 11 14:00:49 2019 UTC and is due to finish in 60 minutes.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:51 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:53 <openstack> The meeting name has been set to 'tc'
14:00:57 <ttx> Hi everyone!
14:01:01 <ttx> #link https://giphy.com/gifs/hello-minions-waving-wAVA7WdV2jita/fullscreen
14:01:10 <fungi> troll call ;)
14:01:10 <gmann> o/
14:01:19 <ttx> Who in tc-members is here for the TC meeting?
14:01:19 <lbragstad> o/
14:01:24 <mnaser> o/
14:01:26 <dhellmann> o/
14:01:28 <TheJulia> o/
14:01:32 * mugsie is double booked, but wathcing
14:01:32 <fungi> aloha
14:01:38 * fungi double-booked too
14:01:45 <fungi> oh, no, not for another hour
14:01:47 * TheJulia is also double-booked
14:01:49 <fungi> focused then!
14:01:51 <ttx> mugsie: come over here, I was relying on your GIF game
14:01:59 <mugsie> :D
14:02:04 <ttx> OK, let's start easy
14:02:09 <ttx> #topic Follow up on past action items
14:02:13 <ttx> 1/6 Health check changes
14:02:20 <ttx> asettle to update community (done), fungi to update wiki (done), mugsie to update yaml file with liasons and mnaser to update the tooling
14:02:36 <mnaser> mugsie: picked up the tooling so thanks :)
14:02:51 <ttx> OK so this is in the pipe, right
14:03:04 <mugsie> mnaser: yeah, I totally forogt you were going to do it, and neeed to populate the yaml to test so I wrote a thing :)
14:03:48 <ttx> Status: Under review
14:04:05 <ttx> #link https://review.opendev.org/#/c/668004/
14:04:06 <mugsie> http://replygif.net/i/716.gif
14:04:14 <ttx> 2/6 Help-most-needed list
14:04:24 <ttx> AlanClark and zaneb to update investment opportunities document
14:04:33 <ttx> Not sure what the status is there
14:04:41 <ttx> A bunch of things were merged for sure
14:05:15 <gmann> so for 2019, only glance is there. are we going to add others also in that ?
14:05:27 <fungi> that's part of the rewrite activity
14:05:35 <ttx> gmann: plan was to convert them and add them all to 2019
14:05:41 <fungi> glance was just first in the queue
14:05:45 <ttx> Status: work in progress
14:06:00 <ttx> 3/6 Goal selection
14:06:01 <gmann> ok. I am going to add that in my slide for openstack day tokyo next week.
14:06:06 <ttx> lbragstad to prune the community-goals etherpad
14:06:09 <ttx> #link https://etherpad.openstack.org/p/community-goals
14:06:15 <lbragstad> yeah
14:06:15 <ttx> lbragstad: how is that going?
14:06:17 <lbragstad> that's done
14:06:21 <ttx> Status:Done
14:06:23 <lbragstad> #link http://eavesdrop.openstack.org/irclogs/%23openstack-tc/%23openstack-tc.2019-06-06.log.html#t2019-06-06T15:35:13
14:06:31 <lbragstad> i removed the obvious ones
14:06:41 <ttx> 4/6 Pop-up teams
14:06:45 <ttx> ttx to define pop-up teams
14:06:46 <fungi> lbragstad: it does seem a good deal shorter than the last time i looked
14:06:49 <ttx> https://giphy.com/gifs/spongebob-spongebob-squarepants-episode-12-3ohzAi9KJLc5Vi9CPm/fullscreen
14:06:59 <ttx> That is done. However we may want to assign a TC "liaison" for the Image encryption team
14:07:07 <ttx> Any volunteer?
14:07:44 <fungi> can put me down as volunteer for that
14:07:55 <ttx> Great, thanks fungi
14:08:02 <fungi> i've been trying to keep the security sig in the loop on what's going on there anyway
14:08:15 <ttx> #action fungi to add himself as TC liaison for Image Encryption popup team
14:08:29 <ttx> Status: Done
14:08:34 <ttx> 5/6 Explaining governance
14:08:40 <ttx> ricolin has produced a draft
14:08:42 <ttx> #link https://review.opendev.org/#/c/668093/
14:08:48 <ttx> I posted a -1 because I feel like it's presenting things backward
14:08:50 <ttx> ricolin: I can help reorganize it to my liking, if you want
14:08:58 <ricolin> I just update the patch according to comments
14:09:08 <ricolin> ttx sure
14:09:12 <ttx> ah, jinxed
14:09:12 <ricolin> that will be super
14:09:18 <ttx> Will rereview
14:09:21 <ttx> Status: Under review
14:09:33 <ttx> 6/6 Review PTL Guide
14:09:38 <ttx> https://review.opendev.org/#/c/665699/ was merged
14:09:41 <ttx> Status: Done
14:09:55 <ttx> Any comment on those past action items?
14:10:57 <ttx> https://media.tenor.com/images/c32c6ff16cd7fb47769c87f2eb5e95f4/tenor.gif
14:11:07 <ttx> dammit
14:11:27 <ttx> https://tenor.com/view/green-cola-no-gif-9810848
14:11:39 <ttx> #topic Active initiatives
14:11:44 <ttx> 1/3 Python 3
14:11:51 <ttx> mnaser to sync up with swift team on python3 migration and mugsie to sync with dhellmann or release-team to find the code for the proposal bot
14:12:00 <ttx> What's up on that?
14:12:13 * mugsie didn't do it
14:12:26 <fungi> concise!
14:12:36 <mnaser> i've personally been looking from the sidelines, it looks like things are progressing well and it seems like some effort/help from rh is coming in to help iron all these out
14:12:49 <ttx> ok, let's carry that over
14:13:03 <ttx> Status: In progress
14:13:09 <ttx> 2/3 Forum follow-up
14:13:13 <ttx> ttx to organise Milestone 2 forum meeting with tc-members
14:13:16 <ttx> That will happen in the coming weeks
14:13:22 <ttx> Status: In progress
14:13:28 <ttx> 3/3 Make goal selection a two-step process
14:13:32 <ttx> We need reviews at
14:13:34 <ttx> #link https://review.opendev.org/#/c/667932/
14:14:01 <ttx> Any comment on active initiatives? Anything missing?
14:14:14 <ttx> Status: under review
14:14:23 <mugsie> I like the 2 step process doc
14:14:50 <gmann> i have not reviewed it yet. need to get more background on that.
14:14:59 <ttx> I hope it will solve the approval/refinement/selection bottleneck
14:15:12 <ttx> doing everything in a single review has proven... inefficient in the past
14:15:14 <mugsie> we need to make sure we graduate some idea into the proposed bucket when we merge
14:15:52 <dhellmann> I think that was part of the point of having lbragstad prune the existing etherpad, wasn't it?
14:15:59 <fungi> gmann: we discussed it at the forum/ptg but it's basically a way to keep us from getting stuck on full quorum voting of implementation details for goal approval
14:16:06 <ttx> we need some intermediary sandbox for ideas to mature before being selected basically. And separate goal submission from goal selection reviews
14:16:34 <evrardjp> shouldn't be a different "kind of topic" with more lenient reviews? I thought we agreed on that
14:16:37 <ttx> since we select a set of goals together, not just individual proposals independently
14:17:09 <ttx> evrardjp: yes we said that refining a goal should be approved leniently
14:17:10 <fungi> evrardjp: yeah, the implementation plan was going to be handled under documentation review process while the goal ideas would still be under formal vote
14:17:33 <evrardjp> fungi: funny I thought it was otherwise
14:17:43 <ttx> Anyway, feel free to ask further questions on the review for everyone to benefit
14:17:52 <evrardjp> I thought the proposal of the idea was lenient, but the validation was to be a strict proposal
14:18:11 <ttx> evrardjp: depends on what you mean by "validation"
14:18:12 <fungi> evrardjp: selecting cycle goals is the formal vote, deciding how many widgets a thingamabob needs to meet the goal requirement under some circumstance is just documentation
14:18:43 <ttx> ultimately you select them with a strict vote
14:19:06 <evrardjp> on that we agree, those selected for a cycle are following a strict vote
14:19:07 <fungi> so it should be easier to fix/amend the implementation details, after the goal itself is approved
14:19:15 <gmann> I feel without having implementation details it will be difficult  to have clear pic of goal . example osc-client goal.
14:19:54 <ttx> gmann: that is why you wait until the implementation is more detailed before selecting them.
14:20:10 <fungi> right, i stated them in reverse chronological order
14:20:13 <ttx> but improving the goal becomes an incremental process
14:20:45 <ttx> OK, onto our two topics of discussion for today
14:20:51 <ttx> #topic Update on U release naming process
14:20:58 <fungi> sorry. improve/amend implementation details in the repo (as documentation reviews), prior to goal selection (which is the formal vote)
14:21:03 <mnaser> (sorry for being a complete pita in that process)
14:21:03 <ttx> There is a bit a confusion with the plan here -- in particular the WeChat activity to select China-friendly names
14:21:13 <ttx> Can anyone give us an update?
14:21:45 <gmann> fungi: +1.
14:22:05 <ttx> (personally at this point I would go with any name the China community likes)
14:22:21 <evrardjp> I am like ttx on this
14:22:39 <fungi> yes, i'm inclined to just approve a non-conforming name that has some community consensus and is unencumbered and non-offensive
14:23:10 <mnaser> i agree with ttx
14:23:15 <mnaser> i think right now the best thing to do is let the process happen on its own
14:23:18 <fungi> we're fast coming up on a cycle which will otherwise end up being called "unnamed"
14:23:24 <evrardjp> agreed with fungi, that's so elegantly said, who can refuse? :D
14:23:25 <ttx> mnaser: is the wechat poll supposed to come up with candidate names ?
14:23:29 <mnaser> and if there are proposals that are "out of normal criteria"
14:23:33 <mnaser> they can be proposed like train
14:23:34 <dhellmann> so the only way to vote would be the wechat poll?
14:23:34 <jroll> unnamed would be quite appropriate
14:23:35 <ricolin> ttx I'm pushing that part now but most people from china community wechat group agree on the list I give last time
14:23:54 <evrardjp> dhellmann: wait what?
14:24:04 <ttx> dhellmann: no
14:24:09 <dhellmann> evrardjp : I'm not sure, I don't understand what's happening :-/
14:24:10 <dhellmann> ok, good
14:24:16 * ricolin looking for the name list
14:24:17 <dhellmann> so the poll is what, then? coming up with suggestions?
14:24:17 <fungi> i thought the wechat bit was asking the community there for suggestions of names
14:24:17 <ttx> That would select a shortlist and we'd put that to our usual voting
14:24:22 <dhellmann> ok
14:24:33 <ttx> Just making sure all candidates on the ballot are "good"
14:24:43 <dhellmann> ok, got it
14:24:47 <ttx> So select between their top picks
14:25:18 <dhellmann> that works for me, and aligns with a comment I made in channel earlier when I suggested we formalize a "local contributor" selection committee for names in the future
14:25:21 <ttx> ricolin: my point is, it's also OK to add non-geographic-but-very-popular-in-china options to the list, imho
14:25:33 <gmann> +1, easy and less controversial way
14:25:35 <ricolin> location: Urumqi Ussri(Ussri River)Ulanqab Ulanhot Ulansu(Ulansu sea) Urad (乌拉特中旗) Ujimqin(东/西乌珠穆沁旗)Ula (Ula nara)
14:25:35 <ricolin> others:Unnamed Undefined Unique Unicorn Undead Uncle Umpire Utopia umbrella ultimate
14:25:42 <dhellmann> yeah, please let's just get a list of 5-10 names and start voting
14:26:16 <ricolin> These are raised from WeChat group, but not formal voting yet
14:26:18 <ttx> I'm just afraid we put 3 chinese names and "unnamed" on the list and our US/EU community selects unnamed out of familiarity
14:26:39 <ttx> and we miss an opportunity
14:26:52 <dhellmann> yeah, I think unnamed and undefined have negative connotations and I would not support including those on the ballot
14:27:08 <gmann> me too. we can avoid those
14:27:09 <mugsie> ttx: the vote is only an "indicative vote" right? We don't have to take it if we feel there is an issue with the name
14:27:12 <ttx> unicorn would work, if people in China end up liking it
14:27:14 <fungi> we should probably limit voting to geographical/place names if we have enough to make a reasonable length ballot with them
14:27:31 <ttx> mugsie: yes there is still a... marketing filter
14:27:40 <ttx> + a trademark one
14:27:50 <ttx> but that is done after the ranking
14:28:16 <evrardjp> but who doesn't like a unicorn?
14:28:18 <mugsie> I personally would not put unnamed on the ballot at all
14:28:20 <ttx> Like "Unupgradeable" would probably not make it
14:28:27 <ricolin> the most popular are Ussri and Urumqi IIRC
14:28:31 <evrardjp> ttx: oh surprise?!
14:28:38 <fungi> one benefit of ranked voting. you can safely eliminate ineligible candidates after the poll closes without significantly mipacting the relative popularity of the remainder
14:28:55 <ttx> Undead maybe...
14:28:57 <evrardjp> ricolin: ussr-i?
14:29:09 <fungi> i was hoping for unpossible... oh well
14:29:17 <evrardjp> fungi: haha
14:29:23 <evrardjp> I guess we completely disgressed now
14:29:53 <fungi> naming the bikeshed
14:29:57 <evrardjp> anyway, is there something to decide?
14:29:59 <ttx> ricolin, mnaser: so.. what is the next step ? Wechat activity ranking a top 5 options and then us vetting that list, and putting it into a vote?
14:30:07 <ricolin> evrardjp, it' Russian
14:30:36 <ricolin> ttx I do plan for such thing, but when will be the deadline for it?
14:30:45 <ttx> ricolin: I'd say ASAP
14:31:02 <evrardjp> ricolin: https://www.youtube.com/watch?v=a1Y73sPHKxw
14:31:12 <fungi> our technical election officials need to plan our upcoming elections, and need a cycle name to associate with those
14:31:26 <fungi> which was a big part of the urgency on this
14:31:39 <mnaser> if we put an arbitrary say
14:31:44 <mnaser> next wednesday is that ok?
14:31:53 <ttx> oh sure
14:32:23 <mnaser> do we want to just do a resolution to say that for this release
14:32:24 <ricolin> ttx Horace said he will use official wechat for the polling activity, not sure how that goes for now
14:32:27 <ricolin> will check
14:32:30 <mnaser> we'll be accepting anything that's "china" related
14:32:39 <mnaser> so that is atleast landed by the time we have suggestions so they're all 'valid'
14:32:43 <ttx> and popular with the Chinese community
14:32:46 <mnaser> not to delay things any longer?
14:32:57 <ttx> ++
14:32:59 <mnaser> thatll give it the week it needs for formal-vote
14:33:02 <mnaser> ok, i'll work on that
14:33:06 <mnaser> o'
14:33:12 <ricolin> +1
14:33:22 <mnaser> i'll use the train thing as the template and urge tc-members to vote asap so we can have its grace period
14:33:30 <mugsie> ++
14:33:34 <gmann> +1
14:33:43 <ricolin> +1
14:33:46 <ttx> ok, sounds like we have a way forward
14:33:57 <fungi> awesome, thanks!
14:33:57 <ttx> Did not want to stall it until Tony is back from vacation
14:34:13 <ttx> Next topic...
14:34:15 <ttx> #topic What are retired repos ?
14:34:21 <ricolin> evrardjp, https://en.wikipedia.org/wiki/Ussuri_River
14:34:56 <mnaser> context: i started work on a ci job that checked if a repo was properly retired because we had some disagreements on landing a governance change if the repo was retired (or not)
14:35:16 <fungi> we use the term "retired" to mean several different things in different contexts
14:35:39 <mnaser> yep, that's what surfaced in the ML thread with a bunch of projects that acutally still are somewhat maintained, with commits, but not "official"
14:35:49 <dhellmann> being "out of governance" and "retired" are different
14:35:51 <evrardjp> ricolin: thanks for the link, TIL :)
14:36:04 <mnaser> our governance does not reflect that difference right now, afaik
14:36:04 <fungi> there are also repos which have been "retired" from use in master but still have stable branches maintained
14:36:19 <ttx> should we use different terms then
14:36:29 <dhellmann> mnaser : our governance only reflects being in or out of governance, which seems appropriate.
14:36:31 <gmann> but as per new namespace, are we going to maintain anything non official under openstack/ namespace. that is most confusing part
14:36:35 <fungi> we likely should start by (don't hit me) coming up with new names for some of those concepts?
14:36:53 * mnaser is going to be playing devils advocate
14:36:55 <evrardjp> well I have the impression it's a per branch thing _again_
14:37:06 <mnaser> that means we no longer -1 things if there is no retirement commit
14:37:13 <mnaser> dhellmann: ^
14:37:56 * mnaser is just trying to find a thing we can all agree too for project-update retirement changes
14:38:13 <dhellmann> mnaser : We could say that. Or we could look at each case, and decide what to do based on what the intent is. If we want to encourage folks to follow the full retirement process, we could keep repos under governance until they have done that. If they don't intend to retire the repo, then we don't need to do that.
14:38:35 <evrardjp> dhellmann: +1
14:39:11 <fungi> in the past (before we switched to just using the openstack namespace for everything) the idea was that if a project became unofficial it would have to be renamed out of the openstack namespace. i think that has some problems of its own now that we have redirects in place, since it becomes a lot less obvious to source code consumers when something stops being a part of openstack
14:39:33 <evrardjp> historically OSA for example, has waited for things to be empty on all branches before asking for a retirement, and that was fine
14:39:49 <dhellmann> evrardjp : we've seen problems in other projects that didn't do that
14:40:30 <evrardjp> dhellmann: could those problems have been solved by the right docs? Saying how to properly retire something over time?
14:40:32 <gmann> yeah. out of governance means it should be out of openstack/ namespace. because cmg to governance is cmg under openstack/ namespace
14:40:38 <fungi> being listed in governance means that commits to that repository's stable branches still count as contributions to openstack
14:40:47 <dhellmann> I think our lives would be simpler if the retirement process required that, but that's not what's confusing here, right? It's that we have projects that left governance with the intent to retire and then didn't, or that left governance with the intent to keep running and weren't renamed.
14:41:12 <evrardjp> dhellmann: I guess I misunderstood the problem :p
14:41:26 <dhellmann> evrardjp : the problem you mentioned is related, but not the same
14:42:00 <dhellmann> the first question in my mind is, do we have someone willing to go around and fully retire the repos that look like they have been abandoned?
14:42:12 <fungi> yes, i've in recent years come to the conclusion that we should be forcing projects who want to leave openstack to fork, so we can replace the content in the version which remains behind in the openstack namespace with a notice saying it's no longer part of openstack and where it has gone or what has happened
14:42:23 <dhellmann> and the second question is, do we have someone willing to follow fungi's suggestion and enforce a fork for all of the repos that left governance and are still active?
14:42:31 <evrardjp> fungi: agreed.
14:42:40 <smcginnis> fungi: That is how I've seen some non-OpenStack projects handle that.
14:42:46 <fungi> i don't know that there's a ton of benefit to doing that for historical exits, but for future ones i do
14:43:07 <evrardjp> what is the workload we are talking about?
14:43:18 <evrardjp> I am fine working on cleaning things up
14:43:22 <dhellmann> we should write down this new policy as a formal governance document
14:43:38 <mnaser> i sent a mailing list post with all of the things that "should be retired"
14:43:42 <evrardjp> ofc, else it would be unpossible to apply said policy
14:43:48 <fungi> in cases like fuel where they left openstack and then within a year stopped working on the project but still had users who were becoming increasingly out of date and exposed and thought they were still using openstack software, i think that damage is probably already done. cleanup might be nice but doesn't fix things
14:43:48 <evrardjp> (see what I did there?)
14:44:18 <mnaser> the change https://review.opendev.org/#/c/669549/
14:44:31 <mnaser> http://logs.openstack.org/49/669549/2/check/openstack-tox-linters/4084f9c/job-output.txt.gz#_2019-07-06_17_42_15_763974
14:44:34 <mnaser> the list
14:44:41 <gmann> other example is networking-l2gw which was out of governance (neutron stadium) but in active developement under openstacl/netowkring-l2gw
14:45:13 * mnaser thinks dhellmann approach makes sense of saying if we have someone to go and do this first
14:45:15 <dhellmann> networking-l2gw sounds like a case where we should encourage them to fork to create a new repo
14:45:22 <mnaser> ++
14:45:23 <evrardjp> dhellmann: the more we are discussing this, the more I am wondering if this shouldn't be int he project-team-guide instead
14:45:34 <fungi> for projects which have already been removed from our governance but are still lingering in the openstack namespace, we should probably give them one last opportunity to rename out of the namespace
14:45:36 <dhellmann> evrardjp : process docs, yes, but policy docs no
14:45:47 <mnaser> dhellmann: at the time, my intention was to post to the ML in the hopes that the projects/teams themselves pick it up and take care of it
14:45:50 <evrardjp> on that we agree.
14:46:26 <fungi> retroactively imposing a requirement to fork on them is not super friendly
14:46:32 <gmann> fungi: yes but they are not aware of that. we should communicate them about renaming
14:46:34 <dhellmann> rename, then?
14:46:41 <ricolin> fungi, including rename on Pypi?
14:46:48 <mnaser> pypi doesnt inclue a prefix
14:46:55 <mnaser> things on pypi aren't openstack/foo (afaik)
14:46:59 <fungi> ricolin: there are no namespaces on pypi
14:47:19 <evrardjp> are we focusing on the right things for the right people? I want to make sure if we are making a policy, it's for clarity of the users, not to have a policy
14:47:20 <fungi> (that is a separate conversation the pypi maintainers and users seem to have ~annually)
14:47:56 <mnaser> ok lets take a step back, someone has to retire the abandoned projects first
14:48:15 <mnaser> those have to be done regardless of policy or whatever, they're actually retired projects
14:48:16 <fungi> evrardjp: i think the "policy" is simple (only current official projects in the openstack namespace). the *process* for ensuring that is what needs fleshing out
14:48:30 <evrardjp> so 1) define abandonned project, 2) create a policy about moving them out of governance
14:48:43 <mnaser> does anyone feel like maybe going over those projects and making commits to retire them properly?
14:48:52 <mnaser> or at least following up with the teams to do so?
14:49:16 <mnaser> (some people felt very strongly we don't merge anything that was 'retired' but had code, so perhaps a good time to help enforce this :) )
14:49:17 <fungi> i do think that the process for the current cases (historical removals) can and probably should follow a different process from what we want to do going forward
14:50:05 <mnaser> i don't like this, but alternatively, we can enforce retired-on in legacy.yaml and have the checks only check those past a date, but then we'd have two sets of rules :)
14:51:05 <fungi> i my opinion projects who have already left openstack can be renamed into a different namespace if their maintainers wish it, and then we tell all official projects that any which leave openstack in the future have to fork so we can retire the openstack namespace repo with a prominent notice
14:51:27 <dhellmann> that works for me -- let's get that written down as a resolution or something
14:51:44 <gmann> +1. that will be  very clear for everyone
14:52:00 <ricolin> +1
14:52:10 <fungi> maybe give existing teams a deadline too in case they have some they want to move out of openstack before that rule goes into effect, though that's less important in my mind
14:52:37 <ttx> Alright, who is taking that todo?
14:52:39 <mnaser> dhellmann: just wanna double check the wfm comment is re what fungi  said?
14:52:59 <dhellmann> mnaser : yes, I like his proposal but think we should write it down formally before acting on it
14:53:10 <fungi> i will draft a resolution later today
14:53:21 <mnaser> thanks fungi -- i can try helping with the logistics once it lands
14:53:27 <fungi> appreciated!
14:53:34 <ttx> #action fungi to draft a resolution on proper retirement procedures
14:53:36 <mnaser> talking to teams / getting abandonded code properly retired / renaming things (if needed)
14:53:55 <ttx> #topic Open discussion
14:54:02 <fungi> i'll attempt to encapsulate the historical context for the decision as well
14:54:07 <ttx> Next meeting should in theory be on August 1st but that may be a bit too close from now.
14:54:14 <AlanClark> hey ttx slow reply. I contributed several suggestions to the Glance investment opportunities document.   I also also sent suggestions for the documentation document. Are there others?
14:54:18 <ttx> I was wondering if having next ones on August 8 and September 5 would not spread them out more evenly.
14:54:39 <mnaser> seems reasonable
14:54:48 <fungi> AlanClark: no new ones yet i don't think, though expect a few more in coming months
14:54:56 <evrardjp> AlanClark: would you mind reiterate on a new one? :D
14:54:57 <ttx> AlanClark: there will be others we'll propose a rewrite from. I suspect we'll call you for input on those when ready
14:55:03 <mnaser> thanks for being involved AlanClark
14:55:10 <AlanClark> thanks
14:55:11 <ttx> yes that really helps
14:55:12 <lbragstad> ++ thanks AlanClark
14:55:18 <evrardjp> thanks for the help indeed :)
14:55:21 <mnaser> in other related open topics ,i wanted to ask which tc-members plan/might/will be in shanghai?
14:55:29 <ricolin> thanks AlanClark:)
14:55:34 <fungi> we did also get that first one promoted in the osf newsletter yesterday
14:55:37 <fungi> #link https://superuser.openstack.org/articles/osf-newsletter-july-9/
14:55:38 <ttx> mnaser: I plan to be there, pending visa acceptance
14:55:40 <mugsie> I am planning on it, looks likely I will be there
14:55:44 * mnaser wanted to fill out the ptg tc form
14:55:49 * jroll will not be there
14:55:50 <gmann> mnaser: I will be there (yet to start the visa process though)
14:55:52 <mnaser> how much min/max time do we feel like we want?
14:55:55 <ricolin> definitely:)
14:55:56 * lbragstad is TBD
14:56:00 <evrardjp> mnaser: I do not know yet
14:56:01 <dhellmann> I am not planning to attend
14:56:03 <mnaser> i think last time a day was .. okay
14:56:03 <ttx> #info next TC meeting: August 8
14:56:13 <ricolin> https://i.imgur.com/kzC6MOx.gif
14:56:36 <evrardjp> ricolin: I am glad you're here for sending the gifs :)
14:56:39 <fungi> mnaser: if my visa is approved (and assuming no natural disasters at home this year) then i'll be there
14:57:06 <mnaser> i'm trying to see if we're going to have enough of us there to actually need a ptg-one-day-meeting like we had
14:57:14 <ttx> I'd say 0.5 min/1 day max
14:57:16 <ricolin> evrardjp, I can't resist!
14:57:53 <mnaser> i think that's reasonable ttx
14:58:03 <mnaser> 10-15 people room probably?
14:58:24 <dhellmann> if it's a public meeting, we should allow for observers
14:58:24 <gmann> round chair one right ?
14:58:28 <ttx> we might have others come in.. maybe 18-20
14:58:32 <mnaser> or maybe 20ish i guess
14:58:41 <ttx> That PTG is so full of unknowns
14:58:44 <mnaser> ok, fair nuff, i think i have all that i need to give kendall.
14:58:47 <mnaser> yeah..
14:58:52 <ricolin> mnaser, 18-20 sounds reasonable, counting observers
14:58:56 <fungi> yeah, we have in the past had as many observers as tc members present. no idea if it will be the case again in shanghai
14:59:20 <fungi> who knows, maybe our chinese community are curious about what an elected governing body actually looks like in the flesh
14:59:31 <ricolin> will we be able to get extra chairs if we needed?
14:59:43 <mnaser> i think so
14:59:43 <ttx> I hope it will encourage more to run
14:59:55 <ttx> so it's a bit of a publicity exercise too
15:00:00 <fungi> i agree
15:00:10 <ttx> not a formal onb-boarding, but a bit like it
15:00:20 <mnaser> voila, sent it over, thanks
15:00:21 <ttx> "this is what the TC does" by example
15:00:27 <fungi> show folks how we operate, yeah
15:00:41 <ttx> Alright, we are done here
15:00:45 <ttx> #endmeeting