14:00:23 <dhellmann> #startmeeting tc
14:00:23 <dhellmann> #link http://lists.openstack.org/pipermail/openstack-discuss/2019-January/002231.html agenda for this meeting
14:00:24 <openstack> Meeting started Thu Feb  7 14:00:23 2019 UTC and is due to finish in 60 minutes.  The chair is dhellmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:25 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:28 <openstack> The meeting name has been set to 'tc'
14:00:28 <lbragstad> o/
14:00:32 <dhellmann> #topic roll call
14:00:32 <dhellmann> tc-members, please indicate if you are present for the logs
14:00:38 <gmann> o/
14:00:39 <TheJulia> o/
14:00:43 <mnaser> bonjour o/
14:00:53 <evrardjp> o/
14:00:54 <dhellmann> zaneb has given the second best reason I've seen so far for missing a meeting: "on an expedition to climb an active volcano"
14:00:56 <cdent> ahoy
14:00:57 <ttx> o/
14:01:03 <mnaser> the first best reason being?
14:01:08 <TheJulia> I was just looking at zaneb's reason, and that is epic.
14:01:40 <dhellmann> call me a romantic, but I think when TheJulia missed for her wedding that was a longer term investment in adventure
14:02:05 * TheJulia smiles
14:02:07 <mnaser> ++\
14:03:01 <evrardjp> dhellmann: :)
14:03:04 <TheJulia> Anyway, seems like time to carry on
14:03:05 <dhellmann> I count 8, so we have quorum
14:03:09 <dhellmann> let's start with old business
14:03:15 <dhellmann> #topic correction to TC member election section of bylaws
14:03:16 <evrardjp> TheJulia: don't be so shy :p
14:03:24 <dhellmann> #link https://wiki.openstack.org/wiki/Technical_Committee_Tracker#Correction_to_TC_member_election_section_of_bylaws
14:03:32 <dhellmann> during the most recent foundation board election the foundation membership also voted on a number of bylaws changes,
14:03:32 <dhellmann> including the ones fungi had been tracking related to how TC members are elected
14:03:32 <dhellmann> I think it's now safe to consider that initiative completed, and remove it from the tracker. Do you all agree?
14:03:53 <evrardjp> yes
14:03:54 <lbragstad> ++
14:03:55 <ttx> +1
14:04:06 <mnaser> congrats on the multiyear effort :)
14:04:07 <gmann> yeah
14:04:36 <dhellmann> #action dhellmann remove bylaws update from the tracker
14:04:44 <dhellmann> easy enough
14:04:50 <dhellmann> #topic project team evaluations based on technical vision
14:05:01 <dhellmann> last month cdent and TheJulia agreed to work on initiative to have teams self-evaluate against the technical vision document
14:05:02 <dhellmann> what's the status of that effort?
14:05:36 <TheJulia> I believe 3?? teams have written self evaluations, with fairly positive feedback on each. Truthfully this past month I've been burried in other work and have not had a chance to follow it closely
14:05:38 <cdent> as far as I can tell the teams that TheJulia and I are associated with did some self-evaluation, which led to a small change to the vision to clarify its orientation but not much more than that. TheJulia ?
14:05:46 <cdent> Oh, 3?
14:05:59 <TheJulia> I think cinder, ?manila?, and Ironic
14:06:03 <fungi> oh, i missed roll call, but i'm here
14:06:08 * TheJulia always capitalizes the I
14:06:20 <cdent> placement has a vision reflection document in progress, but it hasn't had much review
14:06:35 <TheJulia> I might be off on my count, but it was not pushed, so for organic I think that is kind of good.
14:06:42 <dhellmann> shall we carry this over to next month, then?
14:07:02 <TheJulia> I think so yes, I should be able to find some more time this next month with no travel (i hope..)
14:07:02 <mnaser> dhellmann: perhaps add #link http://lists.openstack.org/pipermail/openstack-discuss/2019-January/001417.html for reference as well ?
14:07:20 <dhellmann> mnaser : good point
14:07:23 <cdent> Assuming we think the goal of getting the documents written is still relevant, then yes, we should carry it
14:08:10 <dhellmann> are there any specific actions for between now and our next meeting?
14:08:11 <lbragstad> fwiw - we've been going through that exercise in keystone, and it's been helpful (so we see value for sure)
14:08:13 <TheJulia> I think so, reflection and self evaluation is important
14:08:36 <TheJulia> dhellmann: Off the top of my head no, cdent?
14:09:00 <dhellmann> do we want to engage with teams to ensure this is something they're thinking about?
14:09:02 <cdent> Perhaps to republish the idea
14:09:06 <cdent> yeah that
14:09:26 <dhellmann> does someone want to volunteer for that by adding an #action?
14:09:43 <cdent> I'll take it
14:09:57 <TheJulia> cdent: I was just typing out that I would. I can if you want.
14:10:07 * dhellmann pauses for cdent or TheJulia to #action themselves
14:10:12 <cdent> since TheJulia did the first one, me seems "fair"?
14:10:19 <cdent> but if you're eager, please feel free :)
14:10:28 <TheJulia> okay cdent, let me know how I can assist then
14:10:35 <TheJulia> other than revise and get the one for ironic merged :)
14:10:56 <cdent> #action cdent to republish the projects review vision notion
14:11:07 <dhellmann> great, thanks
14:11:12 <dhellmann> moving on
14:11:15 <dhellmann> #topic defining the role of the TC
14:11:15 <dhellmann> #link https://wiki.openstack.org/wiki/Technical_Committee_Tracker#Next_steps_in_TC_Vision_.2F_defining_role_of_the_TC
14:11:22 <dhellmann> last month cdent agreed to start a thread about the documented role of the TC
14:11:22 <dhellmann> that has been done, thank you cdent
14:11:27 <dhellmann> #link http://lists.openstack.org/pipermail/openstack-discuss/2019-January/001612.html
14:11:30 <dhellmann> What are the next steps for this initiative?
14:11:51 * mugsie sneaks in late
14:11:55 <cdent> Yeah, I just went back through that thread to see if I could extract any salient points. Unfortunately most of the best ones are from zane, who is on a volcano
14:11:59 <TheJulia> I've had no time this past month to follow this :(
14:12:29 <TheJulia> cdent: would it make more sense to try and sync up with zane when he is back?
14:12:59 <ttx> I feel like absence of further feedback shows the base document we have somehow corresponds to the current state, and further discussion can be proposed as changes to that doc ?
14:13:01 <cdent> But a main theme that we pulled out (and mentioned in a recent office hour) was that "what if the list is too big because the ideas are too small? What if we can't agree because the stakes are so low?"
14:13:24 <cdent> As in: maybe we need to make goals more audacious
14:13:25 <cdent> another was
14:13:50 <TheJulia> I second that idea, that goals should be kind of scary
14:13:51 <cdent> "It's... strange, if not exactly surprising, to me that facilitating those kinds of conversations (starting with making sure they happen) isn't something we have consensus on as being part of the TC's role."
14:14:16 <mnaser> (i don't want to sign up anyone for more work, but i think we need to figure out how to get more people engaged and give a reason for them to hit that reply button and respond)
14:14:28 <TheJulia> mnaser: ++
14:14:33 <mnaser> that thread is mostly tc members discussing amongst us, but i don't have a solution either.
14:14:39 <gmann> true
14:14:56 <gmann> we need to hear more from community.
14:14:57 <mnaser> (with a few notable, commonly vocal community members, which is awesome too, but yeah.)
14:15:03 <ttx> TheJulia: it's true that goals as theey stand are VERY reasonable, rather than crazy-aspirational
14:15:12 <dhellmann> mnaser : I wonder if the way to do that is just to interpret our role ourselves, and go about the business of running the project. People who object will, and people who support the work will. Both will result in more engagement.
14:15:19 <ttx> maybe we need both
14:15:45 <ttx> (reasonable/attainable in a cycle AND crazy-aspirational multi-cycle)
14:15:47 <mnaser> dhellmann: i think someone would be more inclined to hit 'reply' when action is being taken rather than 'its just talks'
14:15:55 <cdent> ttx++
14:15:56 <dhellmann> mnaser : that's exactly what I mean
14:16:00 <TheJulia> I think it is the only way to really drive innovation or leaps. And we just don't use the asperational one as a hard requirement to shame any project.
14:16:11 <ttx> I don;t think taht invalidates the "role of the TC" -- I think it definitely fits in there
14:16:25 <dhellmann> we're going to be talking a bit about goals later, so let's focus on next steps for this initiative for now
14:16:35 <ttx> in the "Providing technical guidance" section
14:16:50 <mnaser> dhellmann: agreed.  perhaps then we should look into evaluating the role of the tc and saying "this is what we're proposing becoming" and hear comments
14:17:02 <mnaser> and see what type of response we get, i guess.
14:17:26 <cdent> Do people agree with zane's assertion here [t cTUi] that there is not consensus:
14:17:26 <purplerbot> <cdent> "It's... strange, if not exactly surprising, to me that facilitating those kinds of conversations (starting with making sure they happen) isn't something we have consensus on as being part of the TC's role." [2019-02-07 14:13:51.789068] [n cTUi]
14:17:32 <dhellmann> well, I think we should just do it, and expect feedback as we go
14:17:34 <ttx> hmm, which was renamed to "Encouraging a unified OpenStack experience" so that may not capture it indeed
14:18:28 <cdent> (that's from http://lists.openstack.org/pipermail/openstack-discuss/2019-January/001895.html )
14:18:28 <dhellmann> cdent : what "kinds of conversations" is that referring to?
14:18:30 <ttx> Maybe "Providing common goals" would capture that part of the role better
14:18:31 <dhellmann> heh
14:18:39 <fungi> is it what we're proposing becoming, or what we assert we've been doing/trying to do?
14:19:39 <evrardjp> I would like to see ^ clarified
14:19:45 <evrardjp> too
14:20:13 <dhellmann> cdent : I suspect we've leaned a little too far in the direction of being laissez faire
14:20:17 <ttx> I think it's totally part of the role of the TC to paint larger goals, and that painting can include smaller/reachable goals AND wider/aspirational goals.
14:20:51 <ttx> as long as people realize painting them does not magically make then happen
14:20:58 <mnaser> i think the conversation is starting to enter the realm of discussion details and what/how we're doing and the role of the tc rather than 'housekeeping' meeting items
14:21:06 <evrardjp> ttx: we also had, in the past, an approach where we said "this goal failed" -- it doesn't encourage having larger goals, due to fear of failure -- should we not care about failure, it would be different
14:21:11 <ttx> so the keywords become "reachable" and "aspirational"
14:21:12 <mnaser> we can probably take this convo for office hours post meeting :>
14:21:29 <ttx> ++
14:21:35 <evrardjp> mnaser: fair
14:21:40 <mnaser> (imho anyways)
14:21:42 <cdent> dhellmann: I think being less laissez faire about driving conversations would be a useful tc role goal
14:21:46 <fungi> better to take it to the ml
14:21:48 <TheJulia> mnaser: ++
14:21:48 <dhellmann> it sounds like there's more work to do on this, at least to agree on next steps, and that is likely to play in to our goal selection process for train
14:22:01 <dhellmann> ok, let's move on
14:22:08 <dhellmann> #topic keeping up with python 3 releases
14:22:12 <dhellmann> We have approved all of the patches for documenting the policy and for selecting the versions to be covered in Stein.
14:22:16 <dhellmann> What are the next steps for ensuring that any implementation work is handled for Train?
14:22:56 <mnaser> i think deployment tools need to help figure that part out and i think that's probably a next logical step.  i'm not sure on how kolla and tripleo are handling it but those are all the tools that need to make sure they have support
14:23:03 <mnaser> (because really, most people use them to deploy)
14:23:35 <mnaser> i think as a goal, perhaps have deployment projects join effort to see how we can go about this transition especially with how tricky it can be when involving different OS's
14:23:40 <TheJulia> I concur. An end-to-end everything python3 kind of exercise.
14:23:40 <dhellmann> oh, I mean specifically the choosing of python 3 versions for train
14:23:45 <dhellmann> no the implementation of python 3 support
14:23:45 <TheJulia> oh
14:24:00 <mnaser> oh, woops, jumped a bunch of steps then
14:24:16 <dhellmann> the thing we said we would do is evaluate the PTI each cycle. Who is going to do that? When?
14:24:40 <fungi> related (i think), i'm worried we're still on our way to running a lot of our stein testing on ubuntu xenial come release day. the qa team has admirably tackled getting devstack jobs moved to buinic, but many other jobs are still on xenial and we probably need to declare a flag day to switch them over in the base job
14:25:21 <mnaser> i can be #2 on that effort but i cant help lead it because my knowledge of the python 3 + os internals and combinations aren't the strongest.
14:25:57 <mnaser> so id gladly help coordinate, talk back and forth, etc, but i don't think i can lead it just because of lack of personal experience in the subject.
14:25:58 <dhellmann> a flag day seems reasonable if we schedule it carefully. is the QA team still driving that?
14:26:25 <fungi> i don't know, but perhaps gmann is aware of the status there
14:27:18 <gmann> all base job are moved to bionic but legacy jobs are still using xenial
14:27:32 <dhellmann> are legacy jobs defined in each project repo?
14:27:46 <gmann> we decided not to move them to bionic with legacy implementation. they will get moved to bionic once migrating to zuulv3
14:27:53 <gmann> yes project side.
14:28:07 <fungi> it would also mean switching our remaining non-version-specific-but-python3-using jobs from python 3.5 to 3.6 but in most cases i don't anticipate much fallout from that
14:28:45 <dhellmann> fungi : that feels like a step we could take independently of porting the legacy jobs
14:29:21 <fungi> there are still a *lot* of legacy jobs from the zuul v2->v3 mass config migration, many of which projects have copied into their repositories, and i haven't seen a ton of prioritization placed on replacing them
14:29:23 <dhellmann> gmann : ok. we should probably set a deadline for the transition. do you want to start a conversation on the mailing list for that?
14:29:39 <gmann> dhellmann: for legaycy job to zuulv3 ?
14:30:01 <fungi> also a big elephant in that room is grenade, which still uses a legacy job definition. several people have picked up the attempt to rewrite it and then wandered off
14:30:04 <dhellmann> gmann  : for legacy jobs to bionic (I don't know if I care about the implementation details)
14:30:15 <evrardjp> should that be a goal?
14:30:35 <dhellmann> we need it done this cycle, right? otherwise we'll be releasing based on tests running on different platforms
14:30:42 <gmann> dhellmann: ohk but moving legacy to bionic might be extra effort and moving to zuulv3 easy
14:30:52 <gmann> but yea i can take that to ML
14:31:04 <evrardjp> I mean we are talking about public facing goals, but reducing tech debts is something that should be considered as goals too.... Wondering if we should have that as a goal for this cycle
14:31:07 <dhellmann> gmann : that's fine, I'm just saying I don't know enough of the details to care about the implementation but I care about the use of bionic
14:31:13 <clarkb> note its also all the tox jobs running on xenial iirc
14:31:14 <fungi> "easy" isn't necessarily the case given the apparent situation with grenade, at least
14:31:22 <clarkb> not just "legacy" jpbs
14:31:27 <dhellmann> #action gmann raise the topic of porting legacy jobs to bionic on the mailing list
14:31:41 <gmann> thanks
14:31:42 <fungi> right, this is where i think the qa team tends to have devstack+tempest blinders on most of the time
14:31:43 <dhellmann> fungi : do you want to propose a flag day for any jobs we can switch via project-config?
14:32:05 <dhellmann> or openstack-zuul-jobs or whatever -- centrally
14:32:18 <fungi> sure, i'll post something to the ml after i take a bit to look over the stein release schedule
14:32:22 <dhellmann> ok
14:32:33 <dhellmann> #action fungi to propose flag day for proposing moving centrally managed jobs to bionic
14:32:42 <fungi> #action fungi propose a default node flag day to switch to ubuntu bionic
14:32:47 <fungi> er, whoops
14:32:50 <dhellmann> no problem
14:33:07 <cdent> now it will definitely get done
14:33:13 <fungi> it'll get double-done
14:33:18 <dhellmann> now, this topic was actually supposed to be about *train*, so who wants to take the task of figuring out what we need to do for the next cycle?
14:33:24 <evrardjp> cdent: :)
14:34:19 <dhellmann> I think we need someone to look at what OS platforms will be ready to be used, and what python versions they will include, and then update the PTI declaration
14:34:51 <TheJulia> So, at a glance now, 3.6 for now, we should expect 3.7 this time next year. Although I think debian now ships 3.7
14:35:01 * TheJulia was looking during the discussion
14:35:05 <dhellmann> let's not do it right now in the meeting, let's get a volunteer to do the work
14:35:07 <TheJulia> I think dropping py35 makes sense
14:35:14 <dhellmann> is that you signing up, TheJulia ?
14:35:15 <cdent> Is smcginnis here, or is he midcycling still? I think he'd be a good choice for the PTI train work
14:35:18 * smcginnis scans logs
14:35:26 <cdent> incredible
14:35:29 <smcginnis> Still at the midcycle and just got into the room.
14:35:30 <TheJulia> dhellmann: I'm not sure what I'm really singing up for there short of sending an email.
14:36:12 <dhellmann> we need to update https://governance.openstack.org/tc/reference/project-testing-interface.html#tested-runtimes
14:36:17 <mnaser> i think it's following up with the differnet platforms and gathering the information you mentioned and then pushing up a review to that ^
14:36:23 <dhellmann> with a section for train, like https://governance.openstack.org/tc/reference/runtimes/stein.html
14:37:20 <dhellmann> ok, we'll look for volunteers later
14:37:22 <TheJulia> I can do that, but I suspect it will be unchanged. I'll takea  look
14:37:26 <fungi> yeah, debian buster/testing has python3.7 as default, so the next ubuntu lts will most likely as well
14:37:28 <dhellmann> ah, good
14:37:37 <dhellmann> #action TheJulia investigate PTI updates for Train
14:37:45 <fungi> since ubuntu tends to snapshot debian/testing
14:37:46 <dhellmann> let's move on, we have a lot of other topics to cover
14:37:46 <TheJulia> fungi: already does
14:37:53 <dhellmann> #topic Train cycle goals selection update
14:37:58 <dhellmann> let's get an update from lbragstad and evrardjp before we resume any discussion started under the "role of the TC" topic earlier
14:37:58 <lbragstad> a relatively quick update here
14:38:04 <lbragstad> evrardjp and i have been meeting weekly to drive the possible goals - which have all been socialized on the ML
14:38:11 <lbragstad> we've also proposed a schedule for when we'd like certain events to happens, so that we have enough lead time before the summit to decide goals
14:38:17 <lbragstad> #link http://lists.openstack.org/pipermail/openstack-discuss/2019-January/002271.html
14:38:25 <lbragstad> we're planning on getting goals up for review by the end of the month
14:38:35 <lbragstad> currently - the big three prospective goals are 1.) resource cleanup on project deletion 2.) moving off legacy clients 3.) health check middleware
14:38:44 <lbragstad> i think adriant is planning on getting #1 up for review soon
14:38:49 <lbragstad> #link http://lists.openstack.org/pipermail/openstack-discuss/2019-January/002041.html
14:39:03 <lbragstad> there is still pre-work to be done on #2, but artem is working on that and has called for assistance on the mailing list
14:39:10 <lbragstad> #link http://lists.openstack.org/pipermail/openstack-discuss/2019-January/002275.html
14:39:17 <lbragstad> both evrardjp and i think this pre-work is going to be useful in looking for ways to break this up, it's an ambitious goal
14:39:26 <lbragstad> finally, #3 is in the pre-work stage as well, which evrardjp has details on
14:39:33 <lbragstad> #link http://lists.openstack.org/pipermail/openstack-discuss/2019-January/002089.html
14:39:36 * lbragstad is done
14:39:49 <evrardjp> nothing to add :)
14:39:56 <dhellmann> great detail, thanks lbragstad & evrardjp
14:40:19 <dhellmann> does anyone have questions about the current plans?
14:40:51 <evrardjp> gmann: you were interested by adding a documentation one, correct? I think it might be worth discussing after the meeting
14:40:53 <mnaser> thanks for leading the effort lbragstad and evrardjp :>
14:41:16 <dhellmann> it will be interesting to see how those 3 items mesh with the discussion of raising the stakes for goals
14:41:24 <lbragstad> this might not be something for this meeting - but the pre-work is supposed to help us feel comfortable in making informed decisions, i'm curious if other members think what we're doing is sufficient for pre-work is achieving that goal
14:41:37 <gmann> evrardjp: i saw the reply from ttx and dhellmann about wiki page idea. i am still thinking help-wanted on project side contributor doc can be more easy to maintain
14:42:13 <dhellmann> lbragstad : it does seem to be more than what we've done for some goals in the past, so that's good. I think having a "status report" of some sort at the point when we have to actually choose a goal would be helpful.
14:42:16 <evrardjp> I second lbragstad here -- and also I don't want future people to have pressure on helping in that selection process.
14:43:02 <dhellmann> evrardjp : what pressure do you mean?
14:43:12 <gmann> lbragstad: just wanted to have more discussion on #1 about exposing API vs plugin approach. but yeah thats something to disucss separatly not in this meeting
14:43:19 <lbragstad> i'm all ears and i'll be in office hours if folks have additional feedback
14:43:21 <evrardjp> dhellmann: I would like to clarify what you meant by status report first :)
14:43:56 <dhellmann> evrardjp : oh, just a summary email or something with a description of how "ready" we would be to start the work
14:44:08 <dhellmann> if someone promises to do prework, and then doesn't finish it, we need to know that
14:44:15 <evrardjp> I think that maps well with our almost weekly summaries of where we are
14:44:18 <dhellmann> ++
14:44:27 <dhellmann> ok, let's move on to new business then
14:44:39 <dhellmann> #topic TC voting procedures
14:44:39 <dhellmann> Now that we have good automation for evaluating whether a change to the governance repository is ready to be approved,
14:44:39 <dhellmann> I wanted to remind everyone that in the past we recommended that TC members who propose changes also vote on their own changes.
14:44:39 <dhellmann> This is a bit different from the process for code changes in other repos, but it gives us the flexibility to have the same person
14:44:40 <dhellmann> propose several related but different (possibly mutually exclusive) changes and then indicate their own preference clearly
14:44:41 <dhellmann> (something we've done in the past with complex topics).
14:44:42 <dhellmann> So, please keep this in mind as you propose changes.
14:44:51 <dhellmann> Questions?
14:45:25 <ttx> no
14:45:28 <TheJulia> sounds good to me
14:45:49 <cdent> makes sense
14:46:00 <dhellmann> ok, good. I'll happily discuss that further during office hours, but want to push through the last few items on the agenda
14:46:00 <gmann> +1
14:46:10 <dhellmann> #topic upcoming election
14:46:10 <dhellmann> the TC election for Train is coming up
14:46:15 <dhellmann> #info nominations for TC election open 12 Feb
14:46:15 <dhellmann> #link http://lists.openstack.org/pipermail/openstack-discuss/2019-January/001829.html
14:46:22 <dhellmann> cdent, dims, mugsie, mnaser, smcginnis, ttx, and zaneb are up for election this term
14:46:22 <dhellmann> It is time to start considering whether you want to run again, and for all of us to be looking for additional candidates.
14:46:33 <cdent> Tuesday, yeah?
14:46:47 <dhellmann> yes
14:47:10 <dhellmann> if you have candidates you want to see run, please take a few minutes to contact them privately to encourage them to do so
14:47:16 <cdent> Is anyone definitely not running? I'm still deciding.
14:47:23 <smcginnis> I think I am not going to run again to allow room for someone else.
14:47:24 <cdent> I have a few people I plan to prod.
14:47:25 <ttx> I'm not certain to run again -- depends how many people drop
14:47:28 <dims> dhellmann : ack. i won't be standing for re-election. yes, i'll ping some folks who i think should run.
14:47:37 <dhellmann> dims : great, and thank you
14:47:49 <lbragstad> thank you for your service, dims :)
14:47:55 <evrardjp> ++
14:48:01 <dhellmann> smcginnis : thank you
14:48:12 <evrardjp> and likewise for smcginnis
14:48:12 <ttx> I'm sad to lose our favorite K8s community liaison!
14:48:18 <lbragstad> you too smcginnis
14:48:29 <gmann> thanks smcginnis and dims for such a great contribution
14:48:38 <TheJulia> ++
14:48:42 <dhellmann> on a related note, I have decided, based on some other priorities at work, that I should not serve as chair for the Train cycle.
14:48:42 <ttx> and sad to lose smcginnis too of course :) Just can't come with a good joke
14:48:47 <dhellmann> I do intend to serve out my term as a TC member, so I will still be around and pariticipating in discussions.
14:48:53 <dhellmann> If any of you are considering serving as chair, and are interested in talking about the role and responsibilities, please let me know (privately, if you prefer).
14:49:11 <ttx> chairing is fun!
14:49:17 <evrardjp> Thanks for the work and structure you brought dhellmann
14:49:33 <dhellmann> it's less work than I expected in a lot of ways, tbh
14:49:47 <ttx> yes, dhellmann totally added some structure to my old messy ways, so thx dhellmann !
14:50:12 <mnaser> indeed.  having had to keep up for a few days, the 'systems' that dhellmann put in place really simplified things
14:50:17 <TheJulia> That is kind of good to hear from when ttx originally described everything
14:50:19 <evrardjp> I think it would be wise for continuity to not have all our long time TC members drop -- they would be the best at chairing.
14:50:55 <dhellmann> evrardjp : I'll be sticking around (I'm not up for election until next time)
14:51:03 <gmann> good process oriented things and system you setup dhellmann , really helpful for long term in community
14:51:03 <ttx> evrardjp: yes, that's why I'still holding my decision
14:51:09 <dhellmann> I just expect to need to focus more on some other work
14:51:23 <dhellmann> and don't want that to detract from TC work
14:51:33 <mnaser> i plan on running again and (assuming i make it), i think i'd like to try my hand at tc chair as i'm shuffling around priorities to be more free for tha role if need be
14:51:48 <dhellmann> mnaser : great, thank you
14:51:50 <evrardjp> mnaser: great
14:52:11 <ttx> I feel like renewing 3-4 people at each election has worked well
14:52:16 <dhellmann> folks who won't be running, when nominations open please post to the ML to let folks know
14:52:19 <gmann> mnaser: nice.
14:52:21 <evrardjp> ttx: yes it's not a bad ratio
14:52:35 <dhellmann> I know we've had people hold off on running because they didn't think there would be open seats
14:52:48 <dhellmann> ok, 3 more topics on the agenda
14:52:50 <dhellmann> #topic review proposed OIP acceptance criteria
14:52:51 <dhellmann> Allison Randal (wendar) has asked the TC for feedback on the current draft of the board's acceptance criteria for new Open Infrastructure Projects
14:52:51 <dhellmann> She shared a few links to etherpads to help with that review.
14:53:00 <dhellmann> #link WG December/January meeting notes  https://etherpad.openstack.org/p/ProjectConfirmationGuidelines
14:53:00 <dhellmann> #link December idea collection https://etherpad.openstack.org/p/BrainstormingOSFProjectConfirmationGuidelines
14:53:00 <dhellmann> #link TC review draft https://etherpad.openstack.org/p/TCReview-ConfirmationGuidelines
14:53:08 <dhellmann> The current plan is to give us a little time (about a week) to provide feedback on the current draft
14:53:08 <dhellmann> before opening it up for wider review. So, please spend some time looking at the etherpads and
14:53:08 <dhellmann> leave comments inline in that last one.
14:53:35 <dhellmann> it doesn't look like wendar is here, but I think that's all of the information we have to share at this point
14:53:53 <dhellmann> #action tc-members review OIP acceptance criteria
14:53:56 <ttx> With my TC hat on, I'd ike to weave a bit more "feedback from already-confirmed projects" in there... but there is already some mention of it
14:54:32 <dhellmann> I pointed out on an earlier draft that there was no foundation membership requirement, like we have for OpenStack itself. I find that an interesting difference.
14:54:34 <cdent> By "review" does that mean "make sure this feels complete and doesn't make you uncomfy"?
14:55:04 <dhellmann> wendar asked for comments inline, that's why we have our own version of the latest draft (so she can keep the source of comments straight)
14:55:19 <ttx> The way I envisioned it, we could file some amicus curiae to help the board make its decision
14:55:41 <fungi> dhellmann: yes, i've brought up the lack of foundation membership requirement with osf leadership as well, and been told that ripping it out of the bylaws would have been a bit too much to tackle
14:56:07 <dhellmann> fungi : I was rather thinking we should require it of all voters, myself
14:56:14 <ttx> i think it will be much easier to consider once we have another thing confirmed
14:56:34 <dhellmann> This review also gives us an opportunity to think about the criteria for project teams to become (and remain) official OpenStack projects, so keep that in mind as you read.
14:56:50 <fungi> i also have some side concerns, like the ccla expectations osf has for companies contributing to openstack but seems to not really be pushing for any of the pilot projects (at least as far as i've been able to tell)
14:57:06 <dhellmann> fungi : yes, that's another area where consistency would be good
14:57:16 <dhellmann> let's put all of this into the etherpad
14:57:30 <dhellmann> we have 2 more topics, which I don't think we'll have time to do justice to
14:57:31 <dhellmann> #topic TC goals for Stein
14:57:31 <dhellmann> last month I asked you all to consider what goals the TC should have for itself for the remainder of this cycle
14:57:50 <dhellmann> if anyone wants to propose a goal, maybe that's a conversation for office hours and the mailing list
14:57:58 <dhellmann> #topic health check status for stein
14:57:58 <dhellmann> #link https://wiki.openstack.org/wiki/OpenStack_health_tracker#Project_Teams
14:58:05 <dhellmann> does anyone have anything to raise based on what they have learned in their conversations with PTLs?
14:58:26 <dhellmann> for example, I learned this week that there are basically no active contributors in the Telemetry project and only 1 for qinling
14:58:50 <TheJulia> I do not, but I intend to try and make another pass on the list this month since I went through the list in early january
14:59:11 <ttx> I learned that Winstackers is functional but still a single-vendor/single-contributor thing
14:59:25 <ttx> and started wondering if that should not be a "Windows support SIG" instead
14:59:26 <cdent> that reminds me, do we have a vague definition we can assign to "active" when referring to contribution?
14:59:42 <ttx> since I see that work as disjoint from "teh product"
14:59:47 <cdent> because, informally, I've seen lots of projects have fewer "active" (by some meanings)
14:59:54 <dhellmann> I think it would be useful for us to start considering raising the bar a bit for new and existing teams, but I don't have a specific proposal for how to do that, yet.
15:00:11 <evrardjp> dhellmann: interesting
15:00:29 <ttx> related: whoever is assigned to Searchlight should probably follow up on Trinh's recent email
15:00:35 <TheJulia> Solum is one that concerns me
15:00:38 <dhellmann> cdent : yes, many teams have reported a drop off in contributions or participation from reviewers
15:00:38 <gmann> cdent: IMO as long as it take care of incoming request (review, fearure, bugs) is Active
15:00:39 <cdent> that's me and dims
15:00:47 <dhellmann> thanks for the reminder, ttx
15:01:01 <dhellmann> #action cdent and dims follow up on Searchlight review email thread on the mailing list
15:01:19 <ttx> gmann: ++ and releases
15:01:28 <dhellmann> gmann : I heard from several teams that they were not active enough to work on the community goals. That concerns me.
15:01:32 <gmann> yeah release
15:01:53 <cdent> gmann: what about "listening at some point when people show up in the irc channel" or "responding to topical emails"?
15:01:54 <dhellmann> ok, we're a bit over time so let me wrap the meeting up and we can continue in office hours
15:02:00 <ttx> ack
15:02:04 <dhellmann> #topic next meeting
15:02:04 <dhellmann> #info the next TC meeting will be 7 March 2019 1400 UTC in #openstack-tc
15:02:04 <dhellmann> If you have suggestions for topics for the next meeting, please add them to the wiki at https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee#Agenda_Suggestions
15:02:08 <dhellmann> Thank you, everyone!
15:02:17 <dhellmann> #endmeeting