20:01:44 <ttx> #startmeeting tc
20:01:45 <openstack> Meeting started Tue Sep 22 20:01:44 2015 UTC and is due to finish in 60 minutes.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:01:46 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:01:48 <openstack> The meeting name has been set to 'tc'
20:01:55 * edleafe munches on said popped-corn
20:01:55 <ttx> Agenda for this Technical committee meeting lives at:
20:01:59 <ttx> #link https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee
20:02:01 * Rockyg munches quietly and licks my fingers
20:02:07 <ttx> Let's start easy
20:02:12 <ttx> #topic Cross-project spec final approval: Return request ID to caller
20:02:17 <ttx> #link https://review.openstack.org/#/c/156508/
20:02:26 <ttx> This was discussed at multiple cross-project meetings, lastly last week
20:02:40 <ttx> It apparently has consensus now and needs our final approval on it
20:02:45 <dtroyer> o/
20:02:48 <ttx> Any objection to final approval on this one ?
20:03:00 * flaper87 is good with it
20:03:15 <lifeless> +1
20:03:21 * devananda noshes on raspberries and lurks in the back
20:03:27 <lifeless> I stopped tracking it once it got into fine tuning territory
20:03:30 <jgriffith> I don't really have any objection... but one thing I'm not qutie sure on
20:03:32 <redrobot> o/
20:03:50 <jgriffith> well... never mind
20:03:51 <jaypipes> o/
20:03:52 <jgriffith> I get it
20:03:52 <sdague> conceptually it's good, some of the details will probably fall out when trying to do the actual work, as the apiclient bits in oslo are kind of crufty
20:03:57 * edleafe steals one of devananda's tasty raspberries
20:04:02 <sdague> I left that as a comment in the review
20:04:07 <ttx> sdague: yeah, I figured that much
20:04:14 <ttx> ok, approving then
20:04:18 <dims> sdague: i want to nuke oslo-incubator in M :)
20:04:31 <sdague> dims: yeh, also that :)
20:04:36 <sdague> but the concept is good
20:04:40 <Rockyg> dims, yay!
20:04:41 <sdague> they should move ahead on it
20:04:41 <flaper87> dims: +1
20:04:59 <ttx> work on that was started on February 17, so nice persistence from Abhishek
20:05:04 <ttx> approved
20:05:06 <annegentle> nice
20:05:18 * annegentle highfives Abhishek
20:05:20 <ttx> now for more fun
20:05:24 <ttx> #topic Handling project teams with no candidate PTLs
20:05:36 <ttx> So... we have a number of teams with no PTL candidates in the official timeframe
20:05:39 * sergmelikyan sighs
20:05:43 <ttx> Thankfully we have a defined way to address that:
20:05:47 <annegentle> it's okay sergmelikyan :)
20:05:49 <ttx> #link http://governance.openstack.org/resolutions/20141128-elections-process-for-leaderless-programs.html
20:05:57 <ttx> Let's consider them one by one, starting with simpler ones
20:06:02 <ttx> * Security
20:06:10 <ttx> The liberty PTL (Robert Clark) pushed his candidacy after the deadline, no other self-nomination
20:06:15 <ttx> Any other suggestion ?
20:06:24 <lifeless> take him
20:06:29 <jgriffith> #agreed
20:06:31 <dhellmann> yeah, this seems like an easy one
20:06:34 <sdague> #agreed
20:06:35 <jeblair> ++
20:06:35 <dtroyer> +1
20:06:36 <flaper87> I think this sounds like an easy call
20:06:37 <ttx> #agreed Robert Clark nominated PTL for the Security Team in Mitaka
20:06:44 <ttx> * Murano
20:06:50 <ttx> The liberty PTL (Serg Melikyan) pushed his candidacy after the deadline, no other self-nomination
20:06:55 <ttx> Any other suggestion ?
20:07:01 <dhellmann> ditto
20:07:03 <sdague> +1
20:07:05 <flaper87> ditto
20:07:09 <jgriffith> Nope... take sergmelikyan
20:07:12 <ttx> #agreed Serg Melikyan nominated PTL for the Murano Team in Mitaka
20:07:15 <dtroyer> +1
20:07:17 * markmcclain-mobi sneaks in late
20:07:20 <sergmelikyan> thank you!
20:07:20 <ttx> * Barbican
20:07:28 <ttx> The liberty PTL (Douglas Mendizabal) confirmed he missed the deadline. Couldn't find any other self-nomination
20:07:36 <ttx> he is redrobot on irc
20:07:41 <ttx> Any other suggestion ?
20:07:45 <mordred> redrobot: you wanna be PTL?
20:07:47 <lifeless> +1
20:07:58 <dhellmann> ditto
20:07:59 <lifeless> mordred: self nomination implies that, no?
20:08:01 <redrobot> mordred indeed.  my calendar skills were not up to par this election
20:08:01 <dtroyer> +1
20:08:02 <jgriffith> redrobot: yeah, do you want to do it?
20:08:04 <annegentle> mordred: I think he does, is there a patch?
20:08:07 <flaper87> if there's no other nomination, take him!
20:08:08 <sdague> +1
20:08:09 <mordred> lifeless: oh, sorry. I mis-read ttx's statement
20:08:11 <annegentle> redrobot: great!
20:08:12 <mordred> +1
20:08:16 <ttx> #agreed Douglas Mendizabal nominated PTL for the Barbican Team in Mitaka
20:08:21 <ttx> * Magnum
20:08:28 <ttx> The liberty PTL (Adrian Otto) pushed his candidacy after the deadline. A challenger (Hongbin Lu) also stepped up.
20:08:31 <jgriffith> mordred: me too, interpretted as he "would if nobody else did"
20:08:36 <ttx> So for that one we have to choose. We can choose one of them, someone else, or run an election with those two
20:08:46 <jgriffith> election
20:08:49 <mordred> election
20:08:50 <annegentle> I'd like an election
20:08:52 <sdague> election
20:09:07 <russellb> election +1
20:09:11 <dhellmann> if they both still want to do it, we should have an election
20:09:14 <flaper87> I'd vote election
20:09:16 <russellb> dhellmann: +1
20:09:18 <annegentle> flaper87: nice
20:09:25 <markmcclain-mobi> Election
20:09:27 <flaper87> :P
20:09:27 <dtroyer> has anyone talked to either of them?  do they both still want it?
20:09:28 <adrian_otto> have you asked Hongbin if he wants an election?
20:09:29 <annegentle> are our election officials up for that?
20:09:35 <hongbin> yes I want
20:09:36 <ttx> with those two candidates, right ? No new nomination period ?
20:09:38 <adrian_otto> ok
20:09:41 <annegentle> dtroyer: I have talked to Adrian and he's up for it
20:09:44 <dhellmann> ttx: right
20:09:46 <annegentle> ttx: yes
20:09:48 <sdague> ttx: yes
20:09:48 <dhellmann> hongbin: ok, thanks for confirming
20:09:50 <ttx> #agreed An election should be held for Magnum contributors to pick their PTL with the two late candidacies in
20:09:52 <annegentle> sounds good hongbin
20:09:58 <dims> ++
20:09:58 <dtroyer> ok, both are confirmed then ,thx
20:10:03 <ttx> * MagnetoDB
20:10:04 <annegentle> thanks for your willingness hongbin!
20:10:06 <dtroyer> ++election
20:10:06 <jgriffith> ttx: +1 to no new nomination period
20:10:10 <ttx> No candidacy for that one.
20:10:16 <ttx> We can confirm the current ptl, volunteer someone, or fast-track its removal from the Big Tent (next topic)
20:10:20 <tristanC> annegentle: I guess we could also ran that election yes, can it wait after TC rounds ?
20:10:24 <russellb> fast track removal
20:10:30 <sdague> fast track removal
20:10:30 <ttx> I think I prefer the latter
20:10:36 <flaper87> fast track removal
20:10:42 <annegentle> tristanC: I think it can wait and will avoid confusion
20:10:42 <ttx> tristanC: would be better to start it asap if possible
20:10:46 <annegentle> h
20:10:46 <jgriffith> fast track removal
20:10:48 <annegentle> ha
20:10:49 <annegentle> :)
20:10:51 <ttx> tristanC: your call
20:10:56 <annegentle> tristanC: or run it this week if possible
20:10:56 <dhellmann> we should mothball magnetodb, but didn't we need to hold onto the repo names for ATC status calculations?
20:11:10 <ttx> annegentle: We kinda need a Mitaka PTL to prepare the design summit asap
20:11:24 <tristanC> that's is doable, I'll check that with tony in a few hours
20:11:27 <annegentle> ttx: ah, true, hadn't considered that
20:11:27 <ttx> If we agree on fasttrack removal, we can move to the next topic
20:11:32 <sdague> so, I'd also like to say I consider all these projects in the dog house, and if they miss deadlines again next time I'm not convinced we should just wave it off
20:11:37 <annegentle> no need for a PTL if there's no project right?
20:11:38 <sdague> because, it's 6 days
20:11:42 <jgriffith> sdague: +1
20:11:45 <jeblair> ttx: agree removal
20:11:49 <mordred> removal
20:11:54 <sdague> waiting until the last minute is completely disrespectful of the openstack community
20:11:57 <ttx> #agreed Fast-track removal for MagnetoDB rather than be awkward and nominate someone to kill it
20:11:58 <dhellmann> sdague: double secret probation?
20:12:01 <flaper87> sdague: ++
20:12:03 <jgriffith> sdague: and I'm bighting my tongue for the "how can you be PTL if you can't submit a proposal"
20:12:07 <jeblair> sdague: yes; i'm willing to give a little leeway because of the new election process, but honestly, that's a flimsy excuse.
20:12:09 <jgriffith> but don't want to get into it
20:12:17 <flaper87> I think we should reconsider the whole candidacy proposal process
20:12:21 <flaper87> and just have a deadline
20:12:33 <flaper87> let it open and just have a single deadline
20:12:35 <annegentle> flaper87: ++ why window it
20:12:39 <mordred> well ...
20:12:49 <jgriffith> flaper87: there's nothing wrong with the process if you actually read the guidelines
20:12:51 <jgriffith> IMHO
20:12:52 <annegentle> mordred: I mean I can think of all kinds of weird situations and bad behavior
20:12:56 <russellb> i think it's just as simple as people not keeping up with openstack-dev
20:12:59 <flaper87> that won't solve people waiting until the last minute BUT jeez, it's fixed deadline
20:13:04 <jgriffith> russellb: +1000
20:13:04 <mordred> I think that's also probelmatic because it's a great passive aggressive way to try to create a lame-duck cycle
20:13:12 <sdague> russellb: these dates are published way in advance
20:13:15 <annegentle> mordred: heh
20:13:29 <ttx> sdague: it's not just disrepectful. It's very risky. Anyone can get in at the last second
20:13:35 <mordred> announce your candidacy for PTL at the start of the cycle - watch hijinx ensue
20:13:36 <sdague> if as the current PTL you can't keep track of when elections are, I'm dubious on your organization skills as a PTL
20:13:38 <adrian_otto> sdague: this was a new process, and it was not well published in advance. I looked months ago, and could not find it.
20:13:49 <redrobot> I don't think there's anything wrong with the current process.  If anything I would request that the deadline be 23:59 UTC instead of early in the morning UTC.  Makes date conversions a little easier.
20:13:54 <jgriffith> sorry, I just think that if you're going to run for PTL you should be involved in the process/ ML etc
20:13:56 <flaper87> jgriffith: sure but there's no need to have a start date
20:14:03 <sergmelikyan> redrobot: +1
20:14:05 <dhellmann> adrian_otto: did you miss the email right before the election period?
20:14:07 <flaper87> it's a step we don't need, especially now that there's an elections repo
20:14:16 <jeblair> mordred: ah yeah.  thanks for articulating that.  i agree that keeping the window is good.
20:14:16 <mordred> dhellmann: there are ... lots ... of emails
20:14:17 <dtroyer> having been through this once now I think we all know what to expect come next spring
20:14:18 <jgriffith> flaper87: Ok.. I'd like to propose my candidacy for the Q release today then
20:14:24 <lifeless> 6 days is less than a holiday
20:14:36 <lifeless> if folk take leave to go to the beach, or skiing
20:14:38 <sdague> flaper87: I'm also fine openning it up a month early
20:14:43 <jgriffith> dtroyer: +1
20:14:47 <mordred> if I'd been running, I probably would have missed it too - I think it's a fair mistake to make
20:14:49 <mordred> dtroyer: ++
20:14:50 <flaper87> jgriffith: you can't until there's no codename ;)
20:14:52 <markmcclain-mobi> I like having a start date.. Otherwise we're perpetual election cycle
20:14:52 <sdague> so that people that know they will be on vacation can put it out there early
20:14:55 <annegentle> mordred: it happens :)
20:14:55 <russellb> mordred: ++
20:14:58 <flaper87> as soon as there's a codename, it should be opened
20:15:02 <devananda> I would suggest the nomination window be declared at the start of the cycle and listed alongside the release schedule
20:15:04 <dtroyer> 6 days is short, it shoudl be longer, but the fact that the election was coming was not a surprise to anyone
20:15:07 <jgriffith> flaper87: well then that should be our next topic.. we need to fix that :)
20:15:10 <edleafe> flaper87: ++
20:15:11 <thingee> August 21st is when the proposal went out for workflow in the next PTL election http://lists.openstack.org/pipermail/openstack-dev/2015-August/072600.html
20:15:11 <dougwig> could we maybe wait and see if this is a repeated problem, instead of kicking the folks that missed this time around?
20:15:14 <russellb> anyway, we should move on
20:15:17 <mordred> devananda: ++
20:15:17 <jeblair> flaper87: the codename can be something like a year in advance now.
20:15:20 <ttx> Also it's good to know who are the PTLs before you start nopminating for TC
20:15:20 <devananda> so that no one is left in the hypothetical state of being on vacation when the nomination window both starts and is announced
20:15:23 <annegentle> dougwig: yeah
20:15:27 <dhellmann> flaper87: as someone sitting through election commercials for an election more than a year off, no, please, have a shorter cycle than that
20:15:36 <adrian_otto> dhellman: yes, I did. My son was in the hospital.
20:15:39 <annegentle> dhellmann: ha srsly
20:15:40 <ttx> Seriously, if you want to be a PTL, one week nomiunation is plenty enough
20:15:41 <devananda> and so that it is listed on the same wiki page that we all reference for timelines of releases and such
20:15:50 <jgriffith> dougwig: not kicking just to be clear, but saying I don' t think our process is broken and needs a revamp or big analysis at this time
20:16:18 <jgriffith> ttx: yeah, I have to agree with you on that for sure
20:16:19 <sdague> devananda: yeh, listing the timelines with the release timelines seems like a good idea
20:16:20 <annegentle> we revamped the process, it caught a few people, but we had the checks in place, so I think we're fine.
20:16:21 <dhellmann> adrian_otto: ok, sorry to hear that, and thanks for saying so. I'm trying to understand how we can communicate better, so it sounds like having > 1 week may have helped here.
20:16:22 <adrian_otto> just publish the requirements far in advance,a nd we will plan accordingly.
20:16:24 <flaper87> FWIW, I'm not complaining about the mistakes, really. That happens ,that could happen to me because I can't calendar
20:16:42 <thingee> adrian_otto, dhellmann: the workflow proposal went out august 21st http://lists.openstack.org/pipermail/openstack-dev/2015-August/072600.html
20:17:09 <anteaya> thingee: that didnt' include dates
20:17:14 <flaper87> I'm just saying that I've seen the trend to just wait until the last minute and I think that kinda suggests we don't need just a week
20:17:17 <anteaya> thingee: that proposed using a git repo
20:17:21 <thingee> anteaya: my point is discussions started.
20:17:26 <flaper87> dhellmann: I didn't suggest to have it opened for a year, though.
20:17:30 <thingee> anteaya: exactly, change in workflow
20:17:32 <dhellmann> flaper87: speaking of calendar, maybe we can get a public ICS file with some of the big dates on it so folks can subscribe to it for updates
20:17:32 <anteaya> thingee: about the git repo instead of the mailing list
20:17:39 <ttx> I propose we move on. I think if the same projects come next year the choice of the TC might be different, like pick new people by principle
20:17:41 <anteaya> thingee: and I started it last spring actually
20:17:41 <sdague> ok, so I think we got our garumphs out on this one
20:17:46 <jgriffith> flaper87: yeah, we should give people 3 weeks to procrastinate :)
20:17:47 <flaper87> dhellmann: that also sounds good
20:17:48 <edleafe> how about we open at a set date, but close it randomly. Encourage people to declare early! :)
20:17:48 <sdague> ttx: yeh, lets move on
20:17:52 <thingee> anteaya: that's what we're talking about, change in workflow mailing list -> git repo
20:17:55 <devananda> dhellmann: we have public ICS for project meetings. ++ to putting election dates on it as well
20:17:59 <thingee> anteaya: and when that started
20:18:00 <ttx> If you have a proposal to change the election process, feel free to push it
20:18:03 <mordred> devananda: ++
20:18:04 <flaper87> jgriffith: I'll take it :P
20:18:05 <mordred> dhellmann: ++
20:18:05 <dhellmann> devananda: release milestones, too
20:18:06 <jgriffith> and I do understand that some folks had circumstances.. so don't take that the wrong way
20:18:08 <mordred> dhellmann: +
20:18:10 <mordred> YES
20:18:19 <mordred> release milestones in ical would be WIN
20:18:22 <ttx> We have a lot to cover today, let's move on
20:18:24 <mordred> I'm constantly looing for those
20:18:37 <ttx> mordred: it did exist and nobody told me they were using it
20:18:41 <dhellmann> mordred, devananda, flaper87 : maybe one of you can take that on?
20:18:47 <ttx> #topic Remove MagnetoDB from OpenStack
20:18:54 <flaper87> dhellmann: happy to help, yup
20:19:05 <dhellmann> flaper87: wonderful, let's brainstorm tomorrow
20:19:24 <mordred> so, it's a dead project, which is not a condemnation of the people or the project, merely a statement of fact
20:19:25 <dhellmann> ttx, fungi : what are the technical requirements for being able to know who contributed to magnetodb for atc status?
20:19:36 <ttx> mordred: oh look, an old ical feed nobody cared about: https://wiki.openstack.org/wiki/DiabloReleaseSchedule
20:19:49 <devananda> flaper87, ttx: fwiw -- http://git.openstack.org/cgit/openstack-infra/irc-meetings/tree/README.rst
20:19:56 <mordred> ttx: dude. that was diablo. almost nobody in this channel was here then
20:20:05 <mestery> mordred: lol :)
20:20:08 <dims> lol
20:20:30 <ttx> mordred: was still around for Folsom :)
20:20:50 <jgriffith> https://wiki.openstack.org/wiki/FolsomReleaseSchedule
20:21:03 <sdague> so... magnetodb....
20:21:03 <ttx> So, MagnetoDB...
20:21:05 <ttx> We can do a specific file to track retired things as a subsequent commit, but landing this commit now would solve the "no PTL" issue.
20:21:21 <sdague> yeh, I'm happy with the retired bits as follow ons
20:21:28 <thingee> ttx: would like to note that based on magentodb's stats (which isn't probably accurate on stackalytics) in reassuring the tag diversity.
20:21:29 <ttx> so I'm fine with it as-is and we can fix the "dead projects" bin later
20:21:43 <dhellmann> that feels a bit sloppy
20:21:47 * flaper87 agrees w/ ttx and sdague
20:21:57 <ttx> thingee: I blame dhellmann for ensuring MagnetoDB diversity
20:22:03 <dhellmann> I mean, we could just as easily move this block of text into a new file, right?
20:22:32 <ttx> dhellmann: except that means a new patchset and new approvals
20:22:38 <ttx> dhellmann: otherwise yes
20:22:44 * dhellmann shrugs
20:22:50 <ttx> dhellmann: also, nitpicking ton new file format
20:22:58 <flaper87> we can agree that the new patch set can be fast tracked ?
20:23:04 <ttx> since it should also be able to contain dead repos
20:23:05 <flaper87> that way we make everyone happy
20:23:08 <dhellmann> ttx: obviously it should be the same, we already have tools to read this format
20:23:33 <ttx> dhellmann: makes it hard to use for dead repos (<cough> openstack/kite)
20:23:54 * flaper87 had forgotten about kite
20:24:11 <ttx> which is why I prefer to merge that one and not bikeshed on the file format now
20:24:12 <dhellmann> I'm not sure I see that.
20:24:25 <dhellmann> Simply deleting the project has voter roll implications, so I don't like doing that.
20:25:05 <ttx> dhellmann: what kind of implication ? MagnetoDB contributors won't be able to vote on TC election ?
20:25:15 <jgriffith> can we delete it as part of M only?
20:25:15 <ttx> dhellmann: that sounds about fair, why would they ?
20:25:29 <jgriffith> so that voter/ATC status counts for L?
20:25:29 <sdague> there is only one contributor that would apply to - http://stackalytics.com/?metric=commits&user_id=tgehrke
20:25:41 <sdague> all other magnetodb contributors have another commit
20:25:51 <lifeless> I propose we add them as a manual excemption
20:25:51 <jgriffith> ahh
20:25:51 <ttx> sdague: and again, if they are out, why would they elect the next 6 months TC members ?
20:25:51 <mordred> we can add that person as an extra-atc
20:25:53 <lifeless> and get on with it
20:25:58 <jgriffith> lifeless: +1
20:26:11 <ttx> mordred, lifeless: why ? What's the point ?
20:26:33 <lifeless> ttx: the point of them getting a summit pass under the rules we've set?
20:26:39 <sdague> http://stackalytics.com/?module=magnetodb-group&metric=commits
20:26:47 <sdague> only 4 contributors total this cycle
20:26:48 <dhellmann> I guess I'm mixing up ATC and voting rights. It's ATC status that applies for more than one cycle.
20:26:50 <ttx> lifeless: they already got it a long time ago
20:26:50 <jeblair> i think i'm with ttx here -- i actually think the retroactive removal is okay
20:27:12 <lifeless> ttx: won't they be valid for N too ?
20:27:28 <ttx> lifeless: summit is 6 months now, no relationship to ATC status at all
20:27:31 <lifeless> ttx: AIUI ATC lasts 2 cycles, not one
20:27:36 <ttx> despite what the badge says
20:27:45 <ttx> lifeless: and it's not our rules
20:27:53 <dhellmann> ok
20:27:53 <ttx> lifeless: it's the event organizer house rules
20:28:04 <Rockyg> ATC might last 2 cycles, but free pass to summit is one
20:28:04 <sdague> for what it's worth, the only contributor that would be affected didn't get the one patch to a mergable state
20:28:07 <lifeless> ttx: ok, so nothing is being taken away from tgehrke if we do this
20:28:15 <sdague> it was initial proposal, but finished by someone else
20:28:15 <lifeless> ttx: in which case I'm fine
20:28:23 <sdague> https://review.openstack.org/#/c/189164/
20:28:24 <dhellmann> yeah, I thought something was being taken away, but if that's not the case I'm ok with it
20:28:31 <ttx> lifeless: he just won't be able to vote on upcoming TC election, and I'm not even sure that would kick in.
20:28:56 <jgriffith> seems fine to me, and if Todd for some reason is interested enough he can always appeal no?
20:29:13 <ttx> I have enough votes to approve it now
20:29:14 <notmyname> please don't get to the point of judging a contribution to see if it's worthy of granting voting status or not
20:29:45 <ttx> notmyname: I'm not sure what you mean here
20:29:50 <sdague> notmyname: it's not whether the contribution is worthy. It's that the contribution was never completed. Someone else actually took it over and did the work.
20:29:52 <jgriffith> notmyname: I don't think they were judging it, just stating he didn't actually contribute it... no?
20:29:57 <dhellmann> jgriffith: I would rather we set a precedent that we're addressing that issue directly, than kicking it down the road. The next project might have 100 people affected by being removed.
20:30:11 <sdague> but things are counted by gerrit owner
20:30:16 <jgriffith> dhellmann: good point
20:30:44 <dhellmann> so if we're saying that if your only contribution is to a project that we remove from the official list you're going to lose any rights you might have had, then that's ok as long as we state that up front
20:30:50 <ttx> any objection to immediate approval ?
20:30:55 <dhellmann> it's not ideal, I guess, but it is better than deciding that after the fact
20:30:57 <notmyname> ttx: from sdague's comment. I don't know all the details. if someone is counted for voting status under the current rules, they should be able to vote, IMO. retroactively removing that seems wrong
20:30:57 <lifeless> I'm not happy about their inability to vote in the TC; its true someone else finished it, but they still contributed
20:31:11 <jgriffith> dhellmann: I get it, yeah
20:31:12 <ttx> notmyname: there is no retroaction
20:31:28 <dhellmann> right, they could have voted in this election, but not the next
20:31:31 <sdague> dhellmann: yeh, I think we should just state that up front
20:31:54 <ttx> lifeless: what if we had removed them 4 months ago ?
20:32:13 <lifeless> ttx: but we didn't
20:32:45 <ttx> OK, let's kick it back to the review and move on
20:32:53 <lifeless> when it comes to voting, I think we have to be both transparent and fair
20:33:02 <flaper87> I think it'd be fair to grant vote rights for that ATC and the state up front what we've just said in this meeting
20:33:09 <ttx> dhellmann: post a -1 then and I'll wait, even if it has more approvals than needed already
20:33:15 <markmcclain-mobi> I think if the team was part of any portion of the cycle we should honor it otherwise the tc could manipulate the electorate
20:33:21 <sdague> yeh, I'd be fine with extra atc status to expire post this election
20:33:21 <lifeless> right, thats all I've asked for - add them to extra-atc for one cycle, done.
20:33:32 <sdague> lifeless: yeh, I'm fine with that
20:33:46 <ttx> lifeless: two cycles
20:33:58 <lifeless> ttx: sure
20:34:00 <ttx> since their contribution grants them ATC for one year
20:34:01 <flaper87> We can write the conclusions of this meeting down in case this happens again
20:34:10 <lifeless> ttx: 'a period of ATC validity'
20:34:30 <anteaya> ATC is for 365 days
20:34:30 <mestery> flaper87: ++, good idea
20:34:34 <ttx> anyway, push it to the review
20:34:35 <anteaya> it is in the by-laws
20:34:35 <sdague> so, it's also weird that our ATC counting does count people that push a patch that fails all the tests, and never show up again
20:34:37 <ttx> moving on
20:34:51 <sdague> and someone else makes the code work and landable
20:35:02 <ttx> sdague: it should only count landed patches
20:35:11 <sdague> ttx: yes, landed by someone else
20:35:24 <sdague> because gerrit owner never resets
20:35:27 <ttx> sdague: yeah, orthogonal discussion
20:35:28 <dhellmann> anteaya: can you add a link to the relevant section of the bylaws in a comment on the review so we can use that to work up the policy?
20:35:31 <jeblair> sdague: if there was no contribution from the original author, i'm not sure why someone would pick up that patch vs starting a new one.
20:35:41 <anteaya> dhellmann: will do
20:35:47 <dhellmann> anteaya: thanks
20:36:05 <ttx> #topic Introduce assert:follows-standard-deprecation tag
20:36:10 <ttx> #link https://review.openstack.org/207467
20:36:20 <ttx> Patchset 4 incorporated all the changes requested at the last TC meeting, based on feedback collected on the email thread and the cross-project meeting
20:36:23 <lifeless> sdague: that means the person that fixed it chose not to reset the author
20:36:28 <ttx> Now has all needed approvals, will approve
20:36:43 <jeblair> lifeless: you can't change the owner in gerrit
20:36:44 <ttx> last-minute objection ?
20:36:48 <sdague> lifeless: actually, gerrit author never resets. Ever.
20:36:53 <jeblair> owner
20:36:54 <jeblair> not author
20:36:58 <sdague> right, owner
20:37:03 <sdague> which is the atc counter
20:37:12 <ttx> approved
20:37:17 * ttx stays on topic
20:37:28 <ttx> #topic Add new project Kosmos
20:37:34 <fungi> dhellmann: sorry, got sucked into other conversations. identifying contributors to a repo as official means we need some way of identifying that the repo was official at some particular point in time. ultimately we on'y really need to know that as far back as two cycles (one year) because of bylaws around tc elections
20:37:52 <ttx> #link https://review.openstack.org/223674
20:38:02 * Rockyg orders a round of beers hoping the TC are happy drunks
20:38:19 <dhellmann> fungi: ok, thanks
20:38:23 <ttx> I propose we go back to owner vs. ATC in open discussion if we have time left
20:38:26 <russellb> Rockyg: huh?
20:38:42 <ttx> Kosmos reignited the debate on how early you can submit project teams for inclusion in the tent
20:38:48 <flaper87> Jus to clarify my view, I'm not against Kosmos or the team but I'd like us to state this clearly too
20:38:51 <annegentle> way to go Kosmos
20:38:54 <ttx> I don't have a very strong position on that. My gut feeling is that I'd prefer the teams have something to show before they can be considered
20:38:55 <annegentle> :)
20:39:00 <lifeless> jeblair: sdague: I thought our tool looked at the git history ?
20:39:01 <ttx> And since we removed the stackforge rename step, I feel like there is no hurry... But I could easily be convinced otherwise
20:39:12 * dhellmann is considering applying for official status for a project to come up with project ideas
20:39:13 <flaper87> It does feel weird to approve empty projects, tbh.
20:39:16 <Rockyg> trying to lighten the discussion.  Getting a bit heated.  Rightfully so, but.....let's stay congenial
20:39:26 <dtroyer> we have pushed off other teams to get some history
20:39:43 <ttx> anyone from Kosmos to tell us why they want/need it now ?
20:39:45 <sdague> I do think it's a little different if those folks are already doing existing projects though
20:39:45 <flaper87> dtroyer: right
20:39:58 <ttx> sdague: yes, agreed, but it feels a bit subjective
20:40:07 <ttx> they are already "one of us" I guess
20:40:14 <russellb> ttx: comments seem to be that they don't care much whether it's now or later, and were just trying to follow process
20:40:14 * Rockyg volunteers to be on dhellmann's project
20:40:16 <annegentle> projects are people too
20:40:18 <flaper87> sdague: while I agree with that, opening it to subjective judgement doesn't feel right
20:40:19 <russellb> it's more of a "tell us when is the right time"
20:40:20 <mugsie_cell> ttx: I am on a mobile, but I gave an overview in my review
20:40:21 <lifeless> sdague: mmm, the namespace was the big thing in the past, but with the new stackforge mechanism... shouldn't matter at all
20:40:25 <dougwig> just filing the paperwork, so to speak. i wasn't aware of a want/need requirement. we're open to whatever.
20:40:27 <mestery> russellb: ++
20:40:35 <russellb> dougwig: thanks
20:40:46 <russellb> so really just up to us to say if this is the right time or not, since it's not clear enough to them
20:40:50 <ttx> mugsie_cell: thx, will read
20:41:03 * russellb thinks it's fine
20:41:06 <russellb> but don't feel that strongly
20:41:21 <russellb> though they make a good point that we could probably help some in clarifying it in new project workflow so people know what to expect
20:41:32 <mestery> Since it's top of mind and if folks don't mind, may make sense to approve now rather than punt this discussion down the road.
20:41:34 <flaper87> I think that either way, we won't be getting in their way
20:41:37 <ttx> right, I'm not -1ing, just raising the topic while it's here
20:41:40 <mestery> flaper87: ++
20:41:50 <russellb> flaper87: agree
20:41:57 <lifeless> I could go either way here
20:42:06 <dougwig> flaper87: indeed, we will be following the openstack conventions from our respective projects either way.
20:42:15 <lifeless> on the on hand, being 'in' early means no remedial catchup on project testing interface etc
20:42:33 <russellb> they'll be doing most of that either way, i suspect
20:42:34 <dtroyer> I think the consistent move is to defer this for a time and come back when there is some history for the project.
20:42:35 <lifeless> on the other hand, we've been prtty consistent about asking for visible evidence of 'doing stuff the openstack way'
20:42:43 <ttx> basically we are saying we are trusting that team to do the right thing
20:42:51 <flaper87> I just don't feel like making subjective judgements. Hope that makes sense. I do trust these folks :)
20:42:52 <jeblair> i'm still okay with new official empty projects
20:42:53 <ttx> rather than seeing the right thing in action
20:43:05 <fungi> lifeless: (still catching up so previous topic) the tool in question is based on gerrit queries for owner accounts (because the author is not necessarily someone holding a foundation membership/agreeing to a cla, but the uploader is) http://git.openstack.org/cgit/openstack-infra/system-config/tree/tools/atc
20:43:10 <ttx> I'm fine with that very small leap of faith
20:43:20 * mordred agrees with jeblair
20:43:33 * mordred has no problem approving empty projets made up of humans who are clearly openstack humans
20:43:38 <flaper87> if we're fine with new empty projects from folks that are already contributors of OpenStack, can we make that a thing in our governance repo?
20:43:38 <russellb> mordred: jeblair especially when it's people we already know
20:43:40 <dhellmann> yeah, esp. since the folks involved are already coming from existing official projects -- that hasn't always been the case for the other projects we've asked to wait
20:43:42 <mestery> mordred: Well said
20:43:43 <mordred> russellb: yup
20:43:46 <flaper87> Just to avoid having this conversation again in the futre
20:43:49 <flaper87> future
20:43:55 <annegentle> mordred: that's... weird. Just cuz I go to soylent green in my mind.
20:44:02 <ttx> the review has flaper87 -1 and is still missing a few approvals
20:44:03 <flaper87> I'm all for changing my vote, I just wanted to make sure we had this conversation
20:44:06 <annegentle> but yeah on the sentiment
20:44:31 * flaper87 changed his vote
20:44:34 <ttx> also I wanted to add -- this team has a worthwhile goal, I would hate to get in their way
20:44:35 <mordred> annegentle: openstack humans are tasty?
20:44:45 <flaper87> I'll try to word this and put it in our governance repo
20:44:46 <annegentle> nutritious!
20:44:51 <flaper87> because we like openstack humans
20:44:56 <ttx> OK, we have enough now
20:45:03 <sdague> though, the reality is being in the gov repo shouldn't really change anything about them getting stuff done
20:45:15 <sdague> because they can still have the gerrit repo regardless
20:45:25 <dtroyer> it shouldn't but it will affect resource allocation in spme companies
20:45:30 <sdague> dtroyer: sure
20:45:32 <ttx> approving in 30 sec tro give others a chance to record their vote
20:45:38 <anteaya> dhellmann: commented
20:45:43 <ttx> or oppose
20:45:44 <dhellmann> anteaya: ty
20:45:48 <anteaya> welcome
20:46:22 <ttx> I'll push the button at the end of this meeting
20:46:27 <ttx> in the mean time
20:46:27 <ttx> #topic Cross-project track at Mitaka design summit: collecting topics
20:46:31 <lifeless> there, I'm the -1 ;)
20:46:37 <ttx> jeblair and myself worked last week to resurrect odsreg
20:46:48 <ttx> lifeless: ah!
20:47:11 <ttx> The session suggestion website is opened at:
20:47:13 <ttx> #link http://odsreg.openstack.org/
20:47:21 <ttx> 5 suggestions there so far
20:47:30 <ttx> Note sure what relationship it should have with the etherpad. Since we posted the etherpad URL here people have been adding stuff to it directly
20:47:48 <ttx> Also, should we publish a deadline ?
20:47:59 <russellb> i would think it makes sense to just input everything from the etherpad into odsreg so it's in one place
20:48:00 * russellb shrugs
20:48:14 <flaper87> ttx: +1 for deadline and I'd recommend sending out an email recommending people to move their topics to odsreg
20:48:28 <ttx> flaper87: ok, who takes that action ?
20:48:35 <ttx> Also I propose to set up a specific meeting for the cross-project track workgroup to come up with a proposed plan, rather than take meeting time to work out the details
20:48:48 <ttx> since we have a bit of a backlog already
20:48:54 <sdague> seems reasonable
20:49:12 <anteaya> annegentle: did you want to suggest a session on communication? as a follow up of your mailing list thread?
20:49:17 <flaper87> ttx: I will
20:49:25 <flaper87> I've some time in my hands now
20:49:29 <sdague> so, was there a particular reason to not just use the etherpad?
20:49:30 <annegentle> anteaya: I did add to the etherpad iirc
20:49:44 <annegentle> but hadn't done the osdreg step
20:49:50 <anteaya> okay so I guess it will be transfered
20:49:50 <ttx> #action flaper87 to send a deadline and recommend  people to move their topics to odsreg
20:49:57 <annegentle> anteaya: do I need to do it?
20:50:01 <annegentle> ah ok
20:50:03 <anteaya> ah self serve looks like
20:50:14 <lifeless> isn't the etherpad better for us ?
20:50:21 * annegentle grabs an ice cream cone
20:50:23 <anteaya> sdague: yes at last weeks meeting folks didn't want to use the etherpad
20:50:39 <dhellmann> *some folks
20:50:47 <sdague> ok
20:50:49 <lifeless> we can't use odsreg to schedule
20:50:53 <anteaya> much discussion about it, then odsreg is alive
20:51:05 <anteaya> dhellmann: thanks for the correction, some folks
20:51:09 <lifeless> the only point - AIUI from last week - was structured data gathering
20:51:34 <ttx> yeah, for workgroup discussion we'll likely put all things in an etherpad again
20:51:37 <dhellmann> yeah, I think the main point was ensuring there was a name attached to everything
20:51:55 <lifeless> so - lets /not/ mass copy stuff to odsreg, waste of valuable time
20:52:09 <ttx> I'm fine aitehr way
20:52:19 <ttx> or either
20:52:27 <jeblair> we may get duplicate submissions that way
20:52:29 <lifeless> if we're going to have to move it all to the etherpad anyway
20:53:04 <annegentle> ok
20:53:30 <ttx> flaper87: so maybe just set a deadline
20:53:46 <ttx> and find a date for a planning meeting
20:53:58 <flaper87> ttx: yeah
20:53:59 <annegentle> I have to duck out early, sorry. Feel free to sign me up for a blog post if needed.
20:54:01 <ttx> moving on ?
20:54:05 <jeblair> i believe we also wanted to use odsreg to collect comments
20:54:14 <jeblair> so i think having all the topics in there would help facilitate that
20:54:48 <jeblair> (actually, i think that was the main thing we wanted it for)
20:55:19 <dhellmann> ah, I thought it was the names on the comments we cared about, since anyone can leave text in the etherpad, too, but I probably misunderstood
20:55:27 <anteaya> jeblair: I remember the ability to create comments
20:55:32 <ttx> flaper87: you write the email you make the call :)
20:55:53 <jeblair> dhellmann: i bet we'd be happiest with both comments and names of people who left them! :)
20:56:01 <flaper87> ttx: Yes sir! I'll read more into this
20:56:04 <ttx> people with a string opinion can discuss with flaper87 about the right wording.
20:56:06 <anteaya> dhellmann: I thought it was the names on the topics, but you will capture names on comments too with odsreg
20:56:11 <ttx> Moving on
20:56:11 <sdague> yeh, the real concern was last time we had topics without owners, that was a mess :)
20:56:17 <dhellmann> jeblair: you got your chocolate in my peanut butter!
20:56:20 <ttx> #topic Add team:non-diverse-affiliation tag
20:56:24 <ttx> #link https://review.openstack.org/218725
20:56:26 <ttx> This is making slow but steady progress
20:56:30 <ttx> Most of the opposition seems to focus on the wording of the first paragraph
20:56:41 <ttx> No time to discuss it now -- If you have other objections it would be good to express those, so that jogo can include them in the next revision of this
20:56:53 <ttx> #topic Communications workgroup report
20:57:13 <ttx> flaper87: we might have enough for a blogpost, and anne signed up for one
20:57:16 <flaper87> We didn't have a blog post last week, but I think we have material for this week
20:57:20 <flaper87> ttx: yup
20:57:27 <ttx> flaper87: any other comment ?
20:57:37 <flaper87> nope, I'm glad she raised her hand
20:57:40 <flaper87> :P
20:57:55 <ttx> #topic Open discussion
20:57:59 <ttx> Skipping "other workgroups" since we don't really have any
20:58:09 <ttx> So it looks like the final decision on Kosmos will be delayed to next week, so we have time to think a bit more about it
20:58:23 <ttx> Quick note that we'll be having TC elections starting next week with self-nominations
20:58:29 <ttx> We renew half the TC (russellb, sdague, annegentle, jgriffith, dhellmann and mordred's seats)
20:59:00 <ttx> Anything else, anyone ?
20:59:06 <flaper87> o/
20:59:09 <flaper87> just a quick note
20:59:13 <ttx> flaper87: one minute
20:59:35 <flaper87> I'd like us to improve a bit the process of reviewing cross-project specs. I'll be digging into this and I'll come back with more info
20:59:48 <flaper87> hopefully a solution or at the very lesat an idea
21:00:10 <ttx> mordred: you will sync with dhellmann for a new patchset on https://review.openstack.org/#/c/224743/ ?
21:00:11 <flaper87> It's my impression that those specs are moving forward very slow
21:00:28 <flaper87> that's it
21:00:38 <ttx> flaper87: you saw the recent thread about it right
21:00:44 <ttx> anne started it
21:00:55 <flaper87> ttx: yes
21:01:01 <ttx> ok, just checking
21:01:03 <flaper87> :)
21:01:14 <ttx> we'll likely have a cross-project session on that, I proposed one
21:01:18 <ttx> and... no time left
21:01:21 <ttx> #endmeeting