20:03:37 <ttx> #startmeeting tc
20:03:38 <openstack> Meeting started Tue Feb 10 20:03:37 2015 UTC and is due to finish in 60 minutes.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:03:39 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:03:41 <openstack> The meeting name has been set to 'tc'
20:03:48 <russellb> o/
20:03:49 <ttx> Our agenda for today:
20:03:49 * reed drumrolls
20:03:53 * sarob lurking
20:03:54 <ttx> #link https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee
20:04:01 <ttx> #topic L naming results
20:04:03 * devananda lurks
20:04:03 <mordred> o/
20:04:10 <ttx> I closed the poll a couple minutes ago
20:04:18 <ttx> It's a *very* close call between Lizard and Liberty.
20:04:29 <ttx> So close I actually have to feed the ballots into a proper Condorcet poll to get the Condorcet winner
20:04:44 <russellb> i'm surprised
20:04:48 <russellb> i thought it'd be one of the other 2
20:04:56 <markmcclain> yeah.. same
20:04:58 <ttx> I guess I should ask... Condorcet sounds like a good way to tell the winner, right ?
20:05:07 <sdague> ttx: +1
20:05:11 <mikal> Works for me
20:05:12 <russellb> sure, why not
20:05:19 <anteaya> if you didn't like what survey monkey gave you
20:05:22 <reed> unless the winner is liberty that way :)
20:05:30 <annegentle> lol reed
20:05:33 <ttx> Well, surveymonkey goves me a % of each ranking
20:05:41 <ttx> which doesn't tell condorcet preference
20:05:41 <anteaya> not very helpful
20:05:51 <ttx> OK, so the winner is:
20:05:53 <sdague> I think the results of the poll are an indication that the TC's ideas on naming often veer wildly from what the community likes :)
20:05:59 <ttx> #link http://civs.cs.cornell.edu/cgi-bin/results.pl?id=E_dc5ea66e94acc07a
20:06:03 <ttx> sorry, anderstj
20:06:07 <ttx> err anteaya
20:06:25 <jaypipes> poo.
20:06:29 <anteaya> shows how much folks know about canada I guess
20:06:57 * dhellmann returns all of the stuffed lizards he ordered online
20:06:59 <ttx> not my choice either
20:07:05 <russellb> it'll do
20:07:05 <anteaya> dhellmann: send them to me
20:07:23 <ttx> but then 1474 votes is also more than previous polls I think
20:07:26 * ttx checks
20:07:51 <ttx> yeah, 908 replies for K
20:07:58 <jeblair> vote early, vote often
20:08:04 <anteaya> apparently
20:08:13 <ttx> and 748 for J
20:08:35 <jbryce> well the community grows and people did sort of make a bigger deal out of this one so the increased visibility is not surprising
20:08:44 <ttx> Anyway, Liberty it is
20:08:58 <ttx> I guess.
20:09:01 <russellb> heh
20:09:04 <sdague> weren't we previously concerned by low voter turn out? seems odd to complain about high turn out for this just because it's none of our first choices
20:09:12 * anteaya dons her green dress and looks for a crown and torch
20:09:15 <ttx> sdague: agreed
20:09:16 <dhellmann> anteaya: I was going to exchange them for novelty handcuffs
20:09:20 <jeblair> who's complaining?
20:09:25 <ttx> #topic Project structure reform
20:09:25 <anteaya> dhellmann: that's all you then
20:09:29 <anteaya> dhellmann: I'm out
20:09:35 <sdague> jeblair: jaypipes said poo :)
20:09:45 <jeblair> haha
20:09:48 <dhellmann> anteaya: foam crowns?
20:09:58 <russellb> nice
20:10:02 <ttx> jeblair: I'm not. Can't win every time :)
20:10:06 <anteaya> dhellmann: never tried them
20:10:15 <ttx> * Adds service to indicate a user-readable and understandable name (https://review.openstack.org/150030)
20:10:21 <ttx> So... This looks ready, i'll approve it when it reaches 7 YES (unless a -1 is posted that we should discuss)
20:10:35 <ttx> one more needed
20:10:47 <ttx> * Make oslo requirement more vague (https://review.openstack.org/152748)
20:10:59 <ttx> So I like that we speak in more general terms here
20:11:21 <ttx> that keeps a pretty subjective item on the list, but looks like we are ok with that
20:11:38 <russellb> it could mention oslo as a clear example, but whatever, it's fine
20:11:42 <jeblair> it's in a "should"
20:11:56 <jeblair> i think its main purpose is to communicate intent and desire anyway
20:12:22 <ttx> one more +1 needed and I'll approve it (starting tomorrow morning)
20:12:26 <britthouser> Liberty Bell?
20:12:39 <britthouser> too patriotic?
20:12:41 <ttx> I'll take a picture while in PHL
20:12:52 <ttx> * New project teams requests
20:13:04 <ttx> OK, so with https://review.openstack.org/#/c/145740/14 merged last week we formally have migrated to the new world order
20:13:14 <ttx> even if we didn't really publicize it that much yet
20:13:26 <ttx> I updated the wiki to match it and mention the new terminology and processes
20:13:27 <russellb> though we haven't exactly clarified the bar for entry though right?
20:13:30 <dhellmann> we stopped blogging about these meetings this cycle
20:13:45 <ttx> So my question to you all is: are we ready to accept new project teams requests, starting now ?
20:13:57 <ttx> I was pinged by a few teams about when the new process would be open for applications
20:14:10 <russellb> oh nevermind
20:14:30 <ttx> Personally I think we can start getting applications, and refine the rules as we go
20:14:38 <ttx> I tentatively described the new process at:
20:14:43 <ttx> #link https://wiki.openstack.org/wiki/Governance/NewProjectTeams
20:14:50 <ttx> if you want to check it out.
20:15:17 <ttx> If we feel we are open for business, I can write a blogpost about the new world order (including the transition from Programs to Project Teams).
20:15:25 <russellb> don't want to put that process in governance repo?
20:15:36 <vishy> o/ sorry i’m late
20:15:40 <anteaya> russellb: +
20:15:41 <ttx> russellb: it's mostly a pointer to governance
20:15:49 <ttx> replacing old wiki pages
20:15:56 <sarob> if you want a test run, im happy to push the first patch
20:16:04 <ttx> Thoughts ? Too early ? Bring it on ?
20:16:41 <devananda> ttx: a trickle at first would be good to test the process, iterate to learn before the summit
20:16:42 <markmcclain> how many folks have inquired…should we have a slow start to the process?
20:16:50 <dhellmann> as long as we're clear that the process for evaluating proposals is still being worked out, and that may mean a lot of back-and-forth, I think having a few concrete requests would be a good thing
20:16:51 <devananda> ttx: as I'm sure we'll have a lot of questions from folks by then
20:16:58 <ttx> markmcclain: the security group (ossg) asked
20:17:11 <devananda> dhellmann: ++
20:17:27 <markmcclain> if we have 1-2 willing to work with us then I think it makes sense
20:17:34 <mikal> Agreed
20:17:34 <ttx> + a few pings about "when" from a couple stackforge projects
20:18:05 <sdague> personally, I'd like to get a bit more of the test / devstack unwind done with existing projects so new projects have a better pattern for integrating into those parts. But I won't hold if up if everyone else wants to move forward.
20:18:54 <ttx> we can build up a queue and I can mention in that blogpost that we are slowly ramping up
20:19:06 <ttx> to set the right expectations delay-wise
20:19:10 <fungi> ossg is probably an easy one to test the waters because it's less repo-oriented and more of a horizontal effort, but conversely that means it won't exercise much of the process which will be heavily used later
20:19:14 <russellb> i'm fine with starting now, but i might not publicize it much just yet
20:19:20 <annegentle> yeah set the timing expectations clearly
20:19:27 <annegentle> and then it's fine to start
20:19:35 <ttx> russellb: not publicizing is a two-edged sword
20:19:51 <ttx> I haven't communicated more about it because i wanted to have that discussion with all of you before
20:19:55 <ttx> but I think we should
20:20:09 <russellb> or could at least coordinate among ourselves which ones to review first to test the process
20:20:15 <russellb> instead of thrashing around on 15 at once
20:20:26 <dhellmann> yeah, I don't think it's fair to just allow projects that have asked ttx about it. We just need to make clear that we're going to review requests one at a time until we have the process down.
20:20:37 <russellb> wfm
20:20:41 <dhellmann> we can start with ossg and then review the others in the order they are submitted, for example
20:20:41 <ttx> wfm too
20:20:55 <jaypipes> wfm 3
20:20:57 <ttx> right, saying we won't process them in parallel
20:21:13 <ttx> bonus points to projects following the TC meeting
20:21:14 <sdague> also, some might be much easier than others
20:21:31 <lsell> I think it would be helpful to lock down and communicate a few more details about the end state / vision / tagging system, etc. before accepting new projects. I think communicating in pieces and starting to accept applications may be confusing
20:21:37 <dhellmann> sdague: true, but maybe we should do a couple of hard ones early
20:21:43 <sdague> I think the more a project needs resources or info from horizontal teams it's ok to delay
20:22:09 <sdague> dhellmann: yeh, my concern is hard ones are probably ones that horiz teams aren't quite ready for externalized support on
20:22:19 <russellb> 564261
20:22:34 <dhellmann> sdague: sure, and that's good feedback and a reasonable outcome is to say "we're not ready to handle you yet" which signals to other projects in a similar state
20:22:35 <ttx> someone turned russellb in a number station
20:22:41 <russellb> damn yubikey :)
20:22:46 <annegentle> are we going to overload our focus on tagging solutions though?
20:22:54 <dhellmann> sdague: we don't have to *approve* the proposals, just review them
20:22:58 <sdague> dhellmann: yep
20:23:02 <ttx> annegentle: i don't think so
20:23:17 <annegentle> ttx: tell me more
20:23:19 <sdague> I think as long as we're clear to folks that we need to unit test this process, so it maybe be slow to start, it's fine
20:23:24 <dhellmann> sdague: ++
20:23:44 <annegentle> so is this gate opening act a way to get tags started? (perhaps I'm just missing something)
20:24:01 <ttx> annegentle: like I said before, I expect most tags maintenance to be delegated. For example, once we define coordinated-release, compatible-release etc. tags I expect maintenance to be delegated to release management team
20:24:02 <dhellmann> annegentle: we're just talking about new projects, right? I don't think we need tags  for that
20:24:12 <russellb> project applications, right
20:24:16 <russellb> to get on "the list"
20:24:25 <dhellmann> russellb: that's The List (tm)
20:24:55 <russellb> got it :)
20:25:08 <ttx> anything more on that before we move on to future release naming process ?
20:25:45 <annegentle> ok so this is for new projects, who are applying without knowing much more than "I want to be an OpenStack Project Team and we're done being a Workgroup"
20:26:03 <ttx> annegentle: right
20:26:24 <ttx> I want my work to be recognized as a part of OpenStack
20:26:38 <annegentle> okay
20:26:57 <annegentle> ttx: oh one more thing
20:26:58 <mordred> I want to recognize people's work
20:27:01 <annegentle> sorry need to type faster.
20:27:10 <ttx> now you sound like Columbo
20:27:23 <annegentle> so they still need to meet the requirements from http://governance.openstack.org/reference/new-projects-requirements.html
20:28:00 <ttx> annegentle: we may realize that this page is a bit too much geared toward projects -as -in - stackforge projects
20:28:21 <ttx> and does not contain enough info for new horizontal teams like translations / OSSG
20:28:43 <ttx> but I'm fine with updating it as we go
20:28:55 <annegentle> ok
20:29:02 <lsell> just to confirm, there will no longer be projects in incubation?
20:29:15 <ttx> lsell: there already is no longer projects in incubation
20:29:37 <ttx> there are just some projects still in a integrated-release.
20:29:42 <ttx> and "other" projects
20:30:14 <ttx> and we'll split integrated-release into more meaningful and defined bits
20:30:35 <ttx> like actually-released-together, actually-tested-together etc
20:30:55 <annegentle> so that still has me worried
20:30:55 <ttx> OK, let's move on...
20:30:59 <russellb> it's going to get a lot more confusing :)
20:31:11 <ttx> russellb: but more precise.
20:31:13 <annegentle> the "gate opening prior to tag definition" :)
20:31:17 <jbryce> as dhellmann pointed out, the post-meeting tc blogging has kind of slowed down and i think there’s still quite a bit of mass confusion out there about the current state of all of this. with 145740 getting merged, it’s probably a good time to try to communicate the purpose and state. especially if new projects are going to start through the process
20:31:20 <mordred> russellb: nope. we're going to redefine confusing as not-confusing
20:31:21 <russellb> hopefully we can mitigate that to some degree ...
20:31:26 <russellb> mordred: oh, neat
20:31:40 <ttx> annegentle: it's not very different from the previous situation
20:31:50 <sarob> jbryce: +1
20:32:04 <ttx> #action ttx to write about the t
20:32:07 <annegentle> ttx: yeah the previous wasn't a good world either, so looking for a way to take lessons learned
20:32:09 <ttx> arr
20:32:14 <annegentle> pirate!
20:32:14 * mordred wants to read the blog about the t
20:32:35 <ttx> #action ttx to write about the transition to project teams, with due setting of expectations on how fast we'll process applications
20:32:39 * jbryce wants to read the blog about the upper T
20:32:59 <ttx> ok, moving on
20:33:05 * sarob shiver me timbers upper T
20:33:06 <ttx> #topic M+ Release naming process
20:33:13 <ttx> #link https://review.openstack.org/150604
20:33:19 <ttx> Since last week Lauren commented with suggestions.
20:33:31 <ttx> Like I said last week, I share the concern with running a public poll with options we strike down after the vote
20:33:45 <ttx> My strawman would be like this: the TC checks candidate names for validity against naming rules, then runs a quick Condorcet poll among TC members to grossly rank all the options
20:33:58 <ttx> then a trademark search is run to select the first 10 valid names, and that's the options we present to the electorate.
20:34:05 <mikal> I haven't voted on this revision because it happened while I was asleep
20:34:10 <jeblair> i pushed up a new revision with the minor/consensus points addressed
20:34:17 <ttx> jeblair: damn!
20:34:30 <ttx> you and your weird timezone
20:34:36 <jeblair> i did not make the changes you and lsell are suggesting
20:34:57 * ttx quickreads
20:35:01 <jeblair> i feel like that substantially alters the proposal from mordred
20:35:19 <jeblair> i think that's a legitimate/important choice to make
20:35:39 <jeblair> but i favor the approach where we get the tc out of choosing as much as possible and let the whole community decide
20:36:14 <david-lyle> does the foundation currently trademark the top four on the ballot before the vote?
20:36:16 <jeblair> i recognize the difficulties posed by post-poll trademark vetting, but i think the benefits outweigh it, and it's worth a try
20:36:36 <mordred> yeah - I'd also like to be out of that game - I think the most recent election shows that the TC's choice on this is not what the community chooses
20:36:37 <jbryce> david-lyle: yes
20:36:49 <ttx> jeblair: I see your point -- just wanted to present an alternative solution
20:36:54 <mordred> as I think the TC would have chosen either Lizard or would have written in Lemming :)
20:36:59 <david-lyle> a wide open list would be easy to block if trademarked after the fact
20:37:12 <jbryce> david-lyle: to be clear, we don’t trademark them but we check their availability
20:37:16 <mikal> Well, trade mark search, not trademark
20:37:17 <mikal> Yes?
20:37:20 <ttx> jeblair: the TC still accepts exceptions, which makes it pretty central to the game
20:37:23 <mikal> Ahhh, yeah, that
20:37:43 <mordred> ttx: sure - but only in an exception manner - not as arbiters of taste in general
20:37:58 <jeblair> ttx: yeah.  i think the revised rules are pretty generous and hopefully will reduce calls for exceptions.
20:38:15 <mordred> also - the TC is the elected body of the ATCs - as was rightly pointed out, this is a decision that encompases more than just ATCs
20:38:46 <mordred> so while I think using the TC for exceptions is fine - it's really just that it's an easy and expedient way to do that which puts less people on the spot
20:38:51 <mordred> given that we have weekly open meetings
20:39:11 <mordred> but if the entire populace of our community can express an opinion here, that's pretty cool!
20:39:28 <ttx> jeblair: how would you run it, though ? The results will be out. People will start using the names. Then we come back and say well... #5 is actually the right name ?
20:39:32 <jeblair> occasionally we might be asked to make decisions that affect the whole community.  hopefully we're up to that.  :)
20:39:38 <ttx> I just don't see how that can work :)
20:39:51 <jeblair> some folks have been using "lemming" for months, but that doesn't make it the name.
20:39:58 <ttx> jeblair: or would you use some secret platform and keep the results for yourself ?
20:40:04 <jbryce> jeblair: pretty much all of your decisions affect the whole community…
20:40:34 <mordred> the name doesn't get encoded anywhere _REAL_ until the materials are printed for the Summit and then 6 months later until it's a stable branch
20:40:35 <ttx> jeblair: *you* have been using it, maybe the TC was using it... But think about 1474 people using it
20:40:47 <mordred> I'm pretty sure the foundation staff is not going to start printing code names until the trademark check is done
20:40:53 <ttx> mordred: it appears in spec repos quite fast
20:41:07 <mordred> ok. so we shame those people - no big deal
20:41:13 <jbryce> the other thing to keep in mind is that trademark searches are not a binary yes/no answer. sometimes it can take days to more than a week to get an answer
20:41:36 <jeblair> ttx: i don't think it's going to be a problem.  and if it is, we could see about a platform that lets us delay publishing results.
20:41:40 <mordred> if we do a vote and don't have an official answer for another 6 weeks I personally don't see that as a problem - but then I'm unreasonable
20:42:00 <jbryce> and often the most popular names are usually the most likely to be already trademarked, so if we have to do that cycle a few times to get to the right one, it could easily be 2-3 weeks after the vote closed
20:42:10 <mordred> ok
20:42:25 <ttx> I guess i don't want to be *that* election official
20:42:29 <morganfainberg> i only ask one thing, how does ubuntu handle this? they publish possible names waaay in advance - and seem to coalesce on a real name when it's official
20:42:39 <mordred> morganfainberg: theya re chosen in secret by mark
20:42:41 <ttx> morganfainberg: Mark Shuttleworth picks
20:42:44 <ttx> no contest
20:42:53 <mikal> He also sometimes changes his mind later
20:42:59 <morganfainberg> sure. but the options are still published then mark picks something
20:43:03 <mikal> And then they do a big renaming of things
20:43:06 <ttx> morgabra: no
20:43:11 <ttx> morganfainberg: of course not
20:43:12 <reed> morganfainberg, they also put an adjective to the name, so I believe the chances that a trademark is registered on 2 words is much lower
20:43:18 <morganfainberg> reed, ++
20:43:23 <ttx> morganfainberg: the options are not published
20:43:25 <jeblair> jbryce: you could still check the top N names, and be no worse off than today as far as investment in that process goes
20:43:33 <morganfainberg> ttx oh i thought they were. *shrug*
20:43:50 <jeblair> morganfainberg: i thought that too
20:44:06 <jbryce> jeblair: i’m talking more about the concern of how long people are willing to wait after a vote to find the actual winner
20:44:25 <david-lyle> the longer the wait, the more closed the system appears
20:44:27 <mordred> jbryce: it can't be worse than waiting for months to have a vote in the first place and not knowing when that's goign to happen
20:44:28 <morganfainberg> jbryce, i think a delay of "when we have an answer" is probably fine.
20:44:31 <ttx> david-lyle: ++
20:44:33 <sdague> jbryce: I think if we get a couple of cycles in advance people won't car as much
20:44:49 <sdague> like if we're doing the N naming now, and it takes 6 weeks from now to know, that's cool
20:44:49 <morganfainberg> sdague, ++
20:44:51 <mordred> I think if there is a clear statement of "we did the vote, here are the prelim results - but guess what, we have to do legal trademark checks, so hang out for a sec"
20:44:52 <jbryce> sdague: that would be nice
20:44:55 <mordred> sdague: ++
20:45:00 <ttx> jeblair, mordred: I just fear the system will appear even more arbitrary and closed than today
20:45:12 <mordred> ttx: I don't see how that's possible
20:45:22 <sdague> so I'd say that if we are moving to this, we make it a goal to have the next 3 releases named
20:45:22 <ttx> jeblair, mordred: I take it you're fine with being the election officials for this one ?
20:45:26 <mordred> it has a clear system for getting nominations
20:45:29 <mordred> a clear system for voting on them
20:45:29 <jbryce> ttx: also a good point. when we’ve had to deal with trademark names before, we always get accused of not trying hard enough
20:45:41 <mordred> ttx: sure!
20:45:41 <jeblair> sdague: oh, that's something we might still need to tweak in my patch.  i think i have it limited so that we could do L now, but not N until after L is released (still before the L summit though).  do folks want to push that back one more cycle?
20:45:57 <jbryce> and the reality is that when you get into some of those discussions (like potential liability), you just can’t talk about that in an open forum
20:46:05 <morganfainberg> sdague, i think being more than "next cycle" does really address that.
20:46:29 <ttx> jeblair: "as soon as we know officially where the next summit is" ?
20:46:30 <morganfainberg> because then there is no rush to get results in a narrow window
20:46:30 <jeblair> jbryce: i have full faith that the foundation is equipped to turn the vagaries of a tm search into a binary yes/no
20:46:34 <mordred> ++
20:46:53 <ttx> jeblair: but then "the Foundation" is blamed for slashing favorites
20:46:54 <lsell> it just feels to me like we're jumping from one extreme to another without trying to make some modifications like putting more names on the ballot, getting more community input via other means before finalizing the ballot, being more transparent about which names do or do not have risk from a trademark perspective before we come up with the final roster, etc...
20:47:12 <dhellmann> jeblair: I liked keeping that limited, so we wouldn't pick N until we start work on L
20:47:32 <mordred> I think we're just trying to put a process in place that does not have arbitrary limitions
20:47:44 <mordred> the ONLY limitations are if a trademark check comes back negative ex post facto
20:47:48 <mordred> which is completely fair game
20:48:01 <mordred> and does not, to jbryce's point, need open discussion
20:48:35 <ttx> The other contentious point was marketing feedback
20:48:48 <ttx> As far as marketing feedback goes, I think we can either add a "no disparaging or negative connotation" rule and have the TC judge that in phase 1 (with public input from marketing)...
20:48:59 <ttx> ...or just flag options which trigger marketing concerns and let the electorate make the final call
20:49:06 <ttx> I think the current proposal is the latter
20:49:07 <jeblair> dhellmann: yes, i want _some_ time limit so that we don't just pick the next 100 names at once, but if it would improve things to know the name sooner than what i wrote (opening of development on previous release, which, to be fair, is much earlier than we have been doing), i'm open.
20:49:11 <mordred> I think the electorate are smart people and trust their decision making ability
20:49:20 <sdague> personally, I don't really mind the current process. The only draw back I've seen with it is names coming too late, so we really do have long arc plans in some projects which we have to mark as "well, that's an L thing, and this is probably M, so that we can do the following in N"
20:49:21 <dhellmann> jeblair: ++
20:49:27 <mordred> I think if they are informed as to concerns, then their voting can be very robust
20:49:49 <sdague> like cells v2 in nova had conversations that went like that
20:49:51 <dhellmann> sdague: yeah, I'd love it if we had the M name by the L summit
20:50:13 <jeblair> dhellmann: cool, so that's the timetable i have in my proposal -- we would do M right after the L release.
20:50:17 <ttx> we used to not even know wher ethe nest summit would be until the summit itself
20:50:21 <ttx> next*
20:50:21 <lsell> so in practice, how many names do you expect to see on the ballot?
20:50:25 <jeblair> grr
20:50:28 <mordred> 50?
20:50:29 <jeblair> dhellmann: cool, so that's the timetable i have in my proposal -- we would do M right after the K release.
20:50:44 <mordred> I believe the initial list for G was something like that size, wasn't it ttx?
20:50:51 <dhellmann> jeblair: would that actually leave time for the trademark search before the L summit?
20:51:08 <ttx> Well, the list for L was about 30 names yes
20:51:17 <jeblair> dhellmann: i think there's like 3 weeks, so it sounds like it could go either way.  also, foundation staff might be busy.  :)
20:51:34 <dhellmann> jeblair: right, so maybe we actually need to run that sooner than your proposal
20:51:48 <ttx> mordred: arguably one issue with the current system was that nobody added anything to that wiki page
20:51:52 <dhellmann> jeblair: if we double up this cycle, we can move to one poll per cycle after this one
20:52:04 <dhellmann> jeblair: maybe between the 1 and 2 milestones?
20:52:07 <mordred> ttx: ++
20:52:12 <jeblair> dhellmann: wfm
20:52:17 <mordred> jeblair, dhellmann ++
20:52:27 <mikal> jeblair: I'd like to open L specs now, so having the next name mid-cycle would help
20:52:33 <mikal> jeblair: now is a bit late for my needs
20:52:43 <mordred> mikal: good point
20:52:58 <ttx> OK, I guess we can do another round of comments on the review. If someone feels strongly that an alternate proposal is better, they should file it
20:53:04 <dhellmann> mikal: yeah, we'll be a little late this time but next cycle we should have the future names sooner
20:53:04 <mikal> I want to do that as part of freezing new features for Kilo
20:53:05 <morganfainberg> mikal, ++
20:53:21 <jeblair> mikal: even my current proposal would accomodate that; the proposed change would have you knowing M by this point.
20:53:22 <ttx> jeblair: unless you intend to still tweak it ?
20:53:40 <mikal> jeblair: excellent
20:54:13 <ttx> I still have a couple points to cover on the agenda
20:54:17 <jeblair> ttx: i think the only thing that might change is the timing; so maybe folks should review this, with particular attention to that
20:54:37 <mordred> ttx: are any of the next points things that involve the color of sheds in which bikes are held?
20:54:44 <ttx> jeblair: right, so people wanting something else should file that something else rather than expect you change your proposal significantly at this point
20:54:47 <jeblair> or do we want me to go ahead and back it off so that, if we were using it now, we would have just finished the "M" poll?
20:55:20 <jeblair> ttx: yes, i think any more substantial changes should be another proposal
20:55:29 <ttx> jeblair: frankly the timing is a non-issue, you could even remove it from the draft ("no later than" is plenty enough)
20:55:56 <ttx> poll will happen when someone steps up to do it, like always
20:56:21 <ttx> Historically I realize I should have already done it and I start working on it
20:56:32 <ttx> I expect the future officials to do the same
20:56:45 <ttx> and ask the TC about if timing sounds right
20:56:56 <jeblair> i'd like some guidance about timing in there
20:56:59 <anteaya> ttx +1 for no later than
20:57:13 <ttx> ok moving on
20:57:18 <ttx> #topic Other governance changes
20:57:22 <ttx> * Add Cinder's os-brick library to cinder (https://review.openstack.org/153673)
20:57:29 <ttx> There is a comment from mikal on os-* names which sounds like a valid concern to me
20:57:44 <mikal> I got talked around though
20:57:49 <mikal> There being a pypi clash and all
20:57:50 <ttx> don't want to go to an early rename
20:57:56 <mikal> I still don't love it though
20:58:05 <dhellmann> The name 'brick' is taken, so do we want to recommend completely renaming it?
20:58:10 <ttx> so let's wait a bit on this one and think it through
20:58:18 <ttx> dhellmann: right,n that's what I meant
20:58:24 <jeblair> yeah, 'os-' was not because we love having 'os-' in names, it was because "apply-config" was just really generic.
20:58:25 <anteaya> I am not in favour of os-* names
20:58:35 <ttx> The last 3 shall be approved tomorrow morning unless someone complains by then
20:58:36 <jeblair> "brick" is not generic.  it's just taken.  :)
20:58:38 <ttx> * Remove oslo.version from official projects (https://review.openstack.org/152654)
20:58:41 <ttx> * Removes <service>-api repos from Documentation program (https://review.openstack.org/152140)
20:58:45 <ttx> * Typo in Morgan's name and IRC nick (https://review.openstack.org/153213)
20:58:54 <ttx> #topic Open discussion
20:58:59 <mikal> I should -1 that last one and ask if Morgan can just change his name
20:59:00 <sdague> can we all -1 https://review.openstack.org/153213 and make him change his name?
20:59:05 <morganfainberg> mikal, hahah
20:59:07 <mikal> sdague: nap!
20:59:13 <mikal> snap even
20:59:13 <ttx> As promised I pushed the discussion on openstack-specs approval rules to -dev but only Morgain replied:
20:59:19 <ttx> I prefer to just call him Morgain
20:59:24 <jeblair> oh wait i didn't see that
20:59:26 <ttx> #link http://lists.openstack.org/pipermail/openstack-dev/2015-January/055387.html
20:59:26 <sdague> but, seriously, can we actually just merge changes like that
20:59:35 <ttx> sdague: ok ok ok
21:00:01 <ttx> I'm getting careful now, don't want other people saying I'm abusing my power
21:00:17 <ttx> On the abovementioned thread, I would appreciate more people chiming in so that we can make a final call on that, before we rubberstamp another spec
21:00:35 <jeblair> ttx: will do
21:00:44 <ttx> Anything else, anyone ?
21:00:47 <jeblair> i have finally written up an analysis of our alternatives
21:00:51 <jeblair> so i can reply to that thread with it
21:00:58 <jeblair> i just did not see it in my ML reading
21:00:58 <ttx> jeblair: ++
21:01:01 <jeblair> (skimming)
21:01:11 <ttx> which is why I mention it today
21:01:17 <jeblair> thank you muchly!
21:01:23 * morganfainberg forgot i even responded to that thread
21:01:27 <ttx> ok, I think we are done
21:01:29 <morganfainberg> i had to re-read my own response to see waht i said
21:01:39 <ttx> #endmeeting