20:01:53 <ttx> #startmeeting tc
20:01:54 <openstack> Meeting started Tue Oct 21 20:01:53 2014 UTC and is due to finish in 60 minutes.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:01:55 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:01:57 <openstack> The meeting name has been set to 'tc'
20:02:02 <dhellmann> o/
20:02:02 <ttx> Our agenda for today:
20:02:09 <ttx> #link https://wiki.openstack.org/wiki/Governance/TechnicalCommittee
20:02:16 <ttx> First meeting of the Kilo season ! woohoo
20:02:18 <devananda> o/
20:02:24 <russellb> \o/
20:02:27 <ttx> #topic Welcome new Kilo TC members
20:02:35 <ttx> welcome back jgriffith
20:02:40 <jaypipes> welcome jgriffith
20:02:41 <ttx> #link https://review.openstack.org/129274
20:02:47 <dhellmann> jgriffith: o/
20:02:47 <jeblair> welcome jgriffith!
20:02:49 <ttx> This is housekeeping, will approve now unless someone complains
20:02:59 <jgriffith> :)  Thanks!!!!
20:03:40 <ttx> #topic Election of the Kilo TC chair
20:03:46 <ttx> Is anyone else interested in chairing the TC ?
20:03:51 <ttx> I pushed as a candidacy:
20:03:57 <ttx> #link https://review.openstack.org/129275
20:04:01 <mordred> o/
20:04:12 <mordred> not really here, but I support ttx
20:04:34 <annegentle> mordred: heh I thought you were volunteering yourself
20:04:40 <ttx> If you don't want to propose yourself as alternative, just vote on that one
20:04:43 <annegentle> ttx: keep on keeping on
20:05:03 <ttx> well, it's now part of my job description, so I guess my employer agrees
20:05:04 <russellb> ttx: you've done an awesome job, thanks :)
20:05:12 * dhellmann imagines "stay calm, and thierry on" t-shirts
20:05:23 <ttx> dhellmann: lol
20:05:23 <jaypipes> lol
20:05:35 <annegentle> dhellmann: nice
20:05:49 <mikal> Cafe press someone?
20:05:52 * devananda lurks in this meeting while lurking in a f2f meeting
20:05:56 <markmcclain> ttx: congrats looks like you have enough votes
20:06:06 <ttx> yep, approved
20:06:08 <devananda> ttx: grats!
20:06:15 <ttx> Thanks everyone!
20:06:28 <dhellmann> ttx: thank you for signing up for another round :-)
20:06:44 <ttx> I won't stop now that it's becoming fun
20:06:58 <ttx> #topic Cross-project workshops track scheduling
20:07:05 <ttx> So... We need to work this week on selecting the cross-project workshops
20:07:12 <ttx> We have 18 40-min slots available
20:07:16 <ttx> And a lot of proposals @
20:07:21 <ttx> #link https://etherpad.openstack.org/p/kilo-crossproject-summit-topics
20:07:30 <ttx> Who is interested in working on the final selection ? Last time I did it with Russell, wouldn't mind rotating
20:07:32 <markmcclain> I'd be happy to help work on it
20:07:39 <russellb> happy to help
20:07:43 <annegentle> I can too
20:07:44 <russellb> last time really everyone participated
20:07:52 <russellb> or most at least
20:08:02 <russellb> etherpad, where everyone left a -2/-1/0/1/2 score and comments
20:08:08 <russellb> and that got us most of the way there
20:08:08 <jeblair> i would like to help
20:08:20 <jeblair> i thought the process last time worked well
20:08:24 <dhellmann> I'd like to be involved, too
20:08:24 <ttx> Hmm, ok, so we could etherpad it into shape
20:08:25 <jaypipes> I've added my thoughts and interested in tags in there...
20:08:26 <annegentle> do we know how many are on there? I scanned it earlier today
20:08:32 <russellb> yeah, let's etherpad it up
20:08:52 <anteaya> line 71 can be removed unless you want to keep it for tracking purposes
20:08:56 <ttx> and then who wants to work on the synthesis ? russell & mark ?
20:09:02 <vishy> despite all the discussion of big-tent openstack on the ml
20:09:05 <russellb> just need someone to organize the etherpad, and then collect results, help figure out things in the grey area, figure out the proposed schedule
20:09:12 <vishy> there is only one session about fixing testing: Implications of moving functional tests to projects
20:09:17 <russellb> ttx: works for me
20:09:20 <vishy> seems like we need more there
20:09:21 <annegentle> API working group also got a slot
20:09:24 <markmcclain> ttx: sure
20:09:28 <jgriffith> vishy: +1
20:09:33 <mikal> vishy: makes a good point
20:09:39 <jgriffith> I've been away, so not clear n if/what plan there might be
20:09:44 <ttx> vishy: could also be done as a QA session
20:09:59 <annegentle> docs does not have a separate track so cross-project is it for docs
20:09:59 <ttx> #action all TC members to weigh in on therpad
20:10:05 <jeblair> vishy: i don't think the big tent is about fixing testing; that's one very small part.
20:10:07 <jgriffith> ttx: but if the proposal is moving some of it to projects it's kinda "anti-QA" :)
20:10:12 <russellb> ttx: what kind of timeline do we have for this
20:10:17 <russellb> i'm actually traveling the rest of this week ...
20:10:19 <ttx> #action russellb and markmcclain to crystallize it into a schedule near the end of week
20:10:27 <russellb> ha
20:10:28 <jeblair> ttx: i think the functional testing cross-project item is important
20:10:38 <jeblair> ttx: i'm hoping you are not suggesting scheduling that as a qa session
20:10:40 <ttx> we need final schedule by Tuesday next week
20:10:55 <ttx> jeblair: that was not my suggestion
20:11:18 <jeblair> ttx: okay; what were you suggesting be a qa session?
20:11:33 <ttx> jeblair: vishy was saying only one session was proposed about testing -- I expect there to be plenty of QA sessiona bout testing.
20:11:35 <vishy> jeblair: that is one part that will require a lot of cross-project discussion, but my point was that there are no other sessions about other parts (that I could find)
20:11:46 <annegentle> oh maybe API working group didn't get a separate session.
20:12:10 <jeblair> vishy: *nod* do you think something is missing?
20:12:15 <ttx> API wg definitely needs a slot
20:12:40 <markmcclain> +1
20:12:47 <annegentle> yep ttx
20:12:57 <russellb> so how about everyone go through and give some -2/-1/0/+1/+2 votes by the end of the week?
20:12:58 <ttx> russellb: so you can't really work on it by the end of week ?
20:13:00 <annegentle> and honestly the API docs/specs could go in API working group.
20:13:04 <russellb> and then we can make the schedule monday/tuesday?
20:13:11 <annegentle> mostly it's about consolidation agreement
20:13:13 <russellb> or you think we should expedite further?
20:13:14 <ttx> russellb: wfm
20:13:29 <ttx> no, scheduling on Monday/Tuesday sounds good to me
20:13:35 <annegentle> Can someone guesstimate a count?
20:13:49 <russellb> annegentle: count?
20:14:06 <vishy> jeblair: I don’t have any specific topics offhand, but maybe a general big-tent topic to discuss changes
20:14:18 <dhellmann> annegentle: we have 32 proposals
20:14:20 <ttx> <ttx> We have 18 40-min slots available
20:14:35 <vishy> maybe it will be clearer after we discuss/vote on the dhellman proposals
20:14:38 <annegentle> thanks dhellmann (nice way to apply technology to that question)
20:14:49 <dhellmann> annegentle: automate everything
20:15:05 <ttx> russellb: oh and we have some time periods where only two run in parallel, and some time priods when 3 run in parallel
20:15:17 <russellb> fun
20:15:27 <ttx> the idea being to give the slots where only 2 sessions run in parallel to topics we want to maximize attendance for
20:15:28 <russellb> we can sort that out monday once we have a list
20:15:31 <annegentle> oh criminey
20:15:34 <ttx> yep, fun
20:15:49 <ttx> OK, I think we have a plan for this
20:15:57 <ttx> worst case scenario we close it at the TC meetign next week
20:16:04 <russellb> k
20:16:09 <russellb> so we just need votes on the etherpad by friday
20:16:10 <annegentle> ayup
20:16:12 <russellb> to start
20:16:15 <ttx> yes
20:16:26 <zehicle> o/
20:16:40 <annegentle> ttx: is there pod room for cross-project spillover?
20:16:42 <ttx> #undo
20:16:42 <openstack> Removing item from minutes: <ircmeeting.items.Action object at 0x319cf10>
20:16:54 <ttx> #action russellb and markmcclain to crystallize it into a schedule on Monday/Tuesday next week
20:17:12 <ttx> annegentle: there are pods.
20:17:37 <ttx> ok, next topic...
20:17:43 <ttx> #topic TC-owned repositories
20:17:56 <ttx> We have a few governance changes related to TC-owned git repositories
20:18:07 <ttx> Those currently appear nowhere, and don't technically belong to programs.yaml
20:18:12 <ttx> * Add list of repositories owned by the TC (https://review.openstack.org/125733)
20:18:25 <ttx> This review ^ adds the file describing those.
20:18:28 <ttx> The next two are adding two repos:
20:18:33 <ttx> * Add a new openstack-specs repo under the control of the TC (https://review.openstack.org/125509)
20:18:43 <ttx> * Adds a new api-wg repo under the control of the TC (https://review.openstack.org/129188)
20:18:58 <jeblair> 20:17 < clarkb> jeblair hrm I can probably swing something later in afternoon. maybe 3ish?
20:18:59 <ttx> I'm fine with considering them part of the openstack mission and justifying their presence in the openstack/* namespace with a TC stamp for the time being
20:19:04 <jeblair> (oops)
20:19:18 <ttx> since that's what our current governance mandates
20:19:35 <jeblair> i think that's a swell idea
20:19:45 <ttx> sounds like a good workaround
20:19:49 <jeblair> i think giving the api wg a tc charter is a good idea too
20:19:52 <dhellmann> we should document it to make it official
20:20:01 <markmcclain> jeblair: ++
20:20:05 <dhellmann> it == the ownership plan
20:20:16 <anteaya> so when reviewing patches to create new tc repos
20:20:17 <ttx> Approving the first one since it has enough
20:20:23 <anteaya> where do I look for the mandate?
20:20:28 <anteaya> the tc meeting logs?
20:20:31 <annegentle> so the tc is ultimately accountable, or the tc is ultimately governing?
20:20:39 <russellb> so, api wg proposes content, but TC reviews/approves?
20:20:55 <ttx> anteaya: in the governance repo ?
20:21:13 <dhellmann> anteaya: the new file created by https://review.openstack.org/125733
20:21:13 <anteaya> ttx okay I shall refer to the governance repo
20:21:26 <ttx> russellb: personally I see it more as a working group ,they build recommendations
20:21:31 <annegentle> I was thinking of it like api-wg proposes guidelines, TC or api-wg can +1, with one person being the final +1 like how ttx serves on TC voting
20:21:34 <anteaya> dhellmann: awesome
20:21:40 <ttx> then we'll see if we should force it down anyone throat
20:21:51 <ttx> but I'd rather not ti
20:21:54 <ttx> to*
20:22:11 <annegentle> how do we know how many votes are sufficient on reviews?
20:22:24 <ttx> I'd let the wg organize itself
20:22:28 <jaypipes> annegentle: would be up to the API WG to determine a policy.
20:22:36 <annegentle> jaypipes: ok that's fair
20:22:38 <russellb> i guess my only concern is that we're empowering a group, without the group having done work yet to build their credibility
20:22:42 <ttx> Frankly, it's not the first time this working group is created
20:22:52 <ttx> so I'd ratrher let them start producing something
20:22:55 <annegentle> yeah I'd rather support success :)
20:23:07 <russellb> we don't bless a project the day they create a wiki page, we expect them to write a bunch of code and build a community around it
20:23:08 <ttx> we have had API czars before.
20:23:10 <jaypipes> russellb: well, we're empowering a group to create guidelines, not enforce those guideliens.
20:23:17 <ttx> they just never took off
20:23:30 <russellb> jaypipes: fair, though it's implied everyone should follow them, right?
20:23:46 <jeblair> russellb: if they come up with something we think is a good idea?
20:23:49 <ttx> russellb: at this point, I wouldn't say that
20:24:02 <ttx> I want to let them create something
20:24:05 <dhellmann> maybe the policies in this specs repo aren't what people should follow, but it gives them a place to create those policies?
20:24:08 <ttx> If we like it, we can push it forward
20:24:18 <jeblair> dhellmann, ttx: ++
20:24:28 <russellb> if we're just creating a repo that's fine
20:24:31 <jaypipes> russellb: eventually I would like the guidance from the WG to be enforceable, but the guidelines should stand on their own merit. the problem is, who decides if the guidelines have merit?
20:24:36 <ttx> At this point it's just "creating a repo" yes
20:24:45 <russellb> jaypipes: we do, i suppose
20:24:53 <ttx> and let them produce awesome recommendations
20:25:04 <dhellmann> right, we'll have to make a decision about what to do with the policies after they exist
20:25:05 <jaypipes> russellb: right, which is why it's proposed to go under the purview of the TC's repos.
20:25:20 <russellb> which is why my first question was, who approves the contents of the repo
20:25:27 <jaypipes> russellb: frankly, I'd just be happy to have an agreed-upon place to put API guidance proposals :)
20:25:30 <annegentle> russellb: right, that's what I was wondering too
20:25:55 <annegentle> The repo is a step up from the wiki page
20:25:57 <ttx> russellb: they build the recommendation. Then we see if we like it enough to push it
20:26:00 <annegentle> with reviews, etc.
20:26:00 <dhellmann> russellb: the working group will approve them, though I'd like the TC to have voting rights in all working groups. after the proposed policies are defined we should probably put them in the governance repo
20:26:45 <anteaya> in addition to the name of the repo that can be created, should we also have the name of someone infra can seed the core group for the repo? https://review.openstack.org/#/c/125733/1/reference/technical-committee-repos.yaml
20:26:58 <russellb> ok, the end goal workflow just isn't totally clear to me
20:27:23 <ttx> anteaya: how about the owner of the change, unless specified otherwise in the commit message ?
20:27:24 <dhellmann> russellb: I agree, we're still figuring that out
20:27:39 <anteaya> ttx if we like that, that is fine with me
20:28:04 <ttx> russellb: at this point they need a git repo to experiment the process
20:28:13 <russellb> fair enough.
20:28:19 <dhellmann> anteaya: please also add the tc group (whatever it's actually called) to the new groups that can vote +2/-2 on these new repos
20:28:26 <jeblair> so how about we let the wg work on creating something, they come back to us when they are done, and we approve it.  we try to keep in touch in the meantime.  but we make it clear that a commit landing in that repo at this point does not make it policy.
20:28:35 <dhellmann> jeblair: ++
20:28:40 <russellb> jeblair: wfm
20:28:41 <ttx> It's ultimately under our control, so we can "fix" it if we don't like how the organize
20:29:16 <ttx> Any TC member volunteering to keep track of where this is going ? jaypipes maybe ?
20:29:17 <annegentle> ttx: that's a bit... unsettling or demotivating for the wg
20:29:21 <jaypipes> anything other than a wiki page works for me. :)
20:29:33 <jaypipes> ttx: yes, I will take point on it.
20:29:35 <anteaya> dhellmann: does the tc group consist of the members of the tc?
20:29:39 <ttx> annegentle: I think it's less demotivating than waiting before giving them a git repo :)
20:29:46 <anteaya> dhellmann: I'm guessing yes, but would like to be sure
20:29:47 <russellb> the suggestion of just using openstack-specs kinda makes sense too
20:29:50 <russellb> but i don't care much either way
20:29:58 <dhellmann> anteaya: yes, there must be a group in gerrit somewhere that has all of the tc members in it, and that's the one I mean
20:30:00 <jeblair> maybe we should propose a commit to governance chatering the api wg and recording this intent?
20:30:04 <annegentle> russellb: that might be a good way to look at it also
20:30:06 <ttx> #info jaypipes volunteers to report back on TC with API WG progress
20:30:07 <dhellmann> anteaya: whoever can +1/-1 on the governance repo
20:30:14 <russellb> jaypipes: thanks
20:30:19 <dhellmann> jeblair: ++
20:30:19 <jaypipes> no problemo.
20:30:27 <anteaya> dhellmann: https://review.openstack.org/#/admin/groups/205,members
20:30:27 <jgriffith> jeblair: +1
20:30:31 * ttx looks at vote counts on that repo
20:30:32 <annegentle> api working group is basically a specialty for cross-project
20:30:37 <dhellmann> anteaya: that's it
20:30:43 <anteaya> great, thanks
20:30:57 <ttx> We have 8 YES there, so I'll approve it now
20:31:05 <ttx> unless someone screams
20:31:28 <ttx> ok done
20:31:39 <ttx> that should unblock the repo creation
20:31:47 <ttx> #topic Other governance changes
20:31:55 <ttx> * Move config to system-config in the infra program (https://review.openstack.org/129438)
20:32:03 <ttx> This one is housekeeping, will approve unless someone disagrees
20:32:14 <jeblair> we're totally not renaming it back ;P
20:32:22 <ttx> good to know!
20:32:39 <ttx> * Add heat-translator to the Heat program (https://review.openstack.org/127349)
20:32:46 <ttx> This one has Heat PTL's +1 on it, will approve unless someone complains now
20:33:11 <ttx> #topic Stalled changes
20:33:25 <ttx> * Remove support for vendor extensions from our code (https://review.openstack.org/122968)
20:33:38 <mikal> I abandoned my one of those
20:33:50 <ttx> Not a lot of progress there...
20:33:58 <ttx> mikal: yes, I cleaned it up from list
20:34:04 <jeblair> oh, this has been revised
20:34:14 <ttx> yes
20:34:17 <jeblair> it's no longer a flame but a serious suggestion
20:34:27 <mikal> Oh, interesting
20:34:30 <mikal> I was avoiding the flame
20:34:31 <ttx> looks less like a flame yes
20:34:59 <zaneb> less flamey, still quite woolly
20:35:03 <jeblair> i will take a look at it again, because i think the idea merits consideration
20:35:07 * dhellmann wonders who dared mordred to use whereas
20:35:21 <zaneb> dhellmann: I believe it was vishy
20:35:27 <ttx> so, let's keep this one active ?
20:35:30 <dhellmann> zaneb: that sounds like something he'd do
20:35:35 <vishy> +1
20:35:51 <ttx> * Add a docs environment to the testing interface (https://review.openstack.org/119875)
20:35:58 <ttx> This one also failed to pick up support... what's the next step there ?
20:36:19 * jaypipes might have to reconsider that review just because of the use of the phrase "incent the vendor to align with gusto."
20:37:02 <jeblair> ttx: poke mordred and see if he has further thoughts on it?
20:37:18 <dhellmann> ttx: I think we mostly agreed with jeblair to leave the "docs" target as optional
20:37:19 <ttx> yes, I guess...
20:37:46 <annegentle> I'm okay with docs target as optional
20:37:51 <ttx> #action ttx to reach to mordred to check for further thoughts or abandon on https://review.openstack.org/119875
20:37:58 <jgriffith> if it had one more "Whereas" line I would've been +1
20:37:58 <annegentle> I cna change my vote
20:38:01 <ttx> * Naive script to verify extra-atc foundation status (https://review.openstack.org/121696)
20:38:03 <dhellmann> and if it's optional we don't have to include it in the guidelines
20:38:19 <dhellmann> ttx: I just abandoned that one
20:38:19 <ttx> was abandoned
20:38:30 <dhellmann> I'll try to find time to resubmit it to the other suggested repo
20:38:37 <annegentle> I support that tox -edocs exists
20:38:55 <ttx> alrighty. I feel like we are much more efficient in Kilo, we processed like 12 chnages in 39 minutes
20:39:17 <ttx> Now for a funnier topic
20:39:19 <jeblair> annegentle: ++ (and i use it!); i just want to make sure our deliverables are consistently generated
20:39:41 <ttx> #topic Governance structure reform
20:40:05 <ttx> So we obviously don't have the time to thoroughly discuss those proposals in the remaining 20min
20:40:13 <ttx> we have two things up for review:
20:40:20 <ttx> * Doug's series (https://review.openstack.org/#/q/status:open+topic:big-tent,n,z)
20:40:27 <ttx> * Jay's alternative (https://review.openstack.org/126582)
20:40:38 <dhellmann> would everyone prefer to continue reviewing my series as a series, or should I squash them into one commit?
20:40:41 <ttx> Personally I feel like they are both going in the same direction, but from opposite ends
20:40:50 <ttx> dhellmann: I don't mind the series, personally
20:40:52 <devananda> dhellmann: squash please. perhaps 2 changes
20:41:01 <jeblair> i really like that dhellman (and then jaypipes) put those changes up for review; i do think that was the natural next step
20:41:01 <jeblair> but in my mind it has exposed that we may still have some big-picture ideas to agree on
20:41:01 <jeblair> so maybe we can discuss those at the summit to agree on high level "requirements" and then further refine them in review?
20:41:05 <ttx> wouldn't mind squash either
20:41:13 <mikal> I'd like to discuss the premise of dhellmann's if we have time for that
20:41:21 <dhellmann> jeblair: yes, that's exactly why I put the changes together :-)
20:41:21 <ttx> jeblair: ++
20:41:25 <devananda> jeblair: ++
20:41:29 <ttx> Doug's incrementally changes the governance to introduce big-tent things in
20:41:32 <ttx> Jay's rips off the charter first and then rebuilds
20:41:36 <ttx> But the end result is not that different.
20:41:40 <zaneb> jeblair: why not discuss on the mailing list?
20:41:42 <ttx> (imho)
20:42:10 <dhellmann> ttx: do we have a formal in-person meeting of the tc scheduled for any time during the summit?
20:42:28 <ttx> I think I have an empty slot on Wednesday at 4am
20:43:09 <mikal> I feel like face to face is going to go better than yet another 100 email thread
20:43:10 <devananda> ttx: lol
20:43:18 <markmcclain> mikal: +1
20:43:24 <mikal> But yeah, I don't know when that would happen
20:43:28 <dhellmann> mikal: yeah, but if we don't actually have a scheduled meeting it's going to be 100 f2f meetings
20:43:31 <mikal> But I think my underlying concern here is this:
20:43:35 <devananda> f2f ++, with follow up being changes to (or new) patches to governance repo
20:43:37 <ttx> I think we need to converge to a single proposal and then expose it to ML
20:43:38 <zaneb> mikal: maybe for you, but shouldn't the whole community be involved?
20:43:41 <mikal> We're trying to solve our own failure of leadership with yet more governance
20:43:43 <jgriffith> sounds like great dinner conversation :)
20:43:44 <mikal> That's wrong
20:43:47 <jgriffith> Foood fight!!
20:43:47 <mikal> We should just lead more effectively
20:44:10 <mikal> zaneb: maybe, we certainly shouldn't exclude them
20:44:10 <anteaya> mikal: I don't see it as failure of leadership
20:44:15 <ttx> mikal: I wouldn't say "more governance" tbh
20:44:17 <anteaya> I see is as incredbile growth
20:44:19 <mikal> zaneb: however, the TC needs to work out waht they think first
20:44:26 <anteaya> resulting from great leadership
20:44:30 <devananda> mikal: we are evolving our govnernance in response to growth.
20:44:36 <devananda> mikal: I dont know whether it's more or less gov
20:44:40 <jeblair> zaneb: i generally consider that summit sessions do not exclude our community
20:44:41 <jgriffith> ttx: I like your proposal of solidifying a bit and going to ML
20:44:41 <devananda> but it's different
20:44:46 <annegentle> I think requirements first is a good discussion to have.
20:44:48 <ttx> I think the general issue was discussed on ML threads already
20:44:49 <jgriffith> ttx: but going to ML with structure and boundaries :)
20:45:01 <ttx> the next step is a formal proposal
20:45:02 <dhellmann> mikal: I largely agree, but think some of the proposals will also make that easier.
20:45:08 <jaypipes> mikal: actually, my proposal rips away governance, not adds to it.
20:45:18 <ttx> that can be reviewed on Gerrit/discussed on ML
20:45:21 <jaypipes> rather, rips away rigid structure, rather than adds to it.
20:45:32 <dhellmann> jeblair: interesting, should we put this on the cross-project session schedule?
20:45:36 <ttx> because another round of talking generally about the problem won't really help
20:46:00 <ttx> I'd say that both of the proposals on the table today remove governance
20:46:04 <mikal> I like the idea of a cross project session
20:46:13 <jeblair> dhellmann: sounds like a good idea
20:46:17 <markmcclain> dhellmann: +1
20:46:18 * dhellmann adds to the etherpad
20:46:24 <ttx> I think I suggested such a workshop
20:46:27 <ttx> already
20:46:30 * ttx checks
20:47:21 <dhellmann> ttx: #12?
20:47:29 <dhellmann> "growth challenges"
20:47:33 <ttx> yes, including 12.5
20:47:45 <jaypipes> "13 kids and counting"?
20:48:29 <jeblair> jaypipes: you mean 120 kids?
20:48:40 <ttx> dhellmann: so maybe just +1 that? Or build upon it ?
20:48:55 <annegentle> we're up to 20 rest api definitions if you include incubating
20:49:05 <dhellmann> ttx: OK
20:49:22 <ttx> At this point it's also fine of others want to push solid proposals up for review, like Doug and Jay did
20:49:36 <ttx> Good to see what the various options are
20:49:45 <jaypipes> 13 was referring to the TC membership :)
20:49:51 <ttx> So plan is like this
20:50:08 <ttx> 1. Big ML thread about the problem (done)
20:50:28 <ttx> 2. Formal suggestions up on review (in progress)
20:50:40 <ttx> 3. Workshop on potential convergence (Paris)
20:51:16 <ttx> 4. Converged plan proposed on review/ML for further discussion (if we converge)
20:51:37 <ttx> Sounds good to me
20:51:40 <jeblair> ++
20:51:56 <dhellmann> I'll try to address all of the comments on my patch series and squash it together into a smaller number of changes before the summit
20:52:06 <ttx> revolution is difficult, but Paris is the right place to do it.
20:52:09 <annegentle> dhellmann: thanks, I'll find it easier as well
20:52:15 <annegentle> ttx: +1
20:52:27 <ttx> #topic Open discussion
20:52:52 <ttx> I have one question (which I'll also ask the PTLs in the next meeting)
20:53:14 <ttx> The M design summit time span
20:53:19 <ttx> That's the one after Vancouver, located in APAC
20:53:26 <ttx> The main conference will happen Tuesday - Thursday
20:53:35 <ttx> Monday will have Ops Summit, analyst day, and other smallish pre-summit things
20:53:45 <ttx> Foundation staff needs to close on the contract and asks when should design summit be ?
20:53:49 <annegentle> Friday off? :)
20:53:53 <ttx> We can do Tuesday - Friday, but then we fully overlap with the conference, which may impact the PTLs ability to present at the conference
20:54:02 <ttx> We can do Wednesday - Saturday, but then... Saturday. Long week.
20:54:12 <ttx> We can do Monday, Wednesday-Friday (break on Tuesday), too. But feels weird.
20:54:21 <dhellmann> what did we do in hong kong?
20:54:22 <ttx> What is your general preference on that ?
20:54:28 * dhellmann can't remember yesterday
20:54:32 <devananda> wed-fri
20:54:32 <annegentle> all-cross-project by M :)
20:54:33 <vishy> can we do monday - thursday? just to try the opposite?
20:54:50 <annegentle> only mid-cycles for the six months prior
20:54:53 <ttx> vishy: I don't like that, because everyone shows up on the design summit
20:54:55 <russellb> mon-thurs, or tues-fri
20:54:56 <vishy> i guess that doesn’t really help
20:55:01 <ttx> we diud that once (oin POrtland)
20:55:02 <russellb> basically, anything but making the week 6 days
20:55:04 <devananda> i've just accepted that conferences are basically going to be sun-fri
20:55:08 <annegentle> russellb: yup
20:55:16 <jgriffith> russellb: +1
20:55:18 <vishy> i like the monday, w-f idea
20:55:21 <annegentle> I'll keep pushing for four days
20:55:27 <zaneb> dhellmann: iirc we did Tue-Fri in HK
20:55:28 <annegentle> accept the overlap
20:55:35 <jgriffith> cuz in APAC for many of us it's 6-7 days as is
20:55:50 <russellb> and joint tc+board meeting on sunday
20:55:52 <vishy> do they have any candidate cities yet?
20:55:52 <russellb> so that's another day
20:55:57 <russellb> sooo long
20:56:05 <ttx> russellb: I guess the board thing could be on the Monday there
20:56:06 <dhellmann> annegentle: do you think if the sessions were all cross-project that would make it easier for ptls to present?
20:56:20 <ttx> vishy: yes, but won't say until contract is signed
20:56:21 <russellb> ttx: true, but lots of people want to join the ops meetup and stuff ..
20:56:32 <russellb> which is probably more valuable as a day off than a main conf day honestly
20:56:35 <ttx> Soo. not Wed-Sat
20:56:36 <annegentle> dhellmann: more solving for why have a design summit at all
20:56:40 <anteaya> tuesday-friday
20:56:41 <russellb> so my vote is tues-fri
20:56:43 <dhellmann> annegentle: ah
20:56:51 <anteaya> ttx can we pick a city that has some M options?
20:56:53 <annegentle> with the growth, etc.
20:56:56 <ttx> yeah, I think Tue-Fri is the less wrong solution
20:56:58 <anteaya> like Melbourne?
20:57:00 <dhellmann> yeah, I think tue-fri is best
20:57:02 <markmcclain> Tues-Fri
20:57:05 <russellb> ttx: ++
20:57:05 <devananda> ++
20:57:07 <dhellmann> anteaya: ++
20:57:14 <asalkeld> anteaya, ++
20:57:18 <anteaya> ttx or like not japan
20:57:22 <anteaya> I want to go to japan
20:57:28 <anteaya> but not many M's there
20:57:38 <ttx> Mitsubishi ?
20:57:38 <russellb> the amount of answers i expect ttx to give about possible locations: 0
20:57:48 <mikal> So...
20:57:51 <ttx> russellb: you would be right
20:57:54 <anteaya> ttx I smell a trademark issue
20:57:54 <mikal> Did we just decide anything with the L summit?
20:57:56 <annegentle> heh
20:58:14 <mikal> Tues - Fri was popular last time the community was asked
20:58:33 <ttx> mikal: I think Vancouver is traditional iirc Mon-Thu conference Tue-Fri Design Summit
20:58:45 <ttx> I wasn't asked any question about it
20:58:51 <mikal> Oh sorry
20:58:54 <mikal> I have misunderstood
20:58:57 <mikal> You're asking for M?
20:59:01 <ttx> only thing I know iss that "I'll love the Design Summit area"
20:59:05 <ttx> yes
20:59:10 <mikal> Ahhh, ok
20:59:16 <mikal> Well, I vote for the same as L then
20:59:20 <mikal> Cause its what people are used to now
20:59:23 <jeblair> anteaya: there are _tons_ of cities in japan that start with M
20:59:37 <ttx> ok, anything else, anyone ?
20:59:38 <anteaya> jeblair: great, I'm glad my geography is poor
20:59:44 <mikal> On more important issues, can we call the L release "Lemming"?
20:59:58 <ttx> Oh, that's true, we can pick the L name
20:59:58 <dhellmann> mikal: do they have those in vancouver?
21:00:02 <anteaya> mikal: find a canadian city named lemming and you have a chance
21:00:06 <russellb> Lemons
21:00:16 <russellb> Liger
21:00:17 <anteaya> dhellmann: no no lemmings in vanvouver
21:00:18 <mikal> La di da
21:00:22 <jeblair> anteaya: 75 according to wikipedia (and that's just cities)
21:00:24 <anteaya> lauier
21:00:31 <anteaya> jeblair: cool
21:00:33 <mikal> No releases I can't pronounce please
21:00:36 <ttx> ok, time is up
21:00:36 <anteaya> laval
21:00:45 <ttx> #endmeeting